Créer un état simple

Access permet de créer toutes sortes d’états, du plus simple au plus complexe. Commencez par réfléchir à la source d’enregistrement de votre état. Que votre état soit une simple liste d’enregistrements ou une synthèse groupée de ventes par région, vous devez commencer par déterminer les champs qui contiennent les données que vous voulez afficher dans votre état, ainsi que les tables ou requêtes dans lesquelles celles-ci figurent.

Après avoir choisi votre source d’enregistrement, vous trouverez généralement très simple de créer votre état à l’aide de l’Assistant État. L’Assistant État est une fonctionnalité d’Access qui vous guide à travers une série de questions, puis génère un état basé sur vos réponses.

Que voulez-vous faire ?

Choisir une source d’enregistrement

Créer un état à l’aide de l’outil État

Créer un état à l’aide de l’Assistant État

Créer des étiquettes à l’aide de l’Assistant Étiquette

Créer un état à l’aide de l’outil État vierge

Comprendre les sections d’un état

Comprendre les contrôles

Ajuster finement votre état en mode Page

Ajuster finement votre état en mode Création

Ajouter des contrôles à l’état

Enregistrer votre travail

Afficher, imprimer ou envoyer sous la forme d’un e-mail votre état

Afficher votre état

Imprimer votre état

Envoyer votre état sous la forme d’un e-mail

Choisir une source d’enregistrement

Un état contient des informations extraites de tables ou requêtes, ainsi que des informations stockées avec la création d’état, telles que des étiquettes, des titres et des graphiques. Les tables ou requêtes qui fournissent les données sous-jacentes sont également appelées sources d’enregistrement de l’état. Si les champs que vous souhaitez inclure figurent tous dans une même table, utilisez celle-ci comme source d’enregistrement. Si les champs se trouvent dans plusieurs tables, vous devez utiliser une ou plusieurs requêtes comme source d’enregistrement. Ces requêtes peuvent préexister dans votre base de données, ou vous pouvez créer des requêtes spécifiquement adaptées aux besoins de votre état.

Créer un état à l’aide de l’outil État

L’outil État est le moyen le plus rapide de créer un état, car il génère celui-ci immédiatement, sans demander d’informations. L’état affiche tous les champs de la table ou de la requête sous-jacente. Il se peut que l’outil État ne crée pas l’état final peaufiné tel que vous le souhaitez, mais il est très utile pour consulter rapidement les données sous-jacentes. Vous pouvez ensuite enregistrer l’état et le modifier en mode Page ou Création afin qu’il corresponde mieux à vos besoins.

  1. Dans le volet de navigation, cliquez sur la table ou la requête sur laquelle vous voulez baser l’état.

  2. Sous l’onglet Créer, dans le groupe États, cliquez sur État. Image du bouton

    Access génère l’état et l’affiche en mode Page.

  3. Pour plus d’informations sur l’affichage et l’impression de votre état, voir la section Afficher, imprimer ou envoyer sous la forme d’un e-mail votre état.

Après avoir consulté l’état, vous pouvez l’enregistrer, puis le fermer ainsi que la table ou la requête sous-jacente que vous avez utilisée comme source d’enregistrement. Lors de la prochaine ouverture de l’état, Access affiche les données les plus récentes de votre source d’enregistrement.

Créer un état à l’aide de l’Assistant État

L’Assistant État vous permet d’être plus sélectif concernant les champs qui apparaissent dans l’état. Vous pouvez également spécifier la manière dont les données sont regroupées et triées, et utiliser des champs de plusieurs tables ou requêtes, à la condition d’avoir préalablement défini les relations entre les tables et les requêtes.

  • Sous l’onglet Créer, dans le groupe État, cliquez sur Assistant État.

  • Suivez les instructions fournies dans les pages de l’Assistant État. Dans la dernière page, cliquez sur Terminer.

    Lorsque vous prévisualisez l’état, vous le voyez tel qu’il apparaîtra à l’impression. Vous pouvez également augmenter le facteur de zoom pour agrandir des détails. Pour plus d’informations sur l’affichage et l’impression de votre état, voir la section Afficher, imprimer ou envoyer sous la forme d’un e-mail votre état.

Remarque : Si vous souhaitez inclure des champs de plusieurs tables ou requêtes dans l’état, ne cliquez pas sur Suivant ou sur Terminer après avoir sélectionné les champs de la première table ou requête dans la première page de l’Assistant État. Au lieu de cela, répétez les étapes de sélection d’une table ou d’une requête, puis cliquez sur les autres champs à inclure dans l’état. Cliquez ensuite sur Suivant ou sur Terminer pour continuer.

Créer des étiquettes à l’aide de l’Assistant Étiquette

L’Assistant Étiquette vous aide à créer facilement des étiquettes pour un vaste éventail de tailles d’étiquette standard.

  1. Dans le volet de navigation, ouvrez la table ou la requête qui sera la source d’enregistrement de vos étiquettes en double-cliquant dessus.

  2. Sous l’onglet Créer, dans le groupe États, cliquez sur Étiquettes.

  3. Suivez les instructions fournies dans les pages de l’Assistant Étiquette. Dans la dernière page, cliquez sur Terminer.

Access affiche vos étiquettes en mode Aperçu avant impression afin que vous puissiez les voir telles qu’elles apparaîtront lors de leur impression. Vous pouvez utiliser le contrôle du curseur sur la barre d’état d’Access pour agrandir des détails. Pour plus d’informations sur l’affichage et l’impression d’états, voir la section Afficher, imprimer ou envoyer sous la forme d’un e-mail votre état.

Remarque : L’aperçu avant impression est le seul mode d’affichage permettant de voir plusieurs colonnes. Les autres modes d’affichage présentent les données dans une seule colonne.

Créer un état à l’aide de l’outil État vierge

Si vous ne souhaitez pas vous servir de l’outil État ou de l’Assistant État, vous pouvez utiliser l’outil État vierge pour créer un état de toutes pièces. Cela peut vous permettre de créer un état très rapidement, en particulier si vous envisagez de ne placer que quelques champs dans l’état. La procédure suivante explique comment utiliser l’outil État vierge :

  • Sous l’onglet Créer, dans le groupe États, cliquez sur État vierge. Image du bouton

    Un état vierge s’affiche en mode Page, le volet Liste de champs apparaissant sur le côté droit de la fenêtre Access.

  • Dans le volet Liste de champs, cliquez sur le signe plus (+) en regard des tables contenant les champs qui doivent figurer sur l’état.

  • Glissez-déplacez successivement chaque champ sur l’état, ou sélectionnez plusieurs champs en maintenant la touche Ctrl enfoncée, puis glissez-déplacez-les sur l’état en même temps.

  • Servez-vous des outils du groupe En-tête/Pied de page sous l’onglet Création pour ajouter un logo, un titre, des numéros de page ou la date et l’heure à l’état. Notez que, si vous utilisez Access 2007, ces outils figurent dans le groupe Contrôles sous l’onglet Format.

Comprendre les sections d’un état

Dans Access, un état est divisé en deux sections. Pour voir les sections de l’état, vous pouvez afficher celui-ci en mode Création. Pour créer des états utiles, vous devez comprendre le fonctionnement de chaque section. Par exemple, la section dans laquelle vous choisissez de placer un contrôle calculé détermine la manière dont Access calcule les résultats. La liste suivante répertorie les types de sections et leurs utilisations :

  • En-tête d’état     Cette section n’est imprimée qu’une seule fois, au début de l’état. Utilisez l’en-tête d’état pour regrouper des informations apparaissant habituellement sur une page de garde, telles qu’un logo, un titre ou une date. Lorsque vous placez un contrôle calculé utilisant la fonction d’agrégation Somme dans l’en-tête d’état, la somme est calculée pour l’état entier. L’en-tête d’état est imprimé avant l’en-tête de page.

  • En-tête de page     Cette section est imprimée en haut de chaque page. Utilisez un en-tête de page, par exemple, pour répéter le titre de l’état sur chaque page.

  • En-tête de groupe     Cette section est imprimée au début de chaque nouveau groupe d’enregistrements. Utilisez l’en-tête de groupe pour imprimer le nom du groupe. Par exemple, dans un état groupé par produit, utilisez l’en-tête de groupe pour imprimer le nom du produit. Lorsque vous placez un contrôle calculé utilisant la fonction d’agrégation Somme dans l’en-tête de groupe, la somme est calculée pour le groupe actuel.

  • Détail     Cette section est imprimée une seule fois pour chaque ligne de la source d’enregistrement. C’est l’endroit où vous placez les contrôles constituant le corps principal de l’état.

  • Pied de groupe     Cette section est imprimée à la fin de chaque groupe d’enregistrements. Utilisez un pied de groupe pour imprimer des informations de synthèse sur un groupe.

  • Pied de page     Cette section est imprimée à la fin de chaque page. Utilisez un pied de page pour imprimer des numéros de page ou des informations spécifiques de chaque page.

  • Pied d’état     Cette section n’est imprimée qu’une seule fois, à la fin de l’état. Utilisez le pied d’état pour imprimer des totaux d’état ou d’autres informations de synthèse pour l’ensemble de l’état.

    Remarque : En mode Création, le pied d’état se trouve en dessous du pied de page. En revanche, lorsque l’état est imprimé ou affiché en mode Aperçu avant impression, le pied d’état se trouve au-dessus du pied de page, juste après le dernier pied de groupe ou la dernière ligne de détail sur la page finale.

Haut de la page

Comprendre les contrôles

Les contrôles sont des objets qui affichent des données, effectuent des actions et permettent de visualiser et d’utiliser des informations qui améliorent l’interface utilisateur, telles que des étiquettes et des images. Access prend en charge trois types de contrôles, à savoir dépendants, indépendants et calculés :

  • Contrôle dépendant     Contrôle dont la source de données est un champ ou une requête. Les contrôles dépendants permettent d’afficher des valeurs de champs dans votre base de données. Ces valeurs peuvent être du texte, des dates, des nombres, des valeurs Oui/Non, des images ou des graphiques. Une zone de texte est le type le plus courant de contrôle dépendant. Par exemple, une zone de texte sur un formulaire qui affiche le nom d’un employé pourrait extraire ces informations du champ Nom de la table Employés.

  • Contrôle indépendant     Contrôle n’ayant pas de source de données (champ ou expression). Les contrôles indépendants permettent afficher des informations, des lignes, des rectangles et des images. Par exemple, une étiquette affichant le titre d’un état est un contrôle indépendant.

  • Contrôle calculé     Contrôle dont la source de données est une expression plutôt qu’un champ. Vous spécifiez la valeur que vous souhaitez dans le contrôle en définissant une expression comme source de données. Une expression est une combinaison d’opérateurs (par exemple = et +), de noms de contrôles, de noms de champs, de fonctions qui renvoient une simple valeur, et de valeurs constantes. Par exemple, l’expression suivante calcule le prix d’un article après remise de 25 % en multipliant la valeur du champ Prix unitaire par la valeur constante (0,75).

    = [Prix unitaire] * 0,75

    Une expression peut utiliser les données d’un champ de la table ou de la requête sous-jacente de l’état, ou d’un contrôle dans celui-ci.

Lorsque vous créez un état, il est probablement plus efficace de commencer par ajouter et organiser tous les contrôles dépendants, en particulier s’ils constituent la majorité des contrôles figurant sur l’état. Vous pouvez ensuite ajouter les contrôles indépendants et calculés complétant la création en utilisant les outils du groupe Contrôles sous l’onglet Création.

Vous liez un contrôle à un champ en identifiant le champ à partir duquel le contrôle obtient ses données. Vous pouvez créer un contrôle lié au champ sélectionné en faisant glisser le champ du volet Liste des champs vers l’état. Le volet Liste des champs affiche les champs de la table ou de la requête sous-jacentes de l’état. Pour afficher le volet Liste des champs, sous l’onglet Création, dans le groupe Contrôles, cliquez sur Ajouter un champ existant.

Vous pouvez également lier un champ à un contrôle en tapant le nom du champ dans le contrôle lui-même ou dans la zone de la valeur SourceContrôle dans la feuille de propriétés du contrôle. La feuille de propriétés définit les caractéristiques du contrôle, telles que son nom, la source de ses données et son format.

La meilleure façon de créer un contrôle consiste à utiliser le volet Liste des champs, et ce pour deux raisons :

  • Un contrôle dépendant est associé à une étiquette qui prend le nom du champ (ou la légende définie pour ce champ dans la table ou la requête sous-jacentes) en tant que légende par défaut. Vous n’avez donc pas à entrer celle-ci vous-même.

  • Un contrôle dépendant hérite de bon nombre des paramètres du champ dans la table ou la requête sous-jacentes (comme pour les propriétés Format, Décimales et MasqueSaisie). Par conséquent, vous pouvez être certain que les propriétés de ce champ restent les mêmes chaque fois que vous créez un contrôle lié à ce champ.

Si, après avoir créé un contrôle indépendant, vous souhaitez lier celui-ci à un champ, définissez la propriété SourceContrôle du contrôle sur le nom du champ. Pour plus d’informations sur la propriété SourceContrôle, consultez l’Aide relative à « SourceContrôle ».

Haut de la page

Ajuster finement votre état en mode Page

Après avoir créé un état, vous pouvez facilement affiner sa conception en travaillant en mode Page. En utilisant les données réelles de l’état comme votre guide, vous pouvez ajuster les largeurs des colonnes, réorganiser les colonnes, et ajouter des totaux et des niveaux de regroupement. Vous pouvez placer de nouveaux champs dans la création d’état, et définir les propriétés de l’état et de ses contrôles.

Pour basculer en mode Page, cliquez avec le bouton droit sur le nom de l’état dans le volet de navigation, puis cliquez sur Mode Page Image du bouton .

Access affiche l’état en mode Page.

Vous pouvez utiliser la feuille de propriétés pour modifier les propriétés de l’état ainsi que ses contrôles et sections. Pour afficher la feuille de propriétés, appuyez sur F4.

Vous pouvez utiliser le volet Liste des champs pour ajouter des champs de la table ou de la requête sous-jacentes à votre création d’état. Pour afficher le volet Liste des champs, effectuez l’une des opérations suivantes :

  • Sous l’onglet Création, dans le groupe Outils, cliquez sur Ajouter des champs existants Image du bouton . Notez que, si vous utilisez Access 2007, la commande Ajouter des champs existants figure dans le groupe Outils sous l’onglet Format.

  • Appuyez sur Alt+F8.

Vous pouvez ensuite ajouter des champs en les faisant glisser du volet Liste des champs vers l’état.

Haut de la page

Ajuster finement votre état en mode Création

Vous pouvez également ajuster finement l’aspect de votre état en travaillant en mode Création. Vous pouvez ajouter des contrôles et des champs à l’état en les ajoutant à la grille de création. La feuille de propriétés vous donne accès à un grand nombre de propriétés que vous pouvez définir pour personnaliser votre état.

Pour basculer en mode Création, cliquez avec le bouton droit sur le nom de l’état dans le volet de navigation, puis cliquez sur Mode Création Image du bouton .

Access affiche l’état en mode Création.

Vous pouvez utiliser la feuille de propriétés pour modifier les propriétés de l’état, ainsi que les contrôles et sections qu’il contient. Pour afficher la feuille de propriétés, appuyez sur F4.

Vous pouvez utiliser le volet Liste des champs pour ajouter des champs de la table ou de la requête sous-jacentes à votre création d’état. Pour afficher le volet Liste des champs, effectuez l’une des opérations suivantes :

  • Sous l’onglet Format, dans le groupe Contrôles, cliquez sur Ajouter des champs existants Image du bouton . Notez que, si vous utilisez Access 2007, la commande Ajouter des champs existants figure dans le groupe Outils sous l’onglet Format.

  • Appuyez sur Alt+F8.

Vous pouvez ensuite ajouter des champs en les faisant glisser du volet Liste des champs vers l’état.

Haut de la page

Ajouter des champs à partir du volet Liste des champs

  • Pour ajouter un seul champ, faites glisser celui-ci du volet Liste des champs vers la section dans laquelle vous voulez qu’il apparaisse dans l’état.

  • Pour ajouter plusieurs champs à la fois, cliquez sur les champs souhaités en maintenant la touche Ctrl enfoncée. Ensuite, glissez-déplacez les champs sélectionnés vers l’état.

Lorsque vous déposez les champs sur une section de l’état, Access crée un contrôle de zone de texte dépendante pour chaque champ, et insère automatiquement un contrôle d’étiquette à côté de chaque champ.

Haut de la page

Ajouter des contrôles à l’état

Certains contrôles sont créés automatiquement, tel le contrôle de zone de texte dépendante qui est créé lorsque vous ajoutez un champ à partir du volet Liste des champs à votre état. Vous pouvez créer de nombreux autres contrôles en mode Création, en vous servant des outils du groupe Contrôles sous l’onglet Création.

Déterminer le nom d’un outil

  • Positionnez le pointeur de la souris sur l’outil.

    Access affiche le nom de l’outil.

Créer un contrôle à l’aide des outils du groupe Contrôles

  1. Cliquez sur l’outil correspondant au type de contrôle à ajouter. Par exemple, pour créer une case à cocher, cliquez sur l’outil Case à cocher Image du bouton .

  2. Dans la grille de création d’état, cliquez sur l’emplacement où vous voulez positionner l’angle supérieur gauche du contrôle. Cliquez une fois pour créer un contrôle dimensionné par défaut, ou cliquez sur l’outil et faites glisser dans la grille de création d’état pour créer un contrôle de la taille souhaitée.

  3. Si vous ne positionnez pas le contrôle parfaitement à la première tentative, vous pouvez le déplacer en procédant comme suit :

    1. Cliquez sur le contrôle pour le sélectionner.

    2. Positionnez le pointeur de la souris sur le bord du contrôle jusqu’à ce que le pointeur prenne l’aspect d’une flèche à quatre pointes Pointeur de déplacement .

    3. Faites glisser le contrôle vers l’emplacement de votre choix.

Cette procédure crée un contrôle « indépendant ». Si le contrôle est d’un type permettant d’afficher des données (par exemple, une zone de texte ou une case à cocher), vous devez entrer un nom de champ ou une expression dans la propriété SourceContrôle du contrôle pour que celui-ci puisse afficher des données. Pour plus d’informations, voir la section Comprendre les contrôles dans cette rubrique.

Afficher la feuille de propriétés

Pour afficher la feuille de propriétés en mode Création, effectuez l’une des opérations suivantes :

  • Sous l’onglet Créer, dans le groupe Outils, cliquez sur Feuille de propriétés. Notez que, si vous utilisez Access 2007, la commande Feuille de propriétés figure dans le groupe Afficher/Masquer sous l’onglet Création.

  • Appuyez sur F4.

Haut de la page

Enregistrer votre travail

Après avoir enregistré votre création d’état, vous pouvez générer l’état aussi souvent que nécessaire. La structure de l’état ne change pas, mais les données sont actualisées chaque fois que vous l’affichez ou l’imprimez. Si vos besoins changent, vous pouvez modifier l’état ou créer un état similaire basé sur l’original.

Enregistrer votre création d’état

  • Cliquez sur Fichier > Enregistrer, ou appuyez sur Ctrl+S. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office, puis sur Enregistrer, ou appuyez sur Ctrl+S.

    Cliquez sur Enregistrer Image du bouton dans la barre d’outils Accès rapide.

  • Si l’état n’a pas de titre, tapez un nom dans le champ Nom de l’état, puis cliquez sur OK.

Enregistrer votre création d’état sous un nouveau nom

  • Si vous utilisez Access 2013 ou version ultérieure, cliquez sur Fichier > Enregistrer sous > Enregistrer l’objet sous.

    Si vous utilisez Access 2010, cliquez sur Fichier > Enregistrer l’objet sous.

    Si vous utilisez Excel 2007, cliquez sur le bouton Microsoft Office, puis sur Enregistrer sous > Enregistrer l’objet sous.

  • Dans la boîte de dialogue Enregistrer sous, tapez un nom dans le champ Enregistrer l’état sous pour le nouvel état, puis cliquez sur OK.

Haut de la page

Afficher, imprimer ou envoyer sous la forme d’un e-mail votre état

Une fois votre création d’état enregistrée, vous pouvez l’utiliser autant de fois que nécessaire. La structure de l’état ne change pas, mais les données sont actualisées chaque fois que vous l’affichez ou l’imprimez. Si vos besoins changent, vous pouvez modifier l’état ou créer un état similaire basé sur l’original.

Afficher votre rapport

Vous pouvez afficher votre état de plusieurs façons. La méthode appropriée dépend de ce que vous voulez faire avec l’état et ses données :

  • Si vous souhaitez modifier temporairement les données qui apparaissent sur l’état avant d’imprimer celui-ci, ou si vous voulez copier les données de l’état dans le Presse-papiers, utilisez le mode État.

  • Si vous voulez pouvoir modifier la conception de l’état lorsque vous consultez les données de celui-ci, utilisez le mode Page.

  • Si vous voulez simplement voir à quoi l’état ressemblera à l’impression, utilisez le mode Aperçu avant impression.

Remarque : Si votre état est mis en forme avec plusieurs colonnes, vous pouvez voir le format des colonnes uniquement en mode Aperçu avant impression. Les modes Page et État affichent l’état sous la forme d’une seule colonne.

Afficher votre état en mode État

Le mode État est le mode d’affichage par défaut utilisé lorsque vous double-cliquez sur un état dans le volet de navigation. Si l’état n’est pas ouvert, double-cliquez sur l’état dans le volet de navigation à afficher dans la vue du état.

Si l’état est ouvert, cliquez avec le bouton droit sur son nom dans le volet de navigation, puis cliquez sur Mode État.

Travailler sur vos données en mode État

En mode État, vous pouvez sélectionner du texte et le copier dans le Presse-papiers. Pour sélectionner des lignes entières, cliquez et faites glisser dans la marge en regard des lignes que vous souhaitez sélectionner. Vous pouvez ensuite copier ces lignes dans le Presse-papiers en effectuant l’une des opérations suivantes :

  1. Sous l’onglet Accueil, dans le groupe Presse-papiers, cliquez sur Copier. Image du bouton

  2. Cliquez avec le bouton droit sur les lignes sélectionnées, puis cliquez sur Copier.

  3. Utilisez le raccourci clavier : appuyez sur Ctrl+C.

Afficher uniquement les lignes souhaitées en utilisant des filtres

Vous pouvez appliquer des filtres directement à votre état sans quitter le mode État. Par exemple, si vous avez une colonne « Pays/Région » et souhaitez afficher uniquement les lignes dont la valeur de Pays/Région est « Canada », procédez comme suit :

  1. Recherchez le mot « Canada » dans l’état, puis cliquez dessus avec le bouton droit.

  2. Cliquez sur Égal à « Canada ».

Access crée et applique le filtre.

Activer et désactiver un filtre

Pour basculer entre un affichage filtré et non filtré, sous l’onglet Accueil, dans le groupe Trier et filtrer, cliquez sur Activer/désactiver le filtre. Cela n’a pas pour effet de supprimer le filtre, mais uniquement de l’activer et de le désactiver.

Supprimer un filtre

  1. Cliquez avec le bouton droit sur le champ dont vous souhaitez supprimer le filtre.

  2. Cliquez sur Supprimer le filtre dans nomdechamp (votre champ réel remplace nomdechamp).

Une fois un filtre supprimé, vous ne pouvez pas le réactiver à l’aide de la commande Activer/désactiver le filtre. Vous devez commencer par recréer le filtre.

Remarque : Si vous appliquez un filtre à un état, puis enregistrez et fermez celui-ci, le filtre est enregistré. Toutefois, lors de l’ouverture ultérieure de l’état, Access n’applique pas le filtre. Pour réappliquer le filtre, sous l’onglet Accueil, dans le groupe Trier et filtrer, cliquez sur Activer/désactiver le filtre.

Prévisualiser votre état à l’aide de l’Aperçu avant impression

Cliquez avec le bouton droit sur l’état dans le volet de navigation, puis cliquez sur Aperçu avant impression dans le menu contextuel.

Vous pouvez utiliser les boutons de navigation pour afficher les pages d’un état de manière séquentielle, ou accéder directement à n’importe quelle page de l’état.

Boutons de navigation

1. Cliquez ici pour afficher la première page.

2. Cliquez pour afficher la page précédente.

3. Cliquez pour afficher la page suivante.

4. Cliquez pour afficher la dernière page.

5. Tapez un numéro de page dans ce champ, puis appuyez sur ENTRÉE pour accéder directement à une page spécifique.

En mode Aperçu avant impression, vous pouvez effectuer un zoom avant pour afficher les détails ou un zoom arrière pour voir si les données sont correctement positionnées sur la page. Placez le curseur sur l’état, puis cliquez une fois. Pour inverser l’effet de zoom, cliquez à nouveau. Vous pouvez également utiliser le contrôle de zoom situé dans la barre d’état d’Access pour effectuer un zoom avant ou arrière.

Pour fermer l’Aperçu avant impression, effectuez l’une des opérations suivantes :

  • Sous l’onglet Aperçu avant impression, cliquez sur Fermer l’aperçu avant impression.

  • Dans le volet de navigation, cliquez avec le bouton droit sur l’état, puis, dans le menu contextuel, cliquez sur Mode Page Image du bouton ou Mode Création Image du bouton .

Conseil : Après avoir prévisualisé votre état, vous pouvez exporter les résultats vers Microsoft Word, Microsoft Excel ou plusieurs autres programmes Office. Sous l’onglet Données externes, dans le groupe Exporter, cliquez sur le bouton correspondant au format souhaité, puis suivez les instructions.

Haut de la page

Imprimer votre état

Vous pouvez imprimer un état ouvert dans n’importe quel mode, ou même s’il est fermé. Avant d’imprimer, vérifiez soigneusement les paramètres de la page, tels que les marges ou l’orientation de celle-ci. Access enregistrant les paramètres de la page avec l’état, vous ne devez les définir qu’une seule fois. Vous pourrez les redéfinir ultérieurement si vos besoins d’impression changent.

Modifier les paramètres de la page

  1. Ouvrez l’état en mode Aperçu avant impression. Vous pouvez modifier les paramètres de la page dans n’importe quel mode, mais le mode Aperçu avant impression est préférable, car il permet de voir immédiatement les effets des modifications.

  2. Sous l’onglet Aperçu avant impression, dans les groupes Mise en Page et Taille de la page, cliquez sur Portrait Image du bouton ou Paysage Image du bouton pour définir l’orientation de page, sur Taille Image du bouton pour définir la taille du papier, sur Marges Image du bouton pour ajuster les marges, et ainsi de suite.

  3. Après avoir apporté une modification, utilisez les boutons de navigation pour afficher quelques pages afin de vous assurer que vous n’avez pas créé de problèmes de mise en forme sur les pages suivantes.

Envoyer votre état à une imprimante

  1. Ouvrez l’état dans n’importe quel mode d’affichage, ou sélectionnez-le dans le volet de navigation.

  2. Cliquez sur Fichier > Imprimer > Imprimer. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office, puis sur Imprimer > Imprimer.

    Access affiche la boîte de dialogue Imprimer.

  3. Entrez vos choix pour les options telles que l’imprimante, l’étendue d’impression et le nombre de copies.

  4. Cliquez sur OK.

Haut de la page

Envoyer votre état sous la forme d’un e-mail

Au lieu d’imprimer une copie papier de votre état, vous pouvez envoyer celui-ci en tant qu’e-mail à des destinataires :

  1. Dans le volet de navigation, cliquez sur l’état pour le sélectionner. Sous l’onglet Données externes, dans le groupe Exporter, cliquez sur E-mail. Si vous utilisez Access 2007, cliquez sur l’état dans le volet de navigation pour le sélectionner, sur le bouton Microsoft Office, puis sur E-mail.

  2. Dans la boîte de dialogue Envoyer l’objet comme, dans la liste Sélectionner le format de sortie, cliquez sur le format de fichier que vous voulez utiliser.

  3. Complétez les autres boîtes de dialogue.

  4. Dans votre application de courrier, tapez les détails du message, puis envoyez celui-ci.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×