Créer ou modifier des fichiers .csv à importer dans Outlook

Créer ou modifier des fichiers .csv à importer dans Outlook

Un fichier CSV est un fichier de valeurs séparées par des virgules. Lorsque vous enregistrez du texte et des nombres dans un fichier CSV, vous pouvez les déplacer facilement d’un programme à un autre. Par exemple, vous pouvez exporter vos contacts à partir de Google dans un format CSV, puis les importer dans Outlook.

Les fichiers CSV peuvent être utilisés avec Excel ou n’importe quel autre tableur. Les fichiers CSV diffèrent des autres types de fichier de feuille de calcul dans le sens où vous ne pouvez enregistrer ni la mise en forme, ni les formules.

Télécharger et ouvrir un exemple de fichier .csv dans le cadre de l’importation de contacts dans Outlook

  1. Téléchargez cet exemple de fichier .csv sur votre ordinateur. Lorsque vous y êtes invité, choisissez d’enregistrer le fichier sur votre ordinateur en tant que fichier CSV. Si vous l’enregistrez en tant que fichier Excel (.xls ou .xlsm), l’ensemble des données seront insérées dans une seule colonne.

    Lorsque vous téléchargez l’exemple de fichier .csv, enregistrez-le sur votre ordinateur en tant que fichier .csv.

  2. Sur votre ordinateur, ouvrez Excel.

  3. Dans Excel, accédez à Fichier > Ouvrir, puis accédez au fichier .csv que vous venez de télécharger sur votre ordinateur. Pour trouver le fichier .csv, n’oubliez pas de rechercher dans Tous les fichiers. Cliquez sur le fichier .csv pour l’ouvrir.

    Pour trouver le fichier CSV, n’oubliez pas de rechercher dans Tous les fichiers.

Voici quelques points à retenir lorsque vous utilisez cet exemple de fichier CSV :

  • Outlook a besoin des en-têtes de colonne dans la première ligne, aussi ne les remplacez pas par d’autres informations.

    Voici à quoi ressemble l’exemple de fichier .csv dans Excel

  • Vous pouvez supprimer les données dans les lignes 2-6 (les exemples de noms, numéros de téléphone, adresses de courrier, etc).

  • Vous n’avez pas besoin d’entrer de valeurs pour chaque colonne. Entrez uniquement les informations dont vous avez besoin.

  • Enregistrez le fichier avec un nouveau nom et spécifiez le format CSV (.csv). Si vous utilisez Excel pour travailler dans le fichier, lorsque vous enregistrez celui-ci, Excel affiche un message du type « Voulez-vous vraiment enregistrer ce fichier au format CSV ? ». Sélectionnez toujours Oui. Si vous choisissez Non, le fichier ne sera pas correctement enregistré et vous devrez recommencer l’opération avec un nouvel exemple de modèle.

  • Importez votre fichier CSV avec quelques contacts pour vérifier que les résultats vous conviennent. Vous pouvez ensuite supprimer les contacts importés, en ajouter d’autres à votre fichier CSV, puis réimporter celui-ci.

    Si vous alliez importer les données contenues dans cet exemple de fichier CSV, le résultat obtenu dans Office 365 Outlook sur le web aurait été le suivant :

    Une fois vos contacts importés, ils ressemblent à ceci dans Outlook sur le web.

Modifier un fichier .csv de contacts que vous souhaitez importer dans Outlook

Imaginons que vous vouliez modifier un fichier .csv que vous avez exporté à partir d’Outlook, puis que vous souhaitiez le réimporter dans Outlook ou un autre fournisseur de courrier. L’utilisation d’Excel permet de modifier le fichier .csv facilement.

Voici quelques points à retenir concernant la modification d’un fichier .csv :

  • Conservez les en-têtes de colonne dans la première ligne.

  • Lorsque vous l’enregistrez, Excel affiche plusieurs fois un message du type « Voulez-vous vraiment enregistrer ce fichier au format CSV ? » Sélectionnez toujours Oui. Si vous choisissez Non, le fichier n’est pas correctement enregistré et vous devez recommencer.

Problème : Toutes mes données s’affichent dans la première colonne

Exemple de fichier .csv enregistré au format .xls.

Voici quelques raisons qui peuvent être à l’origine du problème ainsi que des solutions pour le résoudre :

  • Si vous enregistrez le fichier CSV dans un autre format, tel que .xls ou .xlm, l’ensemble des données s’affichent dans la première colonne. Revenez au fichier CSV d’origine et assurez-vous de l’enregistrer au format .csv.

  • Il est possible que le programme qui a créé le fichier CSV ait ajouté des guillemets supplémentaires dans les données. Par conséquent, Excel traite les données comme une seule unité. Par exemple, imaginons que vos données ressemblent à celles-ci :

    a, b, c, d - Excel place chaque lettre dans sa propre colonne.

    "a, b, c, d", e - Excel place a,b,c,d dans une colonne et e dans une autre colonne.

    Pour savoir si vous rencontrez ce problème dans votre fichier, ouvrez ce dernier dans le Bloc-notes : Cliquez avec le bouton droit sur le fichier CSV dans Windows, puis sélectionnez Ouvrir avec > Bloc-notes. Recherchez la présence de guillemets supplémentaires.

    Si vous en trouvez, voici comment résoudre le problème dans votre fichier :

    1. Utilisez Excel pour ouvrir le fichier CSV. Toutes les données sont dans la colonne A et les guillemets sont absents.

    2. Utilisez maintenant l’Assistant Conversion pour répartir les données de la colonne A dans plusieurs colonnes individuelles. Dans la barre de menus, sélectionnez Données > Convertir.

      Sélectionnez Données > Convertir.

    3. Sélectionnez Délimité > Suivant. Sélectionnez ensuite Virgule > Terminer.

    4. Enregistrez le fichier au format.csv de manière à pouvoir l’importer dans Outlook.

Voir aussi

Importer des contacts dans Outlook

Exporter des contacts à partir d’Outlook

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×