Créer ou exécuter une macro

Dans Word, vous pouvez automatiser les tâches fréquentes moyennant la création et l’exécution de macros. Une macro est une série de commandes et d’instructions que vous regroupez au sein d’une même commande afin d’exécuter automatiquement une tâche.

Pour gagner du temps avec les tâches que vous effectuez fréquemment, regroupez les différentes étapes au sein d’une macro. D’abord, vous enregistrez la macro. Puis, vous l’exécutez en cliquant sur un bouton de la barre d’outils Accès rapide ou en appuyant sur une combinaison de touches, selon la configuration définie.

  1. Cliquez sur Affichage > Macros > Enregistrer une macro.

    Commande Enregistrer une macro

  2. Tapez le nom de la macro.

    Zone Nom de la macro

  3. Pour pouvoir utiliser cette macro dans tous vos nouveaux documents, assurez-vous que la zone Enregistrer la macro dans contient Tous les documents (normal.dotm).

    Zone du choix de l’emplacement de l’enregistrement d’une macro

  4. Pour exécuter la macro quand vous cliquez sur un bouton, cliquez sur Bouton.

    Cliquez pour affecter la macro à un bouton

  5. Cliquez sur la nouvelle macro (elle s’intitule approximativement Normal.NewMacros.<votre nom de macro>), puis cliquez sur Ajouter.

    Macro et bouton Ajouter

  6. Cliquez sur Modifier.

    Bouton Modifier de la zone Personnaliser la barre d’outils Accès rapide

  7. Choisissez une image de bouton, entrez le nom de votre choix, puis cliquez sur OK à deux reprises.

    Options de bouton de la zone Bouton Modifier

  8. À présent, il est temps d’enregistrer les étapes. Cliquez sur les commandes ou appuyez sur les touches de chaque étape de la tâche. Word enregistre vos clics et vos séries de touches.

    Remarque : Utilisez le clavier pour sélectionner le texte et enregistrer la macro. Les macros n’enregistrent pas les sélections effectuées à l’aide de la souris.

  9. Pour arrêter l’enregistrement, cliquez sur Affichage > Macros > Arrêter l’enregistrement.

    Commande Arrêter l’enregistrement

Le bouton de la macro apparaît alors sur la barre d’outils Accès rapide.

Bouton Macro de la barre d’outils Accès rapide

Pour exécuter la macro, cliquez sur le bouton.

  1. Cliquez sur Affichage > Macros > Enregistrer une macro.

    Commande Enregistrer une macro

  2. Tapez le nom de la macro.

    Zone Nom de la macro

  3. Pour pouvoir utiliser cette macro dans tous vos nouveaux documents, assurez-vous que la zone Enregistrer la macro dans contient Tous les documents (normal.dotm).

    Zone du choix de l’emplacement de l’enregistrement d’une macro

  4. Pour exécuter la macro quand vous appuyez sur un raccourci clavier, cliquez sur Clavier.

    Cliquez pour affecter la macro à un raccourci clavier

  5. Tapez la combinaison des touches dans la zone Nouvelle touche de raccourci.

  6. Vérifiez que cette combinaison ne soit pas déjà attribuée à une autre commande. Si tel est le cas, essayez une autre combinaison.

  7. Pour pouvoir utiliser ce raccourci clavier dans tous vos nouveaux documents, assurez-vous que la zone Enregistrer dans contient Normal.dotm.

  8. Cliquez sur Assigner.

  9. À présent, il est temps d’enregistrer les étapes. Cliquez sur les commandes ou appuyez sur les touches de chaque étape de la tâche. Word enregistre vos clics et vos séries de touches.

    Remarque : Utilisez le clavier pour sélectionner le texte et enregistrer la macro. Les macros n’enregistrent pas les sélections effectuées à l’aide de la souris.

  10. Pour arrêter l’enregistrement, cliquez sur Affichage > Macros > Arrêter l’enregistrement.

    Commande Arrêter l’enregistrement

Pour exécuter la macro, appuyez sur les touches du raccourci clavier.

Pour exécuter une macro, cliquez sur le bouton dans la barre d’outils Accès rapide, appuyez sur le raccourci clavier. Vous pouvez également exécuter la macro depuis la liste Macros.

  1. Cliquez sur Affichage > Macros > Afficher les macros.

    Commande Afficher les macros

  2. Dans la liste située sous Nom de la macro, cliquez sur la macro que vous souhaitez exécuter.

  3. Cliquez sur Exécuter.

Pour qu’une macro d’un document soit disponible dans tous les nouveaux documents, ajoutez-la au modèle Normal.dotm.

  1. Ouvrez le document contenant les macros.

  2. Cliquez sur Affichage > Macros > Afficher les macros.

    Commande Afficher les macros

  3. Cliquez sur Organiser.

    Bouton Organiser dans la zone Afficher les macros

  4. Cliquez sur la macro que vous voulez ajouter au modèle Normal.dotm, puis cliquez sur Copier.

  1. Cliquez sur Fichier > Options > Personnaliser le ruban.

  2. Sous Choisir les commandes dans les catégories suivantes, cliquez sur Macros.

  3. Cliquez sur la macro souhaitée.

  4. Sous Personnaliser le ruban, cliquez sur l’onglet et le groupe personnalisé auquel vous voulez ajouter la macro.

Si vous n’avez pas de groupe personnalisé, cliquez sur Nouveau groupe. Puis, cliquez sur Renommer et entrez un nom pour votre groupe personnalisé.

  1. Cliquez sur Ajouter.

  2. Cliquez sur Renommer pour choisir une image pour la macro et entrez le nom de votre choix.

  3. Cliquez sur OK à deux reprises.

  1. Sous l’onglet Développeur, dans le groupe Code, cliquez sur Macros.

  2. Dans la zone Nom de la macro, entrez le nom de la macro.

    Remarque : Si vous attribuez à une nouvelle macro le nom d’une macro intégrée dans Word, les actions de la nouvelle macro remplaceront celles de la macro intégrée. Pour afficher la liste des macros intégrées, cliquez sur Commandes Word dans la liste Macros disponibles dans.

  3. Dans la liste Macros disponibles dans, cliquez sur le modèle ou le document dans lequel vous souhaitez enregistrer la macro.

    Pour que votre macro soit disponible dans tous les documents, veillez à cliquer sur Normal.dotm.

  4. Cliquez sur Créer pour ouvrir Visual Basic Editor.

Après avoir ouvert Visual Basic Editor, vous souhaiterez peut-être en savoir plus sur l’utilisation de Visual Basic pour Applications. Pour plus d’informations, cliquez sur Aide de Microsoft Visual Basic dans le menu Aide ou appuyez sur F1.

Vous pouvez enregistrer une séquence d’actions ou créer une macro de toutes pièces en entrant du code Visual Basic pour Applications dans Visual Basic Editor.

Remarque : Pour utiliser des macros Office Word 2007, affichez l’onglet Développeur.

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Word.

  2. Cliquez sur Standard.

  3. Sous Options courantes à utiliser avec Word, activez la case à cocher Afficher l’onglet Développeur dans le ruban.

    Remarque : Le ruban est un élément de l’Interface utilisateur Microsoft Office Fluent.

  1. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Enregistrer une macro.

    Groupe Code de l’onglet Développeur
  2. Dans la zone Nom de la macro, entrez le nom de la macro.

    Remarque : Si vous attribuez à une nouvelle macro le nom d’une macro intégrée dans Office Word 2007, les actions de la nouvelle macro remplaceront celles de la macro intégrée. Pour afficher la liste des macros intégrées, dans l’onglet Développeur du groupe Code, cliquez sur Macros. Dans la liste Macros disponibles dans, cliquez sur Commandes Word.

  3. Dans la zone Enregistrer la macro dans, cliquez sur le modèle ou le document dans lequel vous souhaitez enregistrer la macro.

    Important : Pour que votre macro soit disponible dans tous les documents, veillez à cliquer sur Normal.dotm.

  4. Dans la zone Description, tapez une description de la macro.

  5. Effectuez l’une des opérations suivantes :

    • Lancer l’enregistrement    Pour lancer l’enregistrement de la macro sans l’affecter à un bouton de la barre d’outils Accès rapide ou à une touche de raccourci, cliquez sur OK.

    • Créer un bouton    Pour affecter la macro à un bouton de la barre d’outils Accès rapide, procédez comme suit :

      1. Cliquez sur Bouton.

      2. Sous Personnaliser la barre d’outils Accès rapide, sélectionnez le ou les documents pour lesquels vous souhaitez ajouter la macro dans la barre d’outils Accès rapide.

        Important : Pour que votre macro soit disponible dans tous les documents, veillez à cliquer sur Normal.dotm.

      3. Dans la boîte de dialogue Choisir les commandes dans les catégories suivantes, cliquez sur la macro à enregistrer, puis sur Ajouter.

      4. Pour personnaliser le bouton, cliquez sur Modifier.

      5. Sous Symbole, cliquez sur le symbole que vous voulez utiliser pour votre bouton.

      6. Dans la zone Nom complet, tapez le nom de la macro que vous voulez afficher.

      7. Cliquez deux fois sur OK pour lancer l’enregistrement de la macro.

        Le symbole que vous choisissez s’affiche dans la barre d’outils Accès rapide Le nom que vous entrez s’affiche lorsque vous pointez sur le symbole.

    • Affecter un raccourci clavier    Pour affecter la macro à un raccourci clavier, procédez comme suit :

      1. Cliquez sur Clavier.

      2. Dans la zone Commandes, cliquez sur la macro à enregistrer.

      3. Dans la zone Nouvelle touche de raccourci, tapez la combinaison de touches de votre choix, puis cliquez sur Attribuer.

      4. Cliquez sur Fermer pour lancer l’enregistrement de la macro.

  6. Effectuez les opérations à inclure dans la macro.

    Remarque : Lorsque vous enregistrez une macro, vous pouvez utiliser la souris pour cliquer sur des commandes et des options, mais pas pour sélectionner du texte. Pour sélectionner du texte, vous devez utiliser le clavier. Pour plus d’informations sur la sélection du texte à l’aide du clavier, voir Sélectionner du texte.

  7. Pour arrêter l’enregistrement de vos actions, cliquez sur Arrêter l’enregistrement dans le groupe Code.

Modifier le raccourci clavier affecté à une macro

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Word.

  2. Cliquez sur Personnaliser.

  3. En regard de Raccourcis clavier, cliquez sur Personnaliser.

  4. Dans la liste Catégories, cliquez sur Macros.

  5. Dans la liste Macros, cliquez sur la macro que vous voulez modifier.

  6. Dans la zone Nouvelle touche de raccourci, tapez la combinaison de votre choix.

  7. Activez la case à cocher Touches actuelles pour vous assurer que vous n’affectez pas une combinaison de touches déjà utilisée pour effectuer une autre tâche.

  8. Dans la liste Enregistrer les modifications dans, cliquez sur l’option qui correspond à l’emplacement souhaité pour l’exécution de votre macro.

    Important : Pour que votre macro soit disponible dans tous les documents, veillez à cliquer sur Normal.dotm.

  9. Cliquez sur Fermer.

  1. Dans l’onglet Développeur, dans le groupe Code, cliquez sur Macros.

    Groupe Code de l’onglet Développeur

  2. Dans la liste sous Nom de la macro, cliquez sur la macro à exécuter.

  3. Cliquez sur Exécuter.

  1. Sous l’onglet Développeur, dans le groupe Code, cliquez sur Macros.

    Groupe Code de l’onglet Développeur

  2. Dans la zone Nom de la macro, entrez le nom de la macro.

    Remarque : Si vous attribuez à une nouvelle macro le nom d’une macro intégrée dans Office Word 2007, les actions de la nouvelle macro remplaceront celles de la macro intégrée. Pour afficher la liste des macros intégrées, cliquez sur Commandes Word dans la liste Macros disponibles dans.

  3. Dans la liste Macros disponibles dans, cliquez sur le modèle ou le document dans lequel vous souhaitez stocker la macro.

    Pour que votre macro soit disponible dans tous les documents, veillez à cliquer sur Normal.dotm.

  4. Cliquez sur Créer pour ouvrir Visual Basic Editor.

Après avoir ouvert Visual Basic Editor, vous souhaiterez peut-être en savoir plus sur l’utilisation de Visual Basic pour Applications. Pour plus d’informations, cliquez sur Aide de Microsoft Visual Basic dans le menu Aide ou appuyez sur F1.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×