Office
Se connecter
Créer des tables dans une base de données

Créer des tables dans une base de données

Lorsque vous créez une base de données Access, vous stockez vos données dans des tables, listes d’objets contenant des lignes et colonnes. Par exemple, vous pouvez créer une table Contacts pour stocker une liste de noms, adresses et numéros de téléphone, ou une table Produits pour stocker des informations sur des produits.

Cet article explique comment créer une table, ajouter des champs à une table et définir la clé primaire d’une table. Il explique également comment définir des propriétés de champ et de table.

Étant donné que d’autres objets de base de données dépendent lourdement des tables, vous devez toujours commencer la conception d’une base de données en créant toutes ses tables, puis des autres objets. Avant de créer des tables, examinez soigneusement vos besoins et identifiez toutes les tables nécessaires. Pour une introduction à la planification et à la conception d’une base de données, voir l’article Concepts de base de la conception de base de données.

Contenu de cet article

Vue d’ensemble

Créer une table

Ajouter un champ à une table

Enregistrer une table

Vue d’ensemble

Une table est un objet de base de données permettant de stocker des données sur un sujet particulier, par exemples, des employés ou des produits. Une table se compose d’enregistrements et de champs.

Chaque enregistrement contient des données sur une instance du sujet de la table, par exemple, un employé spécifique. Un enregistrement est aussi communément appelé ligne ou instance.

Chaque champ contient des données concernant un aspect du sujet de la table, tel que le prénom ou l’adresse de messagerie. Un champ est aussi communément appelé colonne ou attribut.

Un enregistrement se compose de valeurs de champ, par exemple, Contoso, Ltd. ou xyz@example.com. Une valeur de champ est aussi communément appelée fait.

Table Clients dans Access montrant la disposition d’enregistrements et de champs

1. Enregistrement

2. Champ

3. Valeur de champ

Une base de données Access peut contenir de nombreuses tables stockant chacune des informations sur un sujet distinct. Chaque table peut comprendre de nombreux champs contenant différents types de données, telles que du texte, des nombres, des dates et des liens hypertexte.

Propriétés de table et de champ

Les tables et les champs ont également des propriétés que vous pouvez définir pour contrôler leurs caractéristiques ou leur comportement.

Feuilles de propriétés de table et de champ
Table ouverte en mode Création.

1. Propriétés d’une table

2. Propriétés d’un champ

Dans une base de données Access, les propriétés d’une table sont des attributs qui affectent l’apparence ou le comportement de celle-ci dans son ensemble. Les propriétés d’une table sont définies dans la feuille de propriétés de celle-ci, en mode Création. Par exemple, vous pouvez définir la propriété Affichage par défaut d’une table pour spécifier la manière dont celle-ci s’affiche par défaut.

Une propriété de champ s’applique à un champ spécifique dans une table, et définit l’une des caractéristiques ou un aspect du comportement du champ. Vous pouvez définir certaines propriétés de champ dans mode Feuille de données. Vous pouvez également définir toute propriété de champ en mode Création à l’aide du volet Propriétés du champ.

Types de données

Chaque champ présente un type de données. Le type de données d’un champ indique le genre de données qui y sont stockées, par exemple, de grandes quantités de texte ou des fichiers joints.

Paramètre de type de données

Un type de données est une propriété de champ qui diffère cependant des autres propriétés comme suit :

  • Vous définissez le type de données d’un champ dans la grille de création de table, pas dans le volet Propriétés du champ.

  • Le type de données d’un champ détermine les autres propriétés de celui-ci.

  • Vous devez définir le type de données d’un champ lors de la création de celui-ci.

    Vous pouvez créer un champ dans Access en entrant des données dans une nouvelle colonne en mode Feuille de données. Lorsque vous créez un champ de cette manière, Access affecte automatiquement un type de données au champ, en fonction de la valeur que vous entrez. Si aucun autre type de données n’est impliqué par votre saisie, Access sélectionne Texte comme type de données. Le cas échéant, vous pouvez modifier le type de données à l’aide du ruban.

Exemples détection automatique du type de données

Le tableau suivant montre comment fonctionne la détection automatique du type de données en Mode Feuille de données.

Si vous entrez :

Access crée un champ avec le type de données :

Gilbert

Texte

http://www.contoso.com

Vous pouvez utiliser n’importe quel préfixe de protocole Internet valide. Par exemple, http://, https:// et mailto : sont des préfixes valides.

Lien hypertexte

1

Nombre, Entier long

50 000

Nombre, Entier long

50 000,99

Nombre, Double

50000,389

Nombre, Double

12/67

Les formats de date et heure reconnus sont ceux de vos paramètres régionaux utilisateur.

Date/Heure

31 décembre 2016

Date/Heure

10:50:23

Date/Heure

10:50

Date/Heure

17:50

Date/Heure

12,50 €

Le symbole monétaire reconnu est celui de vos paramètres régionaux utilisateur.

Devise

21,75

Nombre, Double

123,00%

Nombre, Double

3.46E+03

Nombre, Double

Relations de la table

Bien que chaque table stocke des données sur un sujet différent, les tables d’une base de données Access stockent généralement des données concernant des sujets entre lesquels une relation existe. Par exemple, une base de données peut contenir ce qui suit :

  • une table de clients qui répertorie les clients de votre société et leurs adresses ;

  • une table de produits qui répertorie les produits vendus, avec les prix et les photos de chaque article ;

  • une table de commandes qui permet d’effectuer le suivi des commandes des clients.

Étant donné que vous stockez des données concernant des sujets différents dans des tables distinctes, vous devez disposer d’un moyen de lier les données de façon à pouvoir aisément combiner des données connexes de tables distinctes. Pour connecter des données stockées dans des tables différentes, vous créez des relations. Une relation est une connexion logique entre deux tables, qui spécifie les champs que celles-ci ont en commun.

Clés

Les champs qui font partie d’une relation de table portent le nom de « clé ». Une clé se compose généralement d’un seul champ, mais cela n’est pas toujours le cas. Il existe deux types de clés :

  • Clé primaire    Une table ne peut avoir qu’une seule clé primaire. Une clé primaire se compose d’un ou plusieurs champs identifiant de manière unique chaque enregistrement stocké dans la table. Souvent, un numéro d’identification unique, tel qu’un Numéro d’ID, un numéro de série ou un code, fait office de clé primaire. Par exemple, vous pouvez avoir une table Clients dans laquelle chaque client a un numéro d’ID client unique. Le champ ID client est la clé primaire de la table Clients. Quand une clé primaire contient plusieurs champs, elle est généralement composée de champs préexistants dont la combinaison produit des valeurs uniques. Par exemple, vous pouvez utiliser une combinaison de nom, de prénom et de date de naissance comme clé primaire pour une table concernant des personnes.

  • Clé étrangère    Une table peut avoir une ou plusieurs clés étrangères. Une clé étrangère contient des valeurs qui correspondent à des valeurs figurant dans la clé primaire d’une autre table. Par exemple, vous pouvez avoir une table Commandes dans laquelle chaque commande a un ID client correspondant à un enregistrement dans la table Clients. Le champ d’ID client est alors une clé étrangère de la table Commandes.

La correspondance des valeurs entre les champs clés forme la base d’une relation de table. On utilise une relation de table pour combiner des données de tables liées. Par exemple, supposez que vous avez une table Clients et une table Commandes. Dans votre table Clients, chaque enregistrement est identifié par le champ de clé primaire, ID.

Pour associer chaque commande à un client, vous ajoutez un champ de clé étrangère à la table Commandes qui correspond au champ ID de la table Clients, puis vous créez une relation entre les deux clés. Lorsque vous ajoutez un enregistrement à la table Commandes, vous utilisez une valeur d’ID de client issue de la table Clients. Lorsque vous souhaitez afficher des informations concernant la commande d’un client, vous utilisez la relation pour identifier les données de la table Clients qui correspondent aux différents enregistrements de la table Commandes.

Relation de table Access affichée dans la fenêtre Relations
Relation de table affichée dans la fenêtre Relations.

1. Clé primaire, identifiée par l’icône de clé en regard du nom de champ.

2. Une clé étrangère (notez l’absence d’icône de clé).

Avantages offerts par l’utilisation de relations

Le fait de conserver les données séparées dans des tables liées offre les avantages suivants :

  • Cohérence    Chaque élément de données n’étant enregistré qu’une seule fois, dans une seule table, il existe moins de risque d’ambiguïté ou d’incohérence. Par exemple, vous stockez le nom d’un client une seule fois, dans une table qui concerne les clients, plutôt qu’à plusieurs reprises (avec le risque d’incohérence qui en découle) dans une table qui contient des données relatives aux commandes.

  • Efficacité    L’enregistrement des données dans un seul emplacement permet d’utiliser moins d’espace disque. En outre, les tables plus compactes offrent en général un traitement des données plus rapide que les tables volumineuses. Pour finir, si vous n’utilisez pas des tables distinctes pour des sujets distincts, vous introduirez des valeurs Null (absence de données) et une redondance dans vos tables, ce qui peut nuire aux performances et utiliser de l’espace inutilement.

  • Facilité de compréhension    La structure d’une base de données est plus simple à comprendre si les sujets sont séparés correctement dans des tables.

Conseil : Planifiez votre tables en ayant les relations à l’esprit. Vous pouvez utiliser l’Assistant Liste de choix pour créer un champ de clé étrangère si la table contenant la clé primaire correspondante existe déjà. L’Assistant Liste de choix crée la relation pour vous.

Haut de la page

Créer une table

Une base de données simple telle qu’une liste de contacts peut utiliser une seule table. Toutefois, de nombreuses bases de données utilisent plusieurs tables. Lorsque vous créez une base de données, vous créez sur votre ordinateur un fichier faisant office de conteneur pour tous les objets figurant dans votre base de données, dont vos tables.

Vous pouvez créer une base de données en insérant une table dans une base de données existante, ou en important ou liant une table d’une autre source de données (telle qu’un classeur Microsoft Excel, un document Microsoft Word, un fichier texte ou une autre base de données). Lorsque vous créez une base de données vide, une nouvelle table vide est insérée automatiquement. Vous pouvez ensuite entrer des données dans cette table pour commencer à définir vos champs.

Que voulez-vous faire ?

Créer une table dans une nouvelle base de données

Créer une table dans une base de données existante

Importer ou lier pour créer une table

Utiliser un site SharePoint pour créer une table

Définir la clé primaire d’une table

Définir les propriétés d’une table

Créer une table dans une nouvelle base de données

  1. Cliquez sur Fichier > Nouveau. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office > Nouveau.

  2. Dans la zone Nom de fichier, tapez un nom de fichier pour la nouvelle base de données.

  3. Pour enregistrer la base de données dans un autre emplacement, cliquez sur l’icône de dossier.

  4. Cliquez sur Créer.

    La nouvelle base de données s’ouvre, et une nouvelle table nommée Table1 est créée et s’ouvre en mode Feuille de données.

Créer une table dans une base de données existante

  1. Cliquez sur Fichier > Ouvrir. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données que vous voulez ouvrir, puis cliquez sur Ouvrir.

  3. Sous l’onglet Création, dans le groupe Tables, cliquez sur Table.

    Une nouvelle table est insérée dans la base de données, qui s’ouvre en mode Feuille de données.

Importer ou lier pour créer une table

Vous pouvez créer une table en important des données stockées ailleurs ou en créant un lien avec ces données. Vous pouvez importer ou lier les données d’une feuille de calcul Excel, d’une liste SharePoint, d’un fichier XML, d’une autre base de données Access, d’un dossier Microsoft Outlook et de bien d’autres éléments.

Lorsque vous importez des données, vous créez une copie de ces données dans une nouvelle table de la base de données active. Les modifications apportées ultérieurement aux données sources n’auront aucun effet sur les données importées et les modifications apportées aux données importées n’affectent pas les données sources. Après vous être connecté à une source de données et avoir importé ses données, vous pouvez utiliser les données importées sans vous connecter à la source. Vous pouvez modifier la structure d’une table importée.

Lorsque vous établissez un lien à des données, vous créez une table liée dans la base de données active qui représente un lien actif aux informations existantes stockées autre part. Lorsque vous modifiez des données dans une table liée, vous les modifiez dans la source. Chaque fois que des données changent dans la source, ce changement est affiché dans la table liée. Vous devez être en mesure de vous connecter à la source de données chaque fois que vous utilisez une table liée.

Remarque : Vous ne pouvez pas modifier les données d’une feuille de calcul Excel au moyen d’une table liée. Une solution de contournement consiste à importer les données sources dans une base de données Access, puis à établir un lien avec la base de données à partir d’Excel.

Créer une table en important ou en liant des données externes

  1. Cliquez sur Fichier > Ouvrir. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez et ouvrez la base de données dans laquelle vous voulez créer une table.

  3. Sous l’onglet Données externes, dans le groupe Importer et lier, cliquez sur l’une des sources de données disponibles. Si vous utilisez Access 2007, les sources de données figurent dans le groupe Importer.

    Image du ruban Access

  4. Suivez les instructions fournies par les boîtes de dialogue qui s’affichent à chaque étape.

    Access crée la nouvelle table et l’affiche dans le volet de navigation.

Vous pouvez également importer ou lier une liste SharePoint à l’aide d’une commande sous l’onglet Créer.

Haut de la page

Utiliser un site SharePoint pour créer une table

Vous pouvez créer une table dans votre base de données, qui importe ou lie une liste SharePoint. Vous pouvez également créer une liste SharePoint au moyen d’un modèle prédéfini. Les modèles prédéfinis dans Access sont Contacts, Tâches, Problèmes et Événements.

  1. Cliquez sur Fichier > Ouvrir. Si vous utilisez Access 2007, cliquez sur le bouton Microsoft Office > Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données dans laquelle vous voulez créer la table, puis cliquez sur Ouvrir.

  3. Sous l’onglet Création, dans le groupe Tables, cliquez sur Listes SharePoint.

  4. Vous pouvez effectuer l’une des opérations suivantes :

    • Créer une liste SharePoint basée sur un modèle

      1. Cliquez sur Contacts, Tâches, Problèmes ou Événements.

      2. Dans la boîte de dialogue Créer une nouvelle liste, tapez l’URL du site SharePoint sur lequel vous souhaitez créer la liste.

      3. Entrez un nom et une description pour la nouvelle liste dans les zones Spécifiez le nom de la nouvelle liste et Description.

      4. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

    • Créer une nouvelle liste personnalisée

      1. Cliquez sur Personnalisé.

      2. Dans la boîte de dialogue Créer une nouvelle liste, tapez l’URL du site SharePoint sur lequel vous souhaitez créer la liste.

      3. Entrez un nom et une description pour la nouvelle liste dans les zones Spécifiez le nom de la nouvelle liste et Description.

      4. Pour ouvrir la table liée après sa création, activez la case à cocher Ouvrir la liste une fois l’opération terminée (activée par défaut).

    • Importer des données dans une liste existante

      1. Cliquez sur Liste SharePoint existante.

      2. Dans la boîte de dialogue Données externes, tapez l’URL du site SharePoint qui contient les données à importer.

      3. Cliquez sur Importer les données sources dans une nouvelle table de la base de données active, puis sur Suivant.

      4. Activez la case à cocher en regard de chaque liste SharePoint que vous souhaitez importer.

    • Établir un lien à une liste existante

      1. Cliquez sur Liste SharePoint existante.

      2. Dans la boîte de dialogue Données externes - Site SharePoint, tapez l’URL du site SharePoint qui contient la liste vers laquelle vous souhaitez établir un lien.

      3. Cliquez sur Lier à la source de données en créant une table attachée, puis sur Suivant.

      4. Activez la case à cocher en regard de chaque liste SharePoint vers laquelle vous souhaitez établir un lien.

Haut de la page

Définir la clé primaire d’une table

Sauf si vous avez un motif spécifique ne pas le faire, vous devez spécifier une clé primaire pour une table. Access crée automatiquement un index pour la clé primaire, qui peut contribuer à améliorer les performances de la base de données. Access vérifie également que chaque enregistrement a une valeur dans le champ de clé primaire, et que cette valeur est toujours unique. Il est essentiel que les valeurs soient uniques car, dans le cas contraire, il n’existe aucun moyen fiable de distinguer une ligne particulière des autres.

Lorsque vous créez une table en mode Feuille de données, Access crée automatiquement une clé primaire à laquelle il affecte le nom de champ ID et le type de données NuméroAuto.

En mode Création, vous pouvez modifier ou supprimer la clé primaire, ou définir la clé primaire pour une table qui n’en a pas.

Déterminer les champs à utiliser comme clé primaire

Il peut arriver que vous ayez déjà des données que vous voulez utiliser comme clé primaire. Par exemple, vous avez peut-être des numéros d’ID existants pour vos employés. Si vous créez une table pour effectuer le suivi des informations des employés, vous pouvez décider d’utiliser l’ID d’employé comme clé primaire pour cette table. Ou peut-être que l’ID d’employé n’est unique que combiné avec l’ID du service, de sorte que vous devez utiliser les deux champs conjointement comme clé primaire. Une bonne clé primaire présente les caractéristiques suivantes :

  • Chaque enregistrement a une valeur unique pour le champ ou la combinaison de champs.

  • Le champ ou la combinaison des champs ne sont jamais vides ou null. Ils contiennent toujours une valeur.

  • Les valeurs ne changent pas.

S’il n’existe aucune donnée appropriée utilisable comme clé primaire, vous pouvez créer un champ à utiliser comme clé primaire. Lorsque vous créez un champ à utiliser comme clé primaire, définissez le type de données NuméroAuto pour être certain qu’il présente les trois caractéristiques énoncées ci-dessus.

Définir ou modifier la clé primaire

  1. Sélectionnez la table dont vous voulez définir ou modifier la clé primaire.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Dans la grille de création de table, sélectionnez le ou les champs à utiliser comme clé primaire.

    Pour sélectionner un seul champ, cliquez sur le sélecteur de ligne correspondant au champ souhaité.

    Pour sélectionner plusieurs champs, maintenez la touche CTRL enfoncée, puis cliquez sur le sélecteur de ligne de chacun d’eux.

  4. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

    Groupe Outils sous l’onglet Création

    Un indicateur de clé s’affiche à gauche du ou des champs spécifiés comme clé primaire.

Supprimer la clé primaire

  1. Sélectionnez la table dont vous voulez supprimer la clé primaire.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Cliquez sur le sélecteur de ligne correspondant à la clé primaire actuelle. Si la clé primaire est constituée de plusieurs champs, maintenez la touche CTRL enfoncée, puis cliquez sur le sélecteur de ligne correspondant à chaque champ.

  4. Sous l’onglet Création, dans le groupe Outils, cliquez sur Clé primaire.

    Groupe Outils sous l’onglet Création

    L’indicateur de clé est alors supprimé du ou des champs spécifiés comme clé primaire.

Remarque : Lorsque vous enregistrez une nouvelle table sans définir de clé primaire, Access vous invite à créer un champ pour la clé primaire. Si vous cliquez sur Oui, Access crée un champ ID qui utilise le type de données NuméroAuto afin de fournir une valeur unique pour chaque enregistrement. Si votre table contient déjà un champ NuméroAuto, Access l’utilise comme clé primaire. Si vous cliquez sur Non, Access n’ajoute pas de champ, et aucune clé primaire n’est définie.

Haut de la page

Définir les propriétés d’une table

En plus de définir des champs de propriétés, vous pouvez définir des propriétés qui s’appliquent à une table ou à des enregistrements entiers.

  1. Sélectionnez la table dont vous souhaitez définir les propriétés.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Création.

  3. Sous l’onglet Création, dans le groupe Afficher/Masquer, cliquez sur Feuille de propriétés.

    Groupe Afficher/Masquer sous l’onglet Création dans Access

    La feuille de propriétés de la table s’affiche.

  4. Dans la feuille de propriétés, cliquez sur l’onglet Général.

  5. Cliquez sur la zone à gauche de la propriété que vous voulez définir, puis entrez un paramètre pour la propriété.

    Propriétés de table disponibles

    Utilisez cette propriété de table

    Pour

    Afficher les vues sur un site SharePoint

    Spécifier si les affichages basés sur la table peuvent être affichés sur un site SharePoint.

    Remarque : Les effets de ce paramètre dépendent du paramètre de la propriété de base de données Afficher les vues sur un site SharePoint.

    Sous-feuille de données étendue

    Développer toutes les sous-feuilles de données lorsque vous ouvrez la table.

    Hauteur de la sous-feuille de données

    Effectuez l’une des opérations suivantes :

    • Si vous souhaitez que la fenêtre de sous-feuille de données soit étendue de façon à afficher toutes les lignes, affectez la valeur 0" à cette propriété.

    • Si vous souhaitez contrôler la hauteur de la sous-feuille de données, entrez la hauteur souhaitée en pouces.

    Orientation

    Définir l’orientation de l’affichage en fonction du sens de lecture de votre langue, de gauche à droite ou de droite à gauche.

    Description

    Fournir une description de la table, qui s’affichera dans les info-bulles relatives à celle-ci.

    Affichage par défaut

    Définir Feuille de données, Tableau croisé dynamique ou Graphique croisé dynamique comme affichage par défaut lorsque vous ouvrez la table. Notez que les options Tableau croisé dynamique et Graphique croisé dynamique ont été supprimées depuis Access 2013.

    Règle de validation

    Entrer une expression qui doit être vraie lorsque vous ajoutez ou modifiez un enregistrement.

    Texte de validation

    Entrer un message qui s’affiche quand un enregistrement n’est pas conforme à l’expression dans la propriété Règle de validation.

    Filtre

    Définir des critères pour afficher uniquement certaines lignes en mode Feuille de données.

    Tri par

    Sélectionner un ou plusieurs champs pour spécifier l’ordre de tri par défaut des lignes en mode Feuille de données.

    Nom de la sous-feuille de données

    Spécifier si une sous-feuille doit s’afficher en mode Feuille de données et, dans l’affirmative, la table ou la requête qui doit fournir les lignes dans la sous-feuille.

    Lier les champs enfants

    Répertorier les champs dans la table ou la requête qui sont utilisés pour la sous-feuille de données et qui correspondent à la propriété Lier les champs pères spécifiée pour la table.

    Lier les champs pères

    Répertorier les champs dans la table qui correspondent à la propriété Lier les champs enfants spécifiée pour la table.

    Filtrer au chargement

    Appliquer automatiquement les critères de filtre définis dans la propriété Filtre (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Trier au chargement

    Appliquer automatiquement les critères de tri définis dans la propriété Tri par (en spécifiant la valeur Oui) lorsque la table est ouverte en mode Feuille de données.

    Conseil : Pour disposer de davantage d’espace pour la saisie ou la modification d’un paramètre dans la zone de propriété, appuyez sur Maj+F2 pour afficher la zone Zoom. Si vous affectez la propriété Valide si à une expression et souhaitez obtenir de l’aide, cliquez sur Bouton Générateur en regard de la zone de propriété Valide si pour afficher le Générateur d’expression.

  6. Pour enregistrer vos modifications, Appuyez sur CTRL+S.

Haut de la section

Haut de la page

Ajouter un champ à une table

Vous stockez chaque donnée dont vous souhaitez assurer le suivi dans un champ. Par exemple, dans une table de contacts, vous créez des champs pour le Nom de famille, le Prénom, le Numéro de téléphone et l’Adresse. Dans une table de produits, vous créez des champs pour le Nom du produit, l’ID de produit et le Prix.

Avant de créer des champs, essayez de séparer les données sous leur plus petite forme. Il est beaucoup plus simple de combiner ultérieurement des données que de les séparer. Par exemple, au lieu d’un champ Nom, créez des champs Nom de famille et Prénom. Par la suite, il sera très facile de rechercher ou trier par Prénom, Nom de famille ou les deux. Si vous prévoyez d’exécuter un état, un tri, une recherche ou un calcul sur un élément de données, placez cet élément dans son propre champ.

Après avoir créé un champ, vous pouvez également définir des propriétés de champ afin de contrôler son apparence et son comportement.

Que voulez-vous faire ?

Ajouter un champ en entrant des données

Lorsque vous créez une table ou ouvrez une table existante en mode Feuille de données, vous pouvez ajouter un champ à la table en tapant des données dans la colonne Ajouter un nouveau champ de la feuille de données.

Feuille de données dans Access avec la colonne Ajouter un nouveau champ

1. Entrez des données dans la colonne Ajouter un nouveau champ.

  1. Créez ou ouvrez une table en mode Feuille de données en cliquant avec le bouton droit sur la table souhaitée dans le volet de navigation, puis en cliquant sur Mode Feuille de données dans le menu contextuel.

  2. Dans la colonne Ajouter un nouveau champ, entrez le nom du champ que vous voulez créer.

    Utilisez un nom descriptif pour faciliter l’identification du champ.

  3. Entrez des données dans le nouveau champ.

Ajouter un champ en utilisant un modèle de champ

Parfois, il est plus facile d’opérer un choix dans une liste prédéfinie de champs correspondant à vos besoins que de créer un champ manuellement. Pour opérer un choix dans une liste de modèles de champ, vous pouvez utiliser la liste Plus de champs dans Access 2010, 2013 ou 2016, ou le volet Office Modèles de champ dans Access 2007. Un modèle de champ est un ensemble prédéfini de caractéristiques et propriétés qui décrivent un champ. La définition d’un modèle de champ inclut un nom de champ, un type de données, un paramètre pour la propriété Format du champ, et d’autres propriétés de champ.

Si vous utilisez Access 2010, 2013 ou 2016, procédez comme suit.

  1. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Feuille de données.

  2. Sous l’onglet Champs, dans le groupe Ajouter et supprimer, cliquez sur Plus de champs.

    Capture d’écran du groupe Ajouter et supprimer sous l’onglet de ruban Champs.

  3. Pour insérer la nouvelle colonne, sélectionnez un champ dans la liste Plus de champs. Access insère le champ à droite de la colonne dans laquelle votre curseur est actuellement positionné. Si vous choisissez, sous le titre Démarrage rapide, une option de champ telle que Adresse, Access crée plusieurs champs dans votre table pour accueillir les différentes parties d’une adresse.

Si vous utilisez Access 2007, procédez comme suit.

  1. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis sur Mode Feuille de données.

  2. Sous l’onglet Feuille de données, dans le groupe Champs et colonnes, cliquez sur Nouveau champ.

    Image du ruban Access

  3. Sélectionnez un ou plusieurs champs dans le volet Modèles de champ, puis faites-les glisser vers la table dans laquelle vous voulez insérer la nouvelle colonne.

Définir les propriétés d’un champ

Après avoir créé un champ, vous pouvez définir des propriétés de champ afin de contrôler son apparence et son comportement.

En définissant des propriétés de champ, vous pouvez par exemple :

  • contrôler l’apparence des données dans un champ ;

  • aider à prévenir la saisie de données incorrectes dans un champ ;

  • spécifier des valeurs par défaut pour un champ ;

  • aider à accélérer les opérations de recherche et de tri sur un champ.

Vous pouvez définir une partie des propriétés de champ disponibles pendant que vous travaillez en mode Feuille de données. En revanche, pour avoir accès à la liste complète des propriétés de champ et définir toutes les propriétés de champ, vous devez utiliser le mode Création.

Définir des propriétés de champ en mode Feuille de données

Vous pouvez renommer un champ, modifier son type de données, modifier sa propriété Format, et modifier certaines de ses autres propriétés pendant que vous travaillez en mode Feuille de données.

Ouvrir une table en mode Feuille de données

  1. Dans le volet de navigation, cliquer avec le bouton droit sur la table que vous souhaitez ouvrir.

  2. Dans le menu contextuel, cliquez sur Mode Feuille de données.

Renommer un champ

Lorsque vous ajoutez un champ en entrant des données en mode Feuille de données, Access affecte automatiquement un nom générique au champ. Access affecte le nom Champ1 au premier nouveau champ, Champ2 au deuxième nouveau champ, et ainsi de suite. Par défaut, le nom d’un champ est utilisé en guise d’étiquette partout où le champ est affiché (comme dans l’en-tête de colonne sur une feuille de données). L’attribution de noms descriptifs aux champs facilite leur utilisation lors de l’affichage ou de la modification d’enregistrements.

  1. Cliquez avec le bouton droit sur l’en-tête du champ à renommer (par exemple, Champ1).

  2. Dans le menu contextuel, cliquez sur Renommer le champ. Si vous utilisez Access 2007, cliquez sur Renommer le champ.

  3. Entrez le nouveau nom dans l’en-tête du champ.

    Les noms de champs peuvent compter au maximum 64 caractères (lettres ou nombres), y compris les espaces.

Modifier le type de données d’un champ

Lorsque vous créez un champ en entrant des données en mode Feuille de données, Access examine ces données afin de déterminer le type de données approprié pour le champ. Par exemple, si vous entrez 1/1/2017, Access reconnaît qu’il s’agit d’une date et affecte le type de données Date/heure au champ. Si Access n’est pas en mesure de déterminer le type de données avec certitude, le type de données Texte est utilisé par défaut (Texte court si vous utilisez Access 2016).

Le type de données du champ détermine les autres propriétés de champ que vous pouvez définir. Par exemple, vous pouvez définir la propriété Ajouter uniquement seulement pour un champ dont le type de données est Lien hypertexte ou Mémo (Texte long si vous utilisez Access 2016).

Il peut arriver que vous souhaitiez modifier manuellement le type de données d’un champ. Par exemple, supposez que vous avez des numéros de salles qui ressemblent à des dates, tels que 10/2017. Si vous entrez 10/2017 dans un nouveau champ en mode Feuille de données, la fonctionnalité de détection automatique de type de données sélectionne le type de données Date/heure pour le champ. Les numéros de salles étant des étiquettes, et non des dates, ils doivent utiliser le type de données Texte. Pour modifier le type de données d’un champ, appliquez la procédure suivante.

  1. Dans le ruban, cliquez sur l’onglet Champs. Si vous utilisez Access 2007, cliquez sur l’onglet Feuille de données.

  2. Dans la liste Type de données, dans le groupe Mise en forme, sélectionnez le type de données souhaité. Si vous utilisez Access 2007, dans la liste Type de données, dans le groupe Type de données et mise en forme, sélectionnez le type de données souhaité.

    Quels sont les types de données disponibles ?

    Pour une liste complète des types de données disponibles dans les bases de données Access, voir Types de données pour les bases de données Access de bureau.

    Remarque : La taille maximale d’un fichier de base de données Access est de 2 Go.

    Conseils sur les types de données

    • Pour optimiser les performances, vous devez utiliser la Taille du champ la plus appropriée lorsque vous créez un champ Texte ou Nombre. Par exemple, si vous prévoyez de stocker des codes postaux d’une longueur prévisible, spécifiez-la en tant que la taille du champ. Vous pouvez spécifier la taille du champ en définissant une valeur dans la zone de propriété Taille du champ. Pour plus d’informations, voir la section Définir d’autres propriétés de champ.

    • Pour les numéros de téléphone, numéros de pièce et autres nombres que vous ne comptez utiliser pour des calculs mathématiques, vous devez sélectionner le type de données Texte plutôt que le type de données Nombre. Une valeur numérique stockée en tant que texte peut être triée et filtrée de façon plus logique.

Modifier le format d’un champ

En plus de déterminer le type de données d’un nouveau champ, Access peut définir la propriété Format en fonction de ce que vous avez tapé. Par exemple, si vous entrez 10:50 a.m., Access affecte le type de données Date/heure et affecte à la propriété Format la valeur Heure, réduit. Pour modifier manuellement la propriété Format d’un champ, procédez comme suit :

  1. Dans le ruban, cliquez sur l’onglet Champs. Si vous utilisez Access 2007, cliquez sur l’onglet Feuille de données.

  2. Dans la liste Format, dans le groupe Mise en forme, entrez le format souhaité. Si vous utilisez Access 2007, dans la liste Format, dans le groupe Type de données et mise en forme, entrez le format souhaité.

    Remarque : La liste Format peut ne pas être disponible pour certains champs (par exemple les champs Texte) ; tout dépend du type de données du champ.

Définir d’autres propriétés de champ

  1. En mode Feuille de données, cliquez sur le champ dont vous souhaitez définir la propriété.

  2. Si vous utilisez Access 2010, 2013 ou 2016, sous l’onglet Champs, dans le groupe Propriétés, Mise en forme ou Validation de champ, sélectionnez les propriétés souhaitées.

  3. Si vous utilisez Access 2007, sous l’onglet Feuille de données, dans le groupe Type de données et mise en forme, sélectionnez les propriétés souhaitées.

Définir des propriétés de champ en mode Création

Vous pouvez définir toute propriété de champ lorsque vous travaillez avec une table en mode Création. En mode Création, vous définissez le type de données d’un champ dans la grille de création de table, et d’autres propriétés dans le volet Propriétés du champ.

Ouvrir une table en mode Création

  1. Dans le volet de Navigation, cliquez avec le bouton droit sur la table.

  2. Dans le menu contextuel, cliquez sur Mode Création.

Modifier le type de données d’un champ

  1. Dans la grille de création de table, recherchez le champ dont vous voulez définir le type de données.

  2. Dans la colonne Type de données, choisissez un type de données dans la liste.

    Quels sont les types de données disponibles ?

    Pour une liste complète des types de données disponibles dans les bases de données Access, voir Types de données pour les bases de données Access de bureau.

    Remarque : La taille maximale d’un fichier de base de données Access est de 2 Go.

    Conseils sur les types de données

    • Pour les numéros de téléphone, numéros de pièce et autres nombres que vous ne comptez utiliser pour des calculs mathématiques, vous devez sélectionner le type de données Texte plutôt que le type de données Nombre. Une valeur numérique stockée en tant que texte peut être triée et filtrée de façon plus logique, mais n’est pas facilement utilisable dans des calculs.

    • Pour les types de données Texte et Nombre, vous pouvez spécifier la taille ou le type de données du champ plus précisément en définissant une valeur dans la zone de propriété Taille du champ.

Définir d’autres propriétés de champ

  1. Dans la grille de création de table, sélectionnez le champ dont vous voulez définir les propriétés. Access affiche les propriétés de ce champ dans le volet Propriétés du champ.

    Le type de données du champ détermine les propriétés que vous pouvez définir.

  2. Dans le volet Propriétés du champ, entrez les paramètres souhaités pour chaque propriété, ou appuyez sur F6 et utilisez les touches de direction pour sélectionner une propriété.

    Quelles sont les propriétés de champ disponibles ?

    Pour une liste complète des propriétés de champ disponibles pour chaque type de données dans les bases de données Access, voir Présentation des types de données et des propriétés de champ.

    Remarque : Certaines propriétés ne sont pas disponibles pour tous les champs. Le type de données d’un champ détermine les propriétés de celui-ci.

  3. Pour fournir davantage d’espace pour la saisie ou la modification d’un paramètre de propriété dans la zone de propriété, appuyez sur MAJ+F2 pour afficher la zone Zoom.

    Conseil : Si vous entrez un masque de saisie ou une expression de validation, et souhaitez obtenir de l’aide pour la création de ceux-ci, cliquez sur Bouton Générateur en regard de la zone de propriété pour afficher le générateur approprié.

  4. Pour enregistrer vos modifications, Appuyez sur CTRL+S.

Enregistrer une table

Après avoir créé ou modifié une table, vous devez enregistrer sa conception. Lorsque vous enregistrez une table pour la première fois, donnez-lui un nom descriptif des données qu’elle contient. Vous pouvez utiliser jusqu’à 64 caractères alphanumériques, espaces compris. Par exemple, vous pouvez nommer une table Clients, Inventaire pièces ou Produits.

Conseil : Vous devez établir une convention d’affectation de noms pour les objets dans votre base de données et l’utiliser de manière cohérente.

  1. Si vous utilisez Access 2010, 2013 ou 2016, cliquez sur Fichier > Enregistrer, ou appuyez sur CTRL+S.

  2. Si vous utilisez Excel 2007, cliquez sur le bouton Microsoft Office, puis sur Enregistrer, ou appuyez sur CTRL+S.

  3. Si vous enregistrez la table pour la première fois, tapez un nom, puis cliquez sur OK.

Haut de la page

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×