Créer des pages en mode Collaborateur

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

En tant qu'auteur de contenu, vous devez créer des pages pour contribuer au contenu du site de votre équipe. Lorsque vous créez des pages en tant qu'utilisateur restreint dans un groupe de collaborateurs, vous pouvez remarquer que dans Microsoft Office SharePoint Designer 2007 , certaines commandes sont disponibles alors que d'autres ne le sont pas.

Cet article vous explique comment créer des pages dans Office SharePoint Designer 2007 en tant que membre d'un groupe de collaborateurs travaillant en mode Collaborateur.

Pour en savoir plus sur les paramètres de collaboration, consultez l’article Présentation des paramètres de collaboration.

Important : Pour utiliser les paramètres de collaboration, le site doit se trouver sur un serveur exécutant Windows SharePoint Services 3.0 ou Microsoft Office SharePoint Server 2007.

Contenu de cet article

Quelles sont les fonctionnalités peuvent être indisponible lorsque je crée des pages en mode Collaborateur ?

Afficher les types de pages de votre groupe de collaborateurs peut créer

Créer des pages en mode Collaborateur

Quelles sont les fonctionnalités susceptibles d'être indisponibles lorsque je crée des pages en mode Collaborateur ?

Les types de pages que vous pouvez créer dépendent des restrictions de modification affectées par le gestionnaire du site à votre groupe de collaborateurs. Par exemple, si votre gestionnaire de site a autorisé votre groupe de collaborateurs à créer uniquement des pages à partir d'une page maître existante, vous ne pouvez pas créer des pages qui ne sont pas basées sur la page maître spécifiée par le gestionnaire du site.

Lorsque vous essayez de créer un type de page que votre groupe de collaborateurs n'est pas autorisé à créer, une notification s'affiche dans la barre d'état pour vous indiquer que vos paramètres de collaboration vous empêchent de créer ce type de page.

Notification de barre d'état lorsque vos paramètres de collaboration ne vous autorisent pas à créer le type de fichier sélectionné

Par ailleurs, si vous essayez de créer une page dans la boîte de dialogue Nouveau (menu Fichier), mais que le gestionnaire du site a choisi de ne pas rendre ce type de page disponible auprès de votre groupe de collaborateurs, un message s'affiche dans la boîte de dialogue pour vous indiquer que vos paramètres de collaboration ne vous autorisent pas à créer ce type page. Consultez la section Description sur l'illustration suivante.

Notification dans la boîte de dialogue Nouveau pour les utilisateurs en mode Collaborateur

Vous pouvez éviter une telle approche par tâtonnements en affichant directement vos paramètres de collaboration, qui vous indiquent en un clin d'œil quels types de pages peuvent être créés par votre groupe de collaborateurs dans Office SharePoint Designer 2007. La section suivante vous explique comment procéder.

Haut de la Page

Afficher les types de pages pouvant être créés par votre groupe de collaborateurs

Avant de commencer à travailler dans Office SharePoint Designer 2007, nous vous invitons à consulter les paramètres de collaboration de votre groupe de collaborateurs afin de découvrir quelles sont les fonctionnalités disponibles pour votre groupe. Vous pouvez afficher les types de pages que vous pouvez créer dans la catégorie Création de pages. Il est également recommandé de vérifier dans quel emplacement vous être autorisé à enregistrer vos fichiers, en consultant la catégorie Dossiers. Il est utile de savoir où vous pouvez enregistrer les pages que vous créez, car vous obtiendrez un message d'erreur si vous essayez de les enregistrer dans un emplacement non autorisé.

Par exemple, si vous êtes auteur de contenu et que vous devez régulièrement ajouter du contenu au site SharePoint de votre équipe, il est probable que le gestionnaire du site aura configuré votre groupe de collaborateurs de manière à vous autoriser à créer de nouvelles pages uniquement à partir d'une page maître précise, à ajouter seulement certains types de contenu aux zones de contenu de la page, et à enregistrer votre nouvelle page exclusivement dans un dossier spécifique du site. En affichant vos paramètres de collaboration, vous pouvez déterminer rapidement comment mettre à jour votre site.

  1. Ouvrez votre site dans Office SharePoint Designer 2007.

  2. Si le volet Office Collaborateur n'est pas visible, dans le menu Volets Office, cliquez sur Collaborateur.

    Volet Office Collaborateur tel qu'il s'affiche au groupe de collaborateurs Auteurs de contenu

    1. Cette section affiche le nom du groupe de collaborateurs auquel vous appartenez.

    2. Cliquez sur ce lien pour afficher les paramètres du groupe de collaborateurs auquel vous appartenez.

    3. Cliquez sur ce lien pour ouvrir un message électronique adressé au gestionnaire de site.

    4. Voici une liste des fichiers que vous avez ouverts lors de la session précédente dans Office SharePoint Designer 2007.

    5. Cliquez sur ce lien pour ouvrir la boîte de dialogue Nouveau et créer des fichiers.

    6. Cliquez sur ce lien pour ouvrir la boîte de dialogue Ouvrir, dans laquelle vous pouvez parcourir les dossiers et ouvrir des fichiers.

  3. Dans le volet Office, vous pouvez voir, sous Votre état de collaboration, une description du groupe de collaborateurs dont vous faites partie, ainsi qu'un lien appelé Afficher vos paramètres de collaboration. Cliquez sur ce lien pour afficher les paramètres de votre groupe de collaborateurs.

    Important : Vous ne pouvez pas modifier vos paramètres de collaboration, car seul le gestionnaire du site y est autorisé. Si vous souhaitez accéder à des fonctionnalités supplémentaires, faites-en la demande auprès du gestionnaire du site. Pour afficher les coordonnées du gestionnaire du site, cliquez sur Paramètres de collaboration dans le menu Site.

  4. Dans la boîte de dialogue Afficher vos paramètres de collaboration, cliquez sur Création de pages et affichez les paramètres de création de pages de votre groupe. Vous pouvez également voir à partir de quelles pages maîtres vous êtes autorisé à créer de nouvelles pages.

    Catégorie Création de pages dans la boîte de dialogue Afficher vos paramètres de collaboration

    Remarque : L'option Autoriser la création de pages à partir des pages maîtres suivantes recense les pages maîtres à partir desquelles vous êtes autorisé à créer de nouvelles pages. Ainsi, vous ne pouvez créer de nouvelles pages qu'à partir des pages maîtres mentionnées dans la liste. Si la liste Autoriser la création de pages à partir des pages maîtres suivantes est vide, vous pouvez créer de nouvelles pages à partir de n'importe quelle page maître du site. Par défaut, tout utilisateur peut, dans Office SharePoint Designer 2007, créer une nouvelle page à partir d'une page maître. La liste permet de vous obliger à utiliser uniquement certaines pages maîtres.

  5. Cliquez sur Définir les types de pages pour afficher les types de pages que votre groupe de collaborateurs est autorisé à créer.

    Boîte de dialogue Types de page

  6. Pour voir où vous pouvez enregistrer les pages et les images du site, cliquez sur Dossiers et affichez l'emplacement réservé à votre groupe. Vous pouvez également trouver ces dossiers dans la liste des dossiers.

Haut de la Page

Créer des pages en mode Collaborateur

Maintenant que vous avez affiché les paramètres de collaboration pour découvrir les types de pages que vous pouvez créer et dans quel dossier vous êtes autorisé à les enregistrer dans le site actif, vous êtes prêt à créer des pages en mode Collaborateur. En tant qu'auteur de contenu, vous aurez le plus souvent besoin de créer soit une page ASPX vierge, soit une nouvelle page créée à partir d'une page maître. Ces deux types de pages sont des pages ASP.NET.

Lorsque vous ajoutez une page à un site SharePoint, vous souhaitez presque toujours ajouter une page ASP.NET (ASPX), car les pages ASPX prennent en charge les fonctionnalités de la plage complète de SharePoint. Pour cette raison, une page ASPX est la valeur par défaut pour les nouvelles pages dans un site SharePoint lorsque vous cliquez sur Nouveau Document Image du bouton dans la barre d’outils commun ou appuyez sur CTRL + N.

Créer une nouvelle page à partir d'une page maître

  1. Ouvrez le site dans Office SharePoint Designer 2007.

  2. Si la liste des dossiers est masquée, dans le menu Affichage, cliquez sur Liste des dossiers.

  3. Dans la liste des dossiers, cliquez sur le signe plus (+) en regard du dossier _catalogs pour le développer, puis cliquez sur le signe plus (+) en regard du dossier masterpage (galerie de pages maîtres).

    Remarque : Seules les pages maîtres mises à la disposition du groupe de collaborateurs par le gestionnaire du site s'affichent dans le dossier des pages maîtres de la liste des dossiers.

  4. Cliquez avec le bouton droit sur la page maître à partir de laquelle vous voulez créer la nouvelle page, puis cliquez sur Créer à partir d'une page maître dans le menu contextuel.

  5. Ajoutez le contenu que vous voulez à la page en fonction des paramètres de votre groupe de collaborateurs.

  6. Dans le menu Fichier, cliquez sur Enregistrer. Vous pouvez également appuyer sur CTRL+S pour enregistrer la page à un emplacement dans lequel votre groupe de collaborateurs est autorisé à enregistrer des fichiers.

    Remarque : Vous pouvez savoir dans quel emplacement votre groupe de collaborateurs est autorisé à enregistrer des pages dans le site actif en consultant la catégorie Dossiers dans les paramètres de votre groupe de collaborateurs. Pour plus d'informations, consultez la section précédente.

Créer une page ASPX vierge

  1. Dans le menu Fichier, sélectionnez Nouveau, puis cliquez sur ASPX.

    Une nouvelle page Web vide s'ouvre.

    Remarque : Par défaut, les auteurs de contenu n'ont qu'un accès limité à bon nombre des fonctionnalités de création de Office SharePoint Designer 2007. Certaines activités, telles que le rattachement de feuilles de style, la modification d'éléments de balises, l'ajout de contenu actif (des scripts, par exemple), et l'utilisation de certaines balises, ne sont pas autorisées. Si vous pensez avoir besoin d'accéder à des fonctionnalités supplémentaires, contactez le gestionnaire du site.

  2. Dans le menu Fichier, cliquez sur Enregistrer ou appuyez sur CTRL+S pour enregistrer la page à un emplacement dans lequel votre groupe de collaborateurs est autorisé à enregistrer des fichiers.

    Remarque : Vous pouvez savoir dans quel emplacement votre groupe de collaborateurs est autorisé à enregistrer des pages dans le site actif en consultant la catégorie Dossiers dans les paramètres de votre groupe de collaborateurs. Pour plus d'informations, consultez la section précédente.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×