Créer des formules conditionnelles

Il est très souvent utile de tester si des conditions sont vraies ou fausses et de faire des comparaisons logiques entre des expressions. Pour créer des formules conditionnelles, vous pouvez utiliser les fonctions ET, OU, NON et SI.

La fonction SI utilise les arguments suivants.

Formule avec la fonction SI

Formule utilisant la fonction SI

image du bouton  test_logique : condition à vérifier.

Image du bouton  valeur_si_vrai : valeur à renvoyer si la condition est vraie.

image du bouton  valeur_si_faux : valeur à renvoyer si la condition est fausse.

Pour plus d’informations sur la façon de créer une formule, voir Créer une formule.

Que voulez-vous faire ?

Créer une formule conditionnelle dont le résultat soit une valeur logique (VRAI ou FAUX)

Créer une formule conditionnelle dont le résultat soit un autre calcul ou des valeurs autres que VRAI ou FAUX

Créer une formule conditionnelle dont le résultat soit une valeur logique (VRAI ou FAUX)

Utilisez les fonctions et opérateurs ET, OU et NON comme illustré dans l’exemple suivant.

Exemple

L’exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

Comment copier un exemple ?

  1. Sélectionnez l’exemple de cet article.

    Important : Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

    Sélection d’un exemple de l’aide d’Excel 2013 pour Windows

    Sélection d’un exemple de l’aide

  2. Appuyez sur Ctrl+C.

  3. Créez un classeur ou une feuille de calcul vide.

  4. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur Ctrl+V.

Important : Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  1. Pour passer de l’affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur Ctrl+` (apostrophe) ou, sur l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Une fois que vous avez copié l’exemple dans la feuille de calcul vide, vous pouvez l’adapter selon vos besoins.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Données

15

9

8

Sprockets

Widgets

Formule

Description (Résultat)

=ET(A2>A3, A2<A4)

Détermine si la valeur dans la cellule A2 est supérieure à la valeur dans la cellule A3, et si la valeur dans A2 est inférieure à la valeur dans la cellule A4. (FAUX)

=OU(A2>A3, A2<A4)

Détermine si la valeur dans la cellule A2 est supérieure à la valeur dans la cellule A3, ou si la valeur dans A2 est inférieure à la valeur dans la cellule A4. (VRAI)

=NON(A2+A3=24)

Détermine si la somme des valeurs dans les cellules A2 et A3 n’est pas égale à 24. (FAUX)

=NON(A5="Sprockets")

Détermine si la valeur dans la cellule A5 n’est pas égale à « Sprockets ». (FAUX)

=OU(A5<>"Sprockets",A6 = "Widgets")

Détermine si la valeur de la cellule A5 n’est pas égale à « Sprockets » ou si la valeur de la cellule A6 est égale à « Widgets » (VRAI).

Pour plus d’informations sur l’utilisation de ces fonctions, voir Fonction ET, Fonction OU et Fonction NON.

Haut de la page

Créer une formule conditionnelle dont le résultat soit un autre calcul ou des valeurs autres que VRAI ou FAUX

Utilisez les fonctions et opérateurs SI, ET et OU comme illustré dans l’exemple suivant.

Exemple

L’exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

Comment copier un exemple ?

  1. Sélectionnez l’exemple de cet article.

Important : Ne sélectionnez pas les en-têtes des lignes ou des colonnes.

Sélection d’un exemple de l’aide d’Excel 2013 pour Windows

Sélection d’un exemple de l’aide

  1. Appuyez sur Ctrl+C.

  2. Créez un classeur ou une feuille de calcul vide.

  3. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur Ctrl+V.

Important : Pour que l’exemple fonctionne correctement, vous devez le coller dans la cellule A1 de la feuille de calcul.

  1. Pour passer de l’affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur Ctrl+` (apostrophe) ou, sur l’onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

Une fois que vous avez copié l’exemple dans la feuille de calcul vide, vous pouvez l’adapter selon vos besoins.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Données

15

9

8

Sprockets

Widgets

Formule

Description (Résultat)

=SI(A2=15, "OK", "Pas OK")

Si la valeur de la cellule A2 est égale à 15, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (OK)

=SI(A2<>15, "OK", "Pas OK")

Si la valeur de la cellule A2 n’est pas égale à 15, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (Pas OK)

=Si(NON(A2<=15), "OK", "Pas OK")

Si la valeur de la cellule A2 n’est pas inférieure ou égale à 15, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (Pas OK)

=SI(A5<>"SPROCKETS", "OK", "Pas OK")

Si la valeur de la cellule A5 n’est pas égale à « SPROCKETS », renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (Pas OK)

=SI(ET(A2>A3, A2<A4), "OK", "Pas OK")

Si la valeur de la cellule A2 est supérieure à la valeur de la cellule A3 et que la valeur de la cellule A2 est également inférieure à la valeur de la cellule A4, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (Pas OK)

=SI(ET(A2<>A3, A2<>A4), "OK", "Pas OK")

Si la valeur de la cellule A2 n’est pas égale à la cellule A3 et que la valeur de la cellule A2 n’est pas égale à la cellule A4, renvoie « Pas OK ». (OK)

=SI(OU(A2>A3, A2<A4), "OK", "Pas OK")

Si la valeur de la cellule A2 est supérieure à la valeur de la cellule A3, ou si la valeur dans A2 est inférieure à la valeur dans A4, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (OK)

=SI(OU(A5<>"Sprockets", A6<>"Widgets"), "OK", "Pas OK")

Si la valeur de la cellule A5 n’est pas égale à « Sprockets » et la valeur de la cellule A6 n’est pas égale à « Widgets », renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (Pas OK)

=SI(OU(A2<>A3, A2<>A4), "OK", "Pas OK")

Si la valeur de la cellule A2 n’est pas égale à la valeur de la cellule A3, ou si la valeur dans A2 n’est pas égale à la valeur dans A4, renvoie « OK ». Dans le cas contraire, renvoie « Pas OK ». (OK)

Pour plus d’informations sur l’utilisation de ces fonctions, voir Fonction SI, Fonction ET et Fonction OU.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×