Créer des formulaires et des états Access à partir d’une liste SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez créer des formulaires et états d’une liste SharePoint et les utiliser en tant que vues. Utilisateurs du site SharePoint qui ont Access 2007 installé peuvent ouvrir ces formulaires et états en utilisant le menu affichage de la liste SharePoint. Vous pouvez effectuer un accès à un affichage par défaut pour une liste.

Les vues que vous créez à l’aide de Access 2007 sont stockés dans un fichier de base de données sur le serveur Windows SharePoint Services. Lorsque vous ouvrez un affichage Access d’une liste SharePoint, Access démarre, et il affiche le formulaire ou l’état. Étant donné que la base de données est stockée sur le site SharePoint, l’affichage peut être ouvert par d’autres utilisateurs du site. Un utilisateur n’a pas besoin de connaître l’emplacement, sur le site SharePoint, du fichier de base de données qui contient l’affichage Access afin d’utiliser l’affichage. En outre, l’utilisateur n’a pas encore besoin savoir comment lancer Access — cela est géré automatiquement par le site SharePoint.

Remarque : Un utilisateur doit Access 2007 installée sur son ordinateur pour créer, utiliser ou modifier un affichage Access sur un site SharePoint.

Que voulez-vous faire ?

Créer une vue Access d'une liste SharePoint

Définir un accès comme affichage par défaut pour la liste SharePoint

Utiliser une vue Access d'une liste SharePoint

Modifier une vue Access d'une liste SharePoint

Créer une vue Access d'une liste SharePoint

Lorsque vous créez une vue Access d'une liste SharePoint, Access démarre automatiquement. Dans Access, vous pouvez baser votre vue sur différents modèles de formulaires et d'états, et ensuite personnaliser votre vue. La publication de la vue sur le site SharePoint vous permet de la rendre facilement accessible à d'autres utilisateurs.

Remarque : Pour créer un affichage d’une liste SharePoint, vous devez l’autorisation Gérer les listes, qui, par défaut, est incluse dans le niveau d’autorisation Création Windows SharePoint Services.

Appliquez la procédure suivante pour créer une vue Access d'une liste SharePoint que vous affichez dans votre navigateur.

  1. Sur le site SharePoint, dans le menu affichage Menu déroulant , cliquez sur Créer un affichage.

  2. Sur la page Créer un affichage, cliquez sur Affichage Access.

    Access démarre, puis vous invite à enregistrer une copie locale de la base de données qui contiendra votre nouvelle vue.

  3. Dans la boîte de dialogue Enregistrer une copie locale, naviguez jusqu'à l'emplacement sur votre ordinateur où vous souhaitez enregistrer la copie, tapez un nom pour la copie locale dans la zone Nom du fichier, puis cliquez sur Enregistrer.

    Access enregistre et ouvre la copie locale, puis la boîte de dialogue Créer une vue Access s'affiche.

  4. Dans la boîte de dialogue Créer une vue Access, double-cliquez sur le type de vue à créer.

    Access crée votre nouvelle vue et l'ouvre en mode Page.

  5. Vous pouvez personnaliser votre nouvelle vue en mode Page ou basculer vers le mode Création.

    En mode Page, vous pouvez redimensionner et réorganiser les contrôles (tels que les étiquettes et les champs), mais vous ne pouvez pas ajouter de contrôles supplémentaires à votre affichage. Le mode Page fournit un aperçu des données qui permet de voir l'impact de vos modifications sur l'affichage final.

    En mode Création, vous pouvez redimensionner et réorganiser les contrôles, ainsi qu'ajouter des contrôles supplémentaires à l'affichage. En revanche, ce mode ne propose pas d'aperçu des données.

    Vous pouvez basculer du mode Création au mode Page à votre gré. Si vous utilisez le mode Création pour ajouter des contrôles à l'affichage, vous pouvez passer en mode Page et réorganiser ces contrôles sur l'affichage tout en consultant les données.

  6. Après avoir effectué vos personnalisations, dans la Barre des messages, cliquez sur Publier sur un site SharePoint.

    barre d'outils

    La boîte de dialogue Publier sur le serveur Web apparaît.

    Si la Barre des messages n’est pas visible, affichez-le en procédant comme suit :

    • Sous l'onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Barre des messages.

  7. Par défaut, Access enregistre l’affichage dans un fichier de base de données situé dans la bibliothèque de Documents partagés sur le site SharePoint, ce site contient la liste à partir de laquelle vous avez créé l’affichage. Dans la plupart des cas, c’est probablement que vous souhaitez, mais vous pouvez modifier la bibliothèque de documents dans lequel stocker la base de données en choisissant une autre bibliothèque dans la zone Enregistrer dans zone dans la boîte de dialogue publier sur le serveur Web. Vous pouvez faire ceci pour contrôler plus précisément les personnes ayant accès à l’affichage et si les utilisateurs peuvent ouvrir l’affichage en mode lecture seule ou en mode édition. Le site SharePoint peut-être également des bibliothèques de configurer pour la publication des vues Access, auquel cas vous devrez peut-être modifier l’emplacement Enregistrer dans pour sélectionner la bibliothèque appropriée.

    L'administrateur du site SharePoint peut vous aider à sélectionner la bibliothèque correcte.

  8. Access fournit un nom pour la base de données dans la zone nom de fichier dans la boîte de dialogue publier sur le serveur Web. Ce nom correspond au nom de la base de données que vous avez enregistré comme une copie locale. Vous pouvez modifier le nom si vous le souhaitez, mais dans la plupart des cas, vous devez accepter le nom proposé — Cela facilitera n’oubliez pas de la base de données locale correspond à la base de données que vous publiez sur le site SharePoint.

  9. Cliquez sur Publier pour enregistrer la base de données sur le site SharePoint.

Haut de la page

Définir un accès comme affichage par défaut pour la liste SharePoint

Lorsque vous effectuez un accès à un affichage par défaut pour une liste SharePoint, l’affichage Access s’ouvre automatiquement lorsque les utilisateurs ouvrent la liste, si les utilisateurs ont accès sur leur ordinateur.

Important : Si vous effectuez un affichage Access l’affichage par défaut, les visiteurs de liste qui ne possèdent pas Access 2007 installé ne seront pas en mesure d’utiliser la liste.

  1. Avec la liste SharePoint ouverte, dans le menu paramètres, cliquez sur Paramètres de la liste.

  2. Dans la page Paramètres de la liste, sous affichages, cliquez sur le nom de l’affichage Access que vous souhaitez que l’affichage par défaut.

  3. Dans la page Modifier l’affichage, sélectionnez ce que l’affichage par défaut, puis sur OK.

Haut de la page

Utiliser une vue Access d'une liste SharePoint

Pour utiliser une vue Access d'une liste SharePoint, vous devez choisir la vue Access dans le menu Affichage de la liste.

  • Dans le menu affichage Menu déroulant , cliquez sur le nom de l’affichage Access. Access démarre et affiche ensuite l’affichage en mode lecture seule.

    En mode lecture seule, vous pouvez modifier les données de la vue et imprimer la vue, mais vous ne pouvez pas modifier la structure de la vue. Si vous souhaitez modifier la structure de la vue, consultez la section suivante de cet article, Modifier une vue Access d'une liste SharePoint.

Haut de la page

Modifier une vue Access d'une liste SharePoint

Pour modifier la conception d’un affichage Access, vous enregistrez une copie locale de la base de données qui contient l’affichage Access et apportez les modifications. Vous pouvez ensuite utiliser votre copie locale de la vue ou, si vous avez les autorisations appropriées sur le site SharePoint, vous pouvez publier la nouvelle vue.

Remarque : Vous pouvez modifier une copie locale d’un affichage Access quelle que soit votre niveau d’autorisation Windows SharePoint Services. Toutefois, pour publier votre vue modifiée sur le site SharePoint, vous devez l’autorisation Gérer les listes, qui, par défaut, est incluse dans le niveau d’autorisation Création Windows SharePoint Services. Si vous avez créé l’affichage Access, vous disposez déjà l’autorisation Gérer les listes. Si vous ne savez pas, contactez votre administrateur de site SharePoint pour déterminer si vous avez les autorisations que nécessaires.

  1. Avec la vue Access ouverte, dans la Barre des messages, cliquez sur Enregistrer sous.

    Le bouton Enregistrer sous de la Barre des messages

    Remarque : Si la Barre des messages n’est pas visible, affichez-le en procédant comme suit :

    • Sous l'onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Barre des messages.

  2. Cliquez sur Oui lorsque Access vous invite à fermer la vue et tous les autres objets ouverts.

    La boîte de dialogue Enregistrer sous s’affiche.

  3. Dans la zone Enregistrer dans, spécifiez l'emplacement où vous souhaitez enregistrer la copie locale, tapez un nom pour la copie locale dans la zone nom du fichier, puis cliquez sur Enregistrer.

    Access enregistre puis ouvre la copie locale de la base de données.

  4. Effectuez l’une des actions suivantes :

    • Pour modifier la disposition de la vue sans ajouter de nouveaux contrôles, dans le Volet de navigation, cliquez avec le bouton droit sur la vue, puis cliquez sur Mode Page dans le menu contextuel.

      En mode Page, vous pouvez redimensionner et réorganiser les contrôles (tels que les étiquettes et les champs), mais vous ne pouvez pas ajouter de contrôles supplémentaires à votre affichage. Le mode Page fournit un aperçu des données qui permet de voir l'impact de vos modifications sur l'affichage final.

    • Pour ajouter ou supprimer des contrôles dans la vue (tels que des étiquettes ou des champs), dans le Volet de navigation, cliquez avec le bouton droit sur la vue, puis cliquez sur Mode Page dans le menu contextuel.

      En mode Création, vous pouvez redimensionner et réorganiser les contrôles, ainsi qu'ajouter des contrôles supplémentaires à l'affichage. En revanche, ce mode ne propose pas d'aperçu des données.

      Remarque : Si vous choisissez de modifier la vue en mode Page et que vous envisagez de publier la vue révisée sur le site SharePoint, n'ajoutez pas à la vue de champs ne faisant pas partie de la liste SharePoint.

  5. Vous pouvez basculer du mode Création au mode Page à votre gré. Si vous utilisez le mode Création pour ajouter des contrôles à l'affichage, vous pouvez passer en mode Page et réorganiser ces contrôles sur l'affichage tout en consultant les données.

Publier la vue Access modifiée sur le site SharePoint

Une fois que vous avez terminé de modifier la vue, si vous avez l'autorisation Gérer les listes sur le site SharePoint, vous pouvez publier la vue modifiée en appliquant la procédure suivante.

Pour obtenir l'autorisation Gérer les listes, contactez l'administrateur du site SharePoint.

  1. Enregistrez la vue dans la copie locale de la base de données.

  2. Dans la Barre des messages, cliquez sur Publier sur un site SharePoint.

    barre d'outils

    Remarque : Si vous n’avez pas l’autorisation Gérer les listes, la Barre des messages n’affiche pas le bouton publier sur un SharePoint Site. Si la Barre des messages n’est pas visible, affichez-le en procédant comme suit :

    • Sous l'onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Barre des messages.

  3. Dans la boîte de dialogue Publier sur le serveur Web, cliquez sur Publier.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×