Créer des affichages de tableau croisé dynamique ou graphique croisé dynamique dans une base de données Access

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez utiliser les modes Tableau croisé dynamique et Graphique croisé dynamique quand vous devez effectuer une analyse interactive de données ou créer des graphiques dynamiques et interactifs. Cet article explique la procédure permettant de créer et personnaliser chaque mode.

Que voulez-vous faire ?

En savoir plus sur les modes Tableau croisé dynamique

Exemple de mode tableau croisé dynamique

Afficher les données de détail

Afficher les éléments individuels

Créer un mode tableau croisé dynamique

Étape 1 : Créer une requête

Étape 2 : Ouvrir la requête en mode tableau croisé dynamique

Étape 3 : Ajouter des champs de données au mode tableau croisé dynamique

Ajouter des champs de ligne

Ajouter des champs de colonne

Ajouter des champs de détails

Ajouter des champs de filtre

Déplacer un champ

Supprimer un champ

Étape 4 : Ajouter des champs de détails calculés et des champs de totaux au mode

Ajouter des champs de détails calculés

Ajouter des champs de totaux

Étape 5 : Changer les légendes de champs et mettre en forme des données

Étape 6 : Filtrer, trier et regrouper des données

Concevoir un mode graphique croisé dynamique

Différences entre le mode tableau croisé dynamique et graphique croisé dynamique

Exemples de modes graphique croisé dynamique

Créer un mode graphique croisé dynamique

Étape 1 : Basculer vers le mode graphique croisé dynamique

Étape 2 : Ajouter et supprimer des champs dans le mode graphique croisé dynamique

Ajouter un champ

Supprimer un champ

Étape 3 : Regrouper, filtrer et trier des données

Regrouper des données

Filtrer des données

Trier des données

Étape 4 : Modifier le type de graphique

Étape 5 : Ajouter une légende

Étape 6 : Modifier et mettre en forme de texte

Titres des axes

Étiquettes de données

Étape 7 : Mettre en forme la zone de traçage

En savoir plus sur les modes Tableau croisé dynamique

Un tableau croisé dynamique est un tableau interactif qui combine et compare rapidement de grandes quantités de données. Vous pouvez faire pivoter ses lignes et colonnes pour voir différents résumés des données sources, et vous pouvez afficher les détails des zones qui vous intéressent. Utilisez un tableau croisé dynamique lorsque vous souhaitez analyser des totaux connexes, notamment lorsque vous avez une longue liste de chiffres à additionner et que vous souhaitez comparer plusieurs faits à propos de chaque chiffre.

Exemple de mode Tableau croisé dynamique

L’illustration suivante montre une requête de données de facturation en mode Tableau croisé dynamique. Ce mode affiche uniquement les valeurs résumées.

mode Tableau croisé dynamique

Le champ Pays est filtré pour afficher uniquement les données relatives aux États-Unis.

Le champ Région personnalisée est un champ de groupe personnalisé. Les champs de groupe personnalisés vous permettent de regrouper les éléments de la façon désirée afin d’obtenir une meilleure analyse des données. Ici, les éléments Ville sont regroupés en deux catégories : Côte ouest et Reste du pays.

Valeur totale trans affiche, sous forme de pourcentage, la valeur totale des transactions gérées par un représentant dans chacune des deux régions.

Nbre de trans affiche le nombre de transactions gérées par un représentant dans chacune des deux régions.

Dans l’illustration précédente, vous pouvez facilement comparer les données entre différents représentants et régions. Étant donné que le tableau est interactif, vous pouvez facilement modifier les filtres, les totaux et le niveau de détail affiché, de sorte que vous pouvez analyser vos données de différentes façons.

Haut de la Page

Afficher les données de détail

Vous pouvez cliquer sur le signe plus (+) à droite d’un représentant ou en dessous d’une région pour afficher des enregistrements détaillés individuels. L’illustration suivante montre les données détaillées relatives à Anne Dodsworth.

Afficher les données de détail

Ces champs de détails existent dans la source d’enregistrement sous-jacente.

Un champ de détail calculé utilise une expression basée sur d’autres champs de détails.

Ces transactions individuelles ont été gérées par Anne Dodsworth dans la région Côte ouest.

Les données et champs de synthèse apparaissent en bas de l’affichage.

Vous pouvez cliquer sur le signe moins (-) à droite d’un représentant ou d’une région pour masquer les données de détail correspondantes.

Remarque : Masquer les données de détail améliore les performances du mode Tableau croisé dynamique.

Haut de la Page

Afficher des éléments individuels

Lorsqu’une zone de colonne comporte plusieurs champs, vous pouvez cliquer sur le signe plus (+) ou le signe moins (-) à gauche d’un élément pour afficher ou masquer des éléments de niveau inférieur. Par exemple, pour afficher des données de synthèse ou de détail pour chaque ville sur la Côte ouest, cliquez sur le signe plus (+) à gauche de Côte ouest.

L’illustration suivante affiche les valeurs récapitulatives pour chaque ville dans le groupe Côte ouest.

Afficher des éléments individuels

Les éléments du champ Ville sont regroupés sous le groupe personnalisé Côte ouest.

Données récapitulatives pour Elgin.

Cliquez ici pour afficher les clients basés à Elgin et les données récapitulatives pour chaque client.

Cliquez ici pour afficher les données de détail pour Elgin.

Haut de la Page

Créer un mode Tableau croisé dynamique

Vous pouvez également créer des modes Tableau croisé dynamique et Graphique croisé dynamique pour des requêtes, des tables et des formulaires Access. Dans le cadre de cet article, nous expliquons comment créer un mode Tableau croisé dynamique et un mode Graphique croisé dynamique pour une requête Access.

Étape 1 : créer une requête

Si vous ne disposez pas déjà d’une requête que vous pouvez utiliser pour votre mode Tableau croisé dynamique, créez-en une nouvelle :

  • Sous l’onglet Créer, dans le groupe Requêtes, cliquez sur Assistant Requête si vous voulez qu’un Assistant vous aide à créer votre requête, ou sur Création de requête si vous voulez créer la requête vous-même.

Lors de l’ajout de champs dans la grille de requête, veillez à inclure les éléments suivants :

  • Les champs qui contiennent les données que vous voulez résumer (par exemple, les montants monétaires ou d’autres données numériques).

  • Les champs sur base desquels vous voulez comparer les données, tels que les employés, la région ou la date.

Si vous avez l’intention de compter les éléments dans votre tableau croisé dynamique, vous devez également inclure un champ ID unique pour les éléments que vous comptez. Par exemple, pour compter le nombre de factures, votre requête doit inclure l’ID du tableau de factures.

Pour plus d’informations sur la création de requêtes, voir l’article Présentation des requêtes.

Étape 2 : ouvrir la requête en mode Tableau croisé dynamique

  1. Si la requête n’est pas déjà ouverte, dans le volet de navigation, double-cliquez sur la requête.

  2. Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis cliquez sur Mode Tableau croisé dynamique.

    Access affiche un mode Tableau croisé dynamique vide sans champs ou données.

Étape 3 : ajouter des champs de données au mode Tableau croisé dynamique

Au cours de cette étape, vous ajoutez les champs qui composent les en-têtes de ligne et de colonne du mode Tableau croisé dynamique, ainsi que les champs de détail et de filtre. Pour cela, la liste des champs doit être visible.

  • Si la liste des champs n’est pas visible, sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Liste des champs.

Ajouter des champs de ligne

Champs de ligne sont ceux qui composent les lignes de tableau croisé dynamique. Dans les illustrations au début de cet article, vendeur est le champ de ligne.

Pour ajouter un champ de ligne :

  • Faites glisser le champ depuis la liste des champs vers la zone marquée Placer les champs de ligne ici dans le tableau croisé dynamique.

Vous pouvez également ajouter le champ de filtre au moyen de la procédure suivante :

  1. Sélectionnez le champ dans la liste de champs.

  2. Dans le bas de la liste des champs, sélectionnez Zone de lignes dans la liste déroulante, puis cliquez sur Ajouter à.

Ajouter des champs de colonne

Comme le nom l’indique, les champs de colonne sont ceux qui composent les colonnes de tableau croisé dynamique. Dans les illustrations au début de cet article, ville et CustomerID sont des champs de colonne.

Pour ajouter un champ de colonne :

  • Faites glisser le champ depuis la liste des champs vers la zone marquée Déposer champs de colonne ici dans le tableau croisé dynamique.

Vous pouvez également ajouter le champ de filtre au moyen de la procédure suivante :

  1. Sélectionnez le champ dans la liste de champs.

  2. Dans le bas de la liste des champs, sélectionnez Zone de colonnes dans la liste déroulante, puis cliquez sur Ajouter à.

Ajouter des champs de détails

Champs de détails sont ceux qui composent les cellules de détail du tableau croisé dynamique. Dans les illustrations au début de cet article, les champs Nom du produit, Prix unitaire et quantité sont tous les champs de détails.

Pour ajouter un champ de détail :

  • Faites glisser le champ depuis la liste des champs vers la zone marquée Placer les totaux ou les champs de détails ici dans le tableau croisé dynamique.

Vous pouvez également ajouter le champ de filtre au moyen de la procédure suivante :

  1. Sélectionnez le champ dans la liste de champs.

  2. Dans le bas de la liste des champs, sélectionnez Zone de détails dans la liste déroulante, puis cliquez sur Ajouter à.

Ajouter des champs de filtre

Champs de filtre sont facultatives. Ajout d’un champ de filtre permet de filtrer le tableau croisé dynamique complet par une valeur. Par exemple, dans première illustration au début de cet article, le champ pays a été ajouté comme un champ de filtre. Par conséquent, le tableau croisé dynamique complet peut être filtré pour certains pays.

Pour ajouter un champ de filtre :

  • Faites glisser le champ depuis la liste des champs vers la zone marquée Placer les champs de filtre ici dans le tableau croisé dynamique.

Vous pouvez également ajouter le champ de filtre au moyen de la procédure suivante :

  1. Sélectionnez le champ dans la liste de champs.

  2. Dans le bas de la liste des champs, sélectionnez Zone de filtre dans la liste déroulante, puis cliquez sur Ajouter à.

Déplacer un champ

  • Faites glisser le nom du champ vers l’emplacement souhaité. Veillez à faire glisser le nom de champ lui-même (par exemple, Représentant), et non l’une des valeurs de champ.

Supprimer un champ

  • Sélectionnez le nom de champ que vous voulez supprimer, puis dans le groupe Champ actif de l’onglet Créer, cliquez sur Supprimer le champ.

    Remarque : Cette action supprime le champ dans cet affichage, mais le champ reste disponible dans la source de données sous-jacente.

Étape 4 : ajouter de champs de détails calculés et de champs de totaux au mode

Ajouter des champs de détails calculés

  1. Sous l’onglet Créer, dans le groupe Outils, cliquez sur Formules, puis cliquez sur Créer un champ de détails calculé.

    Access affiche une boîte de dialogue Propriétés.

  2. Dans la zone Nom, entrez un nom pour le champ calculé.

  3. Dans la zone plus grande en dessous de la zone nom, tapez le calcul que vous souhaitez effectuer, par exemple :

    PrixUnitaire * Quantité

    Conseil :  Pendant que vous entrez le calcul, vous pouvez utiliser la liste déroulante et le bouton Insérer un renvoi à dans le bas de la boîte de dialogue Propriétés pour ajouter des champs au calcul.

  4. Cliquez sur Modifier. Access ajoute le champ calculé à la liste de champs.

  5. Répétez les étapes 2 à 4 pour tous les autres champs calculés que vous souhaitez créer.

  6. Fermez la boîte de dialogue Propriétés.

  7. Ajoutez le champ calculé dans le tableau croisé dynamique conformément aux instructions dans la section Ajouter des champs de détails.

Ajouter des champs de totaux

  1. Vérifiez que les cellules de détails sont affichées : sélectionnez une étiquette de titre de colonne, puis sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Afficher les détails.

  2. Sélectionnez l’une des valeurs de détail pour lesquelles vous voulez ajouter un total.

  3. Sous l’onglet Créer, dans le groupe Outils, cliquez sur Calcul automatique, puis cliquez sur le type de total que vous voulez ajouter.

  4. Répétez l’étape 3 pour tout type de totaux que vous voulez ajouter.

Étape 5 : changer les légendes de champs et mettre en forme les données

  1. Dans le tableau croisé dynamique, sélectionnez l’étiquette du champ que vous voulez changer.

  2. Sous l’onglet Créer, dans le groupe Outils, cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Légendes.

  4. Dans la zone Légende, tapez la légende que vous voulez, puis appuyez sur Entrée.

  5. Définissez toute autre option de mise en forme voulue pour les légendes.

  6. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Format.

  7. Utilisez les commandes dans l’onglet Format pour trier les données et pour mettre en forme le texte et les cellules.

  8. Si votre tableau croisé dynamique contient des lignes de totaux, cliquez sur Masquer les détails sous l’onglet Créer pour masquer les champs de détails et afficher uniquement les champs de totaux.

  9. Répétez les étapes 3 à 7 pour définir les légendes et les formats pour les champs de totaux.

Conseil :  Pour afficher les totaux sous forme de pourcentage d’un total général, sélectionnez l’un des totaux, puis sous l’onglet Créer, dans le groupe Outils, cliquez sur Afficher comme, puis sélectionnez le total général avec lequel vous voulez effectuer la comparaison (total de ligne, total de colonne, etc.)

Étape 6 : filtrer, trier et regrouper des données

  • Pour filtrer des données, cliquez sur la flèche vers le bas en regard de tout nom de champ, puis activez ou désactivez les cases à cocher pour obtenir le filtrage souhaité.

  • Pour regrouper des données :

    1. Dans le tableau croisé dynamique, cliquez sur les valeurs que vous voulez regrouper. Par exemple, pour regrouper plusieurs villes, cliquez sur la première ville, puis appuyez sur la touche Ctrl, maintenez-la enfoncée, et cliquez sur les autres villes que vous voulez regrouper.

    2. Cliquez sur une des valeurs sélectionnées, puis cliquez sur Regrouper les éléments.

      Access crée un niveau de groupe personnalisé. Vous pouvez modifier la légende et la mise en forme du groupe à l’aide de la procédure dans la section étape 5 : changer les légendes de champs et mettre en forme des données.

Une fois que vous avez ajouté un niveau de regroupement, vous pouvez sélectionner le groupe et utiliser les commandes Développer le champ et Réduire le champ sous l’onglet Créer pour respectivement afficher ou masquer les champs individuels dans le groupe.

Haut de la Page

Concevoir un mode Graphique croisé dynamique

Différences entre le mode Tableau croisé dynamique et le mode Graphique croisé dynamique

La mise en page d’un mode Graphique croisé dynamique est similaire à celle d’un mode Tableau croisé dynamique, sauf que, par défaut, les modes Tableau croisé dynamique affichent les détails des données tandis que les modes Graphique croisé dynamique affichent les totaux de données ou les résumés (généralement, sous la forme de sommes ou comptes).

Par ailleurs, à la place de zones de lignes et de colonnes, un mode Graphique croisé dynamique affiche les zones de séries et les zones de catégories. Une série est un groupe de points de données connexes et est généralement représentée dans la légende par une couleur particulière. Une catégorie consiste en un point de données issu de chaque série et est généralement représentée par une étiquette dans l’axe des catégories (x).

Les modifications de mise en page que vous effectuez dans une table, une requête ou un formulaire dans d’autres modes sont indépendantes de la mise en page de l’objet dans un mode Tableau croisé dynamique ou Graphique croisé dynamique. Toutefois, un changement de mise en page que vous effectuez en mode Tableau croisé dynamique, comme déplacer un champ depuis la zone de lignes vers la zone de colonnes, est reflété dans le mode Tableau croisé dynamique, et inversement.

Exemples de modes Graphique croisé dynamique

Le premier exemple de mode Graphique croisé dynamique illustre les cinq représentants qui ont eu les meilleurs montants de ventes (comme indiqué par les prix unitaires totaux) aux États-Unis entre 1996 et 1998. Chaque marqueur de données s’étend à la valeur de l’axe des ordonnées (y) qui représente la somme des prix pour les unités vendues.

Prix unitaires vendus Total

Dans la zone de filtre, le champ Pays est filtré pour afficher uniquement les prix unitaires aux États-Unis.

La zone de données affiche les totaux pour les prix unitaires vendus.

La zone de traçage fournit un arrière-plan pour les marques de données.

Le quadrillage permet de voir plus facilement l’endroit où les marques de données se trouvent sur l’axe des ordonnées.

Cette marque de données représente un point de catégorie (en l’occurrence, un représentant) composé de trois points de série (en l’occurrence, les années 1996, 1997 et 1998).

La zone de séries contient le champ de séries Date de commande. Une légende a été ajoutée sur le côté droit de ce graphique et apparaît directement en dessous du champ de séries.

La zone de catégories se compose des étiquettes de catégorie ; en l’occurrence, les étiquettes de catégorie correspondent aux noms des représentants.

L’étiquette de valeur d’axe offre un cadre de référence pour chaque marque de données.

Le même graphique peut être « croisé dynamiquement », ou manipulé, pour illustrer différents ensembles d’analyses, comme dans l’exemple suivant, qui compare les cinq principaux pays/régions pour les commandes passées. (Notez que dans cet exemple, le champ Représentant se trouve à présent dans la zone de filtre, tandis que le champ Pays se trouve dans la zone de catégories).

Vendeur et pays

Haut de la Page

Créer un mode Graphique croisé dynamique

Les instructions suivantes partent de l’hypothèse que vous avez effectué les étapes ci-dessus pour créer un mode Tableau croisé dynamique.

Étape 1 : basculer vers le mode Graphique croisé dynamique

Sous l’onglet Accueil, dans le groupe Affichages, cliquez sur Affichage, puis cliquez sur Mode Graphique croisé dynamique.

Étape 2 : ajouter et supprimer des champs dans le mode Graphique croisé dynamique

Au cours de cette étape, vous pouvez ajouter ou supprimer des champs dans le graphique. Lorsque vous supprimez un champ dans un graphique, les données sont toujours disponibles par le biais de la liste des champs, mais elles n’apparaissent pas dans le graphique.

Ajouter un champ

  • Pour ajouter un champ, faites-le glisser depuis la liste des champs vers l’une des « zones de dépôt » dans le graphique. Vous pouvez également sélectionner le champ dans la liste des champs, puis dans le bas de la liste des champs, sélectionner la zone à laquelle vous voulez ajouter le champ. Cliquez ensuite sur Ajouter à.

    • Si vous ne voyez pas les zones de dépôt, sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Zones de dépôt.

    • Si vous ne voyez pas la liste des champs, sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Liste des champs.

Supprimer un champ

  • Pour supprimer un champ, sélectionnez son étiquette dans le graphique, puis appuyez sur Supprimer. Vous pouvez également faire glisser le champ en dehors du graphique.

Étape 3 : regrouper, filtrer et trier des données

Pour améliorer la lisibilité d’un graphique, il est souvent judicieux de regrouper, filtrer et trier les données. Par exemple, dans les illustrations au début de cette section, dates de commandes sont regroupées par nombre d’années pour qu’elle soit facile de voir résumés pour chaque année en un clin de œil, plutôt que de devoir regarder chaque date de commande individuelle. En outre, les données sont filtrées pour afficher les cinq vendeurs ayant les montants des ventes le plus élevés. Pour finir, chaque marque de données est triée par sa valeur totale par ordre croissant, il est facile de voir parmi les cinq vendeurs avait ventes les plus élevées et qui eu plus bas.

Regrouper les données

  1. Sélectionnez un nom de champ dans le graphique.

  2. Si la boîte de dialogue Propriétés n’est pas déjà affichée, cliquez avec le bouton droit sur le nom de champ, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Filtre et groupe.

  4. Sous Regroupement, dans la liste Grouper les éléments par, sélectionnez l’option de regroupement que vous voulez. Par exemple, dans un champ de date, vous pouvez cliquer sur Années. Dans un champ de texte, vous pouvez effectuer un regroupement sur base des premiers caractères, par exemple les 3 premiers caractères d’un nom.

Filtrer les données

  1. Sélectionnez une marque de données dans le graphique.

  2. Si la boîte de dialogue Propriétés n’est pas déjà affichée, cliquez avec le bouton droit sur la marque de données, puis cliquez sur Propriétés.

  3. Sous l’onglet Filtre et groupe de la boîte de dialogue Propriétés, sous Filtrage, sélectionnez le type de filtrage et le nombre d’éléments que vous voulez afficher. Par exemple, pour afficher les 5 principaux éléments, sélectionnez Haut dans la liste Afficher les, puis tapez 5 dans la zone Éléments.

Trier les données

  • Cliquez avec le bouton droit sur une marque de données dans le graphique, pointez sur Trier, puis cliquez sur l’option de tri que vous voulez.

Étape 4 : modifier le type de graphique

  1. Cliquez avec le bouton droit sur une zone vide dans le graphique, puis cliquez sur Modifier le type de graphique.

  2. Dans la boîte de dialogue Propriétés, dans la liste à gauche, sélectionnez un type de graphique général.

  3. Dans la liste à droite, sélectionnez le type spécifique de graphique que vous voulez.

Étape 5 : ajouter une légende

  1. Cliquez sur une zone vide du graphique.

  2. Sous l’onglet Créer, dans le groupe Afficher/Masquer, cliquez sur Légende.

Étape 6 : modifier et mettre en forme du texte

Intitulés des axes

  1. Sélectionnez l’intitulé d’axe que vous souhaitez mettre en forme.

  2. Si la boîte de dialogue Propriétés n’est pas déjà affichée, cliquez avec le bouton droit sur le titre, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Format et dans la zone Légende, tapez le texte que vous voulez afficher.

  4. Sous Format du texte dans le même onglet, sélectionnez les options de mise en forme que vous voulez.

Étiquettes de données

  1. Cliquez sur une étiquette de données (par exemple, l’une des étiquettes le long de l’axe des abscisses (x).

  2. Cliquez sur l’étiquette à nouveau pour sélectionner toutes les étiquettes de long de l’axe.

  3. Si la boîte de dialogue Propriétés n’est pas déjà affichée, cliquez avec le bouton droit sur l’une des étiquettes, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Format, puis sélectionnez les options de mise en forme que vous voulez.

Étape 7 : mettre en forme la zone de traçage

  1. Cliquez dans la zone de traçage pour la sélectionner. La zone de traçage est la zone qui contient les marques de données.

  2. Si la boîte de dialogue Propriétés n’est pas déjà affichée, cliquez avec le bouton droit sur la zone de traçage, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Bordure/Remplissage.

  4. Sélectionnez les options de mise en forme que vous voulez pour la zone de traçage.

  5. Sélectionnez un quadrillage dans le graphique.

  6. Dans la boîte de dialogue Propriétés, cliquez sur l’onglet Courbe/Marque.

  7. Sélectionnez les options de mise en forme que vous voulez pour le quadrillage.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×