Corriger une erreur #N/A

Corriger une erreur #N/A

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

L’erreur #N/A indique généralement qu’une formule ne trouve pas ce qu’elle est censée rechercher.

Meilleure solution

L’erreur #N/A survient le plus souvent avec les fonctions RECHERCHEV, RECHERCHEH, RECHERCHE ou EQUIV si une formule ne trouve pas une valeur référencée. Par exemple, la valeur recherchée n’existe pas dans les données sources.

La valeur recherchée n’existe pas.  La formule dans la cellule E2 est =RECHERCHEV(D2;$D$6:$E$8;2;FAUX).  La valeur Banane est introuvable, la formule renvoie donc une erreur #N/A.
Élément non trouvé dans les données sources

Dans le cas présent, il n’y a aucune valeur « Banane » dans la table de choix. La fonction RECHERCHEV renvoie donc une erreur #N/A.

Solution : vérifiez que la valeur recherchée existe dans les données sources ou utilisez un gestionnaire d’erreurs tel que SIERREUR dans la formule. Par exemple, =SIERREUR(FORMULE();0) a la signification suivante :

  • =SI(votre formule génère une erreur, afficher 0, sinon afficher le résultat de la formule)

Vous pouvez utiliser “” pour ne rien afficher ou votre propre texte : =SIERREUR(FORMULE();”Message d’erreur ici”)

Si vous ne savez pas quoi faire à ce stade ou vous ignorez le type d’aide dont vous avez besoin, vous pouvez rechercher des questions semblables dans le forum de la Communauté Excel ou publier votre question.

Lien vers le Forum de la Communauté Excel

Pour avancer, vous pouvez consulter la liste de contrôle suivante qui décrit les étapes de dépannage permettant d’identifier les erreurs dans vos formules.

La valeur de recherche et les données sources sont des données de types différents. Par exemple, vous souhaitez que la fonction RECHERCHEV référence un nombre, mais les données sources sont stockées au format texte.

Types de valeur incorrects  L’exemple montre une formule RECHERCHEV qui renvoie une erreur #N/A, car l’élément recherché est mis en forme comme un nombre, mais la table de choix est mise en forme comme du texte.
Erreur #N/A provoquée par différents types de données

Solution : vérifiez que les types de données sont identiques. Vous pouvez vérifier le format des cellules en sélectionnant une cellule ou une plage de cellules, puis cliquer avec le bouton droit et sélectionner Format de cellule > Nombre (ou appuyer sur Ctrl+1), puis modifier le format de nombre si nécessaire.

Boîte de dialogue Format de cellule affichant l’onglet Nombre et l’option Texte sélectionnée

Conseil : Si vous avez besoin de forcer une modification de format sur une colonne entière, commencez par appliquer le format souhaité, puis utilisez les options Données > Convertir > Terminer.

La fonction SUPPRESPACE permet de supprimer les espaces de début ou de fin. L’exemple suivant utilise la fonction SUPPRESPACE imbriquée dans une fonction RECHERCHEV pour supprimer les espaces de début des noms inclus dans la plage A2:A7, puis renvoyer le nom du service.

Utilisation de RECHERCHEV avec SUPPRESPACE dans une formule de tableau pour supprimer les espaces de début ou de fin  La formule dans la cellule E3 est {=RECHERCHEV(D2;SUPPRESPACE(A2:B7);2;FAUX)} et doit être entrée avec Ctrl+Maj+Entrée.

{=RECHERCHEV(D2;SUPPRESPACE(A2:B7);2;FAUX)}

Remarque : Cette formule de tableau doit être entrée avec Ctrl+Maj+Entrée. Excel entoure automatiquement la formule d’accolades ({}). Si vous essayez de les entrer vous-même, Excel affiche la formule en tant que texte.

Par défaut, les fonctions qui recherchent des informations dans des tables doivent être triées dans l’ordre croissant. Les fonctions de feuille de calcul RECHERCHEV et RECHERCHEH contiennent toutefois un argument valeur_proche qui indique à la fonction de rechercher une correspondance exacte même si la table n’est pas triée. Pour rechercher une correspondance exacte, définissez l’argument valeur_proche sur FAUX. L’utilisation de la valeur VRAI, qui indique à la fonction de rechercher une correspondance approximative, peut non seulement générer une erreur #N/A, mais également renvoyer des résultats erronés comme dans l’exemple suivant.

Exemple d’utilisation de RECHERCHEV avec l’argument valeur_proche VRAI pouvant provoquer des résultats erronés
La fonction RECHERCHEV échoue en raison de l’utilisation de l’argument de correspondance approximative dans une table non triée

Dans cet exemple, la valeur « Banane » renvoie une erreur #N/A, tandis que la valeur « Poire » renvoie un prix incorrect. Cela est dû à l’utilisation de l’argument VRAI, qui indique à la fonction RECHERCHEV de rechercher une correspondance approximative plutôt qu’une correspondance exacte. Il n’y a pas de correspondance proche pour « Banane » et « Pêche » vient avant « Poire » dans l’ordre alphabétique. Dans ce cas, l’utilisation de la fonction RECHERCHEV avec l’argument FAUX renverrait le prix correct pour « Poire », mais la valeur « Banane » génèrerait toujours une erreur #N/A, car il n’y a aucune valeur « Banane » correspondante dans la liste de recherche.

Si vous utilisez la fonction EQUIV, essayez de modifier la valeur de l’argument type pour spécifier l’ordre de tri de la table. Pour rechercher une correspondance exacte, donnez à l’argument type la valeur 0 (zéro).

Pour résoudre ce problème, vérifiez que la plage référencée par la formule matricielle comporte le même nombre de lignes et de colonnes que la plage de cellules dans laquelle la formule matricielle a été entrée, ou entrez la formule matricielle dans moins ou plus de cellules pour correspondre à la référence de plage dans la formule.

Dans cet exemple, la cellule E2 fait référence à des plages discordantes :

Exemple de formule de tableau avec des références de plage discordantes à l’origine d’une erreur #N/A  La formule dans la cellule E2 est {=SOMME(SI(A2:A11=D2;B2:B5))} et doit être entrée avec Ctrl+Maj+Entrée.

{=SOMME(SI(A2: A11=D2;B2:B5))}

Pour que la formule soit calculée correctement, elle doit être modifiée de telle sorte que les deux plages reflètent les lignes 2 à 11.

{=SOMME(SI(A2:A11=D2;B2:B11))}

Remarque : Cette formule de tableau doit être entrée avec Ctrl+Maj+Entrée. Excel entoure automatiquement la formule d’accolades ({}). Si vous essayez de les entrer vous-même, Excel affiche la formule en tant que texte.

Exemple de valeur #N/A entrée dans les cellules qui empêche le calcul correct d’une formule SOMME.

Dans ce cas, Mai-Décembre ont des valeurs #N/A de telle sorte que le total ne peut pas être calculé et renvoie une erreur #N/A.

Pour résoudre ce problème, examinez la syntaxe de formule de la fonction que vous utilisez et entrez tous les objets obligatoires dans la formule qui renvoie l’erreur. Cela peut nécessiter l’utilisation de Visual Basic Editor (VBE) pour vérifier la fonction. Vous pouvez accéder à Visual Basic Editor à partir de l’onglet Développeur, ou en appuyant sur Alt+F11.

Pour résoudre ce problème, vérifiez que le classeur contenant la fonction définie par l’utilisateur est ouvert et que la fonction fonctionne correctement.

Pour résoudre ce problème, vérifiez que les arguments de cette fonction sont corrects et utilisés au bon endroit.

Pour résoudre ce problème, appuyez sur Ctrl+Alt +F9 pour recalculer la feuille.

Vous pouvez utiliser l’Assistant Fonction pour vous aider si vous n’êtes pas sûr des arguments corrects. Sélectionnez la cellule contenant la formule concernée, puis accédez à l’onglet Formule sur le ruban et appuyez sur Insérer une fonction.

Bouton Insérer une fonction

Excel charge automatiquement l’Assistant pour vous :

Exemple de boîte de dialogue Assistant Formule

Lorsque vous cliquez sur un argument, Excel vous donne les informations appropriées pour celui-ci.

Les valeurs #N/A peuvent être utiles. Il est courant d’utiliser des valeurs #N/A avec des données comme celles dans l’exemple suivant pour les graphiques, car celles-ci ne sont pas tracées sur un graphique. Voici quelques exemples de graphiques incluant des valeurs nulles et #N/A.

Exemple de graphique en courbes traçant des valeurs nulles

Dans l’exemple précédent, vous verrez que les valeurs nulles sont tracées et affichées sous la forme d’une ligne plate dans la partie inférieure du graphique, puis grimpent en flèche pour afficher le total. Dans l’exemple suivant, les valeurs nulles sont remplacées par des valeurs #N/A.

Exemple de graphique en courbes ne traçant pas de valeurs #N/A

Pour plus d’informations sur l’apparition d’une erreur #N/A dans une fonction spécifique, consultez les rubriques suivantes :

Haut de la page

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Voir aussi

Convertir les nombres stockés en tant que texte en nombres

Fonction RECHERCHEV

Fonction RECHERCHEH

Fonction recherche

Fonction EQUIV

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Erreurs pour détecter les erreurs dans les formules

Raccourcis clavier dans Excel pour Windows

Raccourcis clavier dans Excel pour Mac

Excel toutes les fonctions (par ordre alphabétique)

Excel toutes les fonctions (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×