Correction de l’erreur #VALEUR! dans les fonctions MOYENNE et SOMME

Si les fonctions MOYENNE et SOMME font référence à des cellules qui contiennent des erreurs #VALEUR!, les formules génèrent une erreur #VALEUR!.

Erreur #VALEUR! dans la fonction MOYENNE

Pour contourner les valeurs d’erreur, nous allons créer une formule qui ignore les erreurs présentes dans la plage de référence afin de calculer la moyenne avec les valeurs « normales » restantes.

Pour contourner ce problème, nous allons combiner les fonctions MOYENNE, SI et ESTERREUR afin de déterminer s’il existe une erreur dans la plage spécifiée. Pour ce faire, une formule matricielle est nécessaire :

=MOYENNE(SI(ESTERREUR(B2:D2),"",B2:D2))

Remarque : Cette formule matricielle doit être entrée avec CTRL+MAJ+ENTRÉE. Excel entoure automatiquement la formule d’accolades ({}). Si vous essayez de les entrer vous-même, Excel affiche la formule en tant que texte.

Fonction matricielle dans MOYENNE pour résoudre l’erreur #VALEUR!

Remarque : La fonction ci-dessus s’applique à #VALEUR! mais aussi à #N/A, #NULL, #DIV/0! et autres.

La fonction SOMME peut également être utilisée de la même façon :

=SOMME(SI(ESTERREUR(B2:D2),"",B2:D2))

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction MOYENNE

Fonction SOMME

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×