Correction d’une erreur #VALEUR! dans la fonction SOMMEPROD

Cette rubrique présente les cas les plus courants d’erreurs #VALEUR! liées à la fonction SOMMEPROD.

Problème : Les arguments matriciels n’ont pas la même dimension

Tous les arguments matriciels doivent être de la même dimension. Si ce n’est pas le cas, une erreur #VALEUR! est générée. Par exemple, si la Matrice 1 fait référence à une plage de 3 lignes et 2 colonnes, la plage de la Matrice 2 doit être similaire.

Formule SOMMEPROD générant une erreur : =SOMMEPROD(D2:D13,E2:E10) - E10 doit être remplacé par E13 afin de correspondre à la première plage.
  • =SOMMEPROD(D2:D13,E2:E10)

Cette formule échouera car les plages référencées ne comportent pas le même nombre de lignes (13 dans la première plage et seulement 10 dans la deuxième).

Solution : Remplacez la formule par :

  • =SOMMEPROD(D2:D13,E2:E13)

pour que les numéros des lignes de début et de fin des deux plages correspondent, puis réessayez d’utiliser la formule.

Résolvez l’erreur #VALEUR! présente dans les données afin de résoudre l’erreur SOMMEPROD

Problème : Une ou plusieurs cellules de la plage contiennent du texte

Si une ou plusieurs cellules de la plage référencée contiennent du texte ou sont mises en forme avec le type de données Texte, une erreur #VALEUR! est générée. Le texte peut être le résultat d’un calcul effectué par une autre formule, ou la cellule n’est peut-être pas correctement mise en forme.

La formule de la cellule E15 affiche une erreur #VALEUR! car la colonne E comporte elle-même une erreur #VALEUR!.

Solution : Recherchez une cellule contenant du texte, ou mise en forme en tant que texte, et définissez le type de données approprié.

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction SOMMEPROD

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×