Correction d’une erreur #VALEUR! dans la fonction SOMME.SI/SOMME.SI.ENS

Cette rubrique répertorie les causes les plus courantes de l’erreur #VALEUR! dans les fonctions SOMME.SI et SOMME.SI.ENS ainsi que les solutions de résolution de celle-ci.

Problème : La formule fait référence à des cellules figurant dans un classeur fermé

Les fonctions SOMME.SI/SOMME.SI.ENS qui font référence à une cellule ou à une plage figurant dans un classeur fermé génèrent une erreur #VALEUR!.

Remarque : ce problème concerne également d’autres fonctions Excel telles que NB.SI, NB.SI.ENS ou NB.VIDE. Voir l’article Les fonctions SOMME.SI, NB.SI et NB.VIDE renvoient l’erreur #VALEUR! pour plus d’informations.

Solution : Ouvrez le classeur indiqué dans la formule et appuyez sur F9 pour actualiser celle-ci.

Vous pouvez également contourner le problème en utilisant conjointement les fonctions SOMME et SI dans une formule matricielle. Voir l’article Les fonctions SOMME.SI, NB.SI et NB.VIDE renvoient l’erreur #VALEUR! pour plus d’informations.

Problème : La chaîne de critères dépasse les 255 caractères

Les fonctions SOMME.SI/SOMME.SI.ENS renvoient des résultats incorrects lorsque vous les utilisez pour mettre en correspondance des chaînes comportant plus de 255 caractères.

Solution : Si possible, raccourcissez la chaîne. Si vous ne pouvez pas la raccourcir, utilisez la fonction CONCATENER ou l’opérateur Esperluette (&) pour décomposer la valeur en plusieurs chaînes. Par exemple :

=SOMME.SI(B2:B12;"chaîne longue"&"autre chaîne longue")

Problème : Dans SOMME.SI.ENS, l’argument plage_critères n’est pas cohérent avec l’argument somme_plage.

Dans SOMME.SI.ENS, les arguments relatifs aux plages doivent toujours être identiques. Cela signifie que les arguments plage_critères et somme_plage doivent faire référence au même nombre de lignes et de colonnes.

Dans l’exemple suivant, la formule est censée renvoyer la somme des ventes quotidiennes de pommes à Bellevue. Cependant, le nombre de lignes et de colonnes de l’argument somme_plage (C2:C10) ne correspond pas à celui des arguments plage_critères (A2:A12 & B2:B12). L’utilisation de la syntaxe =SOMME.SI.ENS(C2:C10,A2:A12,A14,B2:B12,B14) générera l’erreur #VALEUR!.

La formule suivante est incorrecte : SOMME.SI.ENS(C2:C10,A2:A12,A14,B2:B12,B14), car C2:C10 doit être remplacé par C2:C12
Dans la fonction SOMME.SI.ENS, les arguments plage_critères et somme_plage doivent être cohérents.

Solution : Dans cet exemple, remplacez l’argument somme_plage par C2:C12, puis réessayez d’utiliser la formule.

Remarque :  SOMME.SI peut utiliser différentes plages de tailles.

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction SOMME.SI

Fonction SOMME.SI.ENS

Vidéos sur les fonctions SI avancées

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×