Correction d’une erreur #VALEUR! dans la fonction SI

SI est l’une des fonctions les plus polyvalentes et populaires d’Excel, et elle est souvent utilisée plusieurs fois dans la même formule ainsi que dans les combinaisons avec d’autres fonctions. Malheureusement, en raison de la complexité de certaines instructions SI, une erreur #VALEUR! peut facilement être générée. Vous pouvez généralement supprimer l’erreur en ajoutant des fonctions spécifiques de gestion des erreurs, comme ESTERREUR, ESTERR ou SIERREUR, à votre formule.

Problème : L’argument fait référence à des valeurs d’erreur

Lorsqu’une cellule fait référence à une valeur d’erreur, SI affiche l’erreur #VALEUR!.

Solution : Vous pouvez utiliser n’importe quelle formule de gestion d’erreurs, comme ESTERREUR, ESTERR ou SIERREUR, avec SI. Les rubriques suivantes expliquent comment utiliser SI, ESTERREUR, ESTERR ou SIERREUR dans une formule lorsque votre argument fait référence à des valeurs d’erreur.

Remarques : 

  • La fonction SIERREUR a été introduite dans Excel 2007 et elle est nettement préférable à ESTERREUR ou ESTERR, car elle n’exige pas que la formule soit créée de manière redondante. Avec les fonctions ESTERREUR et ESTERR, la formule doit être calculée deux fois, d’abord pour voir si elle génère une erreur, puis pour renvoyer son résultat. SIERREUR n’effectue qu’un seul calcul.

  • =SIERREUR(Formule,0) est préférable à =SI(ESTERREUR(Formule,0,Formule))

Problème : la syntaxe est incorrecte

Si la syntaxe d’une fonction est incorrecte, elle peut renvoyer l’erreur #VALEUR!.

Solution : Vérifiez que la syntaxe est correcte. Voici un exemple de formule correcte qui imbrique une fonction SI dans une autre fonction SI pour calculer des déductions d’après un niveau de revenu.

=SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%))

Exemple d’instruction SI bien construite

Autrement dit : SI la valeur de la cellule A5 est inférieure à 31 500, alors multiplier la valeur par 15%. Mais SI ce n’est pas le cas, vérifier que la valeur est inférieure à 72 500. SI c’est le cas, multiplier par 25%, sinon multiplier par 28%.

Pour utiliser SIERREUR avec une formule existante, il vous suffit de l’ajouter à cette formule :

=SIERREUR(SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%)),0)

Autrement dit, SI une partie quelconque de la formule d’origine génère une erreur, afficher 0, sinon renvoyer le résultat de l’instruction SI. Certaines personnes rédigent leurs formules en commençant par une fonction de gestion des erreurs, ce qui n’est pas recommandé car le Gestionnaire d’erreurs supprimera les erreurs potentielles, et vous ne saurez pas nécessairement si votre formule fonctionne correctement ou non. Si vous tenez à ajouter une fonction de gestion des erreurs, mieux vaut l’ajouter après vous être assuré que votre formule fonctionne correctement.

Remarque : Les valeurs d’évaluation des formules ne comportent pas de virgules. Si vous en ajoutez, la fonction SI tente de les utiliser en tant qu’arguments et Excel vous renvoie des erreurs. En revanche, les multiplicateurs de type pourcentage comportent le symbole %. Cela indique à Excel que vous souhaitez afficher ces valeurs sous forme de pourcentages. Sinon, vous devriez les entrer en tant que pourcentages réels, par exemple « E2*0,25 ».

Message Excel généré lors de l’ajout d’une virgule à une valeur

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction SI

Fonction SIERREUR

Fonctions EST

Fonction IFS (Office 365 ou Excel 2016 ou versions ultérieures)

Fonction SI – Utiliser des formules imbriquées et éviter les pièges

Vidéo : Fonctions SI imbriquées

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×