Correction d’une erreur #VALEUR! dans la fonction NB.SI/NB.SI.ENS

Cette rubrique répertorie les causes les plus courantes de l’erreur #VALEUR! dans les fonctions NB.SI et NB.SI.ENS.

Problème : La formule fait référence à des cellules figurant dans un classeur fermé

Les fonctions NB.SI/NB.SI.ENS qui font référence à une cellule ou à une plage figurant dans un classeur fermé génèrent une erreur #VALEUR!.

Remarque : ce problème concerne également d’autres fonctions Excel telles que SOMME.SI, SOMME.SI.ENS ou NB.VIDE. Voir Les fonctions SOMME.SI, NB.SI et NB.VIDE renvoient l’erreur #VALEUR! pour plus d’informations.

Solution : Ouvrez le classeur lié indiqué dans la formule et appuyez sur F9 pour actualiser celle-ci.

Vous pouvez également contourner le problème en utilisant conjointement les fonctions SOMME et SI dans une formule matricielle. Voir Les fonctions SOMME.SI, NB.SI et NB.VIDE renvoient l’erreur #VALEUR! pour plus d’informations.

Problème : La chaîne dépasse les 255 caractères

Solution : Si possible, raccourcissez la chaîne. Si vous ne pouvez pas la raccourcir, utilisez la fonction CONCATENER ou l’opérateur esperluette (&) pour décomposer la valeur en plusieurs chaînes. Par exemple,

  • =NB.SI(B2:B12;"chaîne longue"&"autre chaîne longue")

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction NB.SI

Fonction NB.SI.ENS

Fonction SI – Utiliser des formules imbriquées et éviter les pièges

Vidéo sur les fonctions SI avancées

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×