Correction d’une erreur #VALEUR! dans la fonction CONCATENER

Important : Dans Excel 2016, Excel Mobile, et Excel Online, CONCATENER a été remplacé par la fonction CONCAT. Si CONCATENER est toujours disponible à des fins de compatibilité descendante, il est préférable d’utiliser la fonction CONCAT car elle est plus robuste.

L’erreur #VALEUR! liée à CONCATENER survient généralement lorsque vous tentez de créer une chaîne contenant une référence de cellule qui comporte une erreur, par exemple #VALEUR!.

Dans l’exemple suivant, nous souhaitons concaténer D2 E2 et F2, sachant que E2 comporte une erreur #VALEUR!.

Erreur #VALEUR! dans la fonction CONCATENER

L’erreur de la cellule E2 génère l’erreur #VALEUR!. Pour utiliser la fonction, vous devez remplacer l’erreur par une autre valeur. Vous pouvez créer une formule qui recherche une erreur dans la référence de cellule et, si tel est le cas, afficher la chaîne de texte où un 0 apparaît à la place de l’erreur (ou vous pouvez remplacer votre propre texte par 0, mais vous devez alors mettre le texte entre guillemets : “Votre texte”).

La formule suivante fonctionnera :

=SI(ESTERREUR(E2),CONCATENER(D2," ",0," ",F2))

Fonctions SI et ESTERREUR utilisées comme solution de contournement pour concaténer une chaîne comportant l’erreur #VALEUR!

Comment cela fonctionne-t-il ? La fonction SI utilise SIERREUR pour déterminer s’il existe une erreur dans E2. Si tel est le cas, la fonction CONCATENER combine les valeurs de D2, E2 et F2 (la fonction remplace l’erreur par un 0) et affiche la chaîne de texte qui en résulte. Notez que la formule utilise également des espaces (“ “) afin de séparer les valeurs.

Corriger l’erreur #VALEUR! avec la fonction CONCATENER dans Excel 2003 et versions antérieures

Si vous rencontrez l’erreur #VALEUR! dans Office Excel 2003 ou versions antérieures, vous devez désactiver l’option Autre interprétation des formules dans Excel. Pour résoudre ce problème, suivez les étapes décrites dans Erreur #VALEUR! lors de la concaténation de cellules.

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR!

Fonction CONCATENER

Fonction CONCAT

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×