Contrôle de votre site Web à l'aide de Visio

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Si vous gérez les opérations quotidiennes d'un site Web, vous savez qu'il est essentiel d'avoir une vision claire de la structure globale et du fonctionnement général du site, de suivre les modifications, ainsi que de contrôler et réparer les liens hypertexte rompus. Vous pouvez assurer toutes ces tâches et bien d'autres à l'aide des outils Carte de site Web de Microsoft Office Visio Professional.

Que voulez-vous faire ?

Mappage du contenu de votre site

Vérification automatique des erreurs sur votre site

Effectuer le suivi des modifications apportées à votre site

Créer la carte du contenu de votre site

La gestion de votre site commence par l'analyse de son état actuel. Lorsque vous dressez la carte de votre site, vous créez une représentation graphique à jour de la structure et du contenu du site.

Carte de site Web présentant la structure hiérarchique réelle des liens du site

Chaque forme de la carte de site représente un lien sur votre site Web et comprend des informations sur le type et l'emplacement du lien. En cliquant avec le bouton droit de la souris sur une forme, vous pouvez aller directement de la forme à son emplacement sur le Web.

  1. Dans Visio, dans le menu Fichier, pointez sur Nouveau, sur Logiciel et base de données, puis cliquez sur Carte de site Web.

  2. Dans la boîte de dialogue Générer une carte de site, entrez une adresse de site correspondant à l'un des éléments suivants :

    • dans le cas d'un serveur HTTP, dans la zone Adresse, entrez l'adresse du site Web dont vous dressez la carte ;

    • dans le cas d'un serveur de réseau ou d'un disque dur local, cliquez sur Parcourir, sélectionnez le fichier à mettre à la racine de votre carte de site, puis cliquez sur Ouvrir.

  3. Dans la boîte de dialogue Générer une carte de site, cliquez sur Paramètres pour passer en revue les paramètres correspondant au nombre maximal de niveaux et au nombre de liens à découvrir.

  4. Pour modifier les paramètres, procédez de l'une des manières suivantes :

    • dans l'onglet Disposition, modifiez le style de disposition de la carte de site Web, par exemple le nombre de niveaux à découvrir ou l'utilisation des options Compacter l'arborescence ou Diagramme de flux ;

    • dans l'onglet Extensions, sélectionnez le type de fichiers (comme .doc, .jpg ou .exe) dont vous souhaitez dresser la carte ;

    • dans l'onglet Protocoles, sélectionnez les protocoles (comme mailto, ftp ou NNTP) dont vous souhaitez dresser la carte ;

    • dans l'onglet Attributs, sélectionnez les attributs HTML (comme HREF, SRC ou CODE) à analyser pour la recherche de liens ;

    • dans l'onglet Options avancées, sélectionnez les options qui affineront vos critères de recherche ;

    • cliquez sur OK.

  5. Dans la boîte de dialogue Générer une carte de site, cliquez sur OK.

  6. Pour enregistrer la carte de site, dans le menu Fichier, cliquez sur Enregistrer.

Haut de la Page

Effectuer une recherche automatique des erreurs sur votre site

Veiller à ce que les liens du site restent actifs et sans erreurs constitue la tâche la plus critique dans la gestion d'un site Web.

Lorsque vous dressez la carte de votre site, Visio suit chaque lien conformément aux paramètres que vous avez spécifiés et assure le suivi des erreurs rencontrées. Les liens erronés apparaissent sur la carte de site, dans la fenêtre de filtre et dans la fenêtre de liste, en tant que formes marquées d'un X rouge. Si ces fenêtres ne sont pas visibles, dans le menu Carte de site Web, pointez sur Fenêtres, puis cliquez sur Fenêtre de liste ou Fenêtre de filtre. Il est possible de générer rapidement une liste de liens rompus avec les erreurs associées pour faciliter le suivi de votre travail et effectuer les réparations requises.

Carte de site Web présentant la structure d'un site ; les formes contenant un X rouge indiquent un lien rompu

Créer un rapport des liens erronés sur votre site

  1. Ouvrez la carte du site pour lequel vous souhaitez créer un rapport d'erreurs.

  2. Dans le menu Carte de site Web, pointez sur Rapports, cliquez sur Carte de site Web - Liens erronés, puis sur Exécuter.

  3. Sélectionnez le type de fichier (par exemple, Excel ou XML) dans lequel les informations doivent être enregistrées, puis cliquez sur OK.

    Visio crée un rapport répertoriant tous les liens hypertexte qui présentent des erreurs.

  4. Si votre rapport s'ouvre dans un programme hors de Visio, comme Microsoft Office Excel, nommez-le et enregistrez-le.

Corriger les liens rompus

Certaines ruptures de liens sont provoquées par des erreurs d'expiration. Pour résoudre ces erreurs, cliquez avec le bouton droit de la souris sur le lien, puis cliquez sur Actualiser ou sur Actualiser le parent.

D'autres ruptures de liens sont causées par des sites introuvables, des accès refusés, des demandes de mot de passe, des noms ou des emplacements de fichier incorrects et des fichiers manquants. Tous ces problèmes peuvent entraîner l'affichage d'un message d'erreur 404 ou Fichier introuvable. Tous ces problèmes doivent être corrigés dans votre site Web.

Il n'existe pas de liaison dynamique entre votre site Web et sa carte ; par conséquent, la modification de l'un n'affecte pas automatiquement l'autre. Après avoir corrigé un lien rompu sur le site Web, vous pouvez mettre à jour sa carte en cliquant avec le bouton droit de la souris sur la forme qui représente le lien en question avant de cliquer sur Actualiser le lien hypertexte. Le X rouge disparaît.

Haut de la Page

Effectuer le suivi du travail sur votre site

Si plusieurs développeurs travaillent sur votre site, le suivi de leur travail peut vite devenir une tâche à temps plein. Grâce au rapport de comparaison de cartes de site Web, vous pouvez comparer deux versions de votre site afin de quantifier les changements effectués au cours d'une période donnée. Le rapport compare les deux versions et génère une liste de différences. Il identifie non seulement les liens qui n'apparaissent que dans l'une des cartes, mais répertorie également les changements suivants des liens dans les deux cartes :

  • état de l'erreur ;

  • titre du fichier ;

  • taille du fichier ;

  • date de modification du fichier.

Par exemple, supposons que vous souhaitiez quantifier le travail effectué sur le site chaque semaine. Il vous suffit de dresser une carte du site au début de la semaine et une nouvelle fois à la fin. Ensuite, comparez les deux cartes pour générer un rapport des modifications. Vous pouvez également analyser le rapport par rapport à un calendrier de travail prévu pour la semaine pour vérifier si votre projet de site Web est dans les temps.

Comparer des cartes de site Web

  1. Ouvrez la carte la plus récente de votre site Web.

  2. Dans le menu Carte de site Web, cliquez sur Comparer au document précédent.

  3. Recherchez la carte de site Web avec laquelle vous souhaitez effectuer la comparaison, sélectionnez le fichier, puis cliquez sur Ouvrir.

    Visio compare les deux cartes et génère un rapport HTML répertoriant les différences.

  4. Nommez et enregistrez votre rapport.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×