Concevoir un formulaire pour répondre à un état de flux de travail

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez créer des formulaires Microsoft Office InfoPath pour afficher des données spécifiques qui correspond à l’état actuel d’un flux de travail. Pour cela, vous créez un modèle de formulaire à utiliser des règles qui initier une action dans son formulaires basés sur l’état du flux de travail. Cela permet de rationaliser les processus qui utilisent des personnes à remplir des formulaires.

Cet article décrit comment créer un modèle de formulaire de note de note de frais pour afficher automatiquement les différents affichages du modèle de formulaire, en fonction de l’état de flux de travail approbation associé. Par exemple, avant que le flux de travail est démarré, le formulaire affichera une vue de dépenses qui contient un tableau extensible dans lequel les utilisateurs peuvent taper dépenses. Lorsque l’état du flux de travail est En cours, le formulaire affiche une vue de résumé des dépenses qui affiche le total des frais dans chaque catégorie. Lorsque l’état du flux de travail est terminé, le formulaire affiche la vue terminé, qui inclut des détails sur les durées de remboursement estimée.

Pour permettre aux formulaires de répondre aux états de flux de travail, vous devez réaliser certaines tâches sur le site Microsoft Office SharePoint Server 2007ou sur le site Windows SharePoint Services 3.0 où se trouvent les formulaires, ainsi que certaines tâches dans InfoPath. Sur le site SharePoint, vous devez créer un flux de travail et un type de contenu de site. Dans InfoPath, vous devez ajouter une connexion de données à un modèle de formulaire, créer une règle et publier le modèle de formulaire.

Remarque : Cet article utilise un exemple de scénario dans lequel un modèle de formulaire est publié en tant que type de contenu de site. Vous pouvez également publier un modèle de formulaire sur un emplacement réseau partagé ou créer une bibliothèque de documents lorsque vous publiez un modèle de formulaire sur un site SharePoint. Vous trouverez plus d'informations sur la publication de modèles de formulaire dans la section Voir aussi.

Dans cet article

Introduction à l'utilisation de flux de travail avec des formulaires InfoPath

Considérations en matière de compatibilité

Avant de commencer

Étape 1 : ajouter un flux de travail Approbation à une bibliothèque

Étape 2 : ajouter une connexion de données à un modèle de formulaire

Étape 3 : ajouter une règle à un modèle de formulaire pour afficher une vue spécifique

Étape 4 : publier un modèle de formulaire en tant que type de contenu de site

Étape5: ajouter un type de contenu à une bibliothèque de documents

Introduction à l'utilisation de flux de travail avec des formulaires InfoPath

Les flux de travail aident les personnes à collaborer sur des documents et à gérer des tâches de projet en implémentant des processus métier spécifiques dans des documents et des éléments sur un site Microsoft Office SharePoint Server 2007 ou un site Windows SharePoint Services 3.0. Les flux de travail aident les organisations à respecter des processus métier cohérents et ils améliorent également l'efficacité et la productivité de l'organisation en gérant les tâches et les étapes impliquées dans des processus métier spécifiques. Ainsi, les personnes qui effectuent ces tâches peuvent se concentrer davantage sur la réalisation de leur travail plutôt que sur la gestion du flux de travail.

Vous pouvez activer un formulaire InfoPath pour afficher des données spécifiques qui correspond à l’état actuel d’un flux de travail. Pour cela, vous créez un modèle de formulaire à utiliser des règles qui initier une action dans le formulaire basé sur l’état du flux de travail. Cela permet de rationaliser les processus qui utilisent des personnes à remplir des formulaires. Par exemple, vous pouvez activer un formulaire afficher une vue en lecture seule lorsque l’état d’un flux de travail est terminée et, par conséquent, les données sous la forme ne doivent pas être modifiées.

Il est nécessaire d'ajouter les flux de travail à une liste, une bibliothèque ou un type de contenu SharePoint, afin qu'ils soient disponibles pour une utilisation sur des modèles de formulaire InfoPath. Les flux de travail disponibles pour un site varient également en fonction du type de site et s'ils ont été créés à l'aide de Microsoft Office SharePoint Designer 2007.

Cet article utilise le flux de travail Approbation pour illustrer l'utilisation des flux de travail avec des modèles de formulaire InfoPath. Le flux de travail Approbation route un formulaire InfoPath qui est enregistré dans une bibliothèque vers un groupe de personnes pour approbation. Par défaut, le flux de travail Approbation est associé au type de contenu Document et est automatiquement disponible dans les bibliothèques de documents ou de formulaires.

Chaque flux de travail est définie par distincts statuts des noms descriptifs, par exemple En cours. Les noms pour statuts varient selon le type de flux de travail. Par exemple, un flux de travail approbation, qui est disponible sur les serveurs exécutant Microsoft Office SharePoint Server 2007: inclut un état pour En cours et annuléterminé. Les statuts d’un flux de travail à trois états, qui est disponible dans Windows SharePoint Services 3.0 — peuvent être définies par la personne qui ajoute le flux de travail à une bibliothèque ou liste, tandis que d’autres flux de travail utilisent statuts standard telles que le statut En cours mentionné précédemment. Bien que le nom descriptif est visible par l’utilisateur, statuts de flux de travail sont représentés par programme par des valeurs numériques. Pour créer un modèle de formulaire pour répondre à un état de flux de travail spécifique, vous devez connaître la valeur numérique de l’état du flux de travail que vous souhaitez utiliser. C’est parce que InfoPath utilise la valeur numérique du flux de travail pour initier une action, tels que des vues changement.

Comme nous l'avons vu précédemment, vous pouvez activer un modèle de formulaire InfoPath pour afficher des données spécifiques qui correspondent à l'état actuel d'un flux de travail. Bien que cet article décrive comment activer une note de frais pour afficher automatiquement une vue spécifique en fonction de son état dans le flux de travail, vous pouvez également personnaliser le flux de travail en ajoutant des actions supplémentaires. Par exemple, au lieu d'activer des formulaires pour afficher une vue spécifique, vous pouvez leur permettre d'afficher un message de boîte de dialogue qui fournit des instructions. En outre, au lieu d'utiliser un flux de travail Approbation, vous pouvez utiliser le flux de travail à trois états.

Remarque : Si vous activez des actions autres que celles décrites dans cet article, vous devez éventuellement suivre des étapes supplémentaires afin de vous assurer que votre modèle de formulaire fonctionne correctement avec le flux de travail que vous utilisez.

Haut de la page

Considérations en matière de compatibilité

Si vous prévoyez de créer un modèle de formulaire compatible avec les navigateurs web, n'oubliez pas que la barre d'action de document, qui apparaît lors du remplissage de formulaires dans des documents Microsoft Office, y compris des formulaires InfoPath, n'apparaît pas dans des modèles de formulaire compatibles avec le navigateur que les utilisateurs remplissent dans un navigateur Web. Pour modifier l'état du flux de travail de tels formulaires, les participants au flux de travail peuvent utiliser les paramètres de la bibliothèque de documents. Pour plus d'informations sur la modification des paramètres de flux de travail à l'aide de sites SharePoint, consultez la section Voir aussi.

Haut de la page

Avant de commencer

Vérifiez les éléments suivants avant d'effectuer les tâches qui figurent dans cet article :

  • Contactez l'administrateur de la batterie pour qu'il confirme que les flux de travail Approbation sont installés et activés pour le site SharePoint que vous voulez utiliser.

  • Vérifiez que vous disposez d'au moins un niveau d’autorisation Création pour le site SharePoint. Ce niveau d'autorisation est nécessaire pour publier un modèle de formulaire et pour créer un flux de travail.

  • Créez un modèle de formulaire avec deux ou plusieurs vues et personnalisez chaque vue pour afficher le type de données approprié à chaque état de flux de travail. Par exemple, pour la vue que vous souhaitez faire apparaître lorsque le flux de travail est terminé, vous pouvez définir les contrôles dans cette vue en lecture seule.

  • Créez une bibliothèque de documents ou de formulaires et assurez-vous que la bibliothèque est configurée pour autoriser plusieurs types de contenu.

Haut de la page

Étape 1 : ajouter un flux de travail Approbation à une bibliothèque

Ce scénario se concentre sur le flux de travail Approbation, mais vous pouvez utiliser un autre type de flux de travail si vous le souhaitez. Si vous utilisez un autre type de flux de travail, les options pour ce flux de travail peuvent différer de ceux décrits dans cet article.

  1. Ouvrez la bibliothèque à laquelle vous souhaitez ajouter un flux de travail.

  2. Dans le menu Paramètres, cliquez sur les paramètres du type de bibliothèque que vous ouvrez.

    Par exemple, dans une bibliothèque de documents, cliquez sur Paramètres de la bibliothèque de documents.

  3. Sous Autorisations et gestion, cliquez sur Paramètres du flux de travail.

  4. Cliquez sur Ajouter un flux de travail.

  5. Dans la page Ajouter un flux de travail, dans la section Flux de travail, cliquez sur Approbation.

  6. Dans la section Nom, tapez un nom unique pour le flux de travail.

    1. Dans la section Liste des tâches, définissez une liste de tâches à utiliser avec ce flux de travail.

      Remarques : 

      • Vous pouvez utiliser la liste Tâches par défaut, ou en créer une nouvelle. Si vous utilisez la liste Tâches par défaut, les participants du flux de travail pourront facilement rechercher et consulter leurs tâches de flux de travail dans l'affichage Mes tâches de la liste Tâches.

      • Si les tâches de ce flux de travail doivent révéler des données sensibles ou confidentielles que vous souhaitez conserver distinctes de la liste Tâches générale, vous devez créer une nouvelle liste de tâches.

      • Si votre entreprise a de nombreux flux de travail, ou si ces derniers comportent de nombreuses tâches, vous avez intérêt à créer une nouvelle liste de tâches. Dans ce cas, vous pourriez créer des listes de tâches pour chaque flux de travail.

  7. Dans la section Historique, sélectionnez un historique à utiliser avec ce flux de travail. L'historique affiche tous les événements qui se produisent durant chaque instance du flux de travail.

    Vous pouvez utiliser l'Historique ou en créer un nouveau. Si votre organisation doit disposer de nombreux flux de travail, vous pouvez créer un historique pour chacun des flux de travail.

  8. Pour autoriser le démarrage manuel du flux de travail, activez la case à cocher Autoriser le démarrage manuel de ce flux de travail par un utilisateur authentifié, habilité à modifier les éléments dans la section Options de démarrage.

  9. Pour demander des autorisations supplémentaires permettant de démarrer le flux de travail, activez la case à cocher Les autorisations Gérer les listes sont requises pour démarrer le flux de travail.

  10. Spécifiez toute autre option que vous voulez, y compris le moment auquel le flux de travail doit démarrer, puis cliquez sur Suivant.

  11. Dans la page Personnaliser le flux de travail, spécifiez les options de votre choix, y compris la façon dont les tâches sont routées, les valeurs de démarrage du flux de travail par défaut, ainsi que la manière dont le flux de travail est achevé, puis cliquez sur OK.

    Sélectionnez des options dans n'importe laquelle des sections suivantes. Vous n'êtes pas obligé de spécifier des options dans chaque section :

    Tâches de flux de travail

    Pour

    Procédez comme suit

    Affecter des tâches à tous les participants à la fois (flux de travail parallèle)

    Sélectionnez Tous les participants simultanément (en parallèle).

    Affecter des tâches à un participant à la fois, en exigeant qu'un participant achète une tâche avant que le participant suivant ne reçoive une tâche (flux de travail en série)

    Sélectionnez Un seul participant à la fois (en série).

    Autoriser les participants du flux de travail à réaffecter leurs tâches à d'autres personnes

    Activez la case à cocher Réaffecter la tâche à une autre personne.

    Autoriser les participants du flux de travail à demander une modification du document ou de l'élément. La modification doit être approuvée avant que la tâche ne soit achevée.

    Activez la case à cocher Demander une modification avant l'achèvement de la tâche.

    Valeurs de démarrage du flux de travail par défaut

    Pour

    Procédez comme suit

    Spécifier une liste par défaut des participants pour toutes les instances de ce flux de travail

    Tapez les noms des participants que vous voulez inclure lors du démarrage du flux de travail, ou cliquez sur Approbateurs et sélectionnez les personnes et les groupes à partir du service d'annuaire.

    Remarques : 

    • Séparez les noms par des points-virgules.

    • Si vous configurez ce flux de travail en tant que flux de travail en série, ajoutez les noms des participants au flux de travail dans l'ordre dans lequel vous souhaitez affecter les tâches.

    Affecter une seule tâche à des groupes, plutôt que d'affecter des tâches individuelles à chaque membre de groupe

    Activez la case à cocher Affectez une seule tâche à chaque groupe entré (Ne développez pas les groupes).

    Autoriser les personnes qui démarrent le flux de travail à modifier ou ajouter des participants

    Activez la case à cocher Permettre des changements dans la liste des participants lorsque ce flux de travail a commencé.

    Spécifier un message par défaut qui apparaît avec chaque tâche

    Tapez un message ou des instructions dans la zone de texte.

    Spécifier une date d'échéance pour les flux de travail en parallèle

    Entrez une date sous Échéance des tâches (en parallèle).

    Spécifier le délai imparti aux participants pour effectuer les tâches de flux de travail

    Sous Donnez à chaque personne le délai suivant pour accomplir sa tâche (en série), tapez un nombre, puis sélectionnez Jour(s) ou Semaine(s) comme intervalle de temps.

    Spécifier une liste de personnes qui doivent recevoir des alertes (pas des affectations de tâche) lorsque le flux de travail est démarré

    Sous Avertir les autres utilisateurs, tapez les noms des personnes que vous voulez avertir, ou cliquez sur Cc et sélectionnez des personnes et des groupes à partir du service d'annuaire.

    Remarque : Séparez les noms par des points-virgules.

    Terminer le flux de travail

    Pour

    Procédez comme suit

    Spécifier qu'un flux de travail en parallèle est terminé lorsqu'un certain nombre de participants achèvent leurs tâches

    Activez la case à cocher Le nombre suivant de tâches sont terminées, puis tapez un nombre.

    Spécifier qu'un flux de travail est terminé lorsque le document ou l'élément est rejeté

    Activez la case à cocher Le document est rejeté.

    Spécifier qu'un flux de travail est terminé quand le document ou l'élément est modifié

    Activez la case à cocher Le document est modifié.

    Activités successives à l'achèvement du flux de travail

    Pour

    Procédez comme suit

    Mettez à jour le statut d'approbation d'un document ou d'un élément une fois le flux de travail terminé.

    Activez la case à cocher Mettre à jour le statut d'approbation (ce flux de travail vous permet de contrôler l'approbation de contenu).

    Remarques : 

    • Si vous utilisez le flux de travail d'approbation pour gérer l'approbation du contenu pour une bibliothèque, et que vous avez activé la case à cocher Démarrer ce flux de travail pour approuver la publication d'une version principale de cet élément dans la page Ajouter un flux de travail, cette case à cocher est activée par défaut.

    • Si vous n'avez pas activé la case à cocher Démarrer ce flux de travail pour approuver la publication d'une version principale de cet élément dans la page Ajouter un flux de travail, car vous ne voulez pas que ce flux de travail constitue le flux de travail d'approbation de contenu par défaut pour une bibliothèque, vous pouvez sélectionner cette case à cocher afin de que ce flux de travail devienne un flux de travail d'approbation de contenu secondaire que certains utilisateurs peuvent démarrer manuellement.

Haut de la page

Étape 2 : ajouter une connexion de données à un modèle de formulaire

La procédure suivante explique comment procéder pour ajouter une connexion de données secondaire qui interroge l'état du flux de travail du flux de travail que vous avez ajouté à l'étape 1. Cette connexion de données secondaire fournit les données qui activent les règles dans le formulaire pour basculer entre les vues en fonction à l'état du flux de travail.

  1. Dans le menu Outils d'InfoPath, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Recevoir les données et enfin, sur Suivant.

  4. Dans la page suivante de l'Assistant, cliquez sur Bibliothèque ou liste SharePoint, puis sur Suivant.

  5. Dans la page suivante de l'Assistant, tapez l'URL du site SharePoint.

  6. Dans la liste Sélectionnez une liste ou une bibliothèque, cliquez sur le nom de la bibliothèque de documents où vous avez ajouté le flux de travail Approbation lors de l'étape 1, puis cliquez sur Suivant.

  7. Dans la page suivante de l'Assistant, dans la liste Sélectionnez des champs, activez la case à cocher située en regard du nom du champ qui correspond au nom de flux de travail.

    Le nom du champ risque de ne pas correspondre exactement au nom du flux de travail. Si le nom du champ commence par un caractère spécial autre qu'une lettre ou un trait de soulignement, le nom du flux de travail sera personnalisé dans la liste.

  8. Activez la case à cocher Inclure les données pour le formulaire actif uniquement et cliquez sur Suivant.

  9. Désactivez la case à cocher Enregistrer une copie des données dans le modèle de formulaire, puis cliquez sur Suivant.

  10. Dans la page suivante de l'Assistant, dans la zone Entrez le nom de cette connexion de données, tapez un nom descriptif pour cette connexion de données secondaire. Ce nom correspond à ce qui s'affiche dans la liste Source de données du volet Office Source de données.

  11. Pour exécuter une requête automatiquement, dès que le formulaire est ouvert par un utilisateur, activez la case à cocher Extraire automatiquement les données à l'ouverture du formulaire.

  12. Dans la dernière page de l'Assistant, cliquez sur Terminer.

  13. Dans la boîte de dialogue Connexions de données, cliquez sur Fermer.

Haut de la page

Étape 3 : ajouter une règle à un modèle de formulaire pour afficher une vue spécifique

Lorsque vous concevez un modèle de formulaire, vous pouvez utiliser des règles pour automatiquement afficher une boîte de dialogue, définissez la valeur d’un champ, la requête ou envoyer des données de formulaire vers une connexion de données, basculer entre les affichages, ou ouvrir ou fermer un formulaire en réponse à certains événements et conditions. Les événements peuvent inclure une modification apportée à un champ particulier ou un groupe dans la source de données, d’un simple clic, l’insertion d’une section extensible ou une ligne dans un tableau extensible, ouverture ou envoi d’un formulaire. Les conditions peuvent inclure des calculs, les expressions XPath et les rôles d’utilisateur. Les conditions peuvent également inclure la valeur d’un champ est vide, se trouve dans une plage spécifiée, est égale à celle d’un autre champ, ou commence par ou contient certains caractères.

Dans ce cas, vous allez créer une règle pour basculer entre les vues en fonction de l'état du flux de travail.

  1. Dans le menu Outils, cliquez sur Options de formulaire.

  2. Dans la listeCatégorie, cliquez sur Ouvrir et enregistrer.

  3. Sous Ouvrir un comportement, cliquez sur Règles.

  4. Dans la boîte de dialogue Règles pour l'ouverture de formulaires, cliquez sur Ajouter.

  5. Dans la zone Nom, tapez un nom pour la règle.

    Par exemple, tapez Changer de vue.

  6. Pour spécifier une condition pour l'exécution de la règle, cliquez sur Définir une condition.

  7. Sous Appliquer la règle lorsque cette condition est vraie, dans la première zone, cliquez sur Sélectionnez un champ ou un groupe.

  8. Dans la liste Source de données, cliquez sur le nom de la source de données secondaire que vous avez ajoutée à l'étape 2, puis sur OK.

  9. Cliquez sur le nom du champ qui correspond à l'état du flux de travail.

    Vous devrez peut-être développer les dossiers dans la fenêtre jusqu'à afficher le champ de votre choix.

  10. Dans la boîte de dialogue Condition, dans la deuxième liste, cliquez sur est égal à.

  11. Dans la troisième liste, cliquez sur Tapez un nombre et tapez la valeur qui correspond à l'état du flux de travail.

    Par exemple, pour une vue qui s'affiche lorsque le flux de travail est terminé, tapez 5.

    Des valeurs numériques pour des états de flux de travail dans le flux de travail Approbation

    Statut

    Valeur numérique

    En cours

    2

    Terminé

    5

    Annulé

    15

    Approuvé

    16

    Rejeté

    17

    Remarques : 

    • Les valeurs numériques pour les états dans d'autres flux de travail peuvent différer.

    • La valeur de l'état de flux de travail dans InfoPath est en lecture seule. Cela signifie que vous ne pouvez pas concevoir un modèle de formulaire pour qu'un utilisateur puisse modifier manuellement l'état du flux de travail en entrant une valeur dans un contrôle sur le formulaire même.

  12. Cliquez sur OK.

  13. Dans la boîte de dialogue Règle, cliquez sur Ajouter une action.

  14. Sous Action, cliquez sur Changer de vue.

  15. Sous Afficher, cliquez sur le nom de la vue que vous souhaitez afficher lorsque l'état de flux de travail correspond à l'état pour cette condition, puis cliquez sur OK.

    Par exemple, si vous avez tapé 2lors de l'étape 11, cliquez sur le nom de la vue que vous voulez afficher lorsque l'état du flux de travail est égal à En cours.

  16. Dans la boîte de dialogue Règle, cliquez sur OK.

  17. Répétez les étapes 4 à 16 pour créer des règles supplémentaires pour basculer entre les vues appropriées à chaque étape dans le flux de travail.

Haut de la page

Étape 4 : publier un modèle de formulaire en tant que type de contenu de site

Lorsque vous publiez un modèle de formulaire, vous pouvez soit le publier dans une bibliothèque de documents, soit le publier en tant que type de contenu de site pouvant être utilisé dans plusieurs bibliothèques de documents à travers une collection de sites. Étant donné que vous déjà créé une bibliothèque de documents et que vous lui avez affecté un flux de travail, vous devez publier le modèle de formulaire en tant que type de contenu. Ensuite, vous pouvez associer le type de contenu du site du modèle de formulaire à la bibliothèque que vous avez créée.

En plus de la publication d'un modèle de formulaire en tant que type de contenu du site, vous pouvez également publier un modèle de formulaire sur un emplacement réseau partagé ou créer une nouvelle bibliothèque de documents lorsque vous publiez un modèle de formulaire sur un site SharePoint. Vous trouverez plus d'informations sur la publication de formulaires dans la section Voir aussi.

  1. Dans le menu Fichier, cliquez sur Enregistrer.

  2. Dans la boîte de dialogue Enregistrer sous, accédez à l’emplacement où vous souhaitez enregistrer le modèle de formulaire, puis cliquez sur Enregistrer.

  3. Pour ouvrir le volet Office Vérificateur de mise en page, cliquez sur Vérificateur de mise en page dans le menu Outils.

  4. Si des erreurs sont répertoriées dans le volet Office Vérificateur de mise en page, corrigez ces erreurs, puis cliquez sur Actualiser pour déterminer si les erreurs existent toujours.

  5. Dans le menu Fichier, cliquez sur Publier.

  6. Dans l'Assistant Publication, cliquez sur Vers un serveur SharePoint avec ou sans InfoPath Forms Services, puis cliquez sur Suivant.

  7. Dans la page suivante de l’Assistant, dans la zone Entrez l’emplacement de votre site SharePoint ou InfoPath Forms Services, tapez l’emplacement du site SharePoint où vous souhaitez publier votre modèle de formulaire, puis cliquez sur suivant.

  8. Pour permettre aux utilisateurs de remplir ce formulaire à l'aide d'un navigateur Web, dans la page suivante de l'Assistant, activez la case à cocher Activer ce formulaire pour qu'il puisse être rempli à l'aide d'un navigateur.

  9. Cliquez sur Type de contenu de site (avancé), puis sur Suivant.

  10. Dans la page suivante de l'Assistant, cliquez sur Créer un type de contenu.

  11. Dans la liste Baser le type de contenu sur, cliquez sur Formulaire, puis sur Suivant.

  12. Dans la page suivante de l'Assistant, tapez un nom et une description pour le nouveau type de contenu, puis cliquez sur Suivant.

  13. Dans la page suivante de l'Assistant, dans la zone Indiquez l'emplacement et le nom de fichier du modèle de formulaire, tapez l'emplacement du site SharePoint et cliquez sur Parcourir.

  14. Dans la boîte de dialogue Parcourir, accédez à l'emplacement sur le serveur où vous voulez publier le modèle de formulaire en tant que type de contenu de site, puis dans la zone Nom de fichier, tapez le nom du modèle de formulaire et cliquez sur Enregistrer.

  15. Cliquez sur Suivant.

  16. Choisissez les champs dans le modèle de formulaire que vous souhaitez afficher comme des colonnes dans l'affichage par défaut de la bibliothèque de documents.

    Comment ?

    1. Cliquez sur Ajouter.

    2. Sélectionnez le champ que vous voulez ajouter en tant qu’une colonne dans la bibliothèque de documents, puis effectuez l’une des opérations suivantes :

      • Tapez un nom pour la colonne dans la zone nom de colonne.

      • Sélectionnez la colonne de site dans la liste groupe de colonnes de Site, sélectionnez un nom dans la liste nom de colonne, puis cliquez sur OK.

        Si vous avez sélectionné un champ extensible pour afficher des données dans la bibliothèque de documents, vous pouvez définir comment vous voulez afficher le champ dans la bibliothèque de documents en cliquant sur une valeur dans la liste de fonctions. Vous pouvez choisir si vous voulez afficher la première valeur dans le champ, la dernière valeur dans le champ, ou un compteur de toutes les occurrences du champ, ou si vous souhaitez fusionner toutes les valeurs.

    3. Cliquez sur OK.

  17. Cliquez sur Suivant.

  18. Sur la page suivante de l'Assistant, vérifiez que les informations s'affichent correctement, puis cliquez sur Publier.

  19. Cliquez sur Fermer, puis vérifiez que votre modèle de formulaire est un type de contenu sur le site SharePoint.

    Comment ?

    1. Ouvrez le site SharePoint dans un navigateur Web.

    2. Dans le menu Actions du site situé dans le coin supérieur droit du site, cliquez sur Paramètres du site.

    3. Dans Paramètres du Site, sous galeries, cliquez sur types de contenu de Site.

      Votre modèle de formulaire doit être répertorié sous Types de contenu InfoPath dans la Galerie de Type de contenu de Site.

Haut de la page

Étape 5 : ajouter un type de contenu à une bibliothèque de documents

Types de contenu permettent aux organisations d’organiser, gérer et gérer plus efficacement du contenu au sein d’une collection de sites. En définissant des types de contenu pour certains types de documents, une organisation permet de garantir que chacun de ces groupes de contenu sera géré plus efficacement. Vous pouvez configurer une liste ou bibliothèque peut contenir des éléments de plusieurs types d’éléments ou les types de documents en ajoutant des types de contenu dans la liste ou bibliothèque.

Remarque : Pour ajouter des types de contenu à une liste ou une bibliothèque, vous avez au moins besoin du niveau d'autorisation Création pour cette liste ou bibliothèque.

Avant de commencer, assurez-vous que la bibliothèque est configurée pour autoriser plusieurs types de contenu.

Autoriser plusieurs types de contenu

  1. Dans le menu Paramètres, cliquez sur Paramètres de la bibliothèque de documents.

  2. Sous Paramètres généraux, cliquez sur Paramètres avancés.

  3. Dans la section Types de contenu, sélectionnez Oui pour autoriser plusieurs types de contenu, puis cliquez sur OK.

  1. Si la liste ou la bibliothèque n'est pas déjà ouverte, cliquez sur son nom dans Lancement rapide.

    Remarque : Si le nom de votre liste ou bibliothèque n'apparaît pas, cliquez sur Afficher tout le contenu du site, puis cliquez sur le nom de votre liste ou bibliothèque.

  2. Dans le menu Paramètres, cliquez sur Paramètres de la bibliothèque de documents.

  3. Sous Types de contenus, cliquez sur Ajouter à partir de types de contenu de site existants.

  4. Dans la liste Sélectionner des types de contenu dans de la section Sélectionner des types de contenu, sélectionnez le groupe de types de contenu de site à partir duquel vous voulez effectuer votre sélection.

  5. Dans la liste Types de contenu de site disponibles, cliquez sur le type de contenu de votre choix, puis cliquez sur Ajouter pour déplacer le type de contenu sélectionné vers la liste Types de contenu à ajouter.

  6. Pour ajouter des types de contenu supplémentaires, répétez les étapes 4 et 5, puis cliquez sur OK.

À présent, lorsqu'un utilisateur crée un nouveau formulaire dans cette bibliothèque, la vue du formulaire s'affiche en fonction de l'état du flux de travail.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Ces informations vous ont-elles été utiles ?

Comment pouvons-nous nous améliorer ?

Comment pouvons-nous nous améliorer ?

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.