Compter les nombres ou des dates selon une condition

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Pour compter les nombres ou des dates qui répondent à une seule condition (par exemple égal à, supérieur à, moins, supérieur ou égal à ou inférieur ou égal à), utilisez la fonction Nb.Si . Pour compter les nombres ou des dates appartenant à une plage (par exemple, supérieur à 9000 et en même temps 22500 inférieur), vous pouvez utiliser la fonction Nb.Si.ens . Vous pouvez également utiliser SOMMEPROD trop.

Exemple

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Vendeur

Facture

Beaune

15 000

Beaune

9 000

Suyama

8 000

Suyama

20 000

Beaune

5 000

Duprez

22 500

Formule

Description (résultat)

=NB.SI(B2:B7,">9000")

La fonction NB.Si compte le nombre de cellules dans la plage B2 : B7 qui contiennent des nombres supérieurs à 9000 (4)

=NB.SI(B2:B7,"<=9000")

La fonction NB.Si compte le nombre de cellules de la plage B2 : B7 qui contiennent des nombres inférieures à 9000 (4)

= COUNTIFS(B2:B7,">=9000",B2:B7,"<=22500")

Compte le nombre de cellules dans la B2 : B7 plage supérieure ou égale à 9 000 de la fonction NB.Si.ENS (disponible dans Excel 2007 et versions ultérieure) et est inférieur ou égal à 22500 (4)

= SOMMEPROD ((B2:B7>=9000) * (B2 : B7 < = 22500))

La fonction SOMMEPROD compte le nombre de cellules dans la plage B2 : B7 qui contiennent des nombres supérieurs ou égaux à 9 000 et inférieure ou égale à 22500 (4). Vous pouvez utiliser cette fonction dans Excel 2003 et les versions antérieures, où Nb.Si.ens n’est pas disponible.

Date

3/11/2011

01/01/2010

31/12/2010

30/6/2010

Formule

Description (résultat)

= COUNTIF(B14:B17,">3/1/2010")

Compte le nombre de cellules dans la plage B14:B17 avec un données supérieur à 3/1/2010 (3)

=COUNTIF(B14:B17,"12/31/2010")

Compte le nombre de cellules dans la plage B14:B17 égal à 31/12/2010 (1). Le signe égal n’est pas nécessaire dans les critères, afin qu’il n’est pas incluse ici (la formule fonctionne avec un signe égal si vous incluez il (« = 31/12/2010 »).

= COUNTIFS(B14:B17,">=1/1/2010",B14:B17,"<=12/31/2010")

Compte le nombre de cellules dans la plage B14:B17 qui est comprise entre 1/1/2010 (inclus) et 31/12/2010 (3).

= SOMMEPROD ((B14:B17>=DATEVALUE("1/1/2010")) * (B14:B17 < =DATEVALUE("12/31/2010")))

Compte le nombre de cellules dans la plage B14:B17 qui est comprise entre 1/1/2010 (inclus) et 31/12/2010 (3). Cet exemple sert de remplacement de la fonction NB.Si.ens qui a été introduite dans Excel 2007. La fonction DATEVAL convertit une valeur numérique, la fonction SOMMEPROD pouvez travailler avec les dates.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×