Compter les caractères dans les cellules dans Excel 2016 pour Mac

Lorsque vous devez compter les caractères dans des cellules, utilisez la fonction NBCAR. La fonction compte les lettres, les nombres, les caractères et tous les espaces. Par exemple, la longueur de « La température est de 28° aujourd’hui, je vais aller nager » (chevrons exclus) est de 58 caractères, 49 lettres, 9 espaces, 2 chiffres, une virgule et une apostrophe.

  • Pour utiliser la fonction, entrez =NBCAR(cellule) dans la barre de formule et appuyez sur Entrée. Dans ces exemples, cellule correspond à la cellule que vous voulez compter, par exemple, B1.

  • Pour compter les caractères dans plusieurs cellules, entrez la formule, puis copiez-collez la formule dans d’autres cellules.

  • Pour compter un nombre total de caractères dans plusieurs cellules, utilisez les fonctions SOMME de paire avec NBCAR. Par exemple, =SOMME((NBCAR(cellule1);NBCAR(cellule2);(NBCAR(cellule3)))). Dans cet exemple, la fonction NBCAR compte le nombre de caractères dans chaque cellule et la fonction SOMME additionne les totaux.

  • Pour compter certains caractères spécifiques au sein de cellules, utilisez la fonction NBCAR avec la fonction SUBSTITUE. Par exemple, si vous voulez savoir combien de lettres Z en minuscule se trouvent dans une cellule, utilisez cette formule : =NBCAR(cellule1)-NBCAR(SUBSTITUE(cellule1,"z",""))

Exercices pratiques

Tapez les données suivantes dans une nouvelle feuille de calcul Excel. Commencez à la cellule A1.

Chaînes de texte

Formules

Voix ambiguë d’un cœur qui,

Voix ambiguë d’un cœur qui, au zéphyr,

Voix ambiguë d’un cœur qui, au zéphyr, préfère les jattes de kiwis

Compter les caractères dans une cellule

  1. Cliquez sur la cellule B2.

  2. Dans la cellule, entrez =NBCAR(A2), puis appuyez sur Entrée.

La formule compte les caractères dans la cellule A2, 19 dans ce cas (espaces inclus). S’il y a des espaces après le point final, ils sont également comptés par la formule.

Compter les caractères dans plusieurs cellules

  1. Appuyez sur Ctrl+C pour copier la cellule B2.

  2. Appuyez sur Ctrl+V pour coller sa formule dans la plage de cellules B3:B4.

Cette action copie la formule dans les cellules B3 et B4 et la fonction compte le nombre de caractères dans chaque cellule (26, et 44).

Compter le nombre total de caractères

  1. Cliquez sur la cellule B6.

  2. Dans la cellule, entrez =SOMME(NBCAR(A2),NBCAR(A3),NBCAR(A4)) et appuyez sur Entrée.

Cette formule compte les caractères dans chacune des trois cellules et affiche le nombre total de caractères (89).

Pour compter certains caractères spécifiques au sein de cellules

  1. Cliquez sur la cellule C4.

  2. Dans la cellule, entrez =NBCAR(A4)-NBCAR(SUBSTITUE(A4,"z","")), puis appuyez sur Entrée.

En bref, cette fonction compte toutes les lettres Z en minuscule dans la cellule A4 (1).

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×