Compter le nombre d'occurrences d'une valeur

Supposons que vous souhaitiez déterminer combien de fois une valeur texte ou numérique apparaît. Par exemple :

  • Si une plage contient les valeurs numériques 5, 6, 7 et 6, le nombre 6 apparaît deux fois.

  • Si une colonne contient « Beaune », « Duprez », « Duprez » et « Duprez », alors « Duprez » apparaît trois fois.

Il existe plusieurs manières de compter le nombre d'occurrences d'une valeur.

Que voulez-vous faire ?

Compter le nombre d'occurrences d'une valeur à l'aide d'une fonction

Détails de la fonction

Compter le nombre d'occurrences de plusieurs valeurs numériques à l'aide de plusieurs fonctions

Détails de la fonction

Compter le nombre d'occurrences de valeurs texte ou numériques à l'aide de plusieurs fonctions

Détails de la fonction

Compter le nombre d'occurrences de plusieurs valeurs à l'aide d'un rapport de tableau croisé dynamique

Compter le nombre d'occurrences d'une valeur à l'aide d'une fonction

Utilisez la fonction NB.SI pour effectuer cette tâche.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

Pour copier un exemple

  1. Créez un classeur ou une feuille de calcul vide.

  2. Sélectionnez l'exemple de la rubrique d'aide.

    Remarque   Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

    Sélection d’un exemple de l’aide

    Sélection d'un exemple de l'aide

  3. Appuyez sur CTRL+C.

  4. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.

  5. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (accent grave), ou sous l'onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

1

2

3

4

5

6

7

A

B

Vendeur

Facture

Beaune

15 000

Beaune

9 000

Suyama

8 000

Suyama

20 000

Beaune

5 000

Duprez

22 500

Formule

Description (résultat)

=NB.SI(A2:A7,"Beaune")

Nombre d'entrées pour Beaune (3)

=NB.SI(A2:A7,A4)

Nombre d'entrées pour Suyama (2)

=NB.SI(B2:B7,"< 20000")

Nombre des valeurs de factures inférieures à 20 000 (4)

=NB.SI(B2:B7,">="&B5)

Nombre des valeurs de factures supérieures ou égales à 20 000 (2)

Détails de la fonction

NB.SI

Haut de la page

Compter le nombre d'occurrences de plusieurs valeurs numériques à l'aide de plusieurs fonctions

Supposons que avez besoin de déterminer combien de vendeurs ont vendu un article particulier dans une certaine région, ou que vous voulez connaître le nombre des ventes dépassant une certaine valeur réalisées par un vendeur particulier. Pour ce faire, vous pouvez utiliser les fonctions SI et NB.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

Pour copier un exemple

  1. Créez un classeur ou une feuille de calcul vide.

  2. Sélectionnez l'exemple de la rubrique d'aide.

    Remarque   Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

    Sélection d’un exemple de l’aide

    Sélection d'un exemple de l'aide

  3. Appuyez sur CTRL+C.

  4. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.

  5. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (accent grave), ou sous l'onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

1

2

3

4

5

6

7

8

9

10

11

A

B

C

D

Région

Vendeur

Type

Ventes

Sud

Beaune

Boissons

3571

Ouest

Bartoli

Produits laitiers

3338

Est

Suyama

Boissons

5122

Nord

Suyama

Produits laitiers

6239

Sud

Duprez

Produit

8677

Sud

Bartoli

Viande

450

Sud

Bartoli

Viande

7673

Est

Suyama

Produit

664

Nord

Bartoli

Produit

1500

Sud

Duprez

Viande

6596

Formule

Description (résultat)

=NB(SI((A2:A11="Sud")*(C2:C11="Viande"),D2:D11))

Nombre de vendeurs qui ont vendu de la viande dans la région Sud (3)

=NB(SI((B2:B11="Suyama")*(D2:D11>=1000),D2:D11))

Nombre de ventes supérieures à 1 000 par Suyama (2)

Remarque   

  • Les formules de l'exemple doivent être entrées sous la forme de formule de tableau. Après avoir copié l'exemple dans une feuille de calcul vide, sélectionnez la cellule de formule. Appuyez sur F2 et sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée sous la forme d'une formule matricielle, l'erreur #VALEUR ! est renvoyée.

  • Pour que ces formules fonctionnent, le second argument de la fonction SI doit être un nombre.

Détails de la fonction

NB

SI

Haut de la page

Compter le nombre d'occurrences de valeurs texte ou numériques à l'aide de plusieurs fonctions

Pour ce faire, utilisez les fonctions Si et SOMME :

  • Affectez la valeur 1 à chaque condition vraie à l'aide de la fonction SI.

  • Faites la somme à l'aide de la fonction SOMME.

Exemple

L'exemple sera plus compréhensible si vous le copiez dans une feuille de calcul vide.

Pour copier un exemple

  1. Créez un classeur ou une feuille de calcul vide.

  2. Sélectionnez l'exemple de la rubrique d'aide.

    Remarque   Ne sélectionnez pas les en-têtes des lignes ou des colonnes. 

    Sélection d’un exemple de l’aide

    Sélection d'un exemple de l'aide

  3. Appuyez sur CTRL+C.

  4. Dans la feuille de calcul, sélectionnez la cellule A1 et appuyez sur CTRL+V.

  5. Pour passer de l'affichage des résultats à celui des formules permettant de renvoyer les résultats, appuyez sur CTRL+` (accent grave), ou sous l'onglet Formules, dans le groupe Audit des formules, cliquez sur le bouton Afficher les formules.

1

2

3

4

5

6

7

A

B

Vendeur

Facture

Beaune

15 000

Beaune

9 000

Suyama

8 000

Suyama

20 000

Beaune

5 000

Duprez

22 500

Formule

Description (résultat)

=SOMME(SI((A2:A7="Beaune")+(A2:A7="Duprez"),1,0))

Nombre de factures pour Beaune et Duprez (4)

=SOMME(SI((B2:B7<9000)+(B2:B7>19000),1,0))

Nombre de factures dont la valeur est inférieure à 9 000 ou supérieure à 19 000 (4)

=SOMME(SI(A2:A7="Beaune",IF(B2:B7<9000,1,0)))

Nombre de factures de Beaune dont la valeur est inférieure à 9 000. (1)

Remarque   Les formules de cet exemple doivent être entrées sous la forme de formule de tableau. Sélectionnez chacune des cellules qui contiennent une formule, appuyez sur F2, puis appuyez simultanément sur les touches CTRL+MAJ+ENTRÉE.

Détails de la fonction

SI

SOMME

Haut de la page

Compter le nombre d'occurrences de plusieurs valeurs à l'aide d'un rapport de tableau croisé dynamique

Vous pouvez utiliser un rapport de tableau croisé dynamique pour afficher des totaux et pour compter les occurrences de valeurs uniques.

  1. Sélectionnez la colonne qui contient les données. Vérifiez qu'elle comporte un en-tête.

  2. Sous l'onglet Insertion, dans le groupe Tableaux, cliquez sur Tableau croisé dynamique.

  3. La boîte de dialogue Créer un tableau croisé dynamique s'affiche.

  4. Cliquez sur Sélectionner un tableau ou une plage.

  5. Placez le rapport de tableau croisé dynamique dans une nouvelle feuille de calcul commençant à la cellule A1 en cliquant sur Nouvelle feuille de calcul.

  6. Cliquez sur OK.

    Un rapport de tableau croisé dynamique vide est ajouté à l'emplacement que vous avez spécifié avec la liste des champs de tableau croisé dynamique affichée.

  7. Dans la section des champs au début de la liste des champs de tableau croisé dynamique, cliquez sur le nom du champ approprié et tout en maintenant le bouton de la souris enfoncé, faites glisser le champ vers la zone Étiquettes de lignes de la section Disposition au bas de la liste des champs de tableau croisé dynamique.

  8. Dans la section des champs au début de la liste des champs de tableau croisé dynamique, cliquez sur le même nom de champ et, tout en maintenant le bouton de la souris enfoncé, faites glisser le champ de nouveau vers la zone Valeurs de la section Disposition au bas de la liste des champs de tableau croisé dynamique.

Remarque   Si vos données contiennent des nombres, le rapport de tableau croisé dynamique totalise les entrées au lieu de les compter. Pour passer de la fonction de synthèse SOMME à la fonction de synthèse NB, sélectionnez une cellule dans la colonne, puis sous l'onglet Options dans le groupe Champ actif, cliquez sur Paramètres de champ. Sélectionnez l'onglet Synthèse par, puis cliquez sur Nombre et enfin sur OK.

Haut de la page

S’applique à : Excel 2007



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue