Compter le nombre d’occurrences d’une valeur dans Excel

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Supposons que vous souhaitez déterminer combien de fois une valeur texte ou numérique apparaît dans une plage de cellules. Par exemple :

  • Si une plage, telle que A2:D20, contient les valeurs numériques 5, 6, 7 et 6, le nombre 6 apparaît deux fois.

  • Si une colonne contient « Beaune », « Duprez », « Duprez » et « Duprez », « Duprez » apparaît trois fois.

Il existe plusieurs manières de compter le nombre d’occurrences d’une valeur.

Que voulez-vous faire ?

Compter le nombre d’occurrences d’une valeur à l’aide d’une fonction

Compter en fonction de plusieurs critères à l’aide de la fonction NB.SI.ENS

Compter en fonction de critères à l’aide des fonctions NB et SI

Compter le nombre d’occurrences de plusieurs valeurs numériques à l’aide des fonctions SOMME et SI

Compter le nombre d’occurrences de plusieurs valeurs à l’aide d’un rapport de tableau croisé dynamique

Compter le nombre d’occurrences d’une valeur à l’aide d’une fonction

Utilisez la fonction NB.SI pour effectuer cette tâche.

Exemple

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Vendeur

Facture

Beaune

15 000

Beaune

9 000

Suyama

8 000

Suyama

20 000

Beaune

5 000

Duprez

22 500

Formule

Description

Résultat

=NB.SI(A2:A7,"Beaune")

Nombre d’entrées pour Beaune (3)

=NB.SI(A2:A7,"Beaune")

=NB.SI(A2:A7;A4)

Nombre d’entrées pour Suyama (2)

=NB.SI(A2:A7;A4)

=NB.SI(B2:B7;"< 20000")

Nombre de valeurs de facture inférieures à 20 000 (4)

=NB.SI(B2:B7;"< 20000")

=NB.SI(B2:B7;">="&B5)

Nombre de valeurs de facture supérieures ou égales à 20 000 (2)

=NB.SI(B2:B7;">="&B5)

Pour en savoir plus sur l’utilisation de cette fonction, voir Fonction NB.SI.

Haut de la page

Compter en fonction de plusieurs critères à l’aide de la fonction NB.SI.ENS

Introduite dans Excel 2007, la fonction NB.SI.ENS est semblable à la fonction NB.SI à une exception près : NB.SI.ENS vous permet d’appliquer des critères aux cellules parmi plusieurs plages et compte le nombre de fois où tous les critères sont remplis. Vous pouvez utiliser jusqu’à 127 paires plage/critères avec la fonction NB.SI.ENS. La syntaxe de cette fonction est la suivante :

NB.SI.ENS(plage_critères1; critères1; [plage_critères2; critères2];…)

Exemple

Réf employé

Région No.

Service

20552

2

Ventes

21268

2

Finances

23949

1

Administration

24522

4

Administration

28010

3

IT

29546

4

Ventes

31634

3

IT

32131

1

IT

35106

4

Finances

40499

1

RH

42051

1

Ventes

43068

2

RH

45382

2

Finances

47971

1

IT

Combien d’employés de la région 2 travaillent dans le service Finances ?

’=NB.SI.ENS(B2:B15,"2",C2:C15,"Finances")

=NB.SI.ENS(B2:B15,"2",C2:C15,"Finances")

La première plage de critères est la plage de numéros de région, la seconde les noms de service. Le critère appliqué à la première plage de critères est « 2 », et celui appliqué à la deuxième plage est « Finances ». NB.SI.ENS vérifie si les deux critères s’appliquent.

Pour en savoir plus sur l’utilisation de cette fonction pour compter avec plusieurs plages et critères, voir Fonction NB.SI.ENS.

Haut de la page

Compter en fonction de critères à l’aide des fonctions NB et SI

Supposons que avez besoin de déterminer combien de vendeurs ont vendu un article particulier dans une certaine région, ou que vous voulez connaître le nombre de ventes dépassant une certaine valeur réalisées par un vendeur particulier. Pour ce faire, vous pouvez utiliser les fonctions SI et NB ensemble : tout d’abord, vous utilisez la fonction SI pour tester une condition puis, uniquement si le résultat de la fonction SI est Vrai, vous utilisez la fonction NB pour compter les cellules.

Exemples

Région

Vendeur

Type (Type)

Ventes

Sud

Beaune

Boissons

3571

Ouest

Bartoli

Produits laitiers

3338

Est

Suyama

Boissons

5122

Nord

Suyama

Produits laitiers

6239

Sud

Duprez

Fruits et légumes

8677

Sud

Bartoli

Viande

450

Sud

Bartoli

Viande

7673

Est

Suyama

Fruits et légumes

664

Nord

Bartoli

Fruits et légumes

1500

Sud

Duprez

Viande

6596

Formule

Description

Résultat

=NB(SI((A2:A11="Sud")*(C2:C11="Viande");D2:D11))

Nombre de ventes de viande dans la région Sud. (3)

=NB(SI((A2:A11="Sud")*(C2:C11="Viande");D2:D11))

=NB(SI((B2:B11="Suyama")*(D2:D11>=1000),D2:D11))

Nombre de ventes supérieures à 1,000 € par Suyama. (2)

=NB(SI((B2:B11="Suyama")*(D2:D11>=1000),D2:D11))

Remarque : 

  • Les formules de cet exemple doivent être entrées sous forme de formules matricielles. Si vous avez entré ce classeur dans le programme bureautique Excel et que vous souhaitez modifier la formule ou créer une formule similaire, appuyez sur F2, puis sur Ctrl+Maj+Entrée pour faire en sorte que la formule renvoie les résultats attendus.

  • Pour que ces formules fonctionnent, le second argument de la fonction SI doit être un nombre.

La fonction NB compte le nombre de cellules contenant des nombres et les nombres compris dans la liste des arguments. La fonction SI renvoie une valeur si la condition que vous spécifiez est Vrai et une autre valeur si cette condition est Faux.

Pour en savoir plus sur ces fonctions, voir Fonction NB et Fonction SI.

Haut de la page

Compter le nombre d’occurrences de plusieurs valeurs numériques à l’aide des fonctions SOMME et SI

Dans les exemples qui suivent, nous utilisons les fonctions SI et SOMME conjointement. La fonction SI teste tout d’abord les valeurs de certaines cellules puis, si le résultat du test est Vrai, la fonction SOMME calcule le total des valeurs ayant réussi à ce test.

Exemples

Vendeur

Facture

Beaune

15000

Beaune

9000

Suyama

8000

Suyama

20000

Beaune

5000

Duprez

22500

Formule

Description

Résultat

=SOMME(SI((A2:A7="Beaune")+(A2:A7="Duprez");1;0))

Nombre de factures pour Beaune et Duprez (4)

=SOMME(SI((A2:A7="Beaune")+(A2:A7="Duprez");1;0))

=SOMME(SI((B2:B7<9000)+(B2:B7>19000);1;0))

Nombre de factures ayant une valeur inférieure à 9 000 € ou supérieure à 19 000 €

=SOMME(SI((B2:B7<9000)+(B2:B7>19000);1;0))

=SOMME(SI(A2:A7="Beaune";IF(B2:B7<9000;1;0)))

Nombre de factures de Beaune dont la valeur est inférieure à 9 000 €.

=SOMME(SI(A2:A7="Beaune";IF(B2:B7<9000;1;0)))

Remarque : Les formules de cet exemple doivent être entrées sous forme de formules matricielles. Si vous avez entré ce classeur dans le programme bureautique Excel et que vous souhaitez modifier la formule ou créer une formule similaire, appuyez sur F2, puis sur Ctrl+Maj+Entrée pour faire en sorte que la formule renvoie les résultats attendus.

Haut de la page

Compter le nombre d’occurrences de plusieurs valeurs à l’aide d’un rapport de tableau croisé dynamique

Vous pouvez utiliser un rapport de tableau croisé dynamique pour afficher des totaux et compter les occurrences de valeurs uniques. Un rapport de tableau croisé dynamique offre un moyen interactif de synthétiser rapidement de grandes quantités de données. Il permet de développer et réduire les niveaux de données afin de cibler vos résultats et les analyser en détail à partir des données synthétisées par domaines. De plus, vous pouvez déplacer des lignes dans des colonnes ou des colonnes dans des lignes (par « glissement ») afin d’afficher différents résumés des données sources.

Exemple de données sources et rapport de tableau croisé dynamique résultant

1   Données sources provenant ici d’une feuille de calcul

2   Valeurs sources du résumé Golf Trim3 dans le rapport de tableau croisé dynamique

3   Rapport de tableau croisé dynamique entier

4   Synthèse des valeurs stockées dans C2 et C8 provenant des données sources

Pour créer un rapport de tableau croisé dynamique

  1. Sélectionnez la colonne qui contient les données.
    Vérifiez qu’elle comporte un en-tête.

  2. Sous l’onglet Insertion, dans le groupe Tableaux, cliquez sur Tableau croisé dynamique.
    La boîte de dialogue Créer un tableau croisé dynamique apparaît.

  3. Cliquez sur Sélectionner un tableau ou une plage.

  4. Placez le rapport de tableau croisé dynamique dans une nouvelle feuille de calcul commençant à la cellule A1 en cliquant sur Nouvelle feuille de calcul.

  5. Cliquez sur OK.
    Un rapport de tableau croisé dynamique vide est ajouté à l’emplacement que vous avez spécifié avec la liste des champs de tableau croisé dynamique affichée.

  6. Dans la section des champs au début de la liste des champs de tableau croisé dynamique, cliquez sur le nom du champ approprié et tout en maintenant le bouton de la souris enfoncé, faites glisser le champ vers la zone Étiquettes de lignes de la section Disposition au bas de la liste des champs de tableau croisé dynamique.

  7. Dans la section des champs au début de la liste des champs de tableau croisé dynamique, cliquez sur le même nom de champ et, tout en maintenant le bouton de la souris enfoncé, faites glisser le champ de nouveau vers la zone Valeurs de la section Disposition au bas de la liste des champs de tableau croisé dynamique.

Remarque : Si vos données contiennent des nombres, le rapport de tableau croisé dynamique totalise les entrées au lieu de les compter. Pour passer de la fonction de synthèse SOMME à la fonction de synthèse NB, sélectionnez une cellule dans la colonne, puis sous l’onglet Analyser dans le groupe Champ actif, cliquez sur Paramètres de champ. Sélectionnez l’onglet Synthèse par, puis cliquez sur Nombre et enfin sur OK.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×