Compter le nombre d’occurrences d’une valeur

Un certain nombre de fonctions de feuille de calcul vous permettent de compter le nombre de fois où une valeur textuelle ou numérique particulière apparaît dans une plage de cellules. Par exemple, vous pouvez utiliser la fonction NB.SIpour compter combien de fois une valeur unique apparaît, comme illustré dans l’exemple suivant.

Exemple

Vendeur

Facture

Beaune

15 000

Beaune

9 000

Suyama

8 000

Suyama

20 000

Beaune

5 000

Duprez

22 500

Formule

Description

Résultat

=NB.SI(A2:A7,"Beaune")

Nombre d’entrées pour Beaune (3)

3

=NB.SI(A2:A7;A4)

Nombre d’entrées pour Suyama (2)

2

=NB.SI(B2:B7;"< 20000")

Nombre de valeurs de facture inférieures à 20 000 (4)

4

=NB.SI(B2:B7;">="&B5)

Nombre de valeurs de facture supérieures ou égales à 20 000 (2)

2

NB.SI permet de compter des valeurs en fonction de plusieurs critères

La fonction NB.SI.ENS est semblable à la fonction NB.SI à une exception près : NB.SI.ENS vous permet d’appliquer des critères aux cellules parmi plusieurs plages et compte le nombre de fois où tous les critères sont remplis. Vous pouvez utiliser jusqu’à 127 paires plage/critères avec la fonction NB.SI.ENS. La syntaxe de cette fonction est la suivante :

NB.SI.ENS(plage_critères1; critères1; [plage_critères2; critères2];…)

Exemple

Réf employé

Numéro de région

Service

20552

2

Ventes

21268

2

Finances

23949

1

Admin

24522

4

Admin

28010

3

IT

29546

4

Ventes

31634

3

IT

32131

1

IT

35106

4

Finances

40499

1

RH

42051

1

Ventes

43068

2

RH

45382

2

Finances

47971

1

Informatique

Formule

Description

Résultat

=NB.SI.ENS(B2:B15,"2",C2:C15,"Finances")

Nombre d’employés de la région 2 travaillant dans le service Finances

2

La première plage de critères inclut tous les numéros de région, la seconde inclut tous les noms des services. Le critère appliqué à la première plage de critères est « 2 », et celui appliqué à la deuxième plage est « Finances ». NB.SI.ENS vérifie si les deux critères s’appliquent.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×