Compter des valeurs uniques parmi des doublons

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Supposons que vous voulez savoir combien texte unique ou des nombres dans une plage. Par exemple, si une colonne contient le texte des valeurs de Bradley, Doyle, Doyle, Doyle, il existe deux valeurs uniques — Bradley et Doyle. Si la plage comporte les nombres 5, 6, 7 et 6, les valeurs uniques sont 5, 6 et 7.

Pour compter les valeurs uniques seulement, utilisez une combinaison des fonctions suivantes, comme indiqué dans l’exemple de feuille de calcul ci-dessous :

  • La fonction SI permet d’attribuer une valeur de 1 à chaque condition vraie.

  • La fonction SOMME permet d’ajouter l’ensemble des valeurs uniques.

  • La fonction FREQUENCE permet de compter le nombre de valeurs uniques. Cette fonction ignore les valeurs de texte et les valeurs nulles (zéro). Pour la première occurrence d’une valeur spécifique, cette fonction renvoie un nombre égal au nombre d’occurrences de cette valeur. Pour chaque occurrence de cette valeur, après la première, cette fonction renvoie une valeur de zéro (0).

  • La fonction EQUIV permet de renvoyer la position d’une valeur de texte d’une plage. La fonction FREQUENCE utilise la valeur résultante pour évaluer les valeurs de texte correspondantes.

  • La fonction LEN permet de rechercher les cellules vides. Les cellules vides ont une longueur (nombre de caractères) de 0.

Exemple

Dans Excel, copiez le tableau dans la cellule A1 d’une feuille de travail vide avec des exemples de formules utilisant des fonctions.

Données

Données

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Formule

Description (résultat)

=SOMME(SI(FREQUENCE(A2:A10;A2:A10)>0;1))

Compte le nombre de valeurs uniques numériques dans les cellules A2:A10 mais ne compte pas les cellules vides ou les valeurs de texte (4)

=SOMME(SI(FREQUENCE(EQUIV(B2:B10;B2:B10;0);EQUIV(B2:B10;B2:B10;0))>0;1))

Compte le nombre de valeurs de texte et numériques uniques dans les cellules B2:B10 (qui ne doivent pas contenir de cellules vides) (7)

=SOMME(SI(FREQUENCE(SI(LEN(A2:A10)>0,EQUIV(A2:A10;A2:A10;0);""); SI(NBCAR(A2:A10)>0;EQUIV(A2:A10;A2:A10;0),""))>0;1))

Compte le nombre de valeurs de texte et numériques dans les cellules A2:A10 mais ne compte pas les cellules vides ou les valeurs de texte (6)

Remarques : 

  • Les formules dans cet exemple doivent être entrées sous forme de formules matricielles. Sélectionnez chaque cellule qui contient une formule, appuyez sur F2, puis appuyez sur Ctrl + Maj + Entrée.

  • Pour voir l’évaluation d’une fonction étape par étape, sélectionnez la cellule qui contient la formule, puis, dans le groupe Vérification des formules de l’onglet Formules, cliquez sur Évaluation de formule.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×