Comment corriger une erreur #REF!

Comment corriger une erreur #REF!

L’erreur #REF! s’affiche quand une formule fait référence à une cellule non valide. Cela se produit le plus souvent quand des cellules référencées par des formules sont supprimées ou remplacées.

Exemple - Erreur #REF! causée par la suppression d’une colonne

L’exemple suivant utilise la formule =SOMME(B2;C2;D2) dans la colonne E.

Une formule utilisant des références de cellule explicites, telle que =SOMME(B2;C2;D2), peut générer une erreur #REF! en cas de suppression d’une colonne.

Si vous supprimez la colonne B, C ou D, cela génère une erreur #REF!. Dans ce cas, nous supprimons la colonne C (ventes de 2007). La formule affiche à présent =SOMME(B2;#REF!;C2). Lorsque vous utilisez des références de cellules explicites comme cela (quand vous référencez chaque cellule individuellement, en la séparant par une virgule), puis supprimez une ligne ou une colonne référencées, Excel ne peut pas résoudre les références et renvoie l’erreur #REF!. Il s’agit de la raison principale pour laquelle l’utilisation de références de cellules explicites dans des fonctions n’est pas recommandé.

Exemple d’erreur #REF! causée par la suppression d’une colonne.

Solution

  • Si vous avez supprimé par mégarde des lignes ou des colonnes, vous pouvez immédiatement cliquer sur le bouton Annuler dans la barre d’outils Accès rapide (ou appuyer sur CTRL+Z) pour les restaurer.

  • Ajustez la formule afin qu’elle utilise une référence de plage plutôt que des cellules individuelles, par exemple =SOMME(B2:D2). Vous pouvez à présent supprimer toute colonne dans la plage de somme. Excel ajuste automatiquement la formule. Vous pouvez aussi utiliser la formule =SOMME(B2:B5) pour additionner des lignes.

Exemple : RECHERCHEV avec des références de plage incorrectes

Dans l’exemple suivant, la formule =RECHERCHEV(A8;A2:D5;5;FAUX) renvoie une erreur #REF!, car elle recherche une valeur à renvoyer à partir de la colonne 5, alors que la plage de référence A:D ne comprend que 4 colonnes.

Exemple de formule RECHERCHEV avec une plage incorrecte.  La formule est =RECHERCHEV(A8;A2:D5;5;FAUX).  Comme il n’existe pas de cinquième colonne dans la plage de RECHERCHEV, le chiffre 5 génère une erreur #REF!.

Solution

Ajustez la plage pour l’agrandir, ou réduisez la valeur de recherche de colonne pour qu’elle corresponde à la plage de référence. =RECHERCHEV(A8;A2:E5;5;FAUX) serait une plage de référence valide, tout comme =RECHERCHEV(A8;A2:D5;4;FALSE).

Exemple : INDEX avec une référence de ligne ou de colonne incorrecte

Dans cet exemple, la formule =INDEX(B2:E5;5;5) renvoie une erreur #REF! parce que la plage INDEX comprend 4 lignes sur 4 colonnes, alors que la formule demande le renvoi du contenu de la 5ème ligne de la 5ème colonne.

Exemple de formule INDEX avec une référence de plage non valide.  La formule est =INDEX(B2:E5;5;5), mais la plage n’est que de 4 lignes sur 4 colonnes.

Solution

Ajustez les références de ligne ou de colonne afin qu’elles s’inscrivent à l’intérieur de la plage de recherche INDEX. =INDEX(B2:E5;4;4) renvoie un résultat valide.

Exemple : référence à un classeur fermé avec la fonction INDIRECT

Dans l’exemple suivant, une fonction INDIRECT tente de référencer un classeur fermé, et génère une erreur #REF!.

Exemple d’erreur #REF! causée par une fonction INDIRECT faisant référence à un classeur fermé.

Solution

Ouvrir le classeur référencé

Problèmes OLE/DDE

Si vous avez utilisé un lien OLE (Object Linking and Embedding) qui renvoie une erreur #REF!, démarrez le programme que le lien appelle.

Remarque : OLE est une technologie permettant de partager des informations entre des programmes.

Si vous avez utilisé une rubrique DDE (Dynamic Data Exchange) qui retourne une erreur #REF!, vérifiez que vous êtes référencez la rubrique appropriée.

Remarque : DDE est un protocole établi pour l’échange de données entre des programmes Microsoft Windows.

Problèmes de macro

Si une macro entre dans la feuille de calcul une fonction qui référence une cellule située au-dessus de la fonction, et si la cellule contenant la fonction se trouve dans la ligne 1, la fonction renvoie #REF!, car il n’y a pas de cellule au-dessus de la ligne 1. Vérifiez la fonction pour voir si un argument référence une cellule ou une plage de cellules non valides. La prise en compte de cette situation peut nécessiter une modification de la macro dans Visual Basic Editor (VBE).

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×