Comment corriger une erreur #DIV/0!

Microsoft Excel affiche l’erreur #DIV/0! lorsqu’un nombre est divisé par zéro (0). Cela se produit lorsque vous entrez une formule simple telle que =5/0, ou lorsqu’une formule fait référence à une cellule contenant 0 ou vide, comme illustré dans cette image.

Exemples de formules générant des erreurs #DIV/0!.

Pour corriger cette erreur, effectuez une des opérations suivantes :

  • Vérifiez que le diviseur de la fonction ou de la formule n’est ni zéro (0), ni une cellule vide.

  • Modifiez la référence de cellule dans la formule, de façon à ce qu’elle pointe vers une autre cellule ne contenant ni zéro (0), ni une valeur vide.

  • Entrez #N/A dans la cellule qui n’est pas référencée comme diviseur dans la formule, ce qui remplacera le résultat de la formule par #N/A pour indiquer que la valeur de diviseur n’est pas disponible.

Souvent, l’erreur #DIV/0! est inévitable, car vos formules attendent une entrée. Dans ce cas, vous ne souhaitez que le message d’erreur s’affiche. Ainsi, quelques méthodes de gestion des erreurs permettent de supprimer l’erreur dans l’attente d’une entrée.

Évaluer le dénominateur pour 0 ou une valeur vide

Le moyen le plus simple de supprimer l’erreur #DIV/0! consiste à utiliser la fonction SI pour évaluer l’existence du dénominateur. S’il s’agit d’un 0 ou d’une valeur vide, afficher 0 ou une valeur vide en tant que résultat de la formule au lieu de la valeur d’erreur #DIV/0! ; sinon calculer la formule.

Par exemple, si la formule qui renvoie l’erreur est =A2/A3, utilisez =SI(A3,A2/A3,0) pour renvoyer 0, ou =SI(A3;A2/A3;"") pour renvoyer une chaîne vide. Vous pouvez également afficher un message personnalisé comme suit : =SI(A3;A2/A3;"Une entrée est nécessaire ici"). Avec la fonction QUOTIENT du premier exemple, vous utiliseriez la formule =SI(A3;QUOTIENT(A2;A3);0). Cela indique à Excel SI(A3 existe, renvoyer le résultat de la formule, sinon l’ignorer).

Exemples de la résolution d’erreurs #DIV/0!.

Utiliser SIERREUR pour supprimer l’erreur #DIV/0!

Vous pouvez également supprimer cette erreur en imbriquant votre opération de division dans la fonction SIERREUR. Ici encore, en utilisant A2/A3, vous pouvez utiliser =SIERREUR(A2/A3;0). Cela indique à Excel SI (votre formule génère une erreur, renvoyer 0, sinon renvoyer le résultat de la formule).

Pour les versions d’Excel antérieures à Excel 2007, vous pouvez utiliser la méthode SI(ESTERREUR()) : =SI(ESTERREUR(A2/A3);0;A2/A3) (voir Fonctions EST).

Remarque : les méthodes SIERREUR et SI(ESTERREUR()) sont des gestionnaires d’erreurs globaux, dans la mesure où ils permettent de supprimer toutes les erreurs, pas seulement l’erreur #DIV/0!. Vous devez vous assurer que votre formule fonctionne correctement avant d’appliquer une gestion des erreurs. Autrement, ils se peut que vous ne réalisiez pas que votre formule ne fonctionne pas comme prévu.

Conseil : Si la vérification d’erreur est activée dans Excel, vous pouvez cliquer sur Image du bouton en regard de la cellule affichant l’erreur. Cliquez sur Afficher les étapes du calcul si la commande est disponible et choisissez la résolution adaptée à vos données.

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Fonction SI

Fonction SIERREUR

Fonctions EST

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Corriger les erreurs courantes dans les formules à l’aide de la vérification des erreurs

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×