Comment éviter les formules incorrectes

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Il est assez frustrant de recevoir un résultat inattendu ou une erreur suite à l’exécution d’une formule, surtout si vous ne savez pas comment y remédier.

Le problème peut avoir différentes origines. Il peut être dû, par exemple, à des parenthèses non appariées, des erreurs de saisie ou des références à des données dans des plages qui n’existent pas. Les pratiques recommandées décrites ci-après peuvent vous aider à éviter ou à résoudre des erreurs courantes lorsque vous voulez créer ou corriger vos formules.

Utilisez cette pratique recommandée :

Pour éviter cette erreur courante :

Commencer toutes les fonctions par un signe égal (=)

Si votre entrée ne commence pas par un signe égal, il ne s’agit pas d’une formule et elle ne sera pas calculée ; c’est une erreur classique.

Par exemple, lorsque vous tapez SOMME(A1:A10), Excel Online affiche la chaîne de texte SOMME(A1:A10) au lieu d’un résultat de formule. Si vous tapez 11/2, une date s’affiche, par exemple 11-fév ou 11/02/2009, et non le résultat de la division de 11 par 2.

Pour éviter ces résultats inattendus, commencez toujours par un signe égal. Par exemple, tapez : =SOMME(A1:A10) et =11/2

Faire correspondre toutes les parenthèses ouvrantes et fermantes

Vérifiez que toutes les parenthèses font effectivement partie d’une paire. Dans une formule qui utilise une fonction, chaque parenthèse ouvrante doit avoir une parenthèse fermante pour que la fonction s’exécute correctement.

Par exemple, la formule =SI(B5<0);"Non valide";B5*1,05) ne fonctionnera pas, car elle contient deux parenthèses fermantes et une seule parenthèse ouvrante.

La formule correcte se présente comme suit : =SI(B5<0;"Non valide";B5*1,05).

Taper tous les arguments requis

La plupart des fonctions ont des arguments obligatoires, c’est-à-dire des valeurs que vous devez obligatoirement fournir pour que la fonction s’exécute correctement. Seules quelques fonctions (telles que PI ou AUJOURD’HUI) n’acceptent aucun argument. Vérifiez la syntaxe de la formule qui apparaît lorsque vous commencez à taper un signe égal suivi d’une fonction, afin de vous assurer que vous entrez tous les arguments obligatoires, ni plus, ni moins.

Par exemple, la fonction MAJUSCULE n’accepte qu’une seule chaîne de texte ou référence de cellule comme argument : =MAJUSCULE("bonjour") ou =MAJUSCULE(C2)

En outre, certaines fonctions, telles que SOMME, requièrent des arguments numériques uniquement, tandis que d’autres fonctions, telles que REMPLACER, exigent une valeur de texte pour au moins un de leurs arguments. Si vous utilisez un type de données incorrect, certaines fonctions peuvent renvoyer des résultats inattendus ou une erreur #VALEUR!.

Utiliser des nombres non mis en forme dans les formules

N’entrez pas de nombres accompagnés de symboles dollar ($) ni de séparateurs de décimale (,) dans les formules. Les symboles dollar indiquent des références absolues, et les virgules sont les séparateurs d’arguments. Les nombres mis en forme ne sont pas utilisés dans le calcul de la formule. Au lieu de 1000,00$, entrez 1000 dans la formule.

Si vous utilisez des nombres mis en forme dans les arguments, le calcul produira des résultats inattendus et vous risquez d’obtenir l’erreur #NOMBRE!. Par exemple, si vous entrez la formule =ABS(-2134) pour trouver la valeur absolue de -2134, Excel Online renvoie l’erreur #NOMBRE!, car la fonction ABS n’accepte qu’un seul argument.

Vous pouvez mettre en forme le résultat de la formule avec des séparateurs de décimale et des symboles monétaires après avoir entré la formule composée de nombres non mis en forme, en appliquant un format de nombre.

Utiliser le type de données de cellule approprié

Votre formule peut ne pas renvoyer les résultats escomptés si le type de données de la cellule ne peut pas être utilisé dans les calculs.

Par exemple, si vous entrez une formule simple =2+3 dans une cellule au format texte, Excel Online ne peut pas calculer les données que vous avez entrées. Tout ce qui apparaîtra dans la cellule est =2+3.

Pour résoudre ce problème, remplacez le type de données Texte de la cellule par Général, comme ceci :

  1. Sélectionnez la cellule.

  2. Cliquez sur Accueil, puis sur la flèche Format de nombre et sélectionnez Général.

  3. Appuyez sur F2 pour placer la cellule en mode d’édition, puis appuyez sur Entrée pour accepter la formule.

Si vous entrez une date dans une cellule avec le type de données Nombre, elle risque d’apparaître sous forme d’une valeur de date numérique au lieu d’une date. Pour afficher ce nombre sous forme de date, sélectionnez le format Date dans la galerie Format de nombre.

Utiliser le symbole * pour multiplier des nombres

Vous aimeriez sans doute utiliser x comme opérateur de multiplication dans une formule, mais vous devez en fait utiliser un astérisque (*).

Si vous utilisez x dans votre formule, Excel Online ne peut pas calculer le résultat et seule la formule apparaît dans la cellule, qui est cernée d’une bordure rouge en pointillés pour vous indiquer que la formule est erronée.

Utiliser des guillemets autour du texte dans les formules

Si vous créez une formule qui contient du texte, placez le texte entre guillemets.

Par exemple, la formule ="Nous sommes aujourd’hui le " & TEXTE(AUJOURD’HUI(),"jjjj, mmmm jj") associe le texte "Nous sommes aujourd’hui le " aux résultats des fonctions TEXTE et AUJOURD’HUI, et renvoie Nous sommes aujourd’hui le lundi 30 mai dans la cellule.

Notez que, dans la formule, "Nous sommes aujourd’hui le " contient un espace avant les guillemets de fin, ce qui permet d’ajouter l’espace nécessaire entre "Nous sommes aujourd’hui le" et "lundi 30 mai". Si vous ne placez pas le texte entre guillemets, la formule risque de générer l’erreur #NOM?.

Ne pas imbriquer plus de 64 fonctions dans une formule

Vous pouvez combiner (ou imbriquer) jusqu’à 64 niveaux de fonctions à l’intérieur d’une formule.

Par exemple, la formule =SI(RACINE(PI())<2,"Moins de deux !","Plus de deux !") comporte 3 niveaux de fonctions : la fonction PI est imbriquée dans la fonction RACINE, qui est à son tour imbriquée dans la fonction SI.

Éviter de diviser les valeurs numériques par zéro

Si vous divisez une cellule par une autre contenant zéro (0) ou aucune valeur, une erreur #DIV/0! est générée.

Pour éviter cette erreur, nous vous recommandons d’imbriquer votre opération de division dans la fonction SIERREUR. Par exemple, entrez les deux formules suivantes dans des cellules d’une feuille de calcul :

=SIERREUR(3/0,0)

=SIERREUR(3/7,0)

La première formule renvoie 0, car la fonction SIERREUR reconnaît que la division par zéro entraîne une erreur. La seconde formule renvoie la valeur de 3/7 ; il n’y a pas d’erreur, car vous ne divisez pas par zéro.

Pour vous faciliter la création de formules, n’hésitez pas à consulter ces quelques conseils et astuces relatifs aux formules.

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×