Collecte de données à l'aide de messages électroniques

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Microsoft Office Access 2007 vous aide à recueillir des données concernant des personnes dispersées dans le monde, par exemple les commerciaux de votre service, des participants à une enquête ou des contacts. Office Access 2007 collabore avec Microsoft Office Outlook 2007 pour vous aider à produire et envoyer un message électronique incluant un formulaire d'entrée de données. Lorsque les destinataires remplissent les formulaires et vous les renvoient, les réponses sont traitées selon vos spécifications. Par exemple, si vous optez pour le traitement automatique des réponses, le contenu du formulaire est ajouté à la table appropriée dans votre base de données dès que la réponse arrive dans votre Boîte de réception. Cette nouvelle fonctionnalité (Assistant Collecte de données par messagerie) peut vous faire gagner énormément de temps, puisque vous n'avez pas à entrer les données de vos utilisateurs.

Dans cet article

Quand faut-il utiliser la collecte de données

Avant de commencer

Exécution pas à pas de l'Assistant

Après l'envoi du message électronique

Collecte de données à l'aide de messages électroniques

Quand faut-il utiliser la collecte de données

La liste suivante explore des scénarios dans lesquels il est possible d'utiliser cette nouvelle fonctionnalité.

  • Enquêtes    Vous souhaitez créer une enquête et compiler les résultats dans Access. Pour commencer, vous créez une base de données Access avec les tables nécessaires au stockage des résultats. Ensuite, vous utilisez l'Assistant pour produire un formulaire avec vos questions (présentées sous forme de champs) et vous les envoyez par courrier électronique aux participants. Quand ceux-ci répondent, leurs réponses vont directement dans la table que vous spécifiez.

  • Rapports d'état    Qu'il s'agisse des derniers relevés d'inventaire ou des dernières informations sur des problèmes en cours, votre équipe peut vous envoyer régulièrement des messages électroniques avec ces informations.

  • Gestion des événements    Lors de l'organisation d'un événement, par exemple une conférence ou une formation, vous pouvez envoyer un ou plusieurs formulaires par courrier électronique afin de récupérer des informations sur les contacts, sur les préférences en matière de déplacement et d'hôtel, etc. Si vous optez pour le traitement automatique des réponses, les participants peuvent changer leurs préférences à tout moment sans vous en avertir et vous avez toujours accès aux données les plus récentes pour toutes vos décisions.

Pour vous faciliter la tâche lors de la création et de l'envoi du formulaire de saisie de données par courrier électronique, utilisez l'Assistant Collecte de données par messagerie, qui vous guidera dans les principales étapes de l'opération, notamment la spécification du mode de traitement des réponses quand elles arrivent dans votre Boîte de réception.

Haut de la page

Avant de commencer

Si c'est la première fois que vous collectez des données à l'aide de messages électroniques, suivez les instructions ci-dessous pour être sûr que la collecte des données s'effectuera correctement.

  1. Assurez-vous que les applications suivantes sont installées sur votre ordinateur :

    • Office Access 2007    L'Assistant Collecte de données par messagerie n'est disponible que dans Office Access 2007.

    • Office Outlook 2007    Office Outlook 2007 doit être installé et configuré correctement sur l'ordinateur que vous utilisez pour envoyer des messages électroniques. Si Outlook est installé mais pas encore configuré, démarrez-le et suivez les instructions de l'Assistant Démarrage d'Outlook. Consultez l'Aide d'Outlook pour plus d'informations sur cet Assistant.

    • Microsoft Office InfoPath 2007 (facultatif)    Lors de la création du formulaire de saisie de données, vous avez le choix entre un formulaire simple, au format HTML, et un formulaire au format plus facile à utiliser, produit par InfoPath. Si Office InfoPath 2007 ou version ultérieure n'est pas installé sur votre ordinateur, ou si vous n'êtes pas sûr que tous les destinataires de votre message ont Office InfoPath 2007 ou version ultérieure sur leur ordinateur, choisissez le format HTML.

      Remarque : N'oubliez pas que le formulaire utilisé pour collecter les données par messagerie n'est pas un formulaire Access. L'Assistant produit un formulaire spécial, d'après le format que vous choisissez (HTML ou InfoPath).

  2. Vérifiez que les utilisateurs qui recevront votre message électronique ont bien les applications suivantes sur leur ordinateur. Sans ces logiciels, ils ne pourront pas afficher ni remplir le formulaire.

    • Un client de messagerie prenant en charge le format HTML    Si vous envoyez un formulaire HTML, le destinataire doit utiliser un programme de messagerie qui prend en charge le format HTML.

    • Office Outlook 2007 et Office InfoPath 2007 (facultatifs)    Si vous envoyez un formulaire InfoPath, Office Outlook 2007 et Office InfoPath 2007 doivent être installés sur l'ordinateur du destinataire pour qu'il puisse afficher et modifier le formulaire InfoPath.

  3. Identifiez la base de données de destination. Elle doit être au format .mdb ou .accdb. Les fichiers .mde et .accde sont également pris en charge.

    Si vous ne voulez pas utiliser une base de données existante, vous devez en créer une.

  4. Identifiez ou créez les tables que vous souhaitez remplir avec les données issues des réponses des utilisateurs à votre message. Si vous collectez les données pour des tables existantes, assurez-vous qu'elles ne sont pas en lecture seule et que vous disposez des autorisations nécessaires pour compléter ou modifier leur contenu.

    Pour plus d'informations sur la création des tables, voir l'article Créer des tables dans une base de données.

    Remarque : 

    • Les champs présentant les types de données suivants ne peuvent pas être collectés à l'aide de messages électroniques :

      • Pièce jointe

      • NuméroAuto

      • Champs à plusieurs valeurs

      • OLE

    • Si votre opération de collecte de données remplit une ou plusieurs tables, vous devez créer une requête de sélection et l'utiliser comme source pour les enregistrements du formulaire. Assurez-vous que la requête inclut bien tous les champs requis des tables sous-jacentes. Si vous utilisez une requête existante, assurez-vous qu'elle n'est pas en lecture seule et que vous disposez des autorisations nécessaires pour compléter ou modifier son contenu. Pour plus d'informations sur la création d'une requête basée sur plusieurs tables, consultez l'article Créer une requête basée sur plusieurs tables.

  5. La plupart du temps, vous aurez le choix entre le stockage des données collectées sous la forme de nouveaux enregistrements ou l'utilisation de ces données pour mettre à jour les enregistrements existants. Dans les situations suivantes, vous ne pourrez stocker les données que comme de nouveaux enregistrements :

    • Vous collectez des données pour remplir plusieurs tables.

    • La table sous-jacente n'a pas de champ clé primaire. Les valeurs de clé primaire sont nécessaires pour associer chaque réponse à un enregistrement existant. Si votre table de destination n'a pas de champ clé primaire, ajoutez-le tout de suite ou attribuez comme clé primaire un enregistrement existant qui a des valeurs uniques.

    • La table sous-jacente ne contient aucun enregistrement. Si elle est vide, l'Assistant suppose que vous voulez ajouter des enregistrements.

    • Les adresses de messagerie des destinataires ne sont pas stockées comme champs dans la base de données. Lors de la collecte de données pour mettre à jour les enregistrements, vous ne pourrez pas taper manuellement les adresses dans le message produit par l'Assistant. Le champ de l'adresse doit se trouver dans la table de destination ou dans une table ayant une relation avec elle. Par exemple, si vous collectez des données pour mettre à jour la table Commandes, les adresses doivent être stockées sous la forme d'un champ dans la table Commandes ou dans une table liée (comme la table Clients).

Haut de la page

Exécution pas à pas de l'Assistant

Vous pouvez à présent utiliser l'Assistant qui va vous aider à configurer la collecte de données.

Dans cette section

Démarrer l'Assistant

Choisir le type de formulaire d'entrée de données

Spécifier ce que vous souhaitez faire des données

Sélectionner les champs du formulaire

Spécifier le mode de traitement des données

Indiquer comment vous souhaitez spécifier les adresses de messagerie des destinataires

Spécifier le champ de l'adresse de messagerie

Personnaliser le message électronique

Créer et envoyer des messages électroniques

Démarrer l'Assistant

  1. Ouvrez la base de données de destination.

  2. Pour remplir une seule table, sélectionnez-la dans le volet de navigation. Pour remplir plusieurs tables liées, sélectionnez la requête qui est associée à ces tables.

  3. Effectuez l'une des opérations suivantes pour démarrer l'Assistant :

    • Sous l’onglet Données externes, dans le groupe Collecter les données, cliquez sur Créer une messagerie. Image du bouton

    • Cliquez avec le bouton droit sur la table ou la requête, puis cliquez sur Collecter et mettre à jour les données par messagerie.

      Si la table ne contient aucun champ, ou si elle contient des champs de type NuméroAuto, Objet OLE, Pièce jointe ou Liste de choix à plusieurs valeurs, Access affiche le message La table ou la requête sélectionnée ne comporte aucun champ qui prend en charge la collecte des données à l'aide de la messagerie.

      Si la table contient des champs prenant en charge la collecte des données, l'Assistant démarre. La première page de l'Assistant affiche les principales étapes de la procédure. Si la table de destination prend en charge l'ajout et la mise à jour des données, vous effectuez six étapes essentielles dans l'Assistant.

      Les six étapes principales lorsque la table de destination prend en charge l'ajout et la mise à jour des données

      Si l'objet ne prend en charge que l'ajout des enregistrements, vous effectuez cinq étapes principales :

      Les cinq étapes principales lorsque la table de destination ne prend en charge que l'ajout des données

  4. Cliquez sur Suivant.

    L'Assistant vous invite à sélectionner le type de formulaire que vous souhaitez créer.

Choisir le type de formulaire d'entrée de données

Au cours de cette étape, vous devez choisir de créer un formulaire HTML ou InfoPath. Vous savez déjà qu'un formulaire Access ne permet pas de collecter des données par le biais de messages électroniques : vous devez utiliser un formulaire HTML ou InfoPath, créé dans l'Assistant.

Sélectionner le type de formulaire de saisie de données à envoyer aux utilisateurs

Si InfoPath n'est pas installé sur votre ordinateur, l'option Formulaire Microsoft Office InfoPath n'est pas disponible.

Le type de formulaire que vous créez dépend de deux facteurs : de la simplicité d'utilisation et de la présence ou non des logiciels nécessaires sur l'ordinateur des destinataires. Un formulaire InfoPath est beaucoup plus facile à utiliser, mais un formulaire HTML a moins d'exigences au niveau des logiciels.

Un formulaire InfoPath procure un meilleur environnement de modification et d'entrée des données. De plus, le formulaire InfoPath peut effectuer une validation préliminaire des données lorsque l'utilisateur clique sur le bouton Envoyer, ce qui lui donne une chance de corriger des erreurs avant de vous envoyer la réponse.

En bref, un formulaire InfoPath présente plusieurs avantages par rapport à un formulaire HTML. Toutefois, un formulaire HTML peut être affiché et modifié par n'importe quel utilisateur dont le client de messagerie prend en charge le format HTML.

  1. Dans l'Assistant, ne sélectionnez l'option Formulaire Microsoft Office InfoPath que si tous vos destinataires ont à la fois Office InfoPath 2007 et Office Outlook 2007 sur leur ordinateur. Sinon, sélectionnez l'option Formulaire HTML.

  2. Cliquez sur Suivant.

    La page de l'Assistant qui s'affiche ensuite varie selon que l'objet de destination prend en charge la mise à jour des données. Si cet objet est une requête reposant sur plusieurs tables ou s'il s'agit d'une table qui n'a pas de champ de clé primaire ou qui ne contient aucun enregistrement, l'Assistant suppose que vous voulez ajouter de nouveaux enregistrements et vous invite à sélectionner les champs du formulaire. Dans tous les autres cas, l'Assistant vous invite à spécifier si vous souhaitez ajouter ou mettre à jour des données avant de vous demander de sélectionner les champs.

    Si l'Assistant vous invite à sélectionner les champs du formulaire, passez directement à la section Sélectionner les champs du formulaire de cet article.

Spécifier ce que vous souhaitez faire des données

Dans cette étape, spécifiez si vous souhaitez ajouter de nouveaux enregistrements à la base de données ou mettre à jour ceux qui existent déjà.

Voulez-vous collecter de nouvelles données ou mettre à jour des données existantes ?

Le type de formulaire que vous utilisez affecte le nombre de nouveaux enregistrements qu'un destinataire peut vous envoyer en une seule réponse. Lors de la mise à jour des données, le nombre d'enregistrements qui doivent être mis à jour par un destinataire détermine le nombre de formulaires pré-complétés qui seront inclus dans un message. Le tableau suivant répertorie les différents scénarios :

Type de formulaire

Ajout ou mise à jour

Résultat

HTML

Ajout

Les destinataires ne pourront pas vous envoyer plus d'un nouvel enregistrement dans chaque réponse.

InfoPath

Ajout

Les destinataires pourront vous envoyer plusieurs nouveaux enregistrements dans chaque réponse, en cliquant sur Insérer une ligne au bas du message électronique.

Remarque : Une fois que vous avez spécifié les champs que vous souhaitez inclure dans votre message, une page de l'Assistant s'affiche et vous permet de sélectionner plusieurs options. Dans cette page, vous pouvez choisir le dossier Outlook dans lequel les réponses seront traitées et définir des options sur le mode de traitement.

HTML

Mise à jour

Chaque message électronique inclura un ou plusieurs formulaires pré-remplis, selon le nombre d'enregistrements qui correspondent à une même adresse de messagerie. Le destinataire pourra afficher et mettre à jour tous les formulaires du message.

InfoPath

Mise à jour

Chaque message électronique inclura un ou plusieurs formulaires pré-remplis, selon le nombre d'enregistrements qui correspondent à une même adresse de messagerie. Le destinataire pourra afficher et mettre à jour tous les formulaires du message.

De plus, l'utilisateur peut envoyer d'autres enregistrements en cliquant sur Insérer une ligne au bas du message électronique. Plus loin dans cet article, vous apprendrez comment empêcher l'utilisateur d'ajouter de nouveaux enregistrements pour une demande de mise à jour.

  1. Dans l'Assistant, sélectionnez Collecter les nouvelles informations uniquement ou Mettre à jour les informations existantes.

    Notez bien que si vous voulez ajouter de nouveaux enregistrements, vous pouvez taper les adresses de messagerie dans la zone d'adresse du message électronique lors de la création du message. Mais si vous voulez mettre à jour des données existantes, les adresses des destinataires doivent être stockées sous forme de champs dans la table ou la requête sous-jacente, ou dans une table liée.

  2. Cliquez sur Suivant.

    L'Assistant vous invite à sélectionner les champs à inclure dans le formulaire.

Sélectionner les champs du formulaire

Au cours de cette étape, vous sélectionnez les champs que vous souhaitez inclure dans le formulaire.

Spécifier les données à collecter

Il n'est généralement pas nécessaire d'inclure tous les champs qui figurent dans la table ou requête sous-jacente du formulaire. Il y a toutefois deux exceptions :

  • Champs obligatoires    Si vous collectez de nouveaux enregistrements, l'Assistant inclut automatiquement tous les champs dont la propriété Null interdit a la valeur Oui. Si des champs obligatoires d'un enregistrement sont vides, Access ne peut pas ajouter l'enregistrement à la table.

  • Types de champ non pris en charge    Vous ne pouvez pas inclure certains champs dans le formulaire. En effet, l'Assistant ne prend pas en charge les les champs NuméroAuto, Pièce jointe, Objet OLE et Liste de choix à plusieurs valeurs. Les champs de ces types ne seront pas affichés dans la liste Champs de la table ou Champs dans la requête de l'Assistant. Les champs NuméroAuto de la table se remplissent automatiquement lors de l'ajout de nouveaux enregistrements. Vous devrez remplir les champs Objet OLE, Pièce jointe et Liste de choix à plusieurs valeurs en mode Feuille de données ou Formulaire, car il est impossible à une opération de collecte de données d'ajouter ces valeurs.

  • Champ clé primaire     Le tableau suivant indique quand vous pouvez inclure un champ clé primaire dans un formulaire :

But de la collecte de données

Type de données

Inclure dans le formulaire ?

Ajout

NuméroAuto

Non. La valeur de clé primaire sera produite automatiquement lors de l'ajout de l'enregistrement dans la table.

Ajout

Pas NuméroAuto

Oui. L'utilisateur pourra taper une valeur dans le champ lors de l'ajout d'enregistrements. La réponse ne sera pas traitée si la valeur spécifiée est déjà utilisée.

Mise à jour

NuméroAuto ou pas NuméroAuto

Non. La valeur de clé primaire ne peut pas être modifiée dans le formulaire. Ce champ est utilisé pour associer chaque réponse à un enregistrement existant.

  1. Dans la liste Champs de la table ou Champs dans la requête, double-cliquez sur les champs souhaités. Si vous voulez tous les inclure, cliquez sur >>.

  2. Utilisez les boutons fléchés Haut et Bas pour réorganiser les champs dans la liste Champs à inclure dans un message électronique.

  3. Pour chaque champ inclus, spécifiez une légende sous Propriétés du champ. Cliquez sur Lecture seule si vous mettez à jour des données et que vous souhaitez afficher le champ pour l'utilisateur, sans qu'il puisse en modifier les données. Le champ s'affiche dans le message électronique avec la légende Ce champ est en lecture seule. Cette fonctionnalité s'avère tout particulièrement utile lorsque l'utilisateur met à jour des données existantes.

  4. Cliquez sur Suivant.

    L'Assistant vous invite à spécifier le mode de traitement des réponses.

Spécifier le mode de traitement des données

Au cours de cette étape, vous avez une décision très importante à prendre à propos de la manière dont vous souhaitez traiter les réponses : automatiquement ou manuellement. Notez que dans ce contexte, le traitement manuel n'exige pas une fastidieuse entrée des données en mode Feuille de données ou Formulaire. Cela signifie seulement que vous démarrez manuellement l'exportation pour transférer les données collectées vers la table de destination.

Déterminer le mode de traitement des réponses

Traitement automatique

Si vous souhaitez que les réponses soient traitées automatiquement, dès qu'elles arrivent dans votre boîte aux lettres, Outlook et Access collaborent pour exporter le contenu du formulaire de chaque réponse dans le dossier de destination de votre base de données.

Le traitement automatique peut vous faire gagner beaucoup de temps et vous faciliter la tâche. Les réponses sont exportées sans problème tant que les conditions suivantes sont respectées au moment où les réponses arrivent dans votre boîte aux lettres :

  • Outlook doit déjà être en cours d'exécution sur votre ordinateur. Si ce n'est pas le cas, le traitement commence à son prochain démarrage.

  • Access doit être installé sur votre ordinateur.

  • La base de données ne doit pas être protégée par un mot de passe, ni être ouverte en mode exclusif. Le nom ou l'emplacement de la base de données ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Le nom des tables et des requêtes, ainsi que les propriétés des champs inclus dans le formulaire, ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Vous devez toujours bénéficier des autorisations requises pour ajouter ou mettre à jour le contenu des tables et de la requête sous-jacentes.

Si une ou plusieurs de ces conditions ne sont pas respectées, le traitement automatique échoue. Dans ce cas, essayez de corriger les erreurs, puis exportez manuellement les réponses qui posent problème. Toutes les réponses qui arrivent dans votre Boîte de réception une fois que vous avez résolu le problème continuent d'être traitées automatiquement.

Autoriser uniquement les mises à jour des données

Dans le cadre d'une mise à jour de données, si vous activez la case à cocher Traiter les réponses et ajouter les données à... automatiquement, la case à cocher Autoriser les mises à jour des données existantes uniquement est indisponible. Activez cette case si vous ne voulez pas que l'utilisateur puisse envoyer de nouveaux enregistrements. Si vous ajoutez uniquement de nouvelles données, la case à cocher Autoriser les mises à jour des données existantes uniquement n'est pas visible.

Traitement manuel

Si vous souhaitez contrôler à quel moment et de quelle manière les réponses doivent être traitées, désactivez la case à cocher Traiter les réponses et ajouter les données à x automatiquement. Dans ce cas, les réponses arrivent dans votre Boîte de réception, mais elles ne sont pas transférées à la base de données. Vous devez sélectionner manuellement chaque réponse et cliquer dessus avec le bouton droit dans Outlook, puis cliquer sur Exporter des données vers Microsoft Access dans le menu contextuel pour remplir la base de données.

Vous devrez peut-être aussi traiter manuellement les réponses qui n'ont pas pu être traitées automatiquement. Une fois que vous avez résolu le problème à l'origine de cet échec, vous devez exporter manuellement chacune des réponses existantes.

Tenez compte des points suivants avant d'entreprendre une exportation :

  • Office Access 2007 doit être installé sur l'ordinateur.

  • Si la base de données est protégée par un mot de passe, vous êtes invité à le fournir au début de l'exportation. Par ailleurs, la base de données ne doit pas être ouverte en mode exclusif et son nom ou son emplacement ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Le nom des tables et des requêtes, ainsi que les propriétés des champs inclus dans le formulaire, ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Vous devez bénéficier des autorisations requises pour ajouter ou mettre à jour le contenu des tables et de la requête sous-jacentes.

Spécification d'autres options de traitement

  1. Dans la page Spécifiez le mode de traitement des réponses de l'Assistant, vérifiez le nom du dossier Outlook où sont stockées les réponses. Si vous ne souhaitez pas spécifier un autre dossier pour les réponses à cette demande de collecte de données, cliquez sur le nom du dossier. Dans la boîte de dialogue Sélectionner un dossier, sélectionnez un autre dossier ou cliquez sur Nouveau pour en créer un. Cliquez sur OK, puis revenez dans Access.

  2. Cliquez sur Définissez les propriétés pour contrôler le traitement automatique des réponses afin d'afficher la boîte de dialogue Options de collecte des données à l'aide de la messagerie.

    Boîte de dialogue Options de collecte des données à l'aide de la messagerie

    Utilisez cette boîte de dialogue pour spécifier le mode de traitement des réponses à appliquer. Si vous souhaitez les traiter manuellement, ignorez l'étape suivante.

  3. Dans la boîte de dialogue Options de collecte des données à l'aide de la messagerie, vérifiez, et au besoin modifiez, les paramètres d'une des manières suivantes, puis cliquez sur OK :

    • Ignorer les réponses des personnes auxquelles vous n'avez pas envoyé de message    Activez cette case à cocher si vous souhaitez que seules les réponses ayant été envoyées par les destinataires d'origine de votre message soient traitées automatiquement. Les réponses des autres personnes sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

    • Accepter plusieurs réponses pour chaque destinataire    Un destinataire peut vous envoyer plusieurs réponses. Activez cette case à cocher si vous voulez que seule la première réponse de chaque destinataire soit traitée automatiquement. La deuxième et toutes les suivantes sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

      Remarque : Ce paramètre contrôle uniquement le nombre de réponses qui sont traitées, et non le nombre d'enregistrements figurant dans une même réponse. Autrement dit, si vous envoyez un formulaire InfoPath, un utilisateur peut vous envoyer plusieurs enregistrements dans une seule réponse et Access les traite tous automatiquement, même si cette case à cocher n'est pas activée.

    • Autoriser les mises à jour des données existantes uniquement    Lorsque les destinataires utilisent un formulaire InfoPath pour mettre à jour des données, ils peuvent vous envoyer de nouveaux enregistrements en plus des mises à jour pour ceux qui existent déjà. Activez cette case à cocher si vous souhaitez traiter uniquement les mises à jour sur les enregistrements existants.

    • Nombre de réponses à traiter    Tapez le nombre total de réponses (de tous les destinataires) que vous souhaitez traiter automatiquement. Si vous voulez que toutes les réponses soient traitées automatiquement, entrez une valeur élevée, par exemple 5000, dans la zone de texte. Au-delà de cette valeur, les réponses reçues sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

    • Date et heure d'interruption    Spécifiez quand le traitement automatique des réponses doit s'arrêter pour ce message électronique. Au-delà de cette date et de cette heure, les réponses reçues sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

      Remarque : Pour modifier ces options ultérieurement, dans le groupe Collecter les données de l'onglet Données externes, cliquez sur Gérer les réponses. Dans la boîte de dialogue Gérer les messages de la collecte de données, sélectionnez le message dont vous souhaitez modifier les paramètres, puis cliquez sur Options du message. Les modifications que vous apportez dans cette boîte de dialogue affectent toutes les réponses suivantes reçues pour ce message.

  4. Cliquez sur OK, puis sur Fermer.

    L'étape suivante varie selon que vous ajoutez des données ou en mettez à jour. Si vous ajoutez de nouveaux enregistrements, passez à la section suivante. Si vous collectez des données pour mettre à jour des enregistrements existants, passez directement à la section Spécifier le champ de l'adresse de messagerie.

Indiquer comment vous souhaitez spécifier les adresses de messagerie des destinataires

Si vous collectez uniquement de nouvelles données, vous pouvez spécifier les adresses de messagerie de deux manières :

Sélectionner les destinataires du message électronique

  • Tapez les adresses individuellement dans le message électronique produit par l'Assistant ou sélectionnez-les à partir d'un carnet d'adresses.

  • Utilisez un champ de la base de données active qui contient des adresses de messagerie. Ce champ doit se trouver dans la table ou la requête sous-jacente, ou dans une table liée.

Lorsque vous collectez des données pour mettre à jour des enregistrements existants, vous ne voyez pas cette boîte de dialogue, parce que dans ce cas, les adresses de messagerie des destinataires doivent figurer dans un champ de la base de données.

  1. Dans l'Assistant, sélectionnez l'option souhaitée.

  2. Cliquez sur Suivant.

    Si vous préférez entrer les adresses de messagerie vous-même, passez à la section Personnaliser le message électronique. Si vous préférez utiliser un champ de la base de données, passez à la section suivante.

Spécifier le champ de l'adresse de messagerie

À cette étape, spécifiez le champ qui contient les adresses de messagerie des destinataires.

Spécifier le champ de la base de données qui contient les adresses de messagerie des destinataires

  • Si le champ se trouve dans la table ou la requête active, sélectionnez La table ou requête actuelle, sélectionnez le champ dans la liste déroulante, puis cliquez sur Suivant.

  • Si le champ contenant les adresses de messagerie des destinataires ne se trouve pas dans la table ou la requête active, suivez la procédure ci-dessous :

    1. Sélectionnez Une table associée.

    2. Dans la liste déroulante, sélectionnez le champ de la table active qui le relie à la table contenant les adresses. Il s'agit généralement d'un champ N°.

    3. Effectuez l'une des opérations suivantes :

      • Si le champ sélectionné est associé à une seule table, une liste déroulante supplémentaire s'affiche. Sélectionnez alors le champ contenant les adresses de messagerie.

      • Si le champ sélectionné est associé à plusieurs tables, deux listes déroulantes supplémentaires s'affichent. Dans la première liste, sélectionnez la table qui contient les adresses de messagerie. Dans la seconde, sélectionnez le champ.

    4. Cliquez sur Suivant.

Les tables associées sont celles dont des relations mutuelles sont définies. Pour afficher ou modifier les relations de la base de données :

  • Sous l’onglet Outils de base de données, dans le groupe Afficher/masquer, cliquez sur relations. Image du bouton

Pour plus d'informations sur les relations, consultez les articles Guide des relations entre tables et Créer, modifier ou supprimer une relation.

Lorsque vous décidez d'utiliser un champ d'adresse, vous ne pouvez pas afficher l'aperçu du message électronique ni le personnaliser dans Outlook. Vous le pouvez toutefois dans l'Assistant. À l'étape suivante, l'Assistant affiche l'objet et le corps par défaut du message et vous avez la possibilité de les adapter à votre convenance.

Personnaliser le message électronique

Au cours de cette étape, vous vérifiez les éléments du message et effectuez les modifications nécessaires.

Personnaliser le message électronique

  1. Dans les champs Objet et Introduction, effectuez les modifications souhaitées.

  2. Si vous décidez d'utiliser les adresses de messagerie stockées dans un champ de la base de données, vous pouvez effectuer d'autres sélections sur cette page. Sous Ajouter les adresses de messagerie des destinataires dans :, sélectionnez l'une des options. Quelle que soit l'option sélectionnée, les utilisateurs recevront le message électronique. Si vous entrez les adresses de messagerie dans Microsoft Office Outlook, ces options ne sont pas disponibles.

  3. Cliquez sur Suivant.

Créer et envoyer des messages électroniques

L'Assistant affiche une page vous signalant que vous pouvez à présent créer le message. Cette page vous indique également comment afficher l'état du courrier électronique à l'aide de la commande Gérer les réponses.

Créer le message électronique

Certains messages d'avertissement peuvent s'afficher sur cette page. Le tableau suivant décrit chacun d'eux et indique la mesure à prendre en conséquence.

Avertissement

Description

Solution

Certains enregistrements ne comprennent pas d'adresse valide dans le champ de l'adresse de messagerie spécifié. Aucune donnée ne sera retournée pour ces lignes.

Le champ d'adresse de messagerie que vous avez sélectionné contient des valeurs Null.

Si vous souhaitez collecter des données pour tous les enregistrements, quittez l'Assistant et remplacez les valeurs Null par des adresses de messagerie. Ensuite, redémarrez l'Assistant.

Votre base de données est actuellement ouverte en accès verrouillé exclusif. Tant que ce verrouillage exclusif n'est pas désactivé, le traitement automatique des messages électroniques échouera.

La base de données est actuellement ouverte en mode exclusif.

Si vous aviez opté pour le traitement automatique des réponses, cette opération échoue car Access ne peut pas compléter ni mettre à jour une base de données sur laquelle il y a un verrou exclusif. Fermez puis rouvrez la base de données en mode non exclusif tout de suite après avoir envoyé le message.

Ces messages électroniques risquent de contenir des données confidentielles ou sensibles.

Vous collectez des données pour mettre à jour des enregistrements existants et le formulaire que vous allez envoyer sera pré-complété avec des données existantes.

Si certains champs du formulaire contiennent des données sensibles, revenez à l'étape où vous avez sélectionné les champs dans l'Assistant, puis supprimez les champs de données sensibles du formulaire.

Les étapes suivantes varient selon que vous spécifiez les adresses de messagerie vous-même ou que vous utilisez celles d'une table de votre base de données.

Si vous décidez de spécifier les adresses dans le message électronique Outlook

Dans ce scénario, vous entrez les adresses de messagerie dans Outlook et vous pouvez prévisualiser et personnaliser le message avant de cliquer sur le bouton Envoyer.

  1. Cliquez sur Créer pour continuer.

    Un message Outlook contenant un formulaire d'entrée de données s'affiche. Le corps du message se compose d'une brève introduction et d'un formulaire contenant des contrôles et des conseils. Il est vivement recommandé de ne pas modifier le corps du message. Si la structure du formulaire est modifiée, la réponse ne pourra pas être traitée.

  2. Dans la zone de texte À, Cc, ou Cci, tapez les adresses de messagerie des destinataires. Vous pouvez aussi cliquer sur le bouton À, Cc, ou Cci pour sélectionner les adresses dans un carnet d'adresses.

  3. Cliquez sur Envoyer.

Si vous préférez utiliser un champ d'adresse stocké dans la base de données

Dans ce scénario, vous avez déjà prévisualisé et personnalisé le message. Vous filtrez maintenant le champ de l'adresse de messagerie de façon à pouvoir sélectionner les adresses des utilisateurs à qui envoyer le message.

  1. Cliquez sur Suivant pour afficher la page Envoyer le message électronique à vos destinataires.

    Envoyer le message électronique à vos destinataires

  2. Choisissez les adresses de messagerie à utiliser en activant les cases à cocher correspondantes.

  3. Cliquez sur Envoyer.

    Si certaines valeurs du champ d'adresses ne sont pas des adresses de messagerie valides, une boîte de dialogue s'affiche pour signaler les adresses incorrectes. Dans ce cas, notez les adresses de la liste, cliquez sur Quitter, vérifiez les adresses, puis essayez de renvoyer le message. Pour plus d'informations sur le renvoi d'un message, consultez la section Renvoi d'un message électronique de collecte de données.

Vous avez à présent accompli la plus grande partie du travail concernant la collecte de données à l'aide de messages électroniques. Si vous optez pour un traitement automatique des réponses et qu'aucune erreur ne se produit, les données seront transférées dans la base de données de destination sans autre intervention de votre part.

Toutefois, si vous avez opté pour le traitement manuel des réponses, ou si des erreurs se produisent, vous n'avez pas encore terminé. Lisez la section suivante pour en apprendre davantage sur le traitement manuel des réponses, la résolution des problèmes et la gestion générale des messages de collecte de données et des réponses.

Haut de la page

Après l'envoi du message électronique

Pour répondre au message électronique, le destinataire clique sur Répondre, fournit les informations demandées dans le formulaire, puis clique sur Envoyer. Cette section explique comment afficher les réponses et indique les mesures à prendre si certaines ne sont pas traitées correctement.

Dans cette section

Affichage des réponses

Vérification du traitement automatique des réponses et résolution des problèmes

Traitement manuel des réponses et résolution des erreurs

Renvoi d'un message électronique de collecte de données

Vous trouverez également des informations supplémentaires sur la gestion des réponses et la modification des options de messagerie dans la section Voir aussi.

Affichage des réponses

Quel que soit le mode de traitement des réponses que vous avez choisi, vous voudrez peut-être savoir qui a répondu à votre message et peut-être aussi ouvrir manuellement les réponses. Pour afficher les réponses :

  1. Passez dans Outlook, puis accédez au dossier que vous avez choisi pour stocker les réponses à la collecte de données.

    Conseil : Si vous ne vous souvenez pas du nom du dossier, dans le groupe Collecter les données de l'onglet Données externes, cliquez sur Gérer les réponses. Dans la boîte de dialogue Gérer les messages de la collecte de données, vous trouverez le nom du dossier dans la colonne Dossier Outlook, dans la ligne correspondant au message dont vous voulez voir les réponses.

  2. Pour ouvrir une réponse dans Outlook, double-cliquez dessus. Le formulaire s'affiche tel qu'il a été rempli par l'expéditeur.

Access ne traitera pas les réponses à un message de réponse d'origine. Par conséquent, si vous voyez qu'un ou plusieurs formulaires expédiés sont vides, incomplets ou pas remplis correctement, vous devez renvoyer le message électronique d'origine aux utilisateurs concernés, au lieu d'utiliser la commande Répondre.

De la même façon, si vous souhaitez envoyer la demande à d'autres personnes, renvoyez le message original au lieu de le transférer. Pour plus d'informations, voir la section Renvoi d'un message électronique de collecte de données.

Vérification du traitement automatique des réponses et résolution des problèmes

Si vous préférez que les réponses soient traitées automatiquement, réalisez l'action suivante pour garantir que l'opération s'effectuera correctement :

  • Pour chaque réponse, vérifiez les valeurs des colonnes Indicateur de suivi, Statut de la collection de données et Catégories.

    Conseil : Si vous ne voyez pas les colonnes Indicateur de suivi, Statut de la collection de données et Catégories dans votre affichage, ajoutez-les à l'aide du Sélecteur de champs. Cliquez avec le bouton droit sur l'en-tête de colonne, puis cliquez sur Sélecteur de champs. Dans la boîte de dialogue Sélecteur de champs, faites glisser les champs appropriés pour les déposer à droite ou à gauche d'un en-tête de colonne existant.

    Dans le dossier Outlook, si l'indicateur de suivi affiche La collection des données a réussi, si la colonne Statut de la collection de données est vide et s'il y a un indicateur vert dans la colonne Catégories, c'est que la réponse a été traitée sans problème.

  • Vous voudrez peut-être aussi vérifier le contenu des tables de destination pour vous assurer que les données collectées sont bien stockées sous la forme de nouveaux enregistrements ou de mises à jour de ceux qui existent déjà.

Si vous pensez qu'une réponse n'a pas été traitée automatiquement, vérifiez que toutes les conditions nécessaires étaient réunies. Reportez-vous à la section Traitement automatique plus haut dans cet article. Ensuite, essayez les méthodes suggérées dans le tableau suivant. La plupart de ces suggestions impliquent la résolution du problème puis l'exportation manuelle de la réponse. Vous trouverez toutes les informations nécessaires dans la section suivante, Traitement manuel des réponses et résolution des erreurs.

Problème

Cause

Solution

Il y a une réponse dans le dossier Outlook, mais elle n'a pas été traitée. La colonne Statut de la collection de données affiche Message non traité.

Vérifiez les options de messagerie dans la boîte de dialogue Options de collecte des données à l'aide de la messagerie. Des paramètres sont sélectionnés soit pour un traitement manuel des réponses, soit pour empêcher le traitement automatique de certaines d'entre elles.

Conseil : Pour afficher les options, sous l'onglet Données externes, groupe Collecter les données, cliquez sur Gérer les réponses. Dans la boîte de dialogue, sélectionnez le message souhaité, puis cliquez sur Options des messages.

Exportez manuellement la réponse.

Pour garantir que les réponses qui ne sont pas encore arrivées seront bien traitées automatiquement, modifiez les paramètres de la boîte de dialogue des options.

Pour plus d'informations sur la vérification et la modification des options, consultez l'article Options de collecte des données à l'aide de la messagerie.

J'ai répondu à l'un de mes messages, mais il n'est pas traité.

Le fait de répondre à votre propre message implique une procédure légèrement différente.

Au lieu de remplir le formulaire dans le message que vous recevez, remplissez celui qui se trouve dans le message envoyé, dans le dossier Éléments envoyés. Accédez au dossier Éléments envoyés, puis ouvrez le message. Cliquez sur Répondre, remplissez le formulaire, puis cliquez sur Envoyer.

Une réponse ne va pas dans le dossier approprié.

Seules les réponses originales à un message vont dans le dossier spécifié.

Vos réponses à vos propres messages (sauf si vous avez utilisé la copie du message du dossier Éléments envoyés pour répondre) et les réponses qui font partie d'un fil de discussion risquent de ne pas se placer dans le dossier spécifié.

Il peut y avoir d'autres raisons : Office Access 2007 n'est pas installé ou le complément requis pour le traitement des réponses est introuvable ou endommagé.

Si l'une de vos réponses n'est pas traitée, remplissez le formulaire qui se trouve dans le message envoyé, dans le dossier Éléments envoyés.

Si un utilisateur a rempli un formulaire dans une réponse, demandez-lui de répondre au message original.

Si vous pensez que le complément manque ou est endommagé, passez dans Outlook, puis, dans le menu Outils, cliquez sur Centre de gestion de la confidentialité, puis sur Compléments. Assurez-vous que le complément Microsoft Access Outlook pour la collecte de données et la publication figure dans la liste. S'il ne s'y trouve pas, essayez de réinstaller Access.

La colonne Statut de la collection de données affiche le texte suivant :

La base de données est introuvable. Localisez la base de données et importez les données manuellement.

La base de données a été déplacée, renommée ou supprimée, ou bien elle est endommagée.

Restaurez la base de données à son emplacement d'origine, puis exportez manuellement la réponse.

La colonne Statut de la collection de données affiche le texte suivant :

Impossible d'ouvrir la base de données pour importer des données, car la base de données est déjà en cours d'utilisation. Traitez les réponses manuellement dès que la base de données redevient disponible.

La base de données est ouverte en mode exclusif et il n'est pas possible d'y apporter des modifications tant que ce verrou n'est pas levé.

Demandez à l'utilisateur dont la base de données est ouverte en mode exclusif de la fermer et de la rouvrir en mode normal. Ensuite, essayez d'exporter manuellement la réponse.

La colonne Statut de la collection de données affiche le texte suivant :

Cette base de données Access est protégée par un mot de passe. Exportez ces données manuellement vers Microsoft Access.

La base de données de destination est protégée par un mot de passe. Le traitement automatique échoue si la base de données nécessite un mot de passe.

Exportez manuellement la réponse. Si vous souhaitez que les réponses futures soient traitées automatiquement, supprimez la protection par mot de passe.

La colonne Statut de la collection de données affiche un message indiquant qu'il manque une table, une requête ou un champ.

La table de destination ou la requête a été supprimée ou renommée, ou la structure a été modifiée de telle façon qu'il n'est plus possible d'ajouter le contenu du formulaire dans les tables.

Recréez les tables de destination et les requêtes ou créez et envoyez un nouveau message de collecte de données.

La colonne Statut de la collection de données affiche le texte suivant :

Impossible de traiter ce message électronique. Le formulaire dans ce message électronique est endommagé ou il a été modifié.

Le formulaire de la réponse est endommagé ou quelqu'un (le destinataire ou l'expéditeur) l'a modifié.

Si le destinataire a modifié le formulaire, demandez-lui de vous le renvoyer, puis exportez manuellement la réponse.

Si le formulaire du message original est endommagé ou incorrect, vous devez créer et renvoyer un autre message.

La colonne Statut de la collection de données affiche le texte suivant :

Impossible de trouver les informations requises pour exécuter le traitement dans la base de données spécifiée.

Il manque les informations nécessaires au mappage de la réponse avec l'enregistrement existant qui doit être mis à jour.

Les paramètres de messagerie doivent être synchronisés avec Outlook. Dans Access, sous l'onglet Données externes, groupe Collecter les données, cliquez sur Gérer les réponses. Dans la boîte de dialogue Gérer les réponses, sélectionnez le message. Sous Détails du message, vous pouvez voir une zone d'avertissement. Cliquez sur l'avertissement pour synchroniser les paramètres, puis refermez la boîte de dialogue. Revenez dans Outlook, puis essayez d'exporter manuellement la réponse.

La colonne Statut de la collection de données affiche le texte suivant :

Impossible d'ajouter ou de mettre à jour les données au risque d'avoir une valeur dupliquée dans un champ qui n'accepte que des valeurs uniques.

Un champ dont la propriété Indexé a la valeur Oui (sans doublons) ne peut pas contenir de valeurs dupliquées. Si la valeur attribuée au champ du formulaire existe déjà dans le champ correspondant de la table, l'opération échoue.

Demandez au destinataire d'envoyer une autre réponse, avec une valeur différente dans le champ du formulaire.

La colonne Statut de la collection de données affiche le texte suivant :

La valeur que vous avez entrée ne figure pas dans la liste de choix...

Le formulaire contient un champ obligatoire qui requiert une valeur mais l'utilisateur n'en a pas spécifié pour ce champ, ou bien la propriété LimiterAListe a la valeur Oui, alors que l'utilisateur a spécifié une valeur qui ne figure pas dans la liste.

Demandez au destinataire de renvoyer sa réponse après avoir complété tous les champs, ou bien remplissez et enregistrez le formulaire vous-même, puis essayez à nouveau de l'exporter.

La colonne Statut de la collection de données affiche un message indiquant que la valeur spécifiée dans un champ du formulaire n'est pas valide.

Le destinataire a entré une valeur incorrecte dans un ou plusieurs champs.

Demandez au destinataire de renvoyer sa réponse après avoir complété tous les champs, ou bien remplissez et enregistrez le formulaire vous-même, puis essayez à nouveau de l'exporter.

La colonne Statut de la collection de données affiche le texte suivant :

Ce message contient un formulaire que vous devez remplir. Une fois terminé, envoyez-le à l'expéditeur de ce message électronique.

Le destinataire n'a pas rempli le formulaire.

Demandez au destinataire d'envoyer une autre réponse après avoir rempli le formulaire.

Traitement manuel des réponses et résolution des erreurs

Pour le traitement manuel d'une réponse, il faut démarrer l'exportation dans Outlook.

Vous ne pouvez exporter qu'une seule réponse à la fois. Évitez les réponses pour lesquelles la colonne Statut de la collecte de données a la valeur La collecte de données à l'aide de la messagerie a réussi. Cet état indique en effet que la réponse a déjà été traitée. Les réponses pour lesquelles la colonne Statut de la collecte de données indique Message non traité doivent être traitées manuellement. Une réponse pour laquelle cette colonne affiche un message d'erreur n'a pas pu être traitée automatiquement ; il faut d'abord résoudre le problème avant de pouvoir l'exporter manuellement. Pour plus d'informations sur la résolution des problèmes, consultez la section précédente, Vérification du traitement automatique des réponses et résolution des problèmes.

  1. Dans Outlook, cliquez avec le bouton droit sur la réponse à traiter manuellement.

  2. Cliquez sur Exporter des données vers Microsoft Office Access.

  3. Dans la boîte de dialogue Exporter des données vers Microsoft Access, vérifiez les détails de la réponse, puis cliquez sur OK pour l'exporter.

    Si l'exportation réussit, le message Exportation réussie des données vers la base de données s'affiche. Si elle échoue, le message Impossible d'importer les données à cause d'erreurs s'affiche, suivi de la description des problèmes à l'origine de cet échec. Le tableau suivant énumère les problèmes susceptibles de faire échouer une exportation :

Problème

Cause

Solution

Lorsque je clique avec le bouton droit sur une réponse, je ne vois pas la commande Exporter des données vers Microsoft Access.

Le message sélectionné n'est pas une réponse valide de collecte de données.

Supprimez du dossier spécifié les messages qui ne sont pas des réponses de collecte de données.

Une réponse ne va pas dans le dossier approprié.

Seules les réponses originales à un message vont dans le dossier spécifié.

Vos réponses à vos propres messages (sauf si vous avez utilisé la copie du message du dossier Éléments envoyés pour répondre) et les réponses qui font partie d'un fil de discussion risquent de ne pas se placer dans le dossier spécifié.

Il peut y avoir d'autres raisons : Access n'est pas installé ou le complément requis pour le traitement des réponses est introuvable ou endommagé.

Si l'une de vos réponses n'est pas traitée, remplissez le formulaire qui se trouve dans le message envoyé, dans le dossier Éléments envoyés.

Si un utilisateur a rempli un formulaire dans une réponse, demandez-lui de répondre au message original.

Si vous pensez que le complément manque ou est endommagé, passez dans Outlook. Ensuite, dans le menu Outils, cliquez sur Centre de gestion de la confidentialité, puis sur Compléments. Assurez-vous que le complément Microsoft Access Outlook pour la collecte de données et la publication figure dans la liste. S'il ne s'y trouve pas, essayez de réinstaller Access.

Message :

La base de données est introuvable. Localisez la base de données et importez les données manuellement.

La base de données a été déplacée, renommée ou supprimée, ou bien elle est endommagée.

Restaurez la base de données à son emplacement d'origine, puis réessayez.

Message :

La base de données est déjà en cours d'utilisation.

La base de données est ouverte en mode exclusif et il n'est pas possible d'y apporter des modifications tant que ce verrou n'est pas levé.

Demandez à l'utilisateur dont la base de données est ouverte en mode exclusif de la fermer et de la rouvrir en mode normal. Ensuite, essayez d'exporter manuellement la réponse.

Message :

Table, requête ou champ manquant.

Une table de destination ou une requête a été supprimée ou renommée, ou sa structure a été modifiée de telle façon qu'il n'est plus possible d'ajouter le contenu du formulaire dans les tables.

Créez les tables de destination et les requêtes manquantes ou créez et envoyez un nouveau message de collecte de données.

Message :

Le formulaire est endommagé ou il a été modifié.

Le formulaire de la réponse est endommagé ou quelqu'un (le destinataire ou l'expéditeur) l'a modifié.

Si le destinataire a modifié le formulaire, demandez-lui de vous le renvoyer, puis exportez manuellement la réponse.

Si le formulaire du message original est endommagé ou incorrect, vous devez créer et renvoyer un autre message.

Message :

Impossible de trouver les informations requises pour exécuter le traitement.

Il manque les informations nécessaires au mappage de la réponse avec l'enregistrement existant qui doit être mis à jour.

Les paramètres de messagerie doivent être synchronisés avec Outlook. Dans Access, sous l'onglet Données externes, groupe Collecter les données, cliquez sur Gérer les réponses. Dans la boîte de dialogue Gérer les réponses, sélectionnez le message. Sous Détails du message, vous pouvez voir une zone d'avertissement. Cliquez sur l'avertissement pour synchroniser les paramètres, puis refermez la boîte de dialogue. Revenez dans Outlook, puis essayez d'exporter manuellement la réponse.

Message :

Impossible d'ajouter ou de mettre à jour les données au risque d'avoir une valeur dupliquée dans un champ qui n'accepte que des valeurs uniques.

Un champ dont la propriété Indexé a la valeur Oui (sans doublons) ne peut pas contenir de valeurs dupliquées. Si la valeur attribuée au champ du formulaire existe déjà dans le champ correspondant de la table, l'opération échoue.

Demandez au destinataire d'envoyer une autre réponse, avec une valeur différente dans le champ du formulaire.

Message :

La valeur que vous avez entrée ne figure pas dans la liste de choix.

Le formulaire contient un champ obligatoire qui requiert une valeur mais l'utilisateur n'en a pas spécifié pour ce champ, ou bien la propriété LimiterAListe a la valeur Oui, alors que l'utilisateur a spécifié une valeur qui ne figure pas dans la liste.

Demandez au destinataire de renvoyer sa réponse après avoir complété tous les champs, ou bien remplissez et enregistrez le formulaire vous-même, puis essayez à nouveau de l'exporter.

Message :

Valeur non valide dans un champ du formulaire.

Le destinataire a entré une valeur incorrecte dans un ou plusieurs champs.

Demandez au destinataire de renvoyer sa réponse après avoir complété tous les champs, ou bien remplissez et enregistrez le formulaire vous-même, puis essayez à nouveau de l'exporter.

Message :

Ce message contient un formulaire que vous devez remplir. Une fois terminé, envoyez-le à l'expéditeur de ce message électronique.

Le destinataire n'a pas rempli le formulaire.

Demandez au destinataire d'envoyer une autre réponse après avoir rempli le formulaire.

Essayez d'exporter la réponse jusqu'à ce que la colonne Catégories affiche un carré vert.

Renvoi d'un message électronique de collecte de données

Si vous souhaitez envoyer le message à d'autres utilisateurs, ou si le message original n'a pas été adressé à certains utilisateurs à cause d'erreurs, essayez de le renvoyer plutôt que de le transférer.

  1. Sous l’onglet Données externes, dans le groupe Collecter les données, cliquez sur Gérer les réponses. Image du bouton

    La boîte de dialogue Gérer les messages de la collecte de données s'affiche.

    Boîte de dialogue Gérer les messages de la collecte de données

  2. Dans la boîte de dialogue Gérer les messages de la collecte de données, cliquez sur le message à renvoyer.

  3. Cliquez sur Renvoyer ce message électronique.

    Si le bouton renvoyer ce Message électronique est désactivé

    Ce bouton est estompé (désactivé) s'il faut synchroniser les paramètres de messagerie avec Outlook.

    Cliquez sur la zone d'avertissement sous Détails du message pour synchroniser les paramètres. Si l'opération a réussi, le message La synchronisation a réussi s'affiche. Si un message d'erreur apparaît, essayez de fermer puis de rouvrir la boîte de dialogue.

  4. Access effectue certaines vérifications ; il vérifie par exemple que les tables de destination et la requête existent toujours, qu'elles comportent toujours tous les champs du formulaire et que leurs types de données n'ont pas changé. Si les vérifications ne détectent pas de problème, l'Assistant vous invite à spécifier quel mode de traitement des réponses vous souhaitez. Sinon, un message s'affiche pour vous demander de recréer le message électronique.

  5. Continuez dans l'Assistant comme lorsque vous avez envoyé le message la première fois. Les paramètres ne sont pas forcément les mêmes.

    Pour envoyer le message électronique à différents utilisateurs, effectuez l'une des opérations suivantes :

    • Spécifiez manuellement les adresses de messagerie. (Notez que cette option n'est disponible que lorsque vous collectez des données pour ajouter de nouveaux enregistrements.)

    • Choisissez un autre champ d'adresse de messagerie.

    • Utilisez le même champ d'adresse de messagerie mais, à la dernière étape, sélectionnez uniquement les adresses qui vous intéressent.

      Pour obtenir de l'aide sur les étapes à effectuer dans l'Assistant, voir la section Spécifier le mode de traitement des données plus haut dans cet article.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×