CHOISIR (CHOISIR, fonction)

Cet article décrit la syntaxe de formule et l’utilisation de la fonction CHOISIR dans Microsoft Excel.

Description

Utilise l’argument no_index pour renvoyer l’une des valeurs de la liste des arguments valeur. Utilisez la fonction CHOISIR pour sélectionner l’une des 254 valeurs possibles à partir du rang donné par l’argument no_index. Ainsi, si les arguments valeur1 à valeur7 représentent les jours de la semaine, la fonction CHOISIR renvoie l’un de ces jours lorsque la valeur de l’argument no_index est un nombre compris entre 1 et 7.

Syntaxe

CHOISIR(no_index, valeur1, [valeur2], ...)

La syntaxe de la fonction CHOISIR contient les arguments suivants :

  • no_index    Obligatoire. Désigne l’argument valeur qui doit être sélectionné. L’argument no_index doit être un nombre compris entre 1 et 254, ou une formule, ou une référence à une cellule contenant un nombre compris entre 1 et 254.

    • Si la valeur de l’argument no_index est égale à 1, la fonction CHOISIR renvoie l’argument valeur1, si elle est égale à 2, elle renvoie l’argument valeur2, et ainsi de suite.

    • Si la valeur de l’argument no_index est inférieure à 1 ou supérieure au numéro de la dernière valeur de la liste, la fonction CHOISIR renvoie la valeur d’erreur #VALEUR!

    • Si la valeur de l’argument no_index est une fraction, il est ramené par troncature au nombre entier immédiatement inférieur avant d’être pris en compte.

  • valeur1, valeur2, ...     valeur1 est obligatoire, mais les valeurs suivantes sont facultatives. Il s’agit des 1 à 254 arguments valeur parmi lesquels la fonction CHOISIR sélectionne une valeur ou une action à exécuter en fonction de l’argument no_index spécifié. Ces arguments peuvent être des nombres, des références de cellule, des noms définis, des formules, des fonctions ou du texte.

Remarques

  • Si l’argument no_index est une tableau, chaque valeur est évaluée au moment où la fonction CHOISIR est évaluée.

  • Les arguments valeur sur lesquels la fonction CHOISIR est exécutée peuvent être des références de plage de cellules ou des valeurs simples.

    Ainsi, la formule :

=SOMME(CHOISIR(2;A1:A10;B1:B10;C1:C10))

est évaluée comme :

=SOMME(B1:B10)

qui renvoie alors une valeur calculée à partir de celles contenues dans la plage B1:B10.

La fonction CHOISIR, évaluée en premier, renvoie la référence B1:B10. La fonction SOMME est ensuite évaluée en utilisant comme argument B1:B10, résultat de la fonction CHOISIR.

Exemples

Copiez les données d’exemple dans le tableau suivant, et collez-le dans la cellule A1 d’un nouveau classeur Excel. Pour que les formules affichent des résultats, sélectionnez-les, appuyez sur F2, et sur Entrée. Si nécessaire, vous pouvez modifier la largeur des colonnes pour afficher toutes les données.

Données

 

1er

Clous

2e

Vis

3e

Écrous

Fini

Boulons

Formule

Description

Résultat

=CHOISIR(2,A2,A3,A4,A5)

Valeur du second argument de liste (valeur de la cellule A3)

2e

=CHOISIR(4,B2,B3,B4,B5)

Valeur du quatrième argument de liste (valeur de la cellule B5)

Boulons

=CHOISIR(3,"Étendu",115,"monde",8)

Valeur du troisième argument de liste

monde

Exemple 2

Données

23

45

12

10

Formule

Description (résultat)

Résultat

=SOMME(A2:CHOISIR(2,A3,A4,A5))

Additionne la plage A2:A4. La fonction CHOISIR renvoie A4 comme seconde partie de la plage pour la fonction SOMME.

80

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×