Archiver ou extraire un fichier dans une bibliothèque SharePoint

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Lorsque vous extrayez un fichier d'une bibliothèque située sur un site Microsoft Windows SharePoint Services, vous êtes assuré que personne d'autre ne peut modifier le fichier en même temps que vous. Une fois le fichier extrait, vous pouvez le modifier, le fermer, le rouvrir et l'utiliser sur votre disque dur. Les autres utilisateurs ne pourront modifier ce fichier ou afficher vos modifications que lorsque vous aurez archivé le fichier.

Contenu de cet article

Vue d’ensemble

Extraire un fichier à partir d’une bibliothèque SharePoint

Archiver un fichier dans une bibliothèque SharePoint

Modifier l’emplacement où vous travaillez sur des fichiers récupéré

Présentation

L'extraction de fichiers avant leur utilisation permet d'éviter les conflits et les confusions lorsque plusieurs personnes utilisent le même ensemble de fichiers. Lorsqu'un fichier est extrait pour vous, vous êtes la seule personne à pouvoir le modifier. Vous pouvez extraire n'importe quel fichier d'un site SharePoint pour lequel vous disposez d'autorisations, directement à partir des programmes Microsoft Office System 2007 suivants : Word, Excel, PowerPoint et Visio.

Lorsque vous archivez un fichier, vous pouvez taper des commentaires sur les modifications que vous avez apportées. Les utilisateurs peuvent ainsi comprendre les modifications apportées au fichier d'une version à l'autre. Cela s'avère particulièrement utile si plusieurs personnes utilisent un fichier ou si ce fichier doit subir plusieurs processus de révision. Si la bibliothèque effectue le suivi de versions de fichiers, vos commentaires font partie intégrante de l'historique des versions du fichier, ce qui est utile si les utilisateurs souhaitent afficher ou restaurer une version antérieure.

Votre entreprise peut vous imposer d'extraire un fichier avant de le modifier. Si l'extraction est obligatoire, vous devez archiver un nouveau fichier lorsque vous le créez dans une bibliothèque ou le téléchargez vers une bibliothèque.

Lorsqu'un fichier est extrait pour vous, les modifications que vous apportez ne sont visibles aux autres utilisateurs que lorsque vous archivez le fichier. Dans certains cas, vous pouvez archiver le fichier afin que d'autres puissent voir vos modifications, tout en conservant le fichier extrait pour continuer à travailler dessus. Lorsque vous archivez un fichier, vous pouvez choisir de continuer à travailler dessus, sauf si vous archivez une version principale alors que la bibliothèque effectue le suivi des versions principales et secondaires. En règle générale, une version principale contient des modifications importantes par rapport à la version principale précédente, tandis qu'une version secondaire ne contient que des modifications mineures. Par exemple, une version principale peut inclure une partie importante de nouveau contenu, tandis qu'une version secondaire peut inclure uniquement des corrections de fautes d'orthographe.

Lorsque vous utilisez un programme Office pour extraire un fichier d'un site Windows SharePoint Services 3.0, le fichier est stocké par défaut sur votre disque dur, dans un dossier Brouillons situé dans le dossier Mes documents. Vous pouvez modifier cet emplacement afin de spécifier un autre dossier sur le disque dur ou sur le réseau. Vous pouvez également indiquer que les fichiers extraits doivent être stockés sur le serveur Web lorsque vous travaillez dessus. En fonction des besoins de votre entreprise, votre administrateur peut définir un emplacement personnalisé ou interdire le changement d'emplacement.

Si vous extrayez un fichier à partir d'un site Microsoft Windows SharePoint Services 2.0, le fichier est stocké sur le serveur pendant que vous travaillez dessus. Toutefois, vous devez l'archiver pour que les autres utilisateurs puissent voir vos modifications. Dans la plupart des cas, lorsque vous extrayez un fichier à partir d'un site Windows SharePoint Services 3.0, vous recevez un message vous indiquant l'emplacement de stockage du fichier pendant son extraction. Vous ne recevrez pas ce type de message si vous extrayez un fichier d'un site Windows SharePoint Services 2.0.

Lorsqu'un document est extrait, le volet Office Gestion des documents de votre programme Office fournit une commande permettant d'archiver le fichier.

Si le suivi des versions principales et secondaires des fichiers est activé, vous serez sans doute invité à indiquer le type de version (principale ou secondaire) archivée.

Haut de la Page

Extraire un fichier d'une bibliothèque SharePoint

Suivez la procédure ci-dessous pour extraire un fichier déjà ouvert dans un programme Office. Vous pouvez également extraire un fichier à partir de la bibliothèque du site SharePoint.

Effectuez les opérations suivantes dans ces programmes Office version 2007 :

Word, Excel ou PowerPoint

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office , cliquez sur le serveur, puis cliquez sur Extraire.

    Par défaut, les documents Word s'ouvrent souvent en mode Lecture plein écran. Le cas échéant, cliquez sur Page pour basculer en mode Page afin de pouvoir terminer cette étape.

  2. Si un message s'affiche pour indiquer l'emplacement de stockage du fichier pendant l'extraction, cliquez sur OK.

    Dans la plupart des cas, ce message s'affiche si vous extrayez un fichier à partir d'un site Windows SharePoint Services 3.0.

    Conseil : Dans le message indiquant l'emplacement de stockage du fichier pendant l'extraction, vous pouvez modifier les options relatives au travail sur les fichiers extraits.

Visio

  1. Dans le menu Fichier, cliquez sur Extraire.

  2. Si un message s'affiche pour indiquer l'emplacement de stockage du fichier pendant l'extraction, cliquez sur OK.

    Dans la plupart des cas, ce message s'affiche si vous extrayez un fichier à partir d'un site Windows SharePoint Services 3.0.

    Conseil : Dans le message indiquant l'emplacement de stockage du fichier pendant l'extraction, vous pouvez modifier les options relatives au travail sur les fichiers extraits.

Haut de la Page

Archiver un fichier dans une bibliothèque SharePoint

Suivez la procédure ci-dessous pour archiver un fichier ouvert dans un programme Office. Vous pouvez également archiver un fichier à partir de la bibliothèque du site SharePoint.

Effectuez les opérations suivantes dans ces programmes Office version 2007 :

Word, Excel ou PowerPoint

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office et cliquez sur serveur, puis cliquez sur Archiver.

    Par défaut, les documents Word s'ouvrent souvent en mode Lecture plein écran. Le cas échéant, cliquez sur Page pour basculer en mode Page afin de pouvoir terminer cette étape.

  2. Si vous êtes invité à spécifier le type de version archivée (principale ou secondaire), cliquez sur Version secondaire si vous avez apporté des modifications mineures ou sur Version principale si vous avez apporté des modifications importantes.

  3. Dans la zone Commentaires sur la version, tapez éventuellement des commentaires sur les modifications apportées.

    Ces commentaires s'affichent dans l'historique des versions du fichier dans la bibliothèque SharePoint, ce qui peut être utile si vous ou un autre utilisateur souhaitez consulter des informations sur une version précédente.

  4. Si la case à cocher Laisser le document extrait après l'archivage de cette version est disponible, activez-la si vous souhaitez continuer à travailler sur le fichier.

    Cette option est disponible si la bibliothèque n'effectue pas le suivi des versions, si elle effectue le suivi de la même manière pour toutes les versions ou si vous archivez une version secondaire. Elle n'est pas disponible si vous archivez une version principale ou si vous publiez un fichier.

Visio

  1. Dans le menu Fichier, cliquez sur Archiver.

  2. Si vous êtes invité à spécifier le type de version archivée (principale ou secondaire), cliquez sur Version secondaire si vous avez apporté des modifications mineures ou sur Version principale si vous avez apporté des modifications importantes.

  3. Dans la zone Commentaires sur la version, tapez éventuellement des commentaires sur les modifications apportées.

    Ces commentaires s'affichent dans l'historique des versions du fichier dans la bibliothèque SharePoint, ce qui peut être utile si vous ou un autre utilisateur souhaitez consulter des informations sur une version précédente.

  4. Si la case à cocher Laisser le document extrait après l'archivage de cette version est disponible, activez-la si vous souhaitez continuer à travailler sur le fichier.

    Cette option est disponible si la bibliothèque n'effectue pas le suivi des versions, si elle effectue le suivi de la même manière pour toutes les versions ou si vous archivez une version secondaire. Elle n'est pas disponible si vous archivez une version principale ou si vous publiez un fichier.

Haut de la Page

Modifier l'emplacement d'utilisation des fichiers extraits

La procédure ci-dessous permet de modifier l'emplacement de travail pour le prochain fichier que vous allez extraire. Si vous utilisez actuellement un fichier extrait, cette procédure ne modifie pas cet emplacement.

Effectuez les opérations suivantes dans ces programmes Office version 2007 :

Word, Excel ou PowerPoint

  1. Cliquez sur le Bouton Microsoft Office Image du bouton Office , puis cliquez sur les options de votre programme : Options Word, Excel Options ou Options PowerPoint.

  2. Dans la boîte de dialogue qui s'affiche, cliquez sur Enregistrer.

  3. Dans la section Options d'édition en mode hors connexion pour les fichiers du serveur de gestion de documents, effectuez l'une des opérations suivantes :

    • Suivez la procédure ci-dessous pour travailler sur les fichiers extraits sur votre disque dur ou sur un emplacement réseau :

      1. Sous Enregistrer les fichiers extraits dans, cliquez sur Emplacement sur le serveur des fichiers préliminaires sur cet ordinateur.

      2. Dans la zone Emplacement sur le serveur des fichiers préliminaires, tapez l'emplacement sur votre disque dur dans lequel vous souhaitez travailler sur les fichiers extraits ou cliquez sur Parcourir pour rechercher l'emplacement.

    • Pour travailler sur les fichiers extraits sur un serveur Web, sous Enregistrer les fichiers extraits dans, cliquez sur Le serveur Web.

      Si vous choisissez cette option, vous travaillez sur vos fichiers extraits sur le site ou le serveur Web sur lequel vos fichiers sont stockés. Vous ne pouvez pas personnaliser cet emplacement.

  4. Cliquez sur OK.

Visio

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options, cliquez sur l'onglet Général, puis cliquez sur Options des services.

  3. Dans la boîte de dialogue qui s'affiche, cliquez sur Options d'édition en mode hors connexion.

  4. Dans la section Options d'édition en mode hors connexion pour les fichiers du serveur de gestion de documents, effectuez l'une des opérations suivantes :

    • Suivez la procédure ci-dessous pour travailler sur les fichiers extraits sur votre disque dur ou sur un emplacement réseau :

      1. Pour travailler sur les fichiers extraits sur votre disque dur, sous Enregistrer les fichiers extraits dans, cliquez sur Emplacement sur le serveur des fichiers préliminaires sur cet ordinateur.

      2. Sous Emplacement sur le serveur des fichiers préliminaires, tapez l'emplacement sur votre disque dur dans lequel vous souhaitez travailler sur les fichiers extraits ou cliquez sur Parcourir pour rechercher l'emplacement.

    • Pour travailler sur les fichiers extraits sur un emplacement Web, sous Enregistrer les fichiers extraits dans, cliquez sur Le serveur Web.

      Si vous choisissez cette option, vous travaillez sur vos fichiers extraits sur le site ou le serveur Web sur lequel vos fichiers sont stockés. Vous ne pouvez pas personnaliser cet emplacement.

  5. Cliquez sur OK.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×