Apprendre comment modifier votre nouvelle base de données

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Chaque modèle fourni avec Microsoft Office Access 2007 est une application de suivi complète comportant des tables, des requêtes, des macros, des relations, des formulaires et des états prédéfinis. Ces modèles sont conçus pour être utilisables immédiatement. Vous pouvez donc créer une nouvelle base de données en fonction d'un modèle et être opérationnel très rapidement. Cependant, vous pouvez modifier votre nouvelle base de données ; par exemple, ajouter ou renommer un champ, ou modifier un état.

Cet article explique comment apporter les modifications les plus courantes à une base de données créée à partir d'un modèle. Voir les liens vers les articles pour plus d'informations sur des zones spécifiques.

Que voulez-vous faire ?

Découvrez les notions de base des tables et des champs

Ajouter un champ à une table

Supprimer un champ dans une table

Renommer un champ ou une table

Ajouter un champ à un formulaire ou un état

Ajouter un champ qui stocke des documents, des fichiers ou des images

Modifier l’aspect d’un champ

Découvrir les principes de base des tables et des champs

Lorsque vous créez une base de données, vous stockez vos données dans des tables (des listes de lignes et de colonnes basées sur des objets). Vous stockez les informations que vous souhaitez suivre dans des champs (également appelés colonnes). Par exemple, dans une table Contacts, vous pouvez créer les champs Nom, Prénom, Numéro de téléphone et Adresse. Pour une table Produits, vous pouvez créer les champs Nom du produit, ID de produit et Prix.

Il est important de choisir les champs avec attention. Par exemple, il est déconseillé de créer un champ pour y stocker une valeur calculée. Dans la plupart des cas, Office Access 2007 calcule la valeur lorsque cela est nécessaire. Lorsque vous choisissez les champs, essayez de stocker les informations sous leur plus petite forme. Par exemple, au lieu de stocker un nom complet dans un seul champ, envisagez de stocker un prénom et un nom. D'une façon générale, si vous devez établir un rapport, faire un tri, effectuer une recherche ou un calcul sur une donnée précise, placez-la séparément dans un champ.

Pour plus d’informations sur la conception d’une base de données et le choix des champs, voir l’article Concepts de base sur la conception d’une base de données.

Un champ a plusieurs caractéristiques. Par exemple, chaque champ possède un nom qui l'identifie de façon unique dans une table. Un champ possède également un type de données qui est choisi en fonction du type d'informations qu'il doit stocker. Le type de données détermine les valeurs qu'il est possible de stocker et les opérations possibles, ainsi que l'espace de stockage à conserver pour chaque valeur. Chaque champ possède également un groupe associé de paramètres appelés propriétés qui définissent les caractéristiques de l'apparence et du comportement du champ. Par exemple, la propriété Format définit la mise en forme des champs, c'est-à-dire la façon dont le champ sera affiché.

Haut de la Page

Ajouter un champ à une table

Vous pouvez facilement ajouter un champ à une table en mode Feuille de données. Cependant, vous pouvez également ajouter un champ à une table en mode Création. En mode Feuille de données, vous ajoutez le champ en entrant des données dans la cellule située sous l'en-tête de colonne Ajouter un nouveau champ.

Feuille de données dans Access avec colonne Ajouter un nouveau champ

1. Un nouveau champ, vide

Ajouter un champ en mode Feuille de données

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, double-cliquez sur la table dans laquelle vous souhaitez ajouter le nouveau champ.

    La table s'ouvre en mode Feuille de données.

  4. Entrez vos données dans la cellule située sous l'en-tête de colonne Ajouter un nouveau champ.

    Si la table comporte déjà plusieurs champs, vous devrez peut-être faire défiler les colonnes vers la droite pour afficher la colonne dont l'en-tête est Ajouter un nouveau champ.

Lorsque vous entrez des données dans la nouvelle colonne, Office Access 2007 utilise les informations que vous spécifiez pour reconnaître le type de données approprié du champ. Par exemple, si vous entrez une date dans la colonne, telle que 1/1/2007, Office Access 2007 reconnaît les données entrées en tant que date et définit le type de données du champ à Date/Heure. Si Access ne dispose pas de suffisamment d'informations pour déterminer le type de données, ce dernier est défini à Texte.

Vous pouvez définir explicitement le type de données et le format d'un champ, ce qui remplace le choix de Office Access 2007. Pour cela, cliquez sur les commandes du groupe Type de données et mise en forme dans l'onglet Feuille de données.

Définition explicite du type de données

  • Sous l’onglet feuille de données, dans le groupe Type de données et mise en forme, cliquez sur la flèche dans la liste déroulante en regard de Type de données et sélectionnez un type de données. Groupe ruban Image de Type de données Access et mise en forme

  • Cliquez sur le type de données souhaité.

Définition explicite du format

  1. Sous l’onglet feuille de données, dans le groupe Type de données et mise en forme, cliquez sur la flèche dans la liste déroulante en regard de Format et sélectionnez un format. Groupe ruban Image de Type de données Access et mise en forme

  2. Cliquez sur le format souhaité.

Lorsque vous ajoutez un champ en entrant des informations dans la cellule située sous l'en-tête Ajouter un nouveau champ, Office Access 2007 attribue automatiquement un nom au champ. Ce nom correspond à Champ1 pour le premier champ, Champ2 pour le deuxième champ et ainsi de suite. Il est toutefois recommandé d'utiliser des noms de champ plus descriptifs. Pour renommer un champ, cliquez avec le bouton droit sur son en-tête, puis cliquez sur Renommer la colonne dans le menu contextuel.

Vous pouvez également ajouter un champ en mode Création. Étant donné que le mode Feuille de données vous permet uniquement de définir les propriétés de champ les plus courantes, vous pouvez utiliser le mode Création pour définir une propriété non disponible en mode Feuille de données.

Ajouter un champ en mode Création

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table dans laquelle vous souhaitez ajouter un nouveau champ, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Dans la colonne Nom du champ, cliquez sur la première ligne vide, puis entrez un nom pour le nouveau champ.

  5. Cliquez sur la cellule adjacente dans la colonne Type de données, puis sélectionnez un type de données dans la liste.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Pour plus d’informations sur l’ajout d’un nouveau champ, voir l’article Insérer, ajouter, ou en créer un nouveau champ dans une table.

Remarque : Lorsque vous ajoutez un nouveau champ à une table, le champ n'est pas automatiquement ajouté à vos formulaires et états existants. Vous devez ajouter le champ manuellement à ces formulaires et états pour qu'il s'affiche dans ces derniers.

Haut de la Page

Supprimer un champ dans une table

Si possible, évitez de supprimer un champ dans une base de données générée à partir d'un des modèles fournis ; il est probable que le champ est utilisé dans d'autres objets de base de données, tels que des formulaires et des états. La suppression du champ aura des conséquences sur l'utilisation des autres objets de base de données qui l'emploient, et ces derniers ne fonctionneront pas comme prévu. Vous devrez supprimer toutes les références au champ dans tous les objets qui l'utilisent afin que ces derniers fonctionnent correctement.

Si vous décidez de supprimer un champ dans une base de données générée à partir d'un modèle, utilisez le mode Feuille de données ou le mode Création. N'oubliez pas que si d'autres objets de base de données référencent le champ supprimé, vous devez modifier ces objets afin de supprimer la référence. Par exemple, si un état comporte un contrôle dépendant du champ supprimé et que vous exécutez l'état, un message d'erreur s'affiche car Access ne trouve pas les données du champ.

Lorsque vous supprimez un champ, vous supprimez définitivement toutes les informations stockées dans ce dernier. C'est pourquoi, vous devez prendre des précautions lorsque vous supprimez des champs et créer une copie de sauvegarde de votre base de données avant de supprimer le champ.

Avant de pouvoir supprimer un champ, vous devez vous assurer qu’il ne participer à des relations de table. Si vous tentez de supprimer un champ pour lequel il existe des relations, Access vous avertit que vous devez d’abord supprimer les relations. Pour obtenir des instructions détaillées sur la façon de supprimer une relation entre tables, voir la section Supprimer une relation entre tables.

Supprimer un champ en mode Feuille de données

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, double-cliquez sur la table dans laquelle vous souhaitez supprimer le champ.

    La table s'ouvre en mode Feuille de données.

  4. Sélectionnez le champ (la colonne) que vous souhaitez supprimer.

    Conseil : Pour sélectionner le champ (la colonne), cliquez sur le sélecteur de champ (en-tête de colonne).

  5. Appuyez sur Suppr.

    - ou -

    Sous l’onglet feuille de données, dans le groupe champs et colonnes, cliquez sur Supprimer.

Remarque : Vous ne pouvez pas supprimer un champ qui fait partie d'une clé primaire de la table en mode Feuille de données. Pour supprimer un champ de clé primaire, vous devez utiliser le mode Création.

Pour plus d’informations sur les clés primaires, voir l’article Ajouter, définir, modifier ou supprimer la clé primaire.

Supprimer un champ en mode Création

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table dans laquelle vous souhaitez supprimer le champ, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Sélectionnez le champ (la ligne) à supprimer.

    Conseil : Pour sélectionner la ligne, cliquez sur le sélecteur de ligne.

  5. Appuyez sur Suppr.

    - ou -

    Sous l’onglet Création, dans le groupe Outils, cliquez sur Supprimer les lignes.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Avant de supprimer un champ, assurez-vous qu'il ne fait pas partie de relations entre des tables. Si vous supprimez un champ pour lequel des relations existent, vous recevez un message d'avertissement vous invitant à supprimer les relations dans un premier temps. Pour supprimer une relation entre des tables, procédez comme suit.

Supprimer une relation entre des tables

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Si les tables faisant partie de la relation entre les tables sont ouvertes, fermez-les. Il est en effet impossible de supprimer une relation entre des tables ouvertes.

  4. Sous l'onglet Outils de base de données du groupe Afficher/Masquer, cliquez sur Relations.

  5. Si les tables faisant partie de la relation entre les tables ne sont pas visibles, procédez comme suit :

    1. Sous l’onglet Création, dans le groupe Afficher/masquer, cliquez sur Les noms de tables.

    2. Dans la boîte de dialogue Afficher la table, sélectionnez les tables à ajouter, cliquez sur Ajouter, puis cliquez sur Fermer.

  6. Cliquez sur la ligne de relation pour les relations entre les tables que vous souhaitez supprimer (la ligne apparaît en gras lorsqu'elle est sélectionnée), puis appuyez sur Suppr.

Haut de la Page

Renommer un champ ou une table

Si possible, évitez de renommer un champ ou une table dans une base de données générée à partir d'un des modèles fournis ; il est probable que le champ ou la table est employé dans d'autres objets de base de données, tels que des formulaires et des états. L'affectation d'un nouveau nom au champ ou à la table peut avoir des conséquences lorsque vous utilisez les autres objets de base de données qui emploient le champ ou la table. Les autres objets peuvent ne pas fonctionner correctement s'ils font encore référence à l'ancien nom. Pour que les autres objets fonctionnent correctement, vous devez remplacer l'ancien nom par le nouveau. Si la case à cocher Correction automatique de nom est activée dans la catégorie Base de données en cours de la boîte de dialogue Options Access, cette opération sera effectuée automatiquement.

Vous souhaiterez peut-être modifier le texte qui s’affiche dans l’en-tête de colonne en mode feuille de données. Vous pouvez le faire sans avoir à renommer le champ. Si vous souhaitez modifier uniquement le texte dans l’en-tête de colonne, et vous ne voulez pas renommer un champ, voir la section Modifier le texte qui s’affichent dans un en-tête de colonne.

Si nécessaire, vous pouvez renommer une table dans le volet de navigation, ou renommer un champ en mode Feuille de données ou en mode Création. Avant d'effectuer ces opérations, envisagez d'activer l'option Correction automatique de nom si elle n'est pas déjà activée.

Activer l’option de correction automatique de nom

Lorsque vous renommez un objet de base de données, tel qu'un champ, une table, un formulaire ou un état, vous souhaitez que cette modification se propage dans l'ensemble de la base de données. Sinon, les objets qui font référence à l'ancien nom ne fonctionneront pas correctement. Office Access 2007 intègre la fonctionnalité Correction automatique de nom, qui permet de propager les modifications de nom. Par défaut, l'option Correction automatique de nom est activée pour toutes les nouvelles bases de données dans Office Access 2007. Cependant, si elle est désactivée, pour l'activer procédez comme suit.

Activer l’option de correction automatique de nom

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Options Access.

  2. Dans la boîte de dialogue Options Access, dans le volet de gauche, cliquez sur Base de données en cours.

  3. Sous Options de correction automatique de nom, activez la case à cocher Suivi des informations de correction automatique de nom, puis activez la case à cocher Correction automatique de nom.

  4. Pour conserver une table qui enregistre chaque modification effectuée par l'option Correction automatique de nom, activez la case à cocher Historiques des corrections automatiques de noms.

  5. Cliquez sur OK.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Remarque : La fonctionnalité Correction automatique de nom est distincte de la fonctionnalité Correction automatique. La première corrige les références entre les objets et la seconde corrige les mots ou les phrases mal orthographiés.

Renommer un champ en mode Feuille de données

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, double-cliquez sur la table dans laquelle vous souhaitez renommer le champ.

    La table s'ouvre en mode Feuille de données.

  4. Cliquez avec le bouton droit sur l'en-tête de colonne du champ à renommer, puis cliquez sur Renommer la colonne dans le menu contextuel.

  5. Entrez le nouveau nom du champ, puis appuyez sur Entrée.

Renommer un champ en mode Création

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table dans laquelle vous souhaitez renommer le champ, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Cliquez sur la cellule du champ à renommer dans la colonne Nom du champ.

    Conseil : Pour sélectionner le nom complet du champ, pointez à gauche du premier caractère du nom jusqu'à ce que le curseur se transforme en flèche, puis cliquez.

  5. Modifiez le texte pour renommer le champ.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Renommer une table

Le volet de navigation permet de renommer directement une table ainsi que la plupart des autres objets de base de données.

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table que vous souhaitez renommer, puis cliquez sur Renommer dans le menu contextuel.

    Remarque : Vous devez fermer tous les objets ouverts qui font référence à une table avant de la renommer.

  4. Entrez le nouveau nom, puis appuyez sur Entrée

  5. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Modifier le texte affiché dans un en-tête de colonne

Une légende est un titre ou un en-tête que vous pouvez attribuer à un champ en définissant la propriété Caption du champ. La légende est indépendante du nom du champ ; chaque champ possède un nom de champ et peut également avoir une légende. Par exemple, un nom de champ peut être un seul mot sans espaces. Vous pouvez ensuite utiliser la propriété Caption pour créer un nom plus descriptif qui comporte des espaces. Access affiche la légende à la place du nom du champ en mode Feuille de données et dans des étiquettes et en-têtes pour les requêtes, les formulaires et les états.

Si vous ne spécifiez aucun texte pour la propriété Caption, le nom du champ est utilisé par défaut.

Pour modifier le nom affiché dans un en-tête pour une colonne en mode Feuille de données, et ce sans modifier le nom du champ, définissez la propriété Caption. Pour modifier la propriété Caption d'un champ, procédez comme suit :

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table dans laquelle vous souhaitez modifier la légende, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Cliquez dans la cellule du champ dont vous souhaitez définir la propriété Caption dans la colonne Nom du champ.

  5. Dans la section inférieure, sous Propriétés du champ, dans l'onglet Général, cliquez sur Légende.

  6. Entrez une nouvelle légende pour le champ.

  7. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

La prochaine fois que vous ouvrirez la table en mode Feuille de données, la légende apparaîtra à la place du nom du champ dans l'en-tête de la colonne.

Haut de la Page

Ajouter un champ à un formulaire ou un état

Lorsque vous créez une base de données basée sur un modèle, votre base de données contient plusieurs formulaires et états intégrés préconçus que vous pouvez utiliser immédiatement. Vous pouvez néanmoins ajouter un champ à un formulaire ou à un état. Au cours de cette opération, vous créez un contrôle.

Présentation des contrôles

Les contrôles sont des objets qui affichent des données, exécutent des actions et permettent d'afficher et utiliser des informations qui améliorent l'interface utilisateur, telles que les étiquettes et les images. Les contrôles peuvent être dépendants, indépendants et calculés.

  • Contrôle dépendant    Contrôle dont la source de données est un champ dans une table ou une requête. Les contrôles dépendants permettent d'afficher des valeurs provenant des champs de votre base de données. Ces valeurs peuvent consister en du texte, des dates, des valeurs numériques, des valeurs Oui/Non, des images ou des graphiques. Les contrôles dépendants sont généralement constitués de zones de texte. Par exemple, une zone de texte de formulaire qui présente le nom d'un employé peut tirer cette information du champ Nom de la table Employés.

  • Contrôle indépendant    Ce type de contrôle ne possède pas de source de données (un champ ou une expression). Les contrôles indépendants s'avèrent particulièrement utiles pour afficher des informations, des lignes, des rectangles et des images. Par exemple, une étiquette qui affiche le titre d'un formulaire est un contrôle indépendant.

  • Contrôle calculé    Contrôle dont la source de données est une expression plutôt qu'un champ. Vous pouvez définir la valeur de votre choix pour le contrôle en définissant une expression comme source de données pour le contrôle. Une expression est une combinaison d'opérateurs (tels que = et + ), des noms de contrôles, des noms de champs, des fonctions renvoyant une valeur unique et des valeurs constantes. Par exemple, l'expression suivante calcule le prix d'un article avec une remise de 25 % en multipliant la valeur figurant dans le champ Prix unitaire par une valeur de constante (0,75).

= [Prix unitaire] * 0,75

Une expression peut utiliser les données d'un champ dans la table ou la requête sous-jacente du formulaire, ou les données d'un contrôle du formulaire. Pour plus d'informations sur les expressions, consultez les liens dans la section Voir aussi de cet article.

Une zone de texte peut être un contrôle dépendant, un contrôle indépendant ou un contrôle calculé. Lorsque vous créez un formulaire qui utilise des contrôles dépendants, indépendants et calculés, il est plus efficace d'ajouter et d'organiser tous les contrôles dépendants en premier, plus particulièrement s'ils représentent la majorité des contrôles dans le formulaire. Vous pouvez ensuite ajouter les contrôles indépendants et calculés qui complètent la création en utilisant les outils du groupe Contrôles de l'onglet Création en mode Création.

Vous pouvez lier un contrôle de zone de texte à un champ en identifiant le champ d'où proviennent les données du contrôle. Vous pouvez créer un contrôle lié au champ sélectionné en faisant glisser le champ du volet Liste de champs vers le formulaire. Le volet Liste de champs affiche les champs de la table ou de la requête sous-jacente du formulaire. Pour afficher le volet Liste de champs, sous l'onglet Création, dans le groupe Outils, cliquez sur Ajouter des champs existants. Par défaut, lorsque vous faites glisser un champ du volet Liste de champs vers la grille de création d'un formulaire, Access insère une zone de texte.

Vous pouvez également lier un champ à un contrôle en tapant le nom du champ dans le contrôle proprement dit ou dans la zone de saisie de la propriété Source contrôle qui se trouve dans la feuille de propriétés du contrôle. La feuille de propriétés définit les caractéristiques du contrôle, à savoir, son nom, la source de ses données et son format.

La meilleure façon pour créer une zone de texte dépendante consiste à utiliser le volet Liste de champs et ce, pour deux raisons :

  • Une zone de texte dépendante possède une étiquette attachée, qui porte systématiquement le nom du champ (ou de la légende définie pour ce champ dans la table ou requête sous-jacente), de sorte que vous ne devez pas entrer le nom de la légende manuellement.

  • Une zone de texte dépendante hérite de la plupart des paramètres du champ de la table sous-jacente, telles que les propriétés Format, Décimales et MasqueSaisie). Vous pouvez donc vous assurer que ces propriétés de champ resteront les mêmes à chaque création d'une zone de texte liée à ce champ.

Si vous avez déjà créé un contrôle indépendant et que vous souhaitez lier à un champ, définissez la propriété du contrôle ControlSource sur le nom du champ.

Ajouter un champ à un formulaire ou un état en mode Page

Après avoir créé un formulaire ou un état, vous pouvez facilement affiner sa présentation en mode Page. En vous basant sur les données de l'état actif, vous pouvez ajuster la largeur des colonnes et réorganiser les champs. Vous pouvez placer de nouveaux champs dans le formulaire ou l'état, et définir les propriétés pour le formulaire ou l'état et les contrôles correspondants.

Pour basculer en mode Page, dans le volet de navigation, cliquez avec le bouton droit sur le formulaire ou l'état, puis cliquez sur Mode Page dans le menu contextuel. Vous pouvez également cliquer sur le bouton Mode Page dans la barre d'état Access, ou cliquer avec le bouton droit sur l'onglet Document du formulaire ou de l'état, puis cliquer sur Mode Page dans le menu contextuel.

Basculer en mode Page

  • Dans le volet de navigation, cliquez avec le bouton droit sur le formulaire ou l'état, puis cliquez sur Mode Page dans le menu contextuel.

    - ou -

    Cliquez sur le bouton Mode Page dans la barre d'état Access.

    - ou -

    Cliquez avec le bouton droit sur l'onglet Document du formulaire ou de l'état, puis cliquez sur Mode Page dans le menu contextuel.

Le formulaire ou l'état apparaît en mode Page.

Ouvrir la feuille de propriétés

  • Dans l'onglet Organiser, sous le groupe Outils, cliquez sur Feuille de propriétés.

    Raccourci clavier appuyez sur F4.

Vous pouvez utiliser le volet Liste de champs pour ajouter des champs à partir de la table ou la requête sous-jacente à votre conception. Pour afficher le volet Liste de champs, sous l’onglet Format, dans le groupe contrôles, cliquez sur Ajouter des champs existants. Vous pouvez faire glisser des champs directement depuis le volet Liste de champs vers votre présentation.

Afficher le volet Liste de champs

  • Dans l’onglet Format, dans le groupe Contrôles, cliquez sur Ajouter des champs existants.

Ajout d'un champ à partir du volet Liste de champs

  • Pour ajouter un seul champ, faites-le glisser du volet Liste de champs vers la section où vous souhaitez l'afficher dans le formulaire ou l'état.

  • Pour ajouter plusieurs champs en même temps, maintenez la touche Ctrl enfoncée et cliquez sur les champs de votre choix. Faites glisser les champs sélectionnés vers le formulaire ou l'état.

Lorsque vous déposez les champs dans une section, Access crée un contrôle de zone de texte dépendante pour chaque champ et insère automatiquement une étiquette en regard de chaque champ.

Pour plus d’informations sur les formulaires et états, voir les articles créer un formulaire à l’aide de l’outil formulaire et créer un état simple.

Haut de la Page

Ajouter un champ pour stocker des documents, des fichiers ou des images

Office Access 2007 permet d'ajouter un champ dont le type de données est Pièce jointe pour stocker un ou plusieurs documents, fichiers ou images. Vous pouvez utiliser un champ Pièce jointe pour stocker plusieurs fichiers dans un seul champ. En outre, vous pouvez stocker plusieurs types de fichier dans ce champ. Par exemple, dans une base de données de candidatures, vous pouvez attacher un ou plusieurs CV, ainsi qu'une photo, à l'enregistrement de chaque contact.

Ajouter un champ Pièce jointe à une table

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table dans laquelle vous souhaitez ajouter le champ, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Dans la colonne Nom du champ, cliquez sur la première ligne vide et entrez un nom pour le nouveau champ.

  5. Cliquez sur la cellule adjacente dans la colonne Type de données, puis sélectionnez Pièce jointe dans la liste.

  6. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

    Vous pouvez recevoir un message indiquant que vous ne pouvez pas annuler vos modifications après avoir enregistré la table. Cela signifie que vous ne pouvez pas convertir le champ en un autre type de données, mais vous pouvez le supprimer, si vous avez commis une erreur.

  7. Cliquez sur Oui pour confirmer la modification.

Après avoir ajouté le champ Pièce jointe à la table, la boîte de dialogue Pièces jointes vous permet d'ajouter des documents, des fichiers ou des images à un enregistrement.

Ajouter une pièce jointe à un champ

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, double-cliquez sur la table à laquelle vous souhaitez ajouter la pièce jointe.

    La table s'ouvre en mode Feuille de données.

  4. Dans la table, double-cliquez sur le champ Pièce jointe.

    La boîte de dialogue Pièces jointes apparaît.

  5. Cliquez sur Ajouter.

    La boîte de dialogue Sélectionnez un fichier apparaît.

  6. La liste Regarder dans permet de rechercher le fichier ou les fichiers à joindre à l'enregistrement. Sélectionnez le ou les fichiers, puis cliquez sur Ouvrir.

    Notez que vous pouvez sélectionner plusieurs fichiers de n'importe quel type pris en charge.

  7. Dans la boîte de dialogue Pièces jointes, cliquez sur OK pour ajouter les fichiers à la table.

    Access ajoute les fichiers au champ et incrémente le nombre de pièces jointes en conséquence.

  8. Le cas échéant, répétez ces étapes afin d'ajouter des fichiers au champ actif ou à d'autres champs de la table.

Pour plus d’informations sur les champs de pièce jointe, voir l’article joindre des fichiers et des graphismes aux enregistrements de votre base de données.

Haut de la Page

Modifier l'apparence d'un champ

Vous pouvez personnaliser l'affichage d'un champ. Par exemple, vous pouvez définir des formats d'affichage à utiliser dans la base de données, notamment dans les formulaires et les états, ou lorsque vous ouvrez une table en mode Feuille de données. Pour définir un format d'affichage, définissez la propriété Format d'un champ. Les nouveaux formulaires et états que vous créez héritent ensuite automatiquement de cette propriété.

Définir le format d'affichage en mode Feuille de données

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, double-cliquez sur la table qui contient le champ dont vous souhaitez définir le format.
    La table s'ouvre en mode Feuille de données.

  4. Cliquez sur le champ dont vous souhaitez définir le format d'affichage.

  5. Sous l’onglet feuille de données, dans le groupe Type de données et mise en forme, cliquez sur la flèche dans la liste déroulante en regard de Format et sélectionnez un format. Groupe ruban Image de Type de données Access et mise en forme

    Le champ s'affiche dans le nouveau format d'affichage.

Définir le format d'affichage en mode Création

  1. Cliquez sur le bouton Microsoft Office Image du bouton Office , puis sur Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, sélectionnez la base de données et ouvrez-la.

  3. Dans le volet de navigation, cliquez avec le bouton droit sur la table qui contient les champs dont vous souhaitez modifier le format d'affichage, puis cliquez sur Mode Création dans le menu contextuel.

    La table s'ouvre en mode Création.

  4. Cliquez sur le champ dont vous souhaitez modifier le format.

  5. Sous Propriétés du champ, dans l'onglet Général, activez la case à cocher Format.

  6. Cliquez sur la liste déroulante, puis sélectionnez un format d'affichage.

  7. Pour enregistrer vos modifications, cliquez sur Enregistrer dans la barre d'outils Accès rapide.

Pour plus d’informations sur la façon de modifier l’apparence d’un champ, voir l’article mettre en forme des données dans des lignes et colonnes.

Haut de la Page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×