Aperçu d'un modèle de formulaire

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Pour vous assurer du bon fonctionnement des formulaires basés sur votre modèle de formulaire lors de leur remplissage par les utilisateurs, vous pouvez en afficher un aperçu pour tester leur aspect et leur fonctionnalité. Vous pouvez afficher un aperçu de votre modèle de formulaire lors de sa création pour tester un contrôle ou une fonctionnalité spécifique. Il est également recommandé d'afficher un aperçu de votre modèle de formulaire avant sa publication.

Contenu de cet article

Présentation

Aperçu d'un modèle de formulaire

Aperçu d'un modèle de formulaire avec un niveau de sécurité restreint ou d'autorisation totale

Aperçu d'un modèle de formulaire avec un niveau de sécurité de domaine

Aperçu d'un modèle de formulaire avec des exemples de données

Présentation

Lorsque vous concevez un modèle de formulaire, vous pouvez utiliser la fonctionnalité Aperçu pour tester les fonctionnalités et l'apparence de votre modèle de formulaire. Prévisualiser et tester votre modèle de formulaire permet d'afficher et utiliser votre modèle de formulaire du point de vue de vos utilisateurs. Lorsque vous cliquez sur Aperçu dans la barre d'outils Standard, un formulaire basé sur votre modèle de formulaire s'ouvre dans une fenêtre d'aperçu distincte. Vous pouvez ensuite tester votre modèle de formulaire en entrant des données dans les contrôles pour vérifier plusieurs fonctions, comme du texte mise en forme, mise en forme conditionnelle, les règles, les formules et les validation des données. Si vous utilisez des niveaux de sécurité ou que vous avez ajouté des rôles d'utilisateur à votre modèle de formulaire, vous pouvez également tester ces fonctionnalités lors de l'aperçu de votre modèle de formulaire. À l'aide de la fenêtre d'aperçu permet d'identifier les erreurs dans la conception de votre modèle de formulaire et basculer rapidement à la fenêtre de création, dans lequel vous pouvez les corriger. Pour vous aider à identifier la fenêtre dans laquelle vous êtes en mode Aperçu avant ou Création s'affiche dans la barre de titre de chaque fenêtre.

Si vous utilisez un ensemble uniforme de données pour tester votre modèle de formulaire, vous pouvez en améliorer les performances et la précision grâce à un formulaire avec des exemples de données, plutôt que d'entrer manuellement les données à chaque aperçu. Les exemples de données représentent du texte de l'espace réservé, qui s'affiche dans les contrôles de votre formulaire, et qui vous montre comment il s'affiche dans le contrôle lorsqu'il est rempli par l'utilisateur. Ils ne sont visibles que lors de l'aperçu du modèle de formulaire.

Haut de la page

Aperçu d'un modèle de formulaire

  1. Pour tester un rôle d'utilisateur sur le modèle de formulaire, spécifiez celui que vous souhaitez tester avec le modèle de formulaire.

    Comment ?

    1. Dans le menu Outils, cliquez sur Options de formulaire.

    2. Dans la liste Catégorie, cliquez sur Aperçu.

    3. Dans la liste Aperçu en tant que, sous Rôle d'utilisateur, cliquez sur le rôle d'utilisateur à tester.

  2. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Aperçu d'un modèle de formulaire avec un niveau de sécurité restreint ou d'autorisation totale

  1. Dans le menu Outils, cliquez sur Options de formulaire.

  2. Dans la liste Catégorie, cliquez sur Sécurité et approbation.

  3. Dans la zone Niveau de sécurité, désactivez la case à cocher Déterminer automatiquement le niveau de sécurité (recommandé), puis cliquez sur le niveau de sécurité à appliquer au modèle du formulaire.

  4. Cliquez sur OK.

  5. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Aperçu d'un modèle de formulaire avec un niveau de sécurité de domaine

  1. Dans le menu Outils, cliquez sur Options de formulaire.

  2. Dans la liste Catégorie, cliquez sur Sécurité et approbation.

  3. Dans Niveau de sécurité, désactivez la case à cocher Déterminer automatiquement le niveau de sécurité (recommandé), puis cliquez sur Domaine (le formulaire peut accéder à du contenu provenant du domaine où il se trouve).

  4. Dans la liste Catégorie, cliquez sur Aperçu.

  5. Dans la zone Domaine, tapez le nom du domaine où est publié le modèle de formulaire.

  6. Cliquez sur OK.

  7. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Aperçu d'un modèle de formulaire avec des exemples de données

Si vous comptez tester un modèle de formulaire à plusieurs reprises, vous pouvez économiser du temps en créant un formulaire basé sur un modèle avec des exemples de données, puis en configurant ce modèle de sorte qu'il utilise ces exemples de données à chacun de ses aperçus. Si vous utilisez un formulaire avec des exemples de données, vous n'êtes pas obligé d'entrer ces mêmes données à chaque aperçu du modèle.

  1. Cliquez sur Aperçu dans la barre d'outils Standard, ou appuyez sur Ctrl+ Maj+B.

  2. Entrez les exemples de données dans les contrôles appropriés.

  3. Dans le menu Fichier, cliquez sur Enregistrer.

  4. Dans la boîte de dialogue Enregistrer sous, accédez à l'emplacement dans lequel vous voulez enregistrer le formulaire avec les exemples de données, puis cliquez sur Enregistrer.

  5. Dans la barre d'outils Standard, cliquez sur Fermer l'aperçu.

  6. Dans le menu Outils, cliquez sur Options de formulaire.

  7. Dans la liste Catégorie, cliquez sur Aperçu.

  8. Dans la zone Emplacement du fichier, sous Exemple de données, cliquez sur Parcourir.

  9. Dans la boîte de dialogue Parcourir, accédez à l'emplacement où vous avez enregistré votre formulaire avec les exemples de données, cliquez sur le formulaire, puis cliquez sur Ouvrir.

  10. Cliquez sur OK.

  11. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×