Ajouter une connexion de données en utilisant des paramètres dans une bibliothèque de connexions

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans cet article

Présentation

Avant de commencer

Ajouter une connexion de données de requête

Ajouter une connexion de données d'envoi

Présentation

Si vous créez plusieurs modèles de formulaires qui utilisent des connexions de données similaires, envisagez d'utiliser un fichier de connexion de données au lieu de créer une connexion de données à une source de données externes pour chaque modèle de formulaire. Ainsi, vous devez mettre à ne jour qu'un seul fichier de connexion de données lorsque les informations de connexion de données est modifié pour un ensemble de modèles de formulaire associé. Par exemple, lorsque vous déplacez vos modèles de formulaire à partir d'un réseau de test à un réseau de production, vous devez mettre à jour les paramètres de la connexion de données qu'une seule fois dans la bibliothèque de connexions au lieu de la mise à jour de la connexion de données dans chaque modèle de formulaire. Lorsqu'un formulaire basé sur un modèle de formulaire qui utilise un fichier de connexion de données utilise la connexion de données, la connexion de données est automatiquement mis à jour avec les nouveaux paramètres.

Un fichier de connexion de données est un fichier XML avec une extension de fichier .xml ou .udcx qui contient des informations de connexion pour une source de données externe. Ce fichier est stocké dans une bibliothèque de connexions de données sur un serveur exécutant Microsoft Office SharePoint Server 2007. Un fichier de connexion de données est créé par un développeur ou en convertissant une connexion de données dans un modèle de formulaire existant en un fichier de connexion de données en cliquant sur le bouton convertir dans la boîte de dialogue Connexions de données (menuOutils ).

Avantages de l'utilisation de fichiers de connexion de données :

  • Plusieurs formulaires peuvent utiliser le même fichier de connexion de données, il est inutile pour créer la même connexion de données à partir de zéro pour chaque modèle de formulaire.

  • Si l\rquote emplacement ou les paramètres de connexion d'une source de données externe changent, vous ne devez mettre à jour que le fichier de connexion de données, et pas chaque modèle de formulaire.

  • Le fichier de connexion de données peut contenir des informations d'authentification alternatives qui peuvent être utilisées par le serveur lorsqu'un utilisateur remplit un formulaire à l'aide d'un navigateur Web.

  • Formulaires basés sur un modèle de formulaire compatible avec les navigateurs qui sont remplis dans un navigateur peuvent se connecter aux serveurs dans un autre domaine uniquement avec les connexions de données qui utilisent des fichiers de connexion de données.

Remarque : Microsoft Office InfoPath utilise les fichiers de connexion de données qui suivent le format de fichier 2.0 universel connexion de données. Cette version est un sur-ensemble la version 1.0 du format de fichier utilisé par Microsoft Office FrontPage et Microsoft Office Excel. InfoPath ne peut pas utiliser les fichiers de connexion de données dans le format de fichier 1.0.

Lorsque vous ajoutez une connexion de données à un modèle de formulaire en utilisant les paramètres d'une bibliothèque de connexion de données, vous créez une connexion de données secondaire dans ce modèle de formulaire. Cette connexion de données est différente de la connexion de données principale que vous créez en concevant un modèle de formulaire basé sur une base de données, un service Web ou des paramètres dans une bibliothèque de connexions de données. Vous devez ajouter une connexion de données secondaire uniquement si vous ne pouvez pas recevoir ou envoyer des données via la connexion de données principale.

Haut de la page

Avant de commencer

Pour ajouter une connexion de données à votre modèle de formulaire en utilisant les paramètres qui sont stockés dans une bibliothèque de connexions de données, vous devez obtenir les informations suivantes auprès de l'administrateur de site :

  • L'emplacement du serveur qui exécute Microsoft Office SharePoint Server 2007, qui contient le site qui comprend la bibliothèque de connexions de données

  • Le nom du fichier de connexion de données que vous souhaitez utiliser dans la bibliothèque de connexions de données

  • Si le fichier de connexion de données contient des paramètres adaptés à une connexion de données de requête ou à une connexion de données d'envoi

  • Si vous pouvez configurer le modèle de formulaire pour stocker en toute sécurité les résultats de la requête dans le formulaire pour une utilisation hors ligne, si les paramètres correspondent à une connexion de données de requête

Haut de la page

Ajouter une connexion de données de requête

Pour ajouter une connexion de données à votre modèle de formulaire en utilisant les paramètres d'une bibliothèque de connexions, vous devez suivre la procédure suivante :

  1. Ajouter la connexion de données secondaire au modèle de formulaire.

  2. Lier les contrôle à la requête et aux champs de données dans la source de données secondaire.

  3. Configurer le modèle de formulaire afin d'utiliser la connexion de données à l'aide d'une règle ou d'un bouton.

Étape 1 : Ajouter une connexion de données secondaire

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Rechercher des connexions sur un serveur Microsoft Office SharePoint, puis cliquez sur Suivant.

  4. Sur la page suivante de l'assistant, dans la liste Site, cliquez sur le nom du site sur un serveur qui exécute Office SharePoint Server 2007 avec la bibliothèque de connexions.

    Mon site ne se trouve pas dans la liste

    Pour ajouter votre site à la liste, suivez la procédure suivante :

    1. Cliquez sur Gérer les Sites.

    2. Dans la boîte de dialogue Gérer les Sites, cliquez sur Ajouter.

    3. Dans la zone URL, tapez l'emplacement de la bibliothèque de connexions de données.

    4. Dans la zone nom complet, tapez un nom pour la bibliothèque de connexions de données. Ce nom apparaît dans la liste des sites dans l'Assistant connexion de données.

    5. Cliquez sur OK.

    6. Cliquez sur Fermer.

  5. Cliquez sur le nom de la bibliothèque de connexion de données pour afficher une liste des fichiers de connexion de données, cliquez sur le nom du fichier de connexion de données que vous souhaitez utiliser pour cette connexion de données, puis cliquez sur Suivant.

  6. En fonction des paramètres de connexion contenus dans le fichier de connexion de données, la page suivante de l'assistant peut vous demander d'indiquer des valeurs échantillon pour chaque paramètre.

    Comment indiquer des valeurs échantillon ?

    1. Sélectionnez un paramètre dans la table de paramètres, puis cliquez sur Définir une valeur échantillon.

    2. Dans la zone exemple de valeur, tapez une valeur que votre utilisateur peut utiliser pour ce champ, puis cliquez sur OK.

    3. Répétez ces étapes pour chaque paramètre dans le tableau paramètres, puis cliquez sur suivant.

    Note technique

    Lorsque vous configurez une connexion de données à un service Web dans l'Assistant connexion de données, Microsoft Office InfoPath se connecte au service Web et demande le fichier Service Description Language WSDL (Web). Le fichier WSDL contient le schéma utilisé par le service Web. Le service Web répond à la demande en envoyant ce fichier à InfoPath. InfoPath utilise les informations de ce fichier pour ajouter les champs appropriés et les groupes à la source de données secondaire dans le modèle de formulaire. Si InfoPath détecte un type d'élément inconnu dans le fichier WSDL, InfoPath utilise des exemples de données pour déterminer la définition du type d'élément inconnu, puis ajoute les champs appropriés et les groupes à la source de données secondaire.

  7. Si vous voulez rendre disponibles les résultas de la requête lorsque le formulaire n'est pas connecté à un réseau, sélectionnez la case à cocherEnregistrer une copie des données dans le modèle de formulaire.

    Note de sécurité : Activez cette case à cocher stocke les résultats de la requête dans le modèle de formulaire. Étant donné que les données sont stockées dans le modèle de formulaire, il est disponible dans les formulaires remplis par les utilisateurs, même si leur ordinateur n'êtes pas connecté à un réseau. Si vous obtenez des données sensibles à partir de cette connexion de données, vous souhaiterez désactiver cette fonctionnalité pour aider à protéger les données en cas de perte ou de vol de l'ordinateur.

  8. Cliquez sur Suivant.

    La page suivante de l'assistant affiche un résumé des paramètres de cette connexion de données.

  9. Tapez un nom descriptif pour la connexion de données. Ce nom apparaîtra dans la liste Source de données du volet Office Source de données.

  10. Pour permettre aux formulaires basés sur ce modèle de formulaire d'utiliser cette connexion de données à leur ouverture, activez la case à cocher Extraire automatiquement les données à l'ouverture du formulaire.

Haut de la page

Étape 2 : Ajouter un contrôle pour afficher les données pour vos utilisateurs

  1. Si le volet Office Contrôles n’est pas visible, cliquez sur Autres contrôles dans le menu Insertion, ou appuyez sur Alt+I, C.

  2. Faites glisser un contrôle sur le modèle de formulaire.

  3. Dans la boîte de dialogue Liaison - Contrôle, sélectionnez le champ auquel vous souhaitez lier le contrôle, puis cliquez sur OK.

Étape 3 : Configurer le modèle de formulaire pour utiliser la connexion de données

Si vous souhaitez que les utilisateurs extraient des données à partir de cette connexion de données à l'ouverture du formulaire, vous pouvez ajouter à votre modèle de formulaire une règle qui utilise la connexion de données sous une certaine condition ou ajouter à votre modèle de formulaire un bouton sur lequel vos utilisateurs peuvent cliquer pour utiliser la connexion de données.

Ajouter une règle

Vous pouvez ajouter à votre modèle de formulaire une règle qui exécute la connexion de données de requête dès lors que la condition de la règle est respectée. La procédure suivante suppose que vous ayez créé une connexion de données de requête pour votre modèle de formulaire et que vous ayez configuré un contrôle sur votre modèle de formulaire pour afficher les données de la connexion de données.

  1. Si le modèle de formulaire comporte plusieurs vues, cliquez sur nom de l'affichage dans le menu affichage pour accéder à la vue avec le contrôle dans lequel vous souhaitez afficher les données à partir de la source de données secondaire.

  2. Double-cliquez sur le contrôle auquel vous souhaitez ajouter une règle.

  3. Cliquez sur l'onglet Données.

  4. Sous Validation et Règles, cliquez sur Règles.

  5. Dans la boîte de dialogue Règles, cliquez sur Ajouter.

  6. Dans la case Nom, tapez le nom de la règle.

  7. Pour spécifier une condition lors de la règle doit être exécutée, cliquez sur Définir une Condition, puis entrez la condition. La règle s'exécutera lorsque la condition se produit. Si vous ne définissez pas une condition, la règle s'exécutera chaque fois que l'utilisateur modifie la valeur dans le contrôle, puis passe son curseur en s'éloignant de ce contrôle.

  8. Cliquez sur Ajouter une action.

  9. Dans la liste Action, cliquez sur Exécuter une requête via une connexion de données.

  10. Dans la liste Connexion de données, cliquez sur la connexion de données de requête que vous souhaitez utiliser puis cliquez sur OK pour fermer toutes les boîtes de dialogue.

  11. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Ajouter un bouton pour utiliser la connexion de données de requête

Vous pouvez ajouter à votre formulaire un contrôle de bouton sur lequel vos utilisateurs pourront cliquer lorsqu'ils rempliront un formulaire basé sur votre modèle de formulaire. Lorsqu'il est activé, ce bouton peut extraire des données via la connexion de données de requête.

  1. Si le modèle de formulaire comporte plusieurs vues, cliquez sur nom de l'affichage dans le menu affichage pour accéder à la vue avec le contrôle dans lequel vous souhaitez afficher les données à partir de la source de données secondaire.

  2. Si le volet Office Contrôles n’est pas visible, cliquez sur Autres contrôles dans le menu Insertion, ou appuyez sur Alt+I, C.

  3. Faites glisser un contrôle de bouton sur votre modèle de formulaire.

  4. Double-cliquez sur le contrôle de bouton que vous venez d'ajouter à votre modèle de formulaire.

  5. Cliquez sur l'onglet Général.

  6. Dans la liste Action, cliquez sur Actualiser.

  7. Dans la zone Étiquette, tapez le nom qui doit apparaître sur le bouton de votre modèle de formulaire.

  8. Cliquez sur Paramètres.

  9. Dans la boîte de dialogue Actualiser, cliquez sur Une seule source de données secondaire.

  10. Dans la liste Choisissez la source de données secondaire, cliquez sur la source de données secondaire associée à la connexion de données de requête.

  11. Cliquez sur OK pour fermer chaque boîte de dialogue ouverte.

  12. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Ajouter une connexion de données d'envoi

Si le fichier de connexion de données contient des paramètres correspondant à une connexion de données d'envoi, vous pouvez configurer votre modèle de formulaire de manière à permettre aux utilisateurs d'envoyer les données de leur formulaire via cette connexion de données. Lorsque vous configurez votre modèle de formulaire afin de permettre aux utilisateurs d'envoyer les données de leur formulaire, InfoPath ajoute un bouton Envoyer sur la barre d'outils Standard et une commande Envoyer dans le menu Fichier. Vous pouvez configurer les options d'envoi du modèle de formulaire dans la boîte de dialogue Options d'envoi (menu Outils). Les options d'envoi sont configurées de la même manière que si vous ajoutiez une connexion de données secondaire qui soit une connexion de données d'envoi. Vous trouverez des liens vers des informations supplémentaires sur l'ajout d'une connexion de données d'envoi à votre modèle de formulaire à la section Voir aussi.

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Rechercher des connexions sur un serveur Microsoft Office SharePoint, puis cliquez sur Suivant.

  4. Sur la page suivante de l'assistant, dans la liste Site, cliquez sur le nom du site avec la bibliothèque de connexions.

    Mon site ne se trouve pas dans la liste

    Pour ajouter votre site à la liste, suivez la procédure suivante :

    1. Cliquez sur Gérer les Sites.

    2. Dans la boîte de dialogue Gérer les Sites, cliquez sur Ajouter.

    3. Dans la zone URL, tapez l'emplacement de la bibliothèque de connexions de données.

    4. Dans la zone nom complet, tapez un nom pour la bibliothèque de connexions de données. Ce nom apparaît dans la liste des sites dans l'Assistant connexion de données.

    5. Cliquez sur OK.

    6. Cliquez sur Fermer.

  5. Cliquez sur le nom de la bibliothèque de connexion de données pour afficher une liste des fichiers de connexion de données, cliquez sur le nom du fichier de connexion de données que vous souhaitez utiliser pour cette connexion de données d'envoi, puis cliquez sur Suivant.

  6. Si les paramètres correspondent à une connexion de données d'envoi vers un service Web, peut détecter les paramètres du service Web qui peuvent recevoir des données. Vous pouvez configurer la connexion de données d'envoi pour envoyer toutes les données ou une partie de celles-ci dans le modèle de formulaire.

    Comment ?

    1. Dans la liste Paramètres, cliquez sur un paramètre qui recevra les données du formulaire.

    2. Pour envoyer l'ensemble des données du formulaire pour ce paramètre, y compris l'élément racine et les instructions de traitement, procédez de la manière suivante :

      1. Cliquez sur Formulaire entier (document XML avec instructions de traitement).

      2. Pour envoyer les données sous forme de chaîne, activez la case à cocher Envoyer les données sous forme de chaîne. En général, cette case à cocher est activée pour envoyer des données de signature numérique. Dans la plupart des cas, désactivez cette case à cocher.

    3. Pour spécifier un champ ou un groupe pour ce paramètre, procédez de la manière suivante :

      1. Dans Options de paramètre, cliquez sur Champ ou groupe.

      2. Cliquez sur Modifier Image du bouton .

      3. Dans la boîte de dialogue Sélectionner un champ ou un groupe, cliquez sur le champ ou groupe dont vous souhaitez envoyer les données, puis cliquez sur OK.

      4. Dans la zone Inclure , cliquez sur Texte et éléments enfants uniquement pour envoyer simplement le contenu du champ ou du groupe, ou cliquez sur Sous-arborescence XML comprenant l'élément sélectionné pour envoyer à la fois le contenu ainsi que le champ ou le groupe sélectionné.

    4. Recommencez ces étapes pour chaque paramètre.

  7. Cliquez sur Suivant.

  8. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×