Ajouter une connexion de données à une bibliothèque de documents SharePoint ou à une liste

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez ajouter une ou plusieurs connexions de données secondaire à votre modèle de formulaire pouvant soit interroger les données à partir d'une bibliothèque de documents ou une liste, ou envoyer des données à une bibliothèque de documents sur un serveur exécutant Microsoft Windows SharePoint Services.

Dans cet article

Présentation

Avant de commencer

Ajouter une connexion de données de requête

Ajouter une connexion de données d'envoi

Présentation

Une connexion de données secondaire est une connexion de données à une source de données externes que vous ajoutez à un modèle de formulaire. Cette connexion de données est différente de la connexion de données principale qui est créée lors de la création d'un modèle de formulaire basé sur une base de données, service Web ou paramètres dans une bibliothèque de connexions. Vous ajoutez une connexion de données secondaire uniquement si vous ne pouvez pas demander ou envoyer des données via la connexion de données principale.

Lorsque vous ajoutez une connexion de données secondaire à votre modèle de formulaire qui demande des données, Microsoft Office InfoPath créent une secondaire source de données avec des groupes et des champs de données qui correspond à la manière que les données sont stockées dans la liste ou bibliothèque de documents. Relation entre la source de données externes et la source de données dans le modèle de formulaire.

Étant donné que la structure de données de la source de données secondaire doit correspondre à la manière dont les données sont stockées dans la bibliothèque de documents ou la liste, vous ne pouvez pas modifier les champs ou les groupes existants dans la source de données secondaire.

Une connexion de données que demande des données à partir d'un point de partage les bibliothèques de documents ou de la liste automatiquement renvoie tous les éléments de cette bibliothèque de documents ou de la liste. Si vous utilisez une connexion de données de requête pour remplir une liste boîte, zone de liste déroulante, ou contrôle de zone de liste déroulante et le contrôle contient trop d'éléments ou que vous souhaitez afficher uniquement les éléments qui répondent aux critères spécifiés, vous pouvez utiliser un filtre dans le contrôle pour limiter le nombre d'éléments. Vous trouverez des liens vers des informations supplémentaires sur le filtrage des données affichées dans un contrôle dans la section Voir aussi.

Vous pouvez également configurer chaque connexion de données de requête pour enregistrer ses résultats afin que les utilisateurs aient accès aux données lorsque leur formulaire n'est pas connecté à un réseau. En fonction de la nature des données, vous voudrez peut-être afficher les résultats de la requête uniquement lorsque les utilisateurs sont connectés à un réseau.

Note de sécurité : Si vous utilisez une connexion de données secondaire pour récupérer des données sensibles à partir d'une source de données externe, vous souhaiterez désactiver cette fonctionnalité pour aider à protéger les données à partir d'une utilisation non autorisée en cas de perte ou de vol de l'ordinateur. Si vous désactivez cette fonctionnalité, les données seront disponibles uniquement si l'utilisateur est connecté au réseau.

Lorsque vous ajoutez une connexion de données à un modèle de formulaire, par défaut les formulaires basés sur ce modèle de formulaire utilisent la connexion de données lorsqu'ils sont ouverts par un utilisateur. Vous pouvez également configurer votre modèle de formulaire pour utiliser la connexion de données de requête d'une des façons suivantes :

  • Ajouter une règle    Vous pouvez configurer une règle pour utiliser la connexion de données de requête à chaque fois que la condition dans la règle se produit.

  • Ajouter un bouton    Vous pouvez ajouter un bouton au modèle de formulaire que les utilisateurs peuvent cliquer pour obtenir des données à l'aide de la connexion de données de requête.

  • Utiliser le code personnalisé    Si vous ne pouvez pas ajouter une règle ou un bouton, vous pouvez utiliser un code personnalisé pour obtenir des données à l'aide de la connexion de données de requête. À l'aide de code personnalisé nécessite un développeur créer le code personnalisé.

Lorsque vous ajoutez une connexion de données d'envoi à votre modèle de formulaire, vous pouvez configurer le modèle de formulaire de manière à permettre aux utilisateurs d'envoyer les données de leur formulaire. Vous pouvez également configurer les options d'envoi pour les formulaires qui sont basés sur votre modèle de formulaire.

Haut de la page

Avant de commencer

Avant d'ajouter une connexion de données secondaire à votre modèle de formulaire, vous devez obtenir les informations suivantes auprès de votre administrateur de site :

  • L'emplacement du site SharePoint et les autorisations nécessaires pour y accéder

  • Vérification que le site est configuré de manière à permettre à vos utilisateurs d'obtenir des données de la bibliothèque de documents ou de la liste

  • Vérification que vous pouvez stocker les données de la bibliothèque de documents ou de la liste sur les ordinateurs de vos utilisateurs pour une utilisation hors ligne

Haut de la page

Ajouter une connexion de données de requête

Pour permettre aux utilisateurs d'exécuter une requête de données provenant d'une bibliothèque de documents ou d'une liste sur un site situé sur un serveur qui exécute Microsoft Windows SharePoint Services, vous devez effectuer les actions suivantes dans le modèle de formulaire :

  1. Ajouter une connexion de données secondaire.

  2. Configurer le modèle de formulaire de manière à utiliser la connexion de données secondaire.

Étape 1 : Ajouter une connexion de données secondaire

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Recevoir les données et enfin, sur Suivant.

  4. Dans la page suivante de l'Assistant, cliquez sur Bibliothèque ou liste SharePoint, puis sur Suivant.

    Page dans l'Assistant connexion de données pour spécifier un site SharePoint comme source de données.

  5. Dans la page suivante de l'Assistant, tapez l'URL du site SharePoint contenant la bibliothèque de documents ou la liste, puis cliquez sur suivant. Par exemple, pour utiliser une liste de documents sur un site SharePoint avec l' URL http://www.adventureworks.com/EmployeeList, tapez http://www.adventureworks.com/EmployeeList.

  6. Sur la page suivante, dans la liste Sélectionnez une liste ou une bibliothèque cliquez sur la liste ou la bibliothèque que vous souhaitez utiliser, puis cliquez sur Suivant.

  7. Sur la page suivante du formulaire, sélectionnez les cases à cocher situées à côté des valeurs que vous souhaitez recevoir. Si le modèle de formulaire est destiné à être publié dans la bibliothèque de documents et que vous souhaitez des formulaires basés sur ce modèle de formulaire afin d'obtenir des métadonnées sur le formulaire, cochez la case Inclure des données pour le formulaire actif seulement.

  8. Cliquez sur Suivant.

  9. Si vous souhaitez stocker les résultats de la requête avec le modèle de formulaire, activez la case à cocher Enregistrer une copie des données dans le modèle de formulaire. L'activation de cette case à cocher stocke les résultats de la requête dans le modèle de formulaire. Les données étant stockées dans le modèle de formulaire, elles sont disponibles dans les formulaires remplis par les utilisateurs, même si leurs ordinateurs ne sont pas connectés à un réseau.

    Note de sécurité : Activez cette case à cocher stocke les résultats de la requête dans le modèle de formulaire. Étant donné que les données sont stockées dans le modèle de formulaire, il est disponible dans les formulaires remplis par les utilisateurs, même si leur ordinateur n'êtes pas connecté à un réseau. Si vous obtenez des données sensibles à partir de cette connexion de données, vous souhaiterez désactiver cette fonctionnalité pour aider à protéger les données en cas de perte ou de vol de l'ordinateur.

  10. Cliquez sur Suivant.

  11. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour cette connexion de données secondaire. Il s'agit du nom qui s'affiche dans la liste source de données dans le volet Office source de données. Si vous souhaitez que cette requête s'exécute automatiquement chaque fois que le formulaire est ouvert par un utilisateur, activez la case à cocher extraire automatiquement les données lorsque le formulaire est ouvert.

Étape 2 : Configurer le modèle de formulaire pour utiliser la connexion de données secondaire

Si vous souhaitez que les formulaires basés sur votre modèle de formulaire à utiliser cette connexion de données une fois que l'utilisateur ouvre le formulaire, vous pouvez ajouter une règle au modèle de formulaire qui utilise cette connexion de données une condition, ou vous pouvez ajouter un bouton au modèle de formulaire que les utilisateurs peuvent cliquer pour utiliser cette connexion de données.

Ajouter une règle

Vous pouvez ajouter une règle au modèle de formulaire pour obtenir des données de la connexion de données de requête dès lors que la condition de la règle est respectée. La procédure suivante suppose que vous ayez créé une connexion de données de requête pour votre modèle de formulaire et que vous ayez configuré un contrôle sur votre modèle de formulaire pour afficher les données de cette connexion de données.

  1. Si le modèle de formulaire comporte plusieurs vues, cliquez sur nom de l'affichage dans le menu affichage pour accéder à la vue avec le contrôle dans lequel vous souhaitez afficher les données à partir de la source de données secondaire.

  2. Double-cliquez sur le contrôle qui doit afficher les résultats de la requête.

  3. Cliquez sur l'onglet Données.

  4. Sous Validation et Règles, cliquez sur Règles.

  5. Dans la boîte de dialogue Règles, cliquez sur Ajouter.

  6. Dans la case Nom, tapez le nom de la règle.

  7. Pour spécifier une condition lors de la règle doit être exécutée, cliquez sur Définir une Condition, puis entrez la condition. La règle s'exécutera lorsque la condition se produit. Si vous ne définissez pas une condition, la règle s'exécutera chaque fois que l'utilisateur modifie la valeur dans le contrôle, puis passe son curseur en s'éloignant de ce contrôle.

  8. Cliquez sur Ajouter une action.

  9. Dans la liste Action, cliquez sur Exécuter une requête via une connexion de données.

  10. Dans la liste Connexion de données, cliquez sur la connexion de données de requête que vous souhaitez utiliser puis cliquez sur OK pour fermer toutes les boîtes de dialogue ouvertes.

  11. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Ajouter un bouton

Vous pouvez ajouter à votre modèle de formulaire un contrôle de bouton sur lequel vos utilisateurs peuvent cliquer pour utiliser cette connexion de données de requête. La procédure suivante suppose que vous ayez créé une connexion de données de requête pour votre modèle de formulaire.

  1. Si le modèle de formulaire comporte plusieurs vues, cliquez sur nom de l'affichage dans le menu affichage pour accéder à la vue avec le contrôle dans lequel vous souhaitez afficher les données à partir de la source de données secondaire.

  2. Si le volet Office Contrôles n’est pas visible, cliquez sur Autres contrôles dans le menu Insertion, ou appuyez sur Alt+I, C.

  3. Faites glisser un contrôle de bouton sur votre modèle de formulaire.

  4. Double-cliquez sur le contrôle de bouton que vous venez d'ajouter à votre modèle de formulaire.

  5. Cliquez sur l'onglet Général.

  6. Dans la liste Action, cliquez sur Actualiser.

  7. Dans la zone Étiquette, tapez le nom qui doit apparaître sur le bouton de votre modèle de formulaire.

  8. Cliquez sur Paramètres.

  9. Dans la boîte de dialogue Actualiser, cliquez sur Une seule source de données secondaire.

  10. Dans la liste Choisissez la source de données secondaire, cliquez sur la source de données secondaire qui est associée à la connexion de données de requête, puis cliquez sur OK pour fermer chaque boîte de dialogue ouverte.

  11. Pour tester vos modifications, cliquez sur Aperçu dans la barre d’outils Standard, ou appuyez sur Ctrl+Maj+B.

Haut de la page

Ajouter une connexion de données d'envoi

Pour permettre aux utilisateurs d'envoyer des formulaires basés sur votre modèle de formulaire à une bibliothèque de documents, vous devez procéder de la manière suivante :

  1. Ajoutez une connexion de données secondaire envoyant des données à votre modèle de formulaire.

  2. Configurez le modèle de formulaire de manière à permettre à vos utilisateurs d'envoyer leur modèle de formulaire à la bibliothèque de documents.

Étape 1 : Ajouter une connexion de données secondaire

  1. Dans le menu Outils, cliquez sur Connexions de données.

  2. Dans la boîte de dialogue Connexions de données, cliquez sur Ajouter.

  3. Dans l'Assistant Connexion de données, cliquez sur Créer une nouvelle connexion, puis sur Envoyer les données et enfin, sur Suivant.

  4. Sous Comment souhaitez-vous envoyer vos données, cliquez sur Vers une bibliothèque de documents sur un site SharePoint, puis cliquez sur Suivant.

  5. Dans l'Assistant Connexion de données, dans la zone Bibliothèque de documents, tapez l'URL de la bibliothèque de documents SharePoint.

  6. Dans la zone Nom de fichier, tapez le nom qui sera utilisé pour identifier le formulaire dans la bibliothèque de documents.

    Conseil : Vous pouvez aussi utiliser une formule pour garantir que les noms des formulaires soient tous uniques.

    Comment ?

    1. Cliquez sur Insérer une formule Bouton Formule .

    2. Dans la boîte de dialogue Insérer une formule, effectuez l'une des opérations suivantes :

      • Pour utiliser un champ dans la formule, cliquez sur Insérer un champ ou un groupe, cliquez sur le champ que vous souhaitez utiliser dans la boîte de dialogue Sélectionner un champ ou un groupe, puis cliquez sur OK.

      • Pour utiliser une fonction dans la formule, cliquez sur Insérer une fonction, sélectionnez la fonction que vous souhaitez utiliser dans la boîte de dialogue Insérer une fonction, puis cliquez sur OK.

        Conseil : Si la fonction nécessite des paramètres, sélectionnez la fonction dans la boîte de dialogue Insérer une fonction, cliquez sur OK puis, dans la zone formule de la boîte de dialogue Insérer une formule, double-cliquez sur la fonction que vous avez ajouté et cliquez sur un champ ou un groupe. Recherchez des liens vers des informations supplémentaires sur les fonctions dans la section Voir aussi.

      • Pour insérer une valeur ou un opérateur mathématique dans la formule, tapez la valeur ou le symbole de l'opération mathématique dans la zone Formule.

    Opération

    Symbole

    Addition

    +

    Soustraction

    -

    Multiplication

    *

    Division

    /

    • Remarque : Si votre formule utilise l'opérateur de division (/), vérifiez qu'il y a un espace avant et après l'opérateur de division. Si l'opérateur de division n'a pas d'espace avant et après, InfoPath risque d'interpréter « / » comme un séparateur pour les étapes d'emplacement XPath plutôt que comme un opérateur de division.

    • Pour vérifier si la syntaxe de la formule est correcte, dans la boîte de dialogue Insérer une formule, cliquez sur Vérifier la formule.

      Vous trouverez des liens vers d'autres informations sur les formules dans la section Voir aussi.

  7. Pour remplacer dans la bibliothèque de documents un formulaire existant dont le nom est identique, activez la case à cocher Remplacer le fichier s'il existe.

  8. Cliquez sur Suivant.

  9. Dans la page suivante de l'Assistant, dans la zone Entrez un nom pour cette connexion de données, tapez un nom descriptif pour ce soumettre la connexion de données.

Après avoir ajouté la connexion de données d'envoi secondaire, vous devez configurer votre modèle de formulaire afin de permettre aux utilisateurs d'envoyer les données de leur formulaire à l'aide de cette connexion de données d'envoi.

Étape 2 : Autoriser l'envoi sur le modèle de formulaire

Lorsque vous configurez le modèle de formulaire afin de permettre aux utilisateurs d'envoyer les données de leur formulaire, InfoPath ajoute un bouton Envoyer sur la barre d'outils Standard et une commande Envoyer dans le menu Fichier du formulaire. Vous pouvez également personnaliser les options d'envoi de votre modèle de formulaire de la façon suivante :

  • en modifiant le texte qui apparaît sur le bouton Envoyer.

  • en modifiant le raccourci clavier du bouton Envoyer.

  • en créant des messages personnalisés que les utilisateurs recevront lorsqu'ils enverront les formulaires.

  • en indiquant s'il convient de laisser le formulaire ouvert, de le fermer ou d'en ouvrir un autre (vide) une fois le formulaire envoyé.

  • Dans le menu Outils, cliquez sur Options d'envoi.

  • Dans la boîte de dialogue Options d'envoi, activez la case à cocher Autoriser les utilisateurs à envoyer ce formulaire et cliquez sur Envoyer des données de formulaire vers une seule destination puis, dans la liste, cliquez sur bibliothèque de documents SharePoint.

  • Dans la liste Choisir une connexion de données à envoyer, cliquez sur le nom de la connexion de données d'envoi vers la bibliothèque SharePoint.

    1. Pour modifier le nom du bouton Envoyer qui s'affiche dans la barre d'outils Standard et la commande Envoyer qui s'affiche dans le menu fichier lorsque les utilisateurs rempliront le formulaire, tapez le nouveau nom dans la zone de légende dans la boîte de dialogue Options d'envoi.

      Conseil : Si vous voulez affecter un raccourci clavier à ce bouton et la commande, tapez une esperluette (&) avant le caractère que vous souhaitez utiliser comme un raccourci clavier. Par exemple, pour attribuer ALT + B que le raccourci clavier pour la commande et le bouton Envoyer, tapez & bouton Envoyer.

  • Si vous ne souhaitez pas les personnes à utiliser une commande Envoyer ou le bouton Envoyer dans la barre d'outils Standard lorsqu'ils remplissent votre formulaire, désactivez la case à cocher Afficher l'option de menu Envoyer et le bouton Envoyer.

    1. Par défaut, une fois que les utilisateurs envoient un formulaire InfoPath laisse le formulaire ouvert et affiche un message pour indiquer si le formulaire a été envoyé. Pour modifier ce comportement par défaut, cliquez sur Avancé et effectuez l'une des opérations suivantes :

      • Pour fermer le formulaire ou créer un nouveau formulaire vide après que l'utilisateur a envoyé un formulaire complété, cliquez sur l'option souhaitée dans la liste après avoir soumettre.

      • Pour créer un message personnalisé pour indiquer si le formulaire a été envoyé, activez la case à cocher messages personnalisés utiliser et tapez vos messages dans les zones en cas de réussite et en cas d'échec.

        Conseil : Utiliser un message dans la zone en cas d'échec pour indiquer aux utilisateurs comment procéder si elles ne peuvent pas soumettre leur formulaire. Par exemple, vous pouvez suggérer que les utilisateurs enregistrement leur formulaire et contacter une personne pour obtenir des instructions supplémentaires.

      • Si vous ne souhaitez pas afficher un message après que l'utilisateur a envoyé un formulaire, désactivez la case à cocher Afficher les messages de réussite et Échec.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×