Ajouter les données collectées par le biais de messages électroniques à une base de données Access

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Vous pouvez collecter ou mise à jour des informations via envoie par courrier électronique à l’aide de Microsoft Access 2010 avec Microsoft Outlook 2010. Access vous guide à créer un formulaire de collecte de données et envoyer le formulaire dans un message électronique. Lorsque vos destinataires retournent les formulaires remplis, vous pouvez choisir les données collectées, traitées et stockées dans une base de données Access spécifiée automatiquement. Cette méthode de collecte des données pouvez gagner du temps et effort est généralement impliqué dans un copier-coller ou un processus de saisie manuelle des données. Voici quelques scénarios où vous pouvez utiliser ce processus pour recueillir des données :

Enquêtes   : vous pouvez créer une enquête et compiler les résultats en créant tout d’abord une base de données Access contenant les tables nécessaires pour stocker les résultats et à l’aide de l’Assistant pour générer un formulaire d’enquête et puis de les envoyer aux participants. Lorsque les participants répondent, les données de l’enquête sont automatiquement stockées dans la base de données.

Rapports d’état   : qu’il s’agisse le dernier état niveau stock ou les informations à jour sur les problèmes en cours, votre équipe pouvez tenir informé en envoyant vous les messages électroniques qui contiennent les informations actuelles à intervalles réguliers.

Gestion de l’événement   : lors de l’organisation d’une conférence de formation ou d’autres événements, vous pouvez envoyer un ou plusieurs formulaires par un message électronique pour recueillir des préférences hôtel, de voyage et informations de contact du message et ainsi de suite. Si vous souhaitez que les traitement automatique des réponses, les participants sont en mesure de modifier ses préférences à tout moment sans avoir à vous informer et vous avez toujours accès aux données plus récentes à des fins de prise de décision.

Cet article explique ce que vous devez utiliser ce processus, comment commencer à utiliser l’Assistant et puis vous donne des informations supplémentaires sur les différentes étapes de sorte que vous pouvez effectuer la sélection plus informée que vous suivez l’Assistant

Remarque : Vous ne serez pas en mesure d’ajouter les données collectées si votre destinataire utilisé Hotmail ou Yahoo vous envoyer le formulaire de collecte de données.

Avant de commencer

S’il s’agit de votre première collecte des données à l’aide de messages électroniques, procédez comme suit :

  1. Assurez-vous que les applications suivantes sont installées sur votre ordinateur :

    • Access 2007 ou Access 2010.

    • Outlook 2007 ou Outlook 2010. Vous devez configurer Outlook installé et configuré sur l’ordinateur qui vous permet d’envoyer les messages électroniques. Si vous avez installé Outlook mais pas encore configuré, démarrez Outlook et suivez les instructions de l’Assistant Démarrage d’Outlook. Pour obtenir de l’aide de l’Assistant, voir l’aide d’Outlook.

    • Si vous prévoyez d’utiliser un formulaire InfoPath, vérifiez que vous avez InfoPath 2007 ou version ultérieure installé et vos destinataires également devront disposent d’InfoPath sur leur ordinateur.

    • Messagerie destinataires doivent avoir soit disposer d’InfoPath ou un client de messagerie qui prend en charge au format HTML installé sur leur ordinateur afin de pouvoir afficher et modifier le formulaire.

      Le formulaire utilisé pour collecter les données dans les messages électroniques n’est pas un formulaire Access. L’Assistant génère une forme spécifique au format HTML ou InfoPath.

      Identifiez une base de données de destination. La base de données peut être au format .mdb ou .accdb. En outre, les fichiers .mde et .accde sont prises en charge. Si vous ne voulez pas utiliser une base de données existante, vous devez créer un nouvel identifiant.

  2. Identifiez ou créez les tables que vous souhaitez remplir avec les données dans les réponses de courrier électronique. Si vous collectez des données pour tables existantes, assurez-vous que les tables ne sont pas en lecture seule et que vous disposez des autorisations nécessaires pour ajouter ou mettre à jour son contenu.

Remarque : La pièce jointe, NuméroAuto, OLE et champ à valeurs multiples types ne peuvent pas être collectées à l’aide de messages électroniques

Si votre opération de collecte de données remplit deux tables ou plus, vous devez créer une requête sélection et utiliser comme source d’enregistrement du formulaire. Vérifiez que la requête inclut tous les champs requis des tables sous-jacentes. Si vous utilisez une requête existante, assurez-vous que la requête n’est pas en lecture seule et que vous disposez des autorisations nécessaires pour ajouter ou mettre à jour son contenu. Pour plus d’informations sur la création d’une requête basée sur deux tables ou plus, voir l’article Présentation des requêtes.

Stocker les données comme de nouveaux enregistrements dans les situations suivantes :

  • Si les données rempliront plusieurs tables.

  • Si la table de destination ne comporte pas un champ de clé primaire. Valeurs de clé primaire sont nécessaires pour associer chaque réponse à un enregistrement existant. Si votre table de destination ne comporte pas un champ de clé primaire, ajoutez-le maintenant ou affecter un champ existant qui comporte des valeurs uniques comme clé primaire.

  • Si la table de destination ne comporte pas de tous les enregistrements. Si la table est vide, l’Assistant suppose que vous voulez ajouter des enregistrements.

  • Si les adresses de messagerie des destinataires ne sont pas stockés en tant que champ dans la base de données. Lors de la collecte de données pour mettre à jour des enregistrements, vous ne serez pas en mesure de taper manuellement les adresses dans le message générés par l’Assistant. Le champ adresse doit être placé dans la table de destination ou dans une table qui dispose d’une relation avec la table de destination.

Haut de la page

Prise en main

  1. Ouvrez la base de données dans lequel les données collectées seront stockées.

  2. Pour ajouter les données à une seule table, sélectionnez la table dans le volet de Navigation. Pour remplir plusieurs tables associées, sélectionnez la requête qui est liée à ces tables.

  3. Effectuez l’une des opérations suivantes pour démarrer l’Assistant :

    • Sous l’onglet Données externes, dans le groupe Collecter les données, cliquez sur Créer une messagerie.

    • Cliquez avec le bouton droit sur la table ou la requête, puis cliquez sur Collecter et mettre à jour les données par messagerie.

      Remarque : Si la table ne contient-elle pas tous les champs ou n’affiche que les NuméroAuto, objet OLE, pièce jointe ou les types de champs liste de choix à plusieurs valeurs, Access affiche le message suivant : la table sélectionnée ou la requête n’a pas tous les champs qui prennent en charge la collecte de données via la messagerie électronique.

Si la table contient des champs qui prennent en charge de la collecte de données, l’Assistant démarre. Si la table de destination prend en charge l’ajout et la mise à jour des données, l’Assistant vous guide à travers les étapes nécessaires pour collecter les données dans les messages électroniques.

Utiliser les sections suivantes comme une référence pour toutes les questions que vous deviez via les sept étapes principales du processus.

  1. Choisissez le type de formulaire d’entrée de données que vous voulez envoyer

  2. Indiquez si vous souhaitez collecter de nouvelles données ou mettre à jour des données existantes

  3. Spécifier les données que vous voulez collecter

  4. Spécifier le traitement des données manuel ou automatique

  5. Indiquez comment vous souhaitez spécifier les adresses de messagerie des destinataires

  6. Passez en revue et spécifier la liste des destinataires

  7. Créer et envoyer le message électronique

Haut de la page

Choisissez le type de formulaire d’entrée de données que vous voulez envoyer

Sélectionnez le type de formulaire basé sur la facilité d’utilisation et celles de vos destinataires.

Formulaire HTML Sélectionnez    Un formulaire HTML peut être affiché et modifié par les utilisateurs dont le client de messagerie prend en charge HTML

Formulaire sélectionnez Microsoft InfoPath    Cette option qu'uniquement si InfoPath est installé sur votre ordinateur s’affiche. Sélectionnez cette option uniquement si votre tous les destinataires disposent d’InfoPath et Outlook sont installés sur leur ordinateur. Un formulaire InfoPath offre une meilleure saisie des données et l’environnement d’édition,

La page de l'Assistant qui s'affiche ensuite varie selon que l'objet de destination prend en charge la mise à jour des données. Si cet objet est une requête reposant sur plusieurs tables ou s'il s'agit d'une table qui n'a pas de champ de clé primaire ou qui ne contient aucun enregistrement, l'Assistant suppose que vous voulez ajouter de nouveaux enregistrements et vous invite à sélectionner les champs du formulaire. Dans tous les autres cas, l'Assistant vous invite à spécifier si vous souhaitez ajouter ou mettre à jour des données avant de vous demander de sélectionner les champs.

Haut de la page

Indiquez si vous souhaitez collecter de nouvelles données ou mettre à jour des données existantes

Spécifiez ce que vous voulez faire avec les données. Le type de formulaire que vous utilisez affecte le nombre de nouveaux enregistrements qu’un destinataire peut vous envoyer dans une même réponse. Lors de la mise à jour des données, le nombre d’enregistrements qui doivent être mis à jour par un destinataire détermine le nombre de formulaires complétés pré-mise à inclure dans un message.

Remarque : Pour ajouter de nouveaux enregistrements, tapez les adresses de messagerie dans la zone Adresse du message électronique lorsque le message est créé. Pour mettre à jour des données existantes, les adresses de messagerie des destinataires doivent être stockés en tant que champ dans la table ou la requête sous-jacente, ou dans une table liée.

Haut de la page

Spécifier les données à collecter

Lorsque vous choisissez les champs à inclure dans votre formulaire, il n’est pas nécessaire d’inclure tous les champs qui existe dans la table ou requête sous la forme sous-jacente. Toutefois, les conditions suivantes doivent être remplies :

  • Champs obligatoires :    Champs portant un symbole d’astérisque (*), sont obligatoires. Si vous collectez de nouveaux enregistrements, l’Assistant inclut automatiquement tous les champs dont la propriété obligatoire est définie sur Oui. Si tous les enregistrements de champs obligatoires sont vides, Access ne parvient pas à ajouter l’enregistrement à la table.

  • Non prises en charge des types de champ :    Vous ne pourrez pas inclure certains types de champs dans le formulaire par exemple, NuméroAuto, pièce jointe, objet OLE ou champs de recherche à plusieurs valeurs.

  • Champ de clé primaire :    L’utilisateur sera en mesure de taper une valeur dans le champ lors de l’ajout des enregistrements la réponse ne sera pas traitée si la valeur spécifiée est déjà en cours d’utilisation.

    Remarque : Pour chaque champ inclus, sous Propriétés du champ, spécifiez une étiquette, puis cliquez sur lecture seule si vous ne voulez pas l’utilisateur à modifier les données dans ce champ.

Haut de la page

Spécifier le traitement des données manuel ou automatique

Vous pouvez sélectionner un traitement automatique ou manuel des réponses. Traitement automatique signifie que lorsque vous recevez les réponses, Outlook et Access collaborent pour exporter les données dans les tables de destination dans votre base de données. Traitement automatique peut vous faire gagner du temps et. Traitement manuel signifie uniquement que vous démarrez l’opération d’exportation pour transférer les données à partir d’un dossier spécifié dans Outlook, dans la table de destination dans Access.

Les réponses sont exportées avec succès à la table de destination dans la mesure où les conditions suivantes sont remplies au moment où les réponses vers votre boîte aux lettres :

  • Outlook doit déjà être en cours d'exécution sur votre ordinateur. Si ce n'est pas le cas, le traitement commence à son prochain démarrage.

  • Access ne doit pas être protégées par mot de passe et ne doit pas être ouvert en mode exclusif. Le nom ou l’emplacement de la base de données ne doit pas avoir changé depuis que vous avez envoyé le message électronique.

  • Le nom des tables et des requêtes, ainsi que les propriétés des champs inclus dans le formulaire, ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Vous devez bénéficier des autorisations requises pour ajouter ou mettre à jour le contenu des tables et de la requête sous-jacentes.

    Remarque : Si le traitement automatique échoue, essayez de résoudre les problèmes et puis exportez manuellement les réponses qui a échoué. Les réponses qui arrivent dans votre boîte de réception après avoir résolu les problèmes de continuent à être traité automatiquement.

Définir les propriétés pour contrôler le traitement des réponses automatique

Pour spécifier un autre dossier Outlook où sont stockées les réponses, dans la page spécifier comment vous souhaitez traiter les réponses de l’Assistant, cliquez sur le nom du dossier. Dans la boîte de dialogue Sélectionner un dossier, sélectionnez un autre dossier, ou cliquez sur Nouveau pour créer un nouveau dossier.

Si vous cliquez sur définir les propriétés pour contrôler le traitement des réponses automatique changer ou importer les paramètres de réglage, consultez le tableau suivant pour plus d’informations sur les options disponibles :

Option

Résultat

Ignorer les réponses des personnes auxquelles vous n’avez pas envoyé le message   

Activez cette case à cocher si vous souhaitez que seules les réponses ayant été envoyées par les destinataires d'origine de votre message soient traitées automatiquement. Les réponses des autres personnes sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

Accepter plusieurs réponses pour chaque destinataire   

Activez cette case à cocher si vous voulez uniquement la première réponse de chaque destinataire soit traitée automatiquement. Les réponses suivantes sont stockées dans le dossier de destination, mais ne sont pas traitées automatiquement.

Remarque : Ce paramètre contrôle uniquement le nombre de réponses qui sont traitées, et non le nombre d'enregistrements figurant dans une même réponse. Autrement dit, si vous envoyez un formulaire InfoPath, un utilisateur peut vous envoyer plusieurs enregistrements dans une seule réponse et Access les traite tous automatiquement, même si cette case à cocher n'est pas activée.

Autoriser les mises à jour des données existantes uniquement   

Lorsque les destinataires utilisent un formulaire InfoPath à jour des données, ils peuvent envoyer de nouveaux enregistrements en plus des mises à jour aux enregistrements existants. Activez cette case à cocher traiter uniquement les mises à jour les enregistrements existants.

Nombre de réponses à traiter   

Tapez le nombre total de réponses (de tous les destinataires) que vous souhaitez traiter automatiquement. Si vous voulez que toutes les réponses soient traitées automatiquement, entrez une valeur élevée, par exemple 5000, dans la zone de texte. Au-delà de cette valeur, les réponses reçues sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

Date et heure d'interruption   

Spécifiez quand le traitement automatique des réponses doit s'arrêter pour ce message électronique. Au-delà de cette date et de cette heure, les réponses reçues sont stockées dans le dossier de destination, mais elles ne sont pas traitées automatiquement.

Pour modifier ces options ultérieurement, dans le groupe Collecter les données de l'onglet Données externes, cliquez sur Gérer les réponses. Dans la boîte de dialogue Gérer les messages de la collecte de données, sélectionnez le message dont vous souhaitez modifier les paramètres, puis cliquez sur Options du message. Les modifications que vous apportez dans cette boîte de dialogue affectent toutes les réponses suivantes reçues pour ce message.

Traitement manuel des réponses

Pour contrôler quand et réponses qui sont traitées, ne sélectionnez pas l’option traitement automatique. Les réponses sont stockées dans un dossier spécifié dans Outlook jusqu'à ce que vous sélectionnez et cliquez sur chaque réponse dans le dossier, puis cliquez sur Exporter les données Microsoft Access dans le menu contextuel.

Dans certains cas, vous devrez peut-être également traitement manuel des réponses qui n’a pas pu être traitées automatiquement.

N’oubliez pas les informations suivantes avant l’exportation de données

  • La base de données Access ne doit pas être ouverte en mode exclusif et le nom ou l’emplacement de la base de données ne doit pas avoir changé depuis que vous avez envoyé le message électronique.

  • Le nom des tables et des requêtes, ainsi que les propriétés des champs inclus dans le formulaire, ne doivent pas avoir changé depuis que vous avez envoyé le message électronique.

  • Vous devez bénéficier des autorisations requises pour ajouter ou mettre à jour le contenu des tables et de la requête sous-jacentes.

Haut de la page

Indiquez comment vous souhaitez spécifier les adresses de messagerie des destinataires

Si vous collectez uniquement de nouvelles données, vous pouvez spécifier les adresses de messagerie de deux manières :

  • Tapez les adresses de messagerie individuellement dans le message électronique Outlook, ou sélectionnez les adresses à partir d’un carnet d’adresses.

  • Utiliser le champ adresse de messagerie dans la table ou requête de la base de données Access en cours.

    Remarque : Lors de la collecte de données pour mettre à jour les enregistrements existants, vous ne voyez pas cette boîte de dialogue, parce que les adresses de messagerie des destinataires doivent d’abord être disponibles en tant que champ dans la base de données.

Entrer les adresses de messagerie directement dans Outlook

Si vous spécifiez vos destinataires dans Outlook, vous pouvez afficher un aperçu et personnaliser le message avant de l’envoyer. Dans le message électronique corps du message contient une brève introduction et un formulaire. Il est recommandé de ne pas émettre des modifications au formulaire. Modifications apportées à la structure du formulaire peuvent entraîner la réponse n’est pas traitée.

À l’aide des adresses de messagerie stockées dans un champ dans la base de données

L’option sélectionner associé à une table fait référence à des tables liées. Pour afficher ou modifier des relations entre les tables dans votre base de données, sous l’onglet Outils de base de données., dans le groupe relations, cliquez sur relations

Pour plus d’informations sur les relations, voir l’article Guide pour les relations entre les tables.

Haut de la page

Passez en revue et spécifier la liste des destinataires

La dernière étape principale implique l’aperçu et personnalisation du message électronique, réglage votre liste de destinataires et envoyer votre message de collecte de données.

Créer et envoyer le message électronique

Lorsque l’Assistant vous informe que vous pouvez désormais créer le message électronique et vous montre comment afficher l’état du courrier électronique à l’aide de la commande Gérer les réponses, certains messages d’avertissement peuvent s’afficher. Le tableau suivant décrit chacun d’eux et l’action que vous pouvez prendre pour résoudre ce problème :

Avertissement message

Description

S solution

Certains enregistrements ne comprennent pas d'adresse valide dans le champ de l'adresse de messagerie spécifié. Aucune donnée ne sera retournée pour ces lignes.

Le champ d'adresse de messagerie que vous avez sélectionné contient des valeurs Null.

Si vous souhaitez collecter des données pour tous les enregistrements, quittez l'Assistant et remplacez les valeurs Null par des adresses de messagerie. Ensuite, redémarrez l'Assistant.

Votre base de données est actuellement ouverte en accès verrouillé exclusif. Tant que ce verrouillage exclusif n'est pas désactivé, le traitement automatique des messages électroniques échouera.

La base de données est actuellement ouverte en mode exclusif.

Si vous avez choisi de laisser automatiquement les réponses traitées, de la transformation échoue, car Access Impossible d’ajouter ou mettre à jour une base de données qui comporte un accès exclusif. Fermez et rouvrez la base de données en mode exclusif immédiatement après l’envoi du message

Ces messages électroniques risquent de contenir des données confidentielles ou sensibles.

Vous collectez des données pour mettre à jour des enregistrements existants et le formulaire que vous allez envoyer sera pré-complété avec des données existantes.

Si certains champs du formulaire contiennent des données sensibles, revenez à l’étape de l’Assistant dans laquelle vous avez sélectionné les champs et supprimer les champs qui contiennent des données sensibles à partir du formulaire

Après avoir afficher un aperçu et personnaliser le message, vous pouvez filtrer le champ adresse de messagerie et sélectionner les destinataires. Sélectionnez les adresses de messagerie que vous souhaitez utiliser en activant les cases à cocher correspondantes. Si vous voyez une boîte de dialogue répertoriant les adresses de messagerie non valide, notez les adresses dans la liste et cliquez sur Quitter. Vérifier les adresses non valides, apportez toute modification nécessaire et essayez de renvoyer le message.

Haut de la page

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×