Additionner des valeurs basées sur une ou plusieurs conditions

Additionner des valeurs basées sur une ou plusieurs conditions

Vous voulez additionner des valeurs avec plusieurs conditions, telles que la somme de ventes d’un certain produit dans une certaine région. Pour ce faire, vous pouvez utiliser la fonction SOMME.SI.ENS dans une formule.

Voici un exemple dans lequel nous avons deux conditions : nous voulons la somme des ventes de Viande (dans la colonne C) dans la région Sud (dans la colonne  A).

Données dans une feuille de calcul Excel

Voici la formule à utiliser :

=SOMME.SI.ENS(D2:D11;A2:A11;”Sud”;C2:C11;”Viande”)Le résultat est 14719. Voici comment fonctionne la formule.

=SOMME.SI.ENS est une formule arithmétique. Elle calcule les nombres, qui en l’occurrence se trouvent dans la colonne D. Commencez donc par indiquer à la formule où se trouvent les nombres :

  • =SOMME.SI.ENS(D2:D11;

En d’autres termes, vous voulez que la formule additionne les nombres de cette colonne s’ils répondent aux conditions. Cette plage de cellules est votre premier argument, c’est-à-dire les premières données dont la fonction a besoin pour s’exécuter.

Ensuite, vous voulez trouver des données répondant à deux conditions. Par conséquent, vous entrez votre première condition en indiquant à la fonction où se trouvent les données (A2:A11) et quelle est la condition, à savoir “Sud”. Remarques les points-virgules entre les différents arguments.

  • =SOMME.SI.ENS(D2:D11;A2:A11;”Sud”;

Les guillemets autour de "Sud" indiquent à Excel que des données textuelles sont utilisées.

Enfin, vous entrez les arguments pour votre deuxième condition, la plage de cellules (C2:C11) qui contient le mot "viande", ainsi que le mot lui-même (entre guillemets) pour permettre à Excel de le trouver. Terminez la formule au moyen d’une parenthèse fermante ), puis appuyez sur Entrée pour obtenir le résultat 14719.

  • =SOMME.SI.ENS(D2:D11;A2:A11;”Sud”;C2:C11;”Viande”)

Lorsque vous tapez la fonction SOMME.SI.ENS dans Excel, si vous ne vous souvenez pas des arguments, une aide est toute proche. Après avoir tapé =SOMME.SI.ENS( la saisie semi-automatique de formule apparaît en dessous de la formule, avec la liste d’arguments dans l’ordre correct.

Examinez l’image de la saisie semi-automatique de formule et la liste d’arguments, dans notre exemple plage_somme correspond à D2:D11, à savoir la colonne de nombres à additionner ; plage_critères1 correspond à A2.A11, à savoir la colonne de données où se trouve le critère1 “Sud”.

Utilisation de la saisie semi-automatique de formule pour entrer la fonction SOMME.SI.ENS

Lorsque vous tapez, les autres arguments apparaissent dans la saisie semi-automatique de formule (non illustré ici) ; plage_critères2 correspond à C2:C11, à savoir la colonne de données où se trouve critère2 “Viande”.

Si vous cliquez sur SOMME.SI.ENS dans la saisie semi-automatique de formule, un article apparaît pour vous fournir plus d’aide.

Exercices pratiques

Si vous voulez vous exercer avec la fonction SOMME.SI.ENS, voici des exemples de données et une formule qui utilise la fonction.

Vous pouvez utiliser les exemples de données et les formules ici, dans ce classeur Excel Online. Modifiez les valeurs et les formules, ou ajoutez vos propres valeurs et formules et examinez l’impact sur les résultats en temps réel.

Copiez toutes les cellules dans le tableau ci-dessous, puis collez-les dans la cellule A1 d’une nouvelle feuille de calcul dans Excel. Vous pouvez ajuster la largeur des colonnes pour mieux afficher les formules.

Région

Vendeur

Type

Ventes

Sud

Kurjan

Boissons

3 571

Ouest

Fonteneau

Produits laitiers

3 338

Est

Mitosinka

Boissons

5 122

Nord

Mitosinka

Produits laitiers

6 239

Sud

Thierry

Produits frais

8 677

Sud

Fonteneau

Viande

450

Sud

Fonteneau

Viande

7 673

Est

Mitosinka

Produits frais

664

Nord

Fonteneau

Produits frais

1 500

Sud

Thierry

Viande

6596

Formule

 

Description

Résultat

'=SOMME.SI.ENS(D2:D11;A2:A11;
"Sud";C2:C11;"Viande")

Fait la somme des ventes de viande dans la
colonne C dans la région
Sud dans la colonne A (le résultat est 14 719).

=SOMME.SI.ENS(D2:D11;A2:A11;
"Sud";C2:C11;"Viande")

Remarques : 

  • Vous voulez plus d’exemples ? Vous en trouverez d’autres dans l’article Fonction SOMME.SI.ENS.

  • Si vous voulez créer une valeur totale pour une seule plage en fonction d’une valeur figurant dans une autre plage, utilisez la fonction SOMME.SI.ENS.

Haut de la page

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×