Étape 4 : partager votre macro avec d’autres utilisateurs

Important :  Cet article a été traduit automatiquement, voir l’avertissement. Vous pouvez consulter la version en anglais de cet article ici.

Dans le cadre du partage des macros, il est important de comprendre que celles-ci sont stockées dans le fichier Office, aussi vous devez partager ce fichier avec d’autres personnes. Si vous avez créé une macro dans Word, vous devez partager le fichier en tant que modèle Word prenant en charge les macros (.dotm) ou document Word prenant en charge les macros (.docm). Si vous avez créé une macro dans Excel, vous devez partager le fichier en tant que classeur Excel prenant en charge les macros (.xlsm) ou modèle Excel prenant en charge les macros (.xltm).

Si vous avez créé une macro Word, vous devez effectuer quelques étapes supplémentaires pour partager votre macro :

Créer le modèle Word vide

  1. Ouvrez un nouveau document Word.

  2. Dans le menu Fichier, cliquez sur Enregistrer sous.

  3. Nommez votre fichier global_macros.dotm.

  4. Dans la liste déroulante Format, sélectionnez Modèle Word prenant en charge les macros (*.dotm) comme Format.

  5. Choisissez l’emplacement où vous voulez stocker le fichier sur votre réseau.

  6. Cliquez sur Enregistrer, puis fermez le modèle.

Exporter la macro Word à partir de votre document

Avec la macro que vous avez enregistrée à l’étape 1, procédez comme suit pour exporter la macro :

  1. Ouvrez le document ou le modèle contenant la macro que vous voulez exporter.

  2. Dans le menu Outils, pointez sur Macro, puis cliquez sur Macros.

  3. Sélectionnez la macro que vous voulez exporter, puis cliquez sur Modifier. Sélectionner la macro à exporter

  4. Dans Visual Basic Editor, cliquez sur Fichier > Exporter le fichier.

  5. Enregistrez la macro dans le même dossier que le modèle prenant en charge les macros, global_macros.dotm.

Importer la macro Word dans votre nouveau modèle vide

  1. Ouvrez global_macros.dotm, puis cliquez sur Outils > Macro > Visual Basic Editor.

  2. Pour importer la macro, cliquez sur Fichier > Importer le fichier,accédez au dossier dans lequel vous avez exporté votre macro, sélectionnez le fichier, puis cliquez sur Ouvrir.

  3. Enregistrez le module, fermez Visual Basic Editor, puis quittez Word.

Vous pouvez désormais partager votre macro avec d’autres personnes. Invitez-les à suivre les étapes ci-dessous pour installer la macro sur leur ordinateur.

Installer le modèle : configurer Word pour utiliser votre macro

  1. Placez le fichier global_macro.dotm à cet emplacement :

    • Word pour Mac 2011 : Macintosh HD: Utilisateurs : Nom d’utilisateur: Library: Application Support: Microsoft: Office: User Templates: My Templates

    • Word 2003 sous Windows ou version ultérieure : C:\Documents and Settings\Nom d’utilisateur\Application Data\Microsoft\Word\STARTUP

      Remarque :  Nom d’utilisateur est le nom de connexion de l’utilisateur.

  2. Dans Word, cliquez sur Word > Préférences....

Préférences de Word

  1. Dans la section Paramètres personnels, cliquez sur Emplacement des fichiers

  2. Sélectionnez Démarrage dans la liste Emplacement des fichiers, puis cliquez sur Modifier....

Emplacement du fichier

  1. Vérifiez que Word utilise le dossier dans lequel vous avez placé le fichier global_macro.dotm comme dossier de démarrage.

  2. Cliquez sur Choisir pour fermer la boîte de dialogue Choisir un dossier, puis sur OK pour fermer la boîte de dialogue Emplacement des fichiers.

La dernière étape consiste à indiquer à Word d’utiliser le fichier global_macros.dotm lors de son démarrage.

  1. Dans Word, cliquez sur Outils > Modèles et compléments....

  2. Sélectionnez le fichier global_macros.dotm dans la liste, puis cliquez sur OK.

    Conseil :  Si vous ne voyez pas votre modèle dans la liste, votre fichier global_macros.dotm ne figure pas dans le dossier de démarrage de Word. Revenez à l’étape 1 dans cette section et vérifiez que le dossier Démarrage est celui dans lequel vous avez copié le fichier global_macros.dotm.

Configurer le modèle global dans Word

 Étape 1 : prendre en main l’enregistreur de macro

Étape 2 : lire et comprendre le code

Étape 3 : découvrir les principes de base de la programmation

Étape 4 : partager votre macro avec d’autres utilisateurs

Étape 5 : exemples réels

Remarque : Avertissement traduction automatique : cet article a été traduit par un ordinateur, sans intervention humaine. Microsoft propose cette traduction automatique pour offrir aux personnes ne maîtrisant pas l’anglais l’accès au contenu relatif aux produits, services et technologies Microsoft. Comme cet article a été traduit automatiquement, il risque de contenir des erreurs de grammaire, de syntaxe ou de terminologie.

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×