Découverte de Microsoft Access 2010

Vue d’ensemble

Passer à Access 2010 à partir d’une version précédente Si vous êtes un utilisateur Access expérimenté, ce cours est pour vous. Ce cours explique comment passer à Access 2010 à partir d’une version précédente. Vous apprendrez comment effectuer des tâches habituelles dans Access 2010, telles que l’utilisation de bases de données existantes, la création de nouvelles bases, la génération de tables, ou la création et la modification de formulaires et d’états.

À la fin de ce cours, vous serez à même d'effectuer les tâches suivantes :

  • Utiliser le mode Backstage pour ouvrir des bases existantes de données et en créer de nouvelles.

  • Enregistrer une base de données en tant que fichier Access 2010.

  • Utiliser le Ruban pour lancer le mode Création pour les tables, les formulaires, les états et les requêtes.

  • Utiliser le mode Page pour modifier des formulaires ou des états.

  • Utiliser le mode Page pour grouper des données dans des états.

Ce cours comprend :

  • Un cours d’autoformation.

  • Un court test, proposé à la fin du cours. Ce test ne fait pas l’objet d’une évaluation.

  • Un aide-mémoire, que vous pouvez imprimer à la fin du cours.

Ce cours part du principe que vous possédez déjà une certaine connaissance d’Access : vous avez déjà généré des bases de données et vous comprenez les bases de la création de base de données et les relations entre les tables. Si vous ne connaissez pas Access, voir Prise en main d’Access 2010.

Version hors connexion (172.3 Mo)

Prise en main d’Access 2010

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Prise en main du volet de navigation

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Présentation du Ruban

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Utilisation de fichiers d’une version précédente d’Access

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Prise en main plus rapide des modèles et des bases de données Web

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Création immédiate avec le mode Page

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Exercices pratiques suggérés

Si vous avez déjà utilisé Access 2003 ou une version précédente (pour travailler avec de petites bases de données), ce cours a été écrit pour vous. Voici quelques suggestions d’exercices pour appliquer ce que vous avez appris dans le cours.

Important    Pour suivre ces exercices, vous devez disposer d’Access 2010 sur votre ordinateur et d’une connexion à Internet.

Créer une base de données vide.

Pour suivre ces exercices, vous pouvez utiliser l’une de vos propres bases de données.

  1. Démarrez Access 2010. L’application s’ouvre automatiquement en mode Backstage.

  2. Cliquez sur l’onglet Nouveau. Le modèle Base de données vide est déjà sélectionné.

  3. Dans la section droite de l’onglet, dans le champ Nom de fichier entrez le nom de la nouvelle base de données.

  4. Le cas échéant, cliquez sur l’icône de dossier située à droite du champ Nom de fichier.

    Cette action ouvre la boîte de dialogue Fichier Nouvelle base de données et vous pouvez l’utiliser pour sélectionner un autre emplacement pour la base de données.

  5. Cliquez sur Télécharger.

    La base de données s’ouvre et affiche une table vide en mode Feuille de données, où vous pouvez ajouter des champs.

Ajouter des champs à une table

Vous pouvez ajouter des champs à une table Access de différentes manières. Voici quelques-unes des méthodes les plus courantes.

  1. Avec la table ouverte en mode Feuille de données, vérifiez que vous êtes dans l’onglet Champs (sélectionnez-le si vous n’êtes pas dans cet onglet).

  2. Dans le groupe Ajouter et supprimer, ouvrez la liste Autres champs.

  3. Au bas de la liste, sous Démarrage rapide, cliquez sur Nom.
    Liste Autres champs

  4. Cliquez sur l’en-tête de champ vide situé à droite des nouveaux champs (sur les mots Cliquer pour ajouter), puis répétez l’étape 4 pour ajouter les champs Adresse et Téléphone à votre table.

  5. Cliquez avec le bouton droit sur l’en-tête de champ vide (sur les mots Cliquer pour ajouter) et dans la liste qui apparaît, sélectionnez Mémo.

    Cela permet de définir le type de données pour le champ et rend l’en-tête de champ accessible en écriture.

  6. Dans l’en-tête de champ, entrez Commentaires, puis cliquez hors de l’en-tête pour valider vos modifications.

Parcourez le volet de navigation

Remarque    Vous avez besoin d’une connexion Internet pour suivre la procédure. Commencez par télécharger la base de données exemple Northwind. Pour ce faire, cliquez sur l’onglet Nouveau, puis sur Exemples de modèles. Faites confiance à la base de données (dans la barre de message jaune, cliquez sur Activer le contenu) et connectez-vous à la base de données.

  1. Le volet de navigation est fermé dans ce modèle ; cliquez sur la double flèche pour l’ouvrir.

    Bouton ouvrir/fermer du volet de navigation

  2. Dans le volet, cliquez sur la barre États pour développer ce groupe.

    Notez que le groupe affiche un ensemble de raccourcis vers les objets de la base de données. C’est ainsi que vous savez qu’il s’agit d’une catégorie ou d’un groupe personnalisé.

  3. Cliquez sur la barre située en haut du volet (où s’affiche le nom « Northwind Traders »), et cliquez sur Type d’objet. Désormais, vous regardez une liste d’objets dans la base de données.

  4. Cliquez sur Formulaires, cliquez avec le bouton droit sur le formulaire Liste des clients, puis sur Mode Page.

  5. Cliquez sur le groupe Tables pour le développer, puis double-cliquez sur la table Clients.

  6. Cliquez avec le bouton droit en haut du volet de navigation, puis cliquez sur Volet de recherche.

    Pour rendre la barre visible, répétez cette étape.

  7. Une fois la barre de recherche visible, développez tous les groupes, et dans le champ de recherche, tapez progressivement « client ». Notez comment Access filtre la liste d’objets pendant que vous tapez.

Parcourir le Ruban

Répétez ces étapes avec une base de données telle que Northwind.

  • Ouvrez une table en mode Feuille de données et notez quels onglets contextuels apparaissent, puis explorez ces onglets pour connaître les commandes fournies.

  • Ouvrez une requête en mode Création et notez quels onglets contextuels apparaissent. Explorez ces onglets pour connaître les commandes fournies.

  • Ouvrez un formulaire en mode Page et notez quels onglets contextuels apparaissent. Explorez également ces onglets.

Étapes supplémentaires

  1. Avec une base de données ouverte et l’onglet Accueil affiché, appuyez sur la touche ALT.

    Un ensemble de touches d’accès apparaît.

    Touches d’accès

    Access fournit une touche d’accès pour chaque onglet du Ruban, ainsi qu’une touche d’accès pour les commandes de chaque onglet.

  2. Appuyez de nouveau sur la touche ALT, et notez que les touches d’accès disparaissent.

  3. Appuyez sur ALT+C pour accéder à l’onglet Créer.

    Puisque vous accédez à l’onglet Créer à partir de l’onglet Accueil, Access affiche un ensemble de touches d’accès pour chaque commande de l’onglet Créer.

  4. Appuyez de nouveau sur la touche ALT et notez que les touches d’accès disparaissent.

  5. Appuyez à présent sur ALT+C et notez que les touches d’accès réapparaissent.

    Si vous avez accidentellement fermé les touches d’accès d’un onglet, vous pouvez appuyer sur ALT et la lettre correspondant à cet onglet pour afficher de nouveau les touches d’accès.

  6. Appuyez sur QD pour lancer le concepteur de requête.

  7. Avec le concepteur de requêtes ouvert, appuyez sur ALT+H pour accéder à l’onglet Accueil.

    Notez que les touches d’accès pour les commandes désactivées (grisées) sont également désactivées.

Publier une base de données Web

Commencez par télécharger l’un des modèles de base de données Web, tels que le modèle de base de données de biens Web. Pour ce faire, cliquez sur l’onglet Nouveau, puis sur Exemples de modèles. Faites confiance à la base de données (dans la barre de message jaune, cliquez sur Activer le contenu) et connectez-vous à la base de données..

  1. En mode Backstage, cliquez sur l’ongletEnregistrer et publier.

  2. Cliquez sur Publier sur Access Services.

  3. Cliquez sur Activer le vérificateur de compatibilité.

  4. Cliquez sur Oui pour fermer les objets ouverts et exécuter le vérificateur de compatibilité.

    Si le vérificateur de compatibilité détecte des problèmes ou s’il affiche uniquement des avertissements, la base de données peut être publiée.

  5. Entrez l’URL de votre serveur et un nom pour le site. Obtenez l’URL auprès de votre administrateur système.

  6. Cliquez sur Publier sur Access Services.

    Vous devrez attendre la fin du processus de publication et que le serveur ait terminé de traiter votre nouveau site.

  7. Lancez votre navigateur, accédez au site, ouvrez le formulaire Biens actuels et entrez des données.

Modifier une base de données Web et enregistrer ces modifications sur le Web

  1. Ouvrez la base de données Web de biens dans Access.

  2. Ouvrez le formulaire principal en mode Page.

  3. Cliquez avec le bouton droit de la souris sur l’onglet Prise en main dans le formulaire, cliquez sur Supprimer, puis appuyez sur CTRL+S pour enregistrer les modifications.

  4. Cliquez sur l’onglet Fichier pour revenir en mode Backstage.

  5. Sous l’onglet Informations, cliquez sur Synchroniser tout pour enregistrer vos modifications sur le Web.

    Bouton Synchroniser tout

Contrôle des connaissances

Effectuez le test suivant pour vérifier que vous avez bien compris le cours. Vos réponses sont privées et les résultats du test ne sont pas notés.

Vous pouvez utiliser le mode Création pour modifier les formulaires et les états dans une base de données Web.

Vrai.

Faux. Vous ne pouvez utiliser le mode Création que pour les formulaires ou les états que vous ne publierez pas sur Access Services. Pour une base de données Web, utilisez le mode Page pour modifier les formulaires et les états.

Faux.

Bien vu. Vous pouvez utiliser le mode Page pour modifier les formulaires et les états, mais pas le mode Création.

Vous ouvrez une base de données Access 97 dans Access 2010. Vous entrez des données et modifiez la conception.

Vrai.

Réessayez. Vous pouvez uniquement lire les données lorsque vous ouvrez une base de données Access 97 dans Access 2010.

Faux.

Correct. Vous pouvez uniquement lire les données. Pour effectuer d’autres opérations, enregistrez le fichier au format de fichier Access 2010.

Vous pouvez publier une base de données Web sur n’importe quel site Web.

Vrai.

Faux. La publication des bases de données Web n’est possible que sur un serveur SharePoint exécutant Access Services.

Faux.

Correct. Votre serveur SharePoint 2010 doit exécuter Access Services.

Dans le volet de navigation, vous ouvrez un formulaire pour entrer des données en :

cliquant avec le bouton droit sur le formulaire, puis en cliquant sur le mode Création.

Faux. Si vous procédez de cette façon, vous ouvrez le formulaire pour modifier sa conception, et non pour l’utiliser.

en double-cliquant sur le formulaire.

Vous avez raison. Vous pouvez aussi cliquer sur un objet, puis cliquez sur Ouvrir.

Vous n’utilisez pas le volet de navigation. Vous utilisez la commande Ouvrir sous l’onglet Accueil du Ruban.

Réessayez. Vous pouvez utiliser le volet de navigation pour ouvrir des objets et les utiliser.

Lorsque vous enregistrez un fichier MDB au nouveau format de fichier (en tant que fichier ACCDB), vous pouvez ouvrir le nouveau fichier dans Access 2003.

Vrai.

Réessayez. Vous ne pouvez pas ouvrir les fichiers ACCDB dans Access 2003.

Faux.

Bien vu. Vous ne pouvez utiliser les fichiers ACCDB que dans Access 2007 ou 2010. N’oubliez pas non plus que les fonctionnalités spécifiques à Access 2010 ne fonctionnent pas dans Access 2007.

Commentaires

Aide-mémoire

Formation supplémentaire

Première d’une série pour les débutants.

Concevoir les tables d’une nouvelle base de données

Voir aussi

Personnaliser le Ruban

Classeur de correspondances du Ruban Access

Afficher ou masquer le volet de navigation

Boîte de dialogue Options de navigation

Conversion d’une base de données Access 2010 dans un format de fichier antérieur

Quel mode utiliser : Page ou Création ?

Utilisation du mode Backstage

  • Access 2010 s’ouvre en mode Backstage. Pour accéder au mode Backstage et le quitter, cliquez sur l’onglet Fichier.

  • Vous pouvez ouvrir une base de données en cliquant sur son nom sous Fichier ou en cliquant sur l’onglet Récent.

  • Sous l’onglet Nouveau, vous pouvez créer une nouvelle base de données, y compris des bases de données vides et des modèles :

  • Sous l’onglet Enregistrer et envoyer, vous pouvez enregistrer une base de données dans un autre format de fichier, créer un package et le signer, compiler une base de données en un fichier exécutable, ou la publier sur un serveur SharePoint 2010 exécutant Access Services.

  • Cliquez sur Options pour ouvrir la boîte de dialogue Options Access et définir des options pour vos bases de données et pour Access.

Créer une base de données vide.

  1. Double-cliquez sur le modèle souhaité.

  2. Acceptez le nom par défaut ou entrez un nouveau nom.

  3. Cliquez sur Créer.

Utiliser le volet de navigation

  • Double-cliquez sur un objet pour l’ouvrir et l’utiliser.

  • Cliquez avec le bouton droit sur un objet pour modifier sa conception, l’exporter, le renommer ou ouvrir la feuille de propriétés pour l’objet sélectionné.

Modifier la façon dont les objets sont catégorisés dans le volet

  1. Cliquez sur la barre en haut du volet. Une liste de catégories et de groupes s’ouvre.

  2. Sélectionnez une catégorie dans la moitié supérieure de la liste ou un groupe dans la moitié inférieure.

Définir les options du volet

  • Cliquez avec le bouton droit sur la barre en haut du volet, puis cliquez sur Options de navigation.

Rechercher des objets

  1. Si la barre de recherche n’est pas visible, cliquez avec le bouton droit sur la barre en haut du volet du navigation, puis cliquez sur la Barre de recherche.

  2. Entrez le début ou la totalité du nom d’un objet dans le champ Rechercher. Le volet filtre la liste d’objets pendant que vous tapez.

Pour éviter que les objets de la base de données ne se masquent mutuellement

  1. En mode Backstage, cliquez sur Options.

  2. Cliquez sur Base de données active.

  3. Sélectionnez Documents à onglets et Afficher les onglets des documents.

  4. Fermez, puis réouvrez la base de données pour afficher les modifications.

Utiliser le Ruban

  • Le Ruban n’est pas statique : il change selon l’objet sélectionné ou la tâche effectuée.

  • Le Ruban place les commandes dans un ensemble d’onglets et divise ces onglets en groupes.

  • L’onglet Accueil propose les commandes que vous utilisez le plus.

  • Par ailleurs, la barre d’outils Accès rapide, située en haut à gauche dans la fenêtre Windows, contient les commandes les plus fréquemment utilisées. La barre d’outils Accès rapide ne change pas quel que soit l’onglet du Ruban que vous utilisez.

  • Vous pouvez personnaliser la barre d’outils Accès rapide et le Ruban.

Utiliser les touches d’accès

  • Appuyez sur la touche ALT pour afficher les touches d’accès pour chaque onglet du Ruban. Appuyez sur ALT et la lettre correspondant à un onglet pour accéder à cet onglet.

  • Lorsque vous utilisez les touches d’accès pour accéder à un onglet, vous voyez également les touches d’accès de chaque commande de cet onglet. Pour utiliser une commande, il suffit d’appuyer sur son numéro, sa ou ses lettre(s). Si les touches d’accès des commandes d’un onglet disparaissent, appuyez sur ALT et la lettre correspondant à cet onglet.

Personnaliser la barre d’outils Accès rapide

  1. Cliquez sur la flèche à droite en regard de la barre d’outils pour ouvrir un menu de commandes.

  2. Cliquez sur la commande que vous souhaitez ajouter à la barre d’outils.

  3. Si la commande souhaitée n’est pas disponible, cliquez sur Autres commandes. La boîte de dialogue Options Access s’ouvre alors.

  4. Ajoutez des commandes du volet de gauche vers le volet de droite.

Personnaliser le Ruban

Lorsque vous personnalisez le Ruban, vos modifications s’appliquent à Access, pas à une base de données en particulier.

Important    Lorsque vous placez une commande dans un groupe ou un onglet du Ruban personnalisé, cela affecte le lien entre la commande et sa rubrique d’aide F1.

  1. Cliquez sur l’onglet Fichier pour activer le mode Backstage, puis cliquez sur Options.

  2. Cliquez sur Personnaliser le Ruban.

  3. Sous le volet de gauche, cliquez sur Nouvel onglet, Nouveau groupe ou Renommer, selon vos besoins.

  4. Dans le volet de gauche, entrez un nom pour l’onglet ou le groupe.

  5. Si vous créez un groupe ou un onglet, sélectionnez la commande souhaitée dans le volet de gauche et double-cliquez dessus ou cliquez sur Ajouter pour déplacer la commande vers le volet de droite.

Règles relatives à l’utilisation des fichiers provenant de versions précédentes d’Access

  • Les bases de données créées dans Access 2000, Access 2002 et Access 2003 s’exécutent dans Access 2010, mais certaines fonctionnalités ne fonctionnent pas, notamment la fonctionnalité de réplication et la fenêtre de base de données.

  • Les fichiers Access 97 s’ouvrent dans Access 2010, mais vous pouvez uniquement afficher des objets et ajouter des enregistrements. Vous ne pouvez pas enregistrer les modifications de conception, à moins de convertir la base de données au format de fichier Access 2010.

  • Une fois que vous avez enregistré une ancienne base de données en tant que fichier ACCDB, vous ne pouvez l’utiliser que dans Access 2007 ou 2010.

  • Si vous ouvrez une base de données Access 2010 dans Access 2007, les fonctionnalités spécifiques à Access 2010 ne fonctionnent pas.

Utiliser des modèles et des bases de données Web

Access fournit deux classes de modèles : locaux et en ligne. Les modèles locaux sont installés sur votre ordinateur lorsque vous installez Access. Les modèles en ligne sont disponibles si vous disposez d’une connexion Internet.

Pour utiliser des modèles en ligne

  1. En mode Backstage, sous l’onglet Nouveau, cliquez sur Modèles exemples ou doublez-cliquez sur l’une des catégories de modèle sous Modèles Office.com.

  2. Donnez un nom à cette base de données, choisissez un emplacement si besoin, puis cliquez sur Créer pour télécharger et ouvrir le modèle.

  3. Activer le contenu bloqué et commencez à entrer des données, ou modifier le modèle selon vos besoins.

Publier une base de données Web

  1. En mode Backstage, cliquez sur l’onglet Enregistrer et publier s’il n’est pas déjà sélectionné, puis cliquez sur Publier sur Access Services.

  2. Cliquez sur Activer le vérificateur de compatibilité.

  3. Cliquez sur Oui pour fermer les objets ouverts et exécuter le vérificateur de compatibilité.

  4. Si aucun problème n’est détecté, la base de données peut être publiée.

  5. Entrez l’URL de votre serveur et un nom pour le site.

  6. Cliquez sur Publier sur Access Services.
    Une fois le processus de traduction terminé, les tables de votre base de données deviennent des listes SharePoint et les formulaires se comportent de la même façon que dans Access.

Utiliser le mode Page

Le mode Page est un concepteur visuel pour les formulaires et les états dans Access 2010. C’est également le seul concepteur pour les formulaires et les états dans une base de données Web.

Pour utiliser la page Web

  • Dans le volet de navigation, cliquez avec le bouton droit sur un formulaire ou un état, cliquez sur Mode Page.
    Vous pouvez également
    cliquer avec le bouton droit sur l’onglet de document de n’importe quel formulaire ou état ouvert, puis cliquez sur Mode Page.

Modifications rapides possibles en mode Page

  • Sélectionnez un seul contrôle ou une seule étiquette, puis faites-le(la) glisser pour redimensionner tous les contrôles ou toutes les étiquettes de la colonne.

  • Sélectionnez une étiquette, cliquez sur l’onglet Format, et utilisez les commandes pour changer de police, de couleur de police ou l’alignement du texte.

  • Appuyez sur CTRL, sélectionnez plusieurs étiquettes et mettez-les en forme.

  • Pour effectuer des modifications globales dans une page, cliquez sur le sélecteur de la page, la croix dans le coin supérieur gauche de la page. Par exemple, sélectionnez toute la page. Sous l’onglet Création, cliquez sur Feuille de propriétés pour ouvrir les propriétés du formulaire et définir une hauteur différente pour les contrôles.

Pour déplacer ou placer les contrôles en ajoutant des colonnes vides et des lignes à une page

  1. Sous l’onglet Création, cliquez sur Ajouter des champs existants.

  2. Faites glisser les champs que vous voulez utiliser vers la page.

  3. Selon vos besoins, faites glisser des contrôles séparément depuis leurs étiquettes et déposez-les à l’emplacement souhaité. Une barre indique la destination.

Pour grouper et trier les données de vos états

  1. Sous l’onglet Création, cliquez sur Grouper et trier.

  2. Dans le volet Regrouper, trier et total, cliquez sur Ajouter un groupe, puis cliquez sur le champ pour lequel vous souhaitez regrouper les données. Vos modifications apparaissent immédiatement.
    Vous pouvez ajouter jusqu’à sept niveaux de regroupement.

S’applique à : Access 2010



Ces informations vous ont-elles été utiles ?

Oui Non

Comment pouvons-nous nous améliorer ?

255 caractères restants

Afin de protéger votre vie privée, n’indiquez aucune information de contact dans vos commentaires. Lisez notre déclaration de confidentialité.

Nous vous remercions pour vos commentaires.

Ressources de support

Changer la langue