Tietokantamallin luominen (tunnetaan myös nimellä Käsiterelaatio-kaavio)

Tietokantamallin luominen (tunnetaan myös nimellä Käsiterelaatio-kaavio)

Tietokantamallikaavio-mallin avulla voit luoda uuden mallin tai selvittää olemassa olevan tietokannan lähdekoodin malliksi käyttämällä joko relaatiomallinnusta tai objektirelaatiomallinnusta. Käytä Käsiterelaatio-kaavainta SQL92-standardiin ja aiempiin standardeihin perustuvien tietokantojen mallintamiseen. Käytä Objektirelaatio-kaavainta SQL99-standardiin ja uudempiin standardeihin perustuvien tietokantojen mallintamiseen, sillä se sisältää lisämuotoja työskentelyyn näiden tyyppien kanssa.

Esimerkki tietokantamallista

Tietokantamallikaavio-mallin avulla voit luoda uuden mallin tai selvittää olemassa olevan tietokannan lähdekoodin malliksi käyttämällä joko relaatiomallinnusta tai objektirelaatiomallinnusta. Käytä Käsiterelaatio-kaavainta SQL92-standardiin ja aiempiin standardeihin perustuvien tietokantojen mallintamiseen. Käytä Objektirelaatio-kaavainta SQL99-standardiin ja uudempiin standardeihin perustuvien tietokantojen mallintamiseen, sillä se sisältää lisämuotoja työskentelyyn näiden tyyppien kanssa.

Tässä artikkelissa kuvataan, miten voit luoda tietokantamallin ja mitä voit tehdä mallilla sen luomisen jälkeen.

Etkö löydä tietokannan mallinnusominaisuuksia?

Kaikissa Microsoft Visio -versioissa ei ole tietokantamallitoimintoa. Jos et löydä tämän artikkelin ohjeissa kuvattuja toimintoja, sinulla on todennäköisesti Visio-versio, joka ei sisällä niitä.

  • Microsoft Visio Standard ei sisällä Tietokantamallikaavio-mallia.

  • Microsoft Visio Professional- ja Microsoft Visio Premium -versiot tukevat Tietokantamallikaavio-mallin lähdekoodin selvittämisominaisuuksia (eli mallin luomista Visiossa aiemmin luodun tietokannan pohjalta), mutta ei tue koodin uustuotantoa (eli SQL-koodin luomista Visio-tietokantamallin pohjalta).

  1. Jos haluat luoda tietokantamallikaavion, toimi toisella seuraavista tavoista:

    Uuden mallikaavion luominen alusta alkaen

    Jos sinulla ei ole aiemmin luotua tietokantaa, jota voisit käyttää lähtökohtana, voit aloittaa tyhjästä tietokantamallista ja lisätä siihen haluamasi taulukot ja yhteydet.

    1. Napsauta Tiedosto-välilehteä.

    2. Valitse Uusi, valitse Ohjelmisto ja tietokanta ja kaksoisnapsauta sitten kohtaa Tietokantamallikaavio.

    3. Valitse Tietokanta-välilehden Hallinta-ryhmässä Näytä asetukset.

    4. Valitse Tietokantatiedoston asetukset -valintaikkunassa käytettävä merkistö sekä muut taulukko- ja yhteysvaihtoehdot, ja valitse sitten OK.

    Aiemmin luodun tietokannan käyttäminen lähtökohtana

    Jos sinulla on tietokanta, jonka haluat mallintaa siten, että voisit ymmärtää sitä paremmin tai käyttää sitä lähtökohtana uudelle mallille, voit käyttää ohjattua lähdemääritystä tietokannan rakenteen poimimiseen ja uuden mallin luomiseen.

    Ennen ohjatun toiminnon aloittamista:

    1. Jos haluat selvittää Microsoft Excel -työkirjan lähdekoodin, avaa työkirja ja nimeä sarakeotsikot sisältävä soluryhmä (tai -alue) ennen ohjatun toiminnon käynnistämistä. Jos haluat käyttää useampaa kuin yhtä laskentataulukkoa, nimeä kunkin laskentataulukon sarakesoluryhmä. Ohjattu toiminto käsittelee näitä alueita taulukkoina. Lisätietoja solualueen nimeämisestä on Excelin ohjeaiheessa, jossa käsitellään nimettyjen soluviittausten tai -alueiden määrittämistä.

    2. Saavutat parhaan lopputuloksen määrittämällä oletusohjaimen lähdekoodin selvittämisen kohteena olevaan tietokantaan ennen ohjatun lähdemääritysten selvittämisen käynnistämistä. Näin varmistat, että ohjattu toiminto yhdistää alkuperäiset tietotyypit oikein ja että kaikki ohjatun toiminnon poimima koodi näkyy Koodi-ikkunassa oikein.

    3. Napsauta Tiedosto-välilehteä.

    4. Valitse Uusi, valitse Ohjelmisto ja tietokanta ja kaksoisnapsauta sitten kohtaa Tietokantamallikaavio.

    5. Napsauta Tietokanta-välilehden Malli-ryhmässä Muuta lähdekoodiksi -painiketta.

    6. Toimi ohjatun lähdemääritysten selvittämisen ensimmäisessä näytössä seuraavasti:

      1. Valitse käytettävää tietokannan hallintajärjestelmää (DBMS) vastaava tietokantaohjain. Jos et ole vielä määrittänyt Vision tietokantaohjainta mihinkään tiettyyn ODBC-tietolähteeseen, napsauta Asetukset.

        Huomautus: Jos selvität Excel-laskentataulukon lähdekoodin, valitse Yleinen ODBC-ohjain.

      2. Valitse päivitettävän tietokannan tietolähde. Jos et ole vielä luonut tietolähdettä olemassa olevalle tietokannalle, luo se nyt valitsemalla Uusi.

        Kun luot uuden lähteen, tämän lähteen nimi lisätään Tietolähteet-luetteloon.

      3. Kun olet tehnyt haluamasi muutokset asetuksiin, valitse Seuraava.

    7. Noudata ohjaimeen liittyvissä valintaikkunoissa näkyviä ohjeita.

      Kirjoita esimerkiksi Yhdistä tietolähde -valintaikkunaan käyttäjän nimi ja salasana ja valitse sitten OK.

      Huomautus: Jos käytät yleistä ODBC-ohjainta, näyttöön saattaa tulla virheviesti, jossa ilmoitetaan, että selvitetyt tiedot ovat ehkä puutteellisia. Useimmissa tapauksissa tämä ei ole ongelma, vaan voit jatkaa ohjatun toiminnon suorittamista valittuasi OK.

    8. Valitse valintaruudut poimittavien tietojen mukaan ja valitse sitten Seuraava.

      Huomautus: Jotkin kohteet eivät ehkä ole käytettävissä (näkyvät harmaina), koska kaikki tietokantojen hallintajärjestelmät eivät tue kaikkia osia, joita ohjattu toiminto voi poimia.

    9. Valitse niitä taulukoita (ja mahdollisia näkymiä) vastaavat valintaruudut, joiden lähdemääritykset haluat poimia, tai napsauta Valitse kaikki -painiketta, jos haluat poimia kaikki lähdemääritykset. Valitse sitten Seuraava.

      Huomautus: Jos selvität Excel-laskentataulukon lähdekoodin eikä tässä luettelossa näy mitään, sinun on todennäköisesti nimettävä solualue, joka sisältää laskentataulukon sarakeotsikot.

    10. Jos valitsit Tallennetut toimintosarjat -valintaruudun, valitse nyt poimittavat toimintosarjat tai napsauta Valitse kaikki, jos haluat poimia ne kaikki. Valitse sitten Seuraava.

    11. Valitse, haluatko lisätä lähdekoodiltaan selvitetyt kohteet automaattisesti nykyiselle sivulle.

      Huomautus: Voit valita, että ohjattu toiminto luo piirustuksen automaattisesti sen lisäksi, että se luettelee selvitetyt määritykset Taulukot ja näkymät -ikkunassa. Jos et halua luoda piirustusta automaattisesti, voit koota tietokantamallin manuaalisesti vetämällä kohteet Taulukot ja näkymät -ikkunasta piirustussivulle.

    12. Tarkista tekemäsi valinnat ja varmista, että poimittavat tiedot ovat oikein, ja valitse sitten Valmis.

      Ohjattu toiminto poimii valitut tiedot ja näyttää poimintaan liittyvät huomautukset Kohde-ikkunassa.

    Aiemmin luodun mallin tuominen ja tarkentaminen

    Jos sinulla on aiemmin luotu VisioModeler- tai PLATINUM ERwin -malli, voit ehkä tuoda sen Visio-tietokantamallikaavion luomista varten. Tämä ominaisuus on rajoitettu vain VisioModeler 2.0 -version ja uudempien versioiden sanastomallitiedostoihin (.imd) ja PLATINUM ERwin 2.6-, 3.0- ja 3.52 -versioiden .erx-tiedostoihin.

    1. Napsauta Tiedosto-välilehteä.

    2. Valitse Uusi, valitse Ohjelmisto ja tietokanta ja kaksoisnapsauta sitten kohtaa Tietokantamallikaavio.

    3. Napsauta Tietokanta-välilehden Malli-ryhmässä Tuo ja napsauta sitten mallin tyyppiä.

    4. Kirjoita tuotavan mallin polku ja tiedostonimi tai napsauta Selaa-painiketta, etsi mallitiedosto ja napsauta sitten Avaa.

    5. Valitse Tuo-valintaikkunassa OK.

      Visio tuo tiedoston ja näyttää tuonnin edistymisen Tuloste-ikkunassa. Tuodut taulukot tulevat näkyviin Taulukot ja näkymät -ikkunaan.

    6. Valitse Taulukot ja näkymät -ikkunassa taulukot, jotka haluat mallintaa, ja vedä ne piirustussivulle.

  2. Kun olet luonut tietokantamallikaavion, aloitat kaavion tarkentamisen. Voit lisätä ja mukauttaa taulukkoja ja näkymiä, luoda yhteyksiä ja mukauttaa sarakkeita ja tietotyyppejä.

    Taulukot

    Voit luoda kaavioon taulukon käyttämällä Kohde-muotoa.

    1. Vedä joko Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustukseen Kohde-muoto.

    2. Kaksoisnapsauta muotoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    3. Valitse Luokat-kohdassa Määritys ja kirjoita taulukon nimi.

    4. Valitse Luokat-kohdassa Sarakkeet, kirjoita nimi ja valitse tietotyyppi.

    5. Valitse Pakollinen-valintaruutu niiden sarakkeiden kohdalla, joissa ei voi olla tyhjäarvoja.

    6. Valitse PK (perusavain) -valintaruutu niiden sarakkeiden kohdalla, jotka yksilöivät tietokantataulukon kunkin rivin.

    7. Valitse Luokat-kohdassa Indeksit, Käynnistimet, Tarkistus tai Laajennettu vastaavien valinnaisten elementtien luomiseksi.

    Sarakkeet

    Voit käyttää Tietokannan ominaisuudet -ikkunaa sarakkeiden ominaisuuksien, kuten tietotyyppien ja perusavaimien, lisäämiseen tai muuttamiseen.

    1. Kaksoisnapsauta taulukkoa kaaviossa.

    2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Sarakkeet.

    3. Napsauta ensimmäistä tyhjää Fyysinen nimi -solua ja kirjoita nimi.

    4. Voit muuttaa sarakkeen tietotyyppiä valitsemalla sarakkeen Tietotyyppi-kentän ja valitsemalla tietotyypin luettelosta tai kirjoittamalla sen luetteloon. Voit esimerkiksi kirjoittaa decimal(8,2) tai char(30).

    5. Jos haluat estää tyhjäarvot, valitse Pakollinen -valintaruutu.

    6. Voit määritä sarakkeen perusavaimeksi valitsemalla PK-valintaruudun.

    7. Jos haluat saada näkyviin enemmän sarakeominaisuuksia niiden lisäksi, jotka tulevat näkyviin valitessasi Sarakkeet-luokan, valitse sarake ja napsauta sitten Muokkaa.

    Yhteydet

    Yhteydet hyödyntävät perus- ja viiteavaimia sen sallimiseen, että tietokannat voivat sovittaa yksittäisen taulukon rivin siihen yhdistetyn taulukon riviin. Voit näyttää nämä yhteydet kaaviossa. Lisäksi voit määrittää niiden kardinaliteetin (esimerkiksi yksi-moneen) ja käyttää kukonaskel-, relaatio- tai IDEF1X-merkintää kardinaliteetin osoittamiseen. Et voi esittää monta-moneen-yhteyksiä millään näistä merkinnöistä Tietokantamallikaavio-mallissa.

    1. Yhteyden muodostaminen taulukoiden välillä:

      1. Varmista, että molemmat taulukot näkyvät kaaviossa. Jos olet luonut mallin selvittämällä aiemmin luodun tietokannan lähdekoodin, sinun täytyy ehkä vetää toinen tai molemmat taulukoista Taulukot ja näkymät -ikkunasta piirustussivulle.

      2. Kaksoisnapsauta taulukkoa, jonka haluat määrittää yhteyden perusavainpuolelle.

      3. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Sarakkeet.

      4. Napsauta ruudukon saraketta, jota haluat käyttää taulukon kunkin rivin yksilölliseen tunnistamiseen, ja määritä se perusavaimeksi valitsemalla PK-valintaruutu.

      5. Valitse Objektirelaatio- tai Käsiterelaatio-kaavain, vedä Yhteys-muotoa ja pudota se tyhjään kohtaan sivulla.

      6. Yhdistä yläpää ylätason taulukkoon.

      7. Yhdistä toinen pää alitaulukkoon.

        Jos toisessa taulukossa ei vielä ole saraketta, jolla on sama nimi kuin perusavaimella, mallintaja lisää sen toiseen taulukkoon viiteavaimena.

        Huomautus: Jos yhteysviivat katoavat, valitse Tietokanta-välilehden Hallinta-ryhmässä Näytä asetukset. Valitse Yhteydet -välilehden Näytä-kohdassa Yhteydet-valintaruutu.

    2. Yhteyden kardinaliteetin määrittäminen:

      1. Kaksoisnapsauta yhteysviivaa.

      2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Muut.

      3. Valitse Kardinaliteetti-kohdassa yhteyteen parhaiten soveltuva kardinaliteetti. Yksi-moneen-yhteyksissä paras valinta on Nolla tai enemmän tai Yksi tai enemmän. Yksi-yhteen-yhteyksissä paras valinta on Nolla tai yksi tai Täsmälleen yksi.

  3. Jos haluat tehdä kaavioon muita viimeistelyjä (kuten luoda indeksejä, tarkistusmääreitä ja käynnistimiä), voit toimia seuraavasti:

    Indeksien luominen

    Indeksit parantavat tietokannan suorituskykyä eli nopeutta kyselyissä.

    1. Avaa tietokantamallikaavio.

    2. Kaksoisnapsauta taulukkoa, johon haluat lisätä indeksin, ja valitse Tietokannan ominaisuudet -ikkunan Luokat‑luettelosta Indeksit.

    3. Valitse Uusi.

    4. Kirjoita indeksin nimi Luo indeksi -valintaikkunaan ja valitse sitten OK.

    5. Valitse Indeksityyppi-luettelosta joko yksilöivän tai ei-yksilöivän indeksin luomisen vaihtoehto.

    6. Valitse Käytettävissä olevat sarakkeet -luettelosta jokaisen tähän indeksiin sisällytettävän sarakkeen nimi ja valitse sitten Lisää >.

    7. Valitse Indeksoidut sarakkeet -luettelossa Asc-valintaruutu, jos haluat luoda indeksin, jonka lajittelujärjestys on nouseva, tai poista valintaruudun valinta, jos haluat luoda indeksin, jonka lajittelujärjestys on laskeva.

      Tietokantamallikaavio päivittyy.

    Näkymien luominen

    Voit ajatella näkymää tallennettuna kyselynä. Näkymät ovat erityisen käytännöllisiä, jos sinun on käytettävä toistuvasti samoja tietoja useista taulukoista tai jos haluat näyttää tiedot käyttäjille ilman, että he voivat muuttaa varsinaisia taulukoita.

    Vedä joko Käsiterelaatio- tai Objektirelaatio-kaavaimesta Kohde-muoto piirustussivulle.

    Laajennettujen ominaisuuksien määrittäminen taulukoille ja näkymille

    Käytössä olevan tietokannan hallintajärjestelmän (DBMS) mukaan voit ehkä määrittää taulukoille tai näkymille laajennettuja ominaisuuksia niiden tallennuspaikan määrittämiseksi.

    Kaksoisnapsauta taulukkoa tai näkymää, jonka laajennetut ominaisuudet haluat määrittää, ja valitse Tietokannan ominaisuudet -ikkunan Luokat‑luettelosta Laajennettu.

    Tarkistusmääreiden luominen

    Tarkistusmääreiden avulla voit varmistaa, että tiettyyn sarakkeeseen lisätyt tiedot ovat tietyn arvoalueen puitteissa. Voit esimerkiksi luoda tarkistusmääreen, joka edellyttää, että Ikä-sarakkeen tietona on suurempi arvo kuin 65.

    1. Kaksoisnapsauta taulukkoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    2. Valitse Luokat-kohdassa Sarakkeet ja napsauta sitten saraketta, johon haluat lisätä tarkistusmääreen.

    3. Valitse Muokkaa.

    4. Lisää haluamasi rajoitteet Tarkistus-välilehdelle Sarakkeen ominaisuudet -valintaikkunassa.

      Tarkistusmääre lisätään Koodi-ikkunan Paikallinen koodi -kohtaan.

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden luominen

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden avulla voit luoda koodipaketteja, joita voit käyttää samojen toimintojen toistuvaan suorittamiseen. Suurin ero näiden kahden ominaisuuden välillä on, että käyttäjän määrittämä funktio palauttaa arvon, kun taas tallennettu toimintosarja suorittaa koodin arvoa palauttamatta.

    1. Valitse Tietokanta-välilehden Näytä/piilota-ryhmässä Koodi-valintaruutu, jotta Koodi-ikkuna avautuu.

    2. Valitse Yleinen koodi ja valitse sitten Uusi.

    3. Valitse KoodieditorinOminaisuudet-välilehdellä luotavan koodin tyyppi ja kirjoita koodin nimi.

    4. Valitse Runko-välilehdeltä koodi ja napsauta sitten OK.

    Käynnistimien luominen

    Käynnistimet suorittavat määrittämäsi SQL-koodin, kun tietokannassa tapahtuu tietty tapahtuma.

    1. Kaksoisnapsauta taulukkoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    2. Valitse Luokat-kohdasta Käynnistimet ja valitse sitten Lisää.

    3. Kirjoita käynnistimen nimi Ominaisuudet-välilehdelle.

    4. Valitse Runko-välilehdeltä koodi ja napsauta sitten OK.

      Käynnistin lisätään Koodi-ikkunan Paikallinen koodi -kohtaan.

Tässä artikkelissa kuvataan, miten voit luoda tietokantamallin ja mitä voit tehdä mallilla sen luomisen jälkeen. Voit aloittaa nopeasti valitsemalla Tiedosto-valikossa Uusi, valitsemalla Ohjelmistot ja tietokannat ja valitsemalla sitten Tietokantamallikaavio.

Etkö löydä tietokannan mallinnusominaisuuksia?

Todennäköisin syy on se, että käyttämäsi Microsoft Office Vision versio ei sisällä etsimiäsi ominaisuuksia. Voit selvittää oman Visio-ohjelmasi versiotiedot valitsemalla Ohje-valikosta Tietoja Microsoft Office Visiosta. Version nimi näkyy valintaikkunan ensimmäisellä rivillä.

  • Microsoft Office Visio Standard ei sisällä Tietokantamallikaavio-mallia.

  • Microsoft Office Visio Professional tukee Tietokantamallikaavio-mallin lähdekoodin selvittämisominaisuuksia (eli mallin luomista Visiossa aiemmin luodun tietokannan pohjalta), mutta ei tue koodin uustuotantoa (eli SQL-koodin luomista Visio-tietokantamallin pohjalta).

  • Täydet tietokantamallinnusominaisuudet, lähdekoodin selvittämisominaisuudet ja koodin uustuotanto-ominaisuudet mukaan lukien, sisältyvät Visio for Enterprise Architects -versioon. Visio for Enterprise Architects sisältyy MSDN Premium Subscription -tilaukseen, joka puolestaan on saatavilla Visual Studio Professionalin ja Visual Studio Team Systemin roolipohjaisissa versioissa.

  1. Jos haluat luoda tietokantamallikaavion, toimi toisella seuraavista tavoista:

    Uuden mallikaavion luominen alusta alkaen

    Jos sinulla ei ole aiemmin luotua tietokantaa, jota voisit käyttää lähtökohtana, voit aloittaa tyhjästä tietokantamallista ja lisätä siihen haluamasi taulukot ja yhteydet.

    1. Valitse Tiedosto-valikossa Uusi, valitse Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    2. Valitse Tietokanta-valikossa Asetukset ja valitse sitten Asiakirja.

    3. Valitse Tietokantatiedoston asetukset -valintaikkunassa käytettävä merkistö sekä muut taulukko- ja yhteysvaihtoehdot, ja valitse sitten OK.

    Aiemmin luodun tietokannan käyttäminen lähtökohtana

    Jos sinulla on tietokanta, jonka haluat mallintaa siten, että voisit ymmärtää sitä paremmin tai käyttää sitä lähtökohtana uudelle mallille, voit käyttää ohjattua lähdemääritystä tietokannan rakenteen poimimiseen ja uuden mallin luomiseen.

    Huomautus: Ennen ohjatun toiminnon aloittamista:

    1. Jos haluat selvittää Microsoft Office Excel -työkirjan lähdekoodin, avaa työkirja ja nimeä sarakeotsikot sisältävä soluryhmä (tai -alue) ennen ohjatun toiminnon käynnistämistä. Jos haluat käyttää useampaa kuin yhtä laskentataulukkoa, nimeä kunkin laskentataulukon sarakesoluryhmä. Ohjattu toiminto käsittelee näitä alueita taulukkoina. Lisätietoja solualueen nimeämisestä on Microsoft Office Excelin ohjeaiheessa, jossa käsitellään nimettyjen soluviittausten tai -alueiden määrittämistä.

    2. Saavutat parhaan lopputuloksen määrittämällä oletusohjaimen lähdekoodin selvittämisen kohteena olevaan tietokantaan ennen ohjatun lähdemääritysten selvittämisen käynnistämistä. Näin varmistat, että ohjattu toiminto yhdistää alkuperäiset tietotyypit oikein ja että kaikki ohjatun toiminnon poimima koodi näkyy Koodi-ikkunassa oikein.

    3. Valitse Tiedosto-valikossa Uusi, valitse Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    4. Valitse Tietokanta-valikosta Muuta lähdekoodiksi.

    5. Toimi ohjatun lähdemääritysten selvittämisen ensimmäisessä näytössä seuraavasti:

      1. Valitse käytettävää tietokannan hallintajärjestelmää (DBMS) vastaava Microsoft Office Vision tietokantaohjain. Jos et ole vielä määrittänyt Vision tietokantaohjainta mihinkään tiettyyn ODBC-tietolähteeseen, valitse Asetukset.

        Huomautus: Jos selvität Excel-laskentataulukon lähdekoodin, valitse Yleinen ODBC-ohjain.

      2. Valitse päivitettävän tietokannan tietolähde. Jos et ole vielä luonut tietolähdettä olemassa olevalle tietokannalle, luo se nyt valitsemalla Uusi.

        Kun luot uuden lähteen, tämän lähteen nimi lisätään Tietolähteet-luetteloon.

      3. Kun olet tehnyt haluamasi muutokset asetuksiin, valitse Seuraava.

    6. Noudata ohjaimeen liittyvissä valintaikkunoissa näkyviä ohjeita.

      Kirjoita esimerkiksi Yhdistä tietolähde -valintaikkunaan käyttäjän nimi ja salasana ja valitse sitten OK. Jos tietolähdettä ei ole suojattu salasanalla, valitse OK.

      Huomautus: Jos käytät yleistä ODBC-ohjainta, näyttöön saattaa tulla virheviesti, jossa ilmoitetaan, että selvitetyt tiedot ovat ehkä puutteellisia. Useimmissa tapauksissa tämä ei ole ongelma, vaan voit jatkaa ohjatun toiminnon suorittamista valittuasi OK.

    7. Valitse valintaruudut poimittavien tietojen mukaan ja valitse sitten Seuraava.

      Huomautus: Jotkin kohteet eivät ehkä ole käytettävissä (näkyvät harmaina), koska kaikki tietokantojen hallintajärjestelmät eivät tue kaikkia osia, joita ohjattu toiminto voi poimia.

    8. Valitse niitä taulukoita (ja mahdollisia näkymiä) vastaavat valintaruudut, joiden lähdemääritykset haluat poimia, tai napsauta Valitse kaikki -painiketta, jos haluat poimia kaikki lähdemääritykset. Valitse sitten Seuraava.

      Huomautus: Jos selvität Excel-laskentataulukon lähdekoodin eikä tässä luettelossa näy mitään, sinun on todennäköisesti nimettävä solualue, joka sisältää laskentataulukon sarakeotsikot.

    9. Jos valitsit kohdassa 5 Tallennetut toimintosarjat -valintaruudun, valitse nyt poimittavat toimintosarjat tai napsauta Valitse kaikki, jos haluat poimia ne kaikki. Valitse sitten Seuraava.

    10. Valitse, haluatko lisätä lähdekoodiltaan selvitetyt kohteet automaattisesti nykyiselle sivulle.

      Huomautus: Voit valita, että ohjattu toiminto luo piirustuksen automaattisesti sen lisäksi, että se luettelee selvitetyt määritykset Taulukot ja näkymät -ikkunassa. Jos et halua luoda piirustusta automaattisesti, voit koota tietokantamallin manuaalisesti vetämällä kohteet Taulukot ja näkymät -ikkunasta piirustussivulle.

    11. Tarkista tekemäsi valinnat ja varmista, että poimittavat tiedot ovat oikein, ja valitse sitten Valmis.

      Ohjattu toiminto poimii valitut tiedot ja näyttää poimintaan liittyvät huomautukset Kohde-ikkunassa.

    Aiemmin luodun mallin tuominen ja tarkentaminen

    Jos sinulla on aiemmin luotu VisioModeler- tai PLATINUM ERwin -malli, voit ehkä tuoda sen Visio-tietokantamallikaavion luomista varten. Tämä ominaisuus on rajoitettu vain VisioModeler 2.0 -version ja uudempien versioiden sanastomallitiedostoihin (.imd) ja PLATINUM ERwin 2.6-, 3.0- ja 3.52 -versioiden .erx-tiedostoihin.

    1. Valitse Tiedosto-valikossa Uusi, valitse Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    2. Valitse Tietokanta-valikossa Tuo ja valitse sitten Tuo < mallityyppi >.

    3. Kirjoita tuotavan mallin polku ja tiedostonimi tai napsauta Selaa-painiketta, etsi mallitiedosto ja napsauta sitten Avaa.

    4. Valitse Tuo-valintaikkunassa OK.

      Visio tuo tiedoston ja näyttää tuonnin edistymisen Tuloste-ikkunassa. Tuodut taulukot tulevat näkyviin Taulukot ja näkymät -ikkunaan.

    5. Valitse Taulukot ja näkymät -ikkunassa taulukot, jotka haluat mallintaa, ja vedä ne piirustussivulle.

  2. Kun olet luonut tietokantamallikaavion, aloitat kaavion tarkentamisen. Voit lisätä ja mukauttaa taulukkoja ja näkymiä, luoda yhteyksiä ja mukauttaa sarakkeita ja tietotyyppejä.

    Taulukot

    Voit luoda kaavioon taulukon käyttämällä Kohde-muotoa.

    1. Vedä joko Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustukseen Kohde-muoto.

    2. Kaksoisnapsauta muotoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    3. Valitse Luokat-kohdassa Määritys ja kirjoita taulukon nimi.

    4. Valitse Luokat-kohdassa Sarakkeet, kirjoita nimi ja valitse tietotyyppi.

    5. Valitse Pakollinen-valintaruutu niiden sarakkeiden kohdalla, joissa ei voi olla tyhjäarvoja.

    6. Valitse PK (perusavain) -valintaruutu niiden sarakkeiden kohdalla, jotka yksilöivät tietokantataulukon kunkin rivin.

    7. Valitse Luokat-kohdassa Indeksit, Käynnistimet, Tarkistus tai Laajennettu vastaavien valinnaisten elementtien luomiseksi.

    Sarakkeet

    Voit käyttää Tietokannan ominaisuudet -ikkunaa sarakkeiden ominaisuuksien, kuten tietotyyppien ja perusavaimien, lisäämiseen tai muuttamiseen.

    1. Kaksoisnapsauta taulukkoa kaaviossa.

    2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Sarakkeet.

    3. Napsauta ensimmäistä tyhjää Fyysinen nimi -solua ja kirjoita nimi.

    4. Voit muuttaa sarakkeen tietotyyppiä valitsemalla sarakkeen Tietotyyppi-kentän ja valitsemalla tietotyypin luettelosta tai kirjoittamalla sen luetteloon. Voit esimerkiksi kirjoittaa decimal(8,2) tai char(30).

    5. Jos haluat estää tyhjäarvot, valitse Pakollinen -valintaruutu.

    6. Voit määritä sarakkeen perusavaimeksi valitsemalla PK-valintaruudun.

    7. Jos haluat saada näkyviin enemmän sarakeominaisuuksia niiden lisäksi, jotka tulevat näkyviin valitessasi Sarakkeet-luokan, valitse sarake ja napsauta sitten Muokkaa.

    Yhteydet

    Yhteydet hyödyntävät perus- ja viiteavaimia sen sallimiseen, että tietokannat voivat sovittaa yksittäisen taulukon rivin siihen yhdistetyn taulukon riviin. Voit näyttää nämä yhteydet kaaviossa. Lisäksi voit määrittää niiden kardinaliteetin (esimerkiksi yksi-moneen) ja käyttää kukonaskel-, relaatio- tai IDEF1X-merkintää kardinaliteetin osoittamiseen. Et voi esittää monta-moneen-yhteyksiä millään näistä merkinnöistä Tietokantamallikaavio-mallissa.

    1. Yhteyden muodostaminen taulukoiden välillä:

      1. Varmista, että molemmat taulukot näkyvät kaaviossa. Jos olet luonut mallin selvittämällä aiemmin luodun tietokannan lähdekoodin, sinun täytyy ehkä vetää toinen tai molemmat taulukoista Taulukot ja näkymät -ikkunasta piirustussivulle.

      2. Kaksoisnapsauta taulukkoa, jonka haluat määrittää yhteyden perusavainpuolelle.

      3. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Sarakkeet.

      4. Napsauta ruudukon saraketta, jota haluat käyttää taulukon kunkin rivin yksilölliseen tunnistamiseen, ja määritä se perusavaimeksi valitsemalla PK-valintaruutu.

      5. Valitse Objektirelaatio- tai Käsiterelaatio-kaavain, vedä Yhteys-muotoa ja pudota se tyhjään kohtaan sivulla.

      6. Yhdistä yläpää ylätason taulukkoon.

      7. Yhdistä toinen pää alitaulukkoon.

        Jos toisessa taulukossa ei vielä ole saraketta, jolla on sama nimi kuin perusavaimella, mallintaja lisää sen toiseen taulukkoon viiteavaimena.

        Huomautus: Jos yhteysviivat katoavat näkyvistä, valitse Tietokanta-valikossa Asetukset ja valitse sitten Asiakirja. Valitse Yhteydet -välilehden Näytä-kohdassa Yhteydet-valintaruutu.

    2. Yhteyden kardinaliteetin määrittäminen:

      1. Kaksoisnapsauta yhteysviivaa.

      2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdassa Muut.

      3. Valitse Kardinaliteetti-kohdassa yhteyteen parhaiten soveltuva kardinaliteetti. Yksi-moneen-yhteyksissä paras valinta on Nolla tai enemmän tai Yksi tai enemmän. Yksi-yhteen-yhteyksissä paras valinta on Nolla tai yksi tai Täsmälleen yksi.

  3. Jos haluat tehdä kaavioon muita viimeistelyjä (kuten luoda indeksejä, tarkistusmääreitä ja käynnistimiä), voit toimia seuraavasti:

    Indeksien luominen

    Indeksit parantavat tietokannan suorituskykyä eli nopeutta kyselyissä.

    1. Avaa tietokantamallikaavio.

    2. Kaksoisnapsauta taulukkoa, johon haluat lisätä indeksin, ja valitse Tietokannan ominaisuudet -ikkunan Luokat‑luettelosta Indeksit.

    3. Valitse Uusi.

    4. Kirjoita indeksin nimi Luo indeksi -valintaikkunaan ja valitse sitten OK.

    5. Valitse Indeksityyppi-luettelosta joko yksilöivän tai ei-yksilöivän indeksin luomisen vaihtoehto.

    6. Valitse Käytettävissä olevat sarakkeet -luettelosta jokaisen tähän indeksiin sisällytettävän sarakkeen nimi ja valitse sitten Lisää >.

    7. Valitse Indeksoidut sarakkeet -luettelossa Asc-valintaruutu, jos haluat luoda indeksin, jonka lajittelujärjestys on nouseva, tai poista valintaruudun valinta, jos haluat luoda indeksin, jonka lajittelujärjestys on laskeva.

      Tietokantamallikaavio päivittyy.

    Näkymien luominen

    Voit ajatella näkymää tallennettuna kyselynä. Näkymät ovat erityisen käytännöllisiä, jos sinun on käytettävä toistuvasti samoja tietoja useista taulukoista tai jos haluat näyttää tiedot käyttäjille ilman, että he voivat muuttaa varsinaisia taulukoita.

    Vedä joko Käsiterelaatio- tai Objektirelaatio-kaavaimesta Kohde-muoto piirustussivulle.

    Laajennettujen ominaisuuksien määrittäminen taulukoille ja näkymille

    Käytössä olevan tietokannan hallintajärjestelmän (DBMS) mukaan voit ehkä määrittää taulukoille tai näkymille laajennettuja ominaisuuksia niiden tallennuspaikan määrittämiseksi.

    Kaksoisnapsauta taulukkoa tai näkymää, jonka laajennetut ominaisuudet haluat määrittää, ja valitse Tietokannan ominaisuudet -ikkunan Luokat‑luettelosta Laajennettu.

    Tarkistusmääreiden luominen

    Tarkistusmääreiden avulla voit varmistaa, että tiettyyn sarakkeeseen lisätyt tiedot ovat tietyn arvoalueen puitteissa. Voit esimerkiksi luoda tarkistusmääreen, joka edellyttää, että Ikä-sarakkeen tietona on suurempi arvo kuin 65.

    1. Kaksoisnapsauta taulukkoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    2. Valitse Luokat-kohdassa Sarakkeet ja napsauta sitten saraketta, johon haluat lisätä tarkistusmääreen.

    3. Valitse Muokkaa.

    4. Lisää haluamasi rajoitteet Tarkistus-välilehdelle Sarakkeen ominaisuudet -valintaikkunassa. Saat lisätietoja käytettävissä olevista valinnoista Sarakkeen ja kentän ominaisuudet -valintaikkunasta (Tarkistus-välilehti).

      Tarkistusmääreet lisätään Koodi-ikkunan Paikallinen koodi -kohtaan.

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden luominen

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden avulla voit luoda koodipaketteja, joita voit käyttää samojen toimintojen toistuvaan suorittamiseen. Suurin ero näiden kahden ominaisuuden välillä on, että käyttäjän määrittämä funktio palauttaa arvon, kun taas tallennettu toimintosarja suorittaa koodin arvoa palauttamatta.

    1. Valitse Tietokanta-valikossa Näytä ja valitse sitten Koodi, jotta Koodi-ikkuna avautuu.

    2. Valitse Yleinen koodi ja valitse sitten Uusi.

    3. Valitse KoodieditorinOminaisuudet-välilehdellä luotavan koodin tyyppi ja kirjoita koodin nimi.

    4. Valitse Runko-välilehdeltä koodi ja napsauta sitten OK.

    Käynnistimien luominen

    Käynnistimet suorittavat määrittämäsi SQL-koodin, kun tietokannassa tapahtuu tietty tapahtuma.

    1. Kaksoisnapsauta taulukkoa Tietokannan ominaisuudet -ikkunan avaamiseksi.

    2. Valitse Luokat-kohdasta Käynnistimet ja valitse sitten Lisää.

    3. Kirjoita käynnistimen nimi Ominaisuudet-välilehdelle.

    4. Valitse Runko-välilehdeltä koodi ja napsauta sitten OK.

      Käynnistin lisätään Koodi-ikkunan Paikallinen koodi -kohtaan.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×