Office
Kirjaudu sisään

Taulukko_matriisi-argumentin käyttäminen hakufunktiossa

Huomautus:  Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon .

Kun luot kaavan, PHAKU - tai VHAKU -funktiota, voit kirjoittaa taulukko_matriisi-argumentin, joka on solualue, kuten D2:F39. Funktio etsii yrität löytää tietojen alueella.

Taulukko_matriisi-argumentti on aina PHAKU- tai VHAKU-funktion toinen argumentti (ensimmäinen on etsitty arvo), jota ilman funktiot eivät toimi.

Ensimmäinen argumentti voi olla tietty arvo, kuten "41" tai "smith" tai se voi olla soluviite, kuten F2. Ensimmäinen argumentti näyttäisi tältä:

=PHAKU(F2; ...

Taulukko_matriisi-argumentti on aina haettavan arvon jälkeen:

=PHAKU(F2;B4:D39; ...

Taulukko_matriisi-argumentissa luetellussa solualueessa voidaan käyttää suhteellisia tai absoluuttisia soluviittauksia. Jos kaava kopioidaan toisiin soluihin, on käytettävä absoluuttisia soluviittauksia (huomaa $-merkit) tällä tavalla:

=PHAKU(F2;$B$2:BD$39; ...

Jos taulukko_matriisi-argumentin solut ovat työkirjassa toisessa laskentataulukossa, argumenttiin pitää sisällyttää taulukon nimi ja sen perässä huutomerkki. Kaava näyttäisi seuraavalta:

=PHAKU(F2;Taul2!$C$14:E$42; ...

Sarake, jossa ovat etsityt arvot, on kolmas syötettävä argumentti. Tätä kutsutaan hakusarakkeeksi. Jos tarkasteltavat arvot ovat sarakkeessa D (taulukko_matriisin kolmas sarake), viimeinen argumentti on 3.

=PHAKU(F2;B4:D39;3)

On suositeltavaa, joskin valinnaista, käyttää neljättäkin argumenttia, joko Tosi tai Epätosi. Jos etsit tarkkaa vastinetta, käytä Epätosi.

=PHAKU(F2;B4:D39;3;Epätosi)

Jos käytössä on Tosi tai neljäs argumentti jätetään tyhjäksi, funktio palauttaa ensimmäisen argumentin arvon likimääräisen vastineen. Jos siis ensimmäinen argumentti on "smith" ja käytössä on Tosi, PHAKU palauttaa arvot "Smith," "Smithberg" jne. Mutta jos käytössä on Epätosi, funktio palauttaa ainoastaan arvon "Smith", joka on tarkka vastine, joka useimmiten halutaan tulokseksi.

Tosi-arvon käyttöä hankaloittaa se, että jos hakusaraketta – kolmannessa argumentissa määritettyä saraketta – ei ole lajiteltu nousevassa järjestyksessä (A-Ö tai pienimmästä luvusta suurimpaan), funktio saattaa palauttaa väärän tuloksen.

Lisätietoja PHAKU- ja VHAKU-funktio on haku- ja viitefunktiot (hakemisto).

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×