Kaavat ja funktiot

SUMMA (SUMMA-funktio)

SUMMA (SUMMA-funktio)

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Summa -funktio on yksi Matemaattiset ja trigonometriset Funktiot, lisää arvot. Voit lisätä yksittäisiä arvoja, soluviittauksia tai alueita tai kaikki kolme yhdistelmän.

Esimerkki:

  • =SUMMA(A2:A10)

  • =SUMMA(A2:A10, C2:C10)

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

SUMMA(luku1,[luku2],...)

Argumentin nimi

Kuvaus

luku1    . (Pakollinen)

Ensimmäinen yhteenlaskettava luku. Luku voi olla esimerkiksi 4, soluviittaus, kuten B6, tai solu, alue, kuten B2:B8.

luku2–255    (Valinnainen)

Tämä on toinen yhteenlaskettava luku. Voit määrittää tällä tavalla enintään 255 lukua.

Tässä osassa käsitellään parhaista käytännöistä summa-funktion käyttäminen. Tämä paljon voi käyttää muiden toimintojen käyttö.

Menetelmä =1+2 tai =A+B: Vaikka syöttämällä =1+2+3 tai =A1+B1+C2 saa tarkkoja tuloksia, nämä menetelmät ovat virhealttiita useista syistä:

  1. Kirjoitusvirheet: kuvittele, millaista on syöttää useita ja/tai paljon suurempia arvoja, kuten

    • =14598,93+65437,90+78496,23

    Yritä Vahvista, että tiedot ovat oikein. On helppoa valitseminen yksittäisten solujen arvot ja käytä summa-kaavan. Lisäksi voit muotoilla arvot, kun ne ovat soluissa, että ne paljon luettavissa sitten ollessaan kaavassa.

    Käytä SUMMA-funktiota sen sijaan, että koodaat arvot kiinteästi kaavoihin.  Solussa D5 oleva kaava on =SUMMA(D2:D4)
  2. #ARVO!-virheet viitattaessa tekstiin numeroiden sijasta.

    Jos käytät esimerkiksi seuraavanlaista kaavaa:

    • =A1+B1+C1 tai =A1+A2+A3

    Esimerkki kaavan huonosta rakenteesta  Solussa D2 oleva kaava on =A2+B2+C2

    Voit katkaista kaavan, jos viitattuja soluja, jotka palauttavat #VALUE on jokin muu kuin numeerinen (teksti)-arvot! virhe. SUMMA ohittaa tekstiarvot ja antaa sinulle numeeristen arvojen summan.

    Kaavan oikea rakenne  Kaavan =A2+B2+C2 sijasta solun D2 kaava on =SUMMA(A2:C2)
  3. #VIITTAUS!-virhe rivien tai sarakkeiden poistamisen takia

    Sarakkeen poistamisesta johtuva #VIITTAUS!-virhe  Kaava on muuttunut muotoon =A2+#VIITTAUS!+B2

    Jos poistat rivin tai sarakkeen, kaava ei päivity ja sulje pois poistettua riviä. Tuloksena on #VIITTAUS!-virhe. SUMMA-funktio sen sijaan päivittyy automaattisesti.

    SUMMA-funktio säätyy automaattisesti lisättyjen tai poistettujen rivien ja sarakkeiden mukaan.
  4. Kaavat eivät päivitä viittauksia lisättäessä rivejä tai sarakkeita

    Muodossa =A+B+C olevat kaavat eivät päivity, kun rivejä lisätään.

    Jos lisäät rivin tai sarakkeen, kaava ei päivitä sisältämään lisättyä riviä, jossa summa-funktion päivittää automaattisesti (kunhan et ole ulkopuolelle kaavassa viitattujen). Tämä on erityisen tärkeää, jos odotat päivittää kaavan ja sen ei, se lähtevien voit puutteellinen tuloksia, jotka ehkä ole todellisen.

    Esimerkissä kuvataan SUMMA-kaava, joka laajenee automaattisesti muodosta =SUMMA(A2:C2) muotoon =SUMMA(A2:D2), kun sarake lisätään.
  5. SUMMA ja yksittäiset soluviittaukset vs. alueet

    Seuraavanlaisen kaavan käyttäminen:

    • =SUMMA(A1,A2,A3,B1,B2,B3)

    On tasaisesti virhe voi enää, kun lisäämisen tai poistamisen rivien viitatun alueen sisällä samoista syistä. On paljon parempi käyttää yksittäisiä alueita, kuten:

    • =SUMMA(A1:A3,B1:B3)

    Ne päivittyvät, kun rivejä lisätään tai poistetaan.

Ongelma

Mistä ongelma johtuu?

SUMMA-funktioni ei näytä tulosta, vaan merkkijonon #####.

Tarkista sarakkeiden leveydet. ### tarkoittaa yleensä, että sarake on liian kapea kaavan tuloksen.

SUMMA-funktio näyttää kaavan itsensä tekstinä, ei tulosta.

Tarkista, että solu ei ole muotoiltu tekstiksi. Valitse solu tai solualue poistettavaan ja käyttää Ctrl + 1 tuo näkyviin Muotoile solut -valintaikkunan Valitse numero-välilehti ja valitse haluamasi muoto. Jos solu on muotoiltu tekstiksi ja ei muutu, kun muutat muodon, voit joutua muuttamaan käyttää F2 > Enter Pakota muutettava muoto.

SUMMA-funktioni ei päivity.

Varmista, että Laskenta asettaminen automaattiseksi. Siirry kaava-välilehden Laskenta-asetukset. Voit myös pakottaa voit laskea laskentataulukon F9-näppäintä .

Varmista, että laskennan asetukseksi on määritetty Automaattinen.  Siirry Kaava-välilehdessä kohtaan Laskenta-asetukset.

Joitakin arvoja ei lisätä.

Ainoastaan funktioviittauksen tai alueen lukuarvot voidaan laskea. Tyhjät solut, totuusarvot, kuten TOSI, ja teksti ohitetaan.

Virhe #NIMI? tulee näkyviin odotetun tuloksen sijaan.

Tämä tarkoittaa yleensä, että kaavassa on kirjoitusvirhe, kuten =sume(A1:A10) kaavan =SUMMA(A1:A10) sijaan.

SUMMA-funktioni näyttää kokonaisluvun, mutta sen pitäisi näyttää desimaaleja

Varmista, että desimaalien näyttö on käytössä solumuotoilussa. Valitse kyseinen solu tai solualue ja painamalla Ctrl+1, jolloin Muotoile solut -valintaikkuna avautuu, valitse Luku-välilehti ja valitse haluamasi muoto. Varmista, että määrität haluamasi desimaalien määrän.

  1. Haluan vain laske yhteen, vähentää, kertoa tai jakaa lukuja Katso videosarja Excelin matemaattiset perustoiminnot tai Excelin käyttäminen laskimena.

  2. Miten näyttää enemmän tai vähemmän desimaaleja? Voit muuttaa Sivunumeron muoto. Valitse solu tai solualue poistettavaan ja tuo näkyviin Muotoile solut -valintaikkunassa ja valitse Luku-välilehti ja valitse haluamasi muoto, varmistetaan, että desimaalien lukumäärän Ctrl + 1 avulla.

  3. Miten aikoja lasketaan yhteen ja vähennetään? Voit laskea yhteen ja vähentää aikamääriä muutamilla eri tavoilla. Jos esimerkiksi haluaisit palkanlaskua varten laskea erotuksen välillä 8.00–12.00, käyttäisit kaavaa =("12.00"-"8.00")*24, eli vähentäisit päättymisajasta alkamisajan. Huomaa, että Excel laskee ajat vuorokauden murto-osina, joten tuntien määrän saamiseksi on käytettävä kertoimena arvoa 24. Ensimmäisessä esimerkissä lasketaan kaavan =((B2-A2)+(D2-C2))*24 avulla yhteen tunnit alusta loppuun ilman lounastaukoa (yhteenä 8,50 tuntia).

    Jos vain lasket yhteen tunteja ja haluat näyttää laskutoimituksen niin, voit käyttää yhteenlaskua ilman kerrointa 24. Siksi toisessa esimerkissä käytetään kaavaa =SUMMA(A6:C6), koska annetuista tehtävistä tarvitaan vain tuntien ja minuuttien kokonaismäärä (5.36 tai 5 tuntia 36 minuuttia).

    Aikojen laskeminen

    Lisätietoja on seuraavissa artikkeleissa: Ajan lisääminen tai vähentäminen

  4. Miten pääsen päivämäärän välisen eron? Kellonaikojen, jossa voit lisätä ja päivämäärien vähentäminen. Seuraavassa on yleisiä Esimerkki kahden päivämäärän välisten päivien määrän. On yhtä helppoa kuin = B2 A2. Päivämäärien ja kellonaikojen käsitteleminen avain on aloittaa kanssa Lopeta pvm. / klo ja vähentää Käynnistä pvm. / klo.

    Päivämääräerojen laskemisen

    Lisätietoja päivämäärien laskennasta on seuraavissa artikkeleissa: Laske kahden päivämäärän välissä olevien päivien määrä.

  5. Miten lasken yhteen vain näkyvät solut? Joskus, kun piilotat rivejä manuaalisesti tai näytät vain tietyt tiedot Pikasuodata-toiminnon avulla, voit halutessasi myös laskea yhteen vain näkyvät solut. Voit käyttää VÄLISUMMA-toimintoa. Jos käytät Excel-taulukossa summariviä, mikä tahansa avattavasta Summa-valikosta valitsemasi funktio syötetään automaattisesti välisummaksi. Lisätietoja on artikkelissa Excel-taulukon tietojen laskeminen yhteen.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Lisätietoja summa

Summa.Jos-funktio laskee yhteen ainoastaan yhden ehdon täyttävät arvot

Summa.Jos.joukko-funktio laskee yhteen vain ne arvot, jotka vastaavat useita ehtoja

Laske.Jos-funktio laskee vain yhden ehdon täyttävät arvot

Laske.Jos.joukko-funktio laskee vain ne arvot, jotka vastaavat useita ehtoja

Yleiskuva Excelin kaavoista

Viallisten kaavojen ratkaiseminen

Kaavojen virheiden etsiminen ja korjaaminen

Excel for Windowsin pikanäppäimet

Excel for Macin pikanäppäimet

Matemaattiset ja trigonometriset Funktiot

Excelin Funktiot (aakkosjärjestyksessä)

Excelin Funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×