Sisäkkäisten funktioiden käyttö kaavassa

Jos funktiota käytetään argumenttina funktiota käyttävässä kaavassa, sitä kutsutaan sisäkkäiseksi funktioksi. Jos esimerkiksi JOS-funktion argumentteihin sisällytetään KESKIARVO- ja SUMMA-funktio, seuraavalla kaavalla lasketaan lukujoukon (G2:G5) summa vain, jos toisen lukujoukon (F2:F5) keskiarvo on suurempi kuin 50. Muussa tapauksessa kaava palauttaa arvon 0.

Sisäkkäiset funktiot

KESKIARVO- ja SUMMA-funktiot ovat sisäkkäin JOS-funktiossa.

Voit kirjoittaa funktioita sisäkkäin kaavassa enintään 64 tasolle.

  1. Valitse solu, johon haluat kirjoittaa kaavan.

  2. Jos haluat aloittaa kaavan funktion avulla, valitse kaava riviltä Lisää funktio Painikkeen kuva Painikkeen kuva .

    Excel lisää kaavaan yhtäläisyysmerkin (=) puolestasi.

  3. Valitse Tai valitse luokka -ruudusta Kaikki.

    Jos tunnet funktioluokat, voit valita myös luokan.

    Jos et ole varma käytettävästä funktiosta, voit kirjoittaa toimintoa vastaavan kysymyksen Etsi funktio -ruutuun (esimerkiksi "laske luvut yhteen" palauttaa SUMMA-funktion ).

  4. Jos haluat käyttää toista funktiota argumenttina, kirjoita funktio haluamaasi argumenttiruutuun.

    Funktion argumentit -valintaikkunassa näkyvät kaavan osat vastaavat edellisessä vaiheessa valitsemaasi funktiota.

    Jos esimerkiksi valitsit JOS-funktion, Funktion argumentit -valintaikkunassa näkyvät JOS-funktion argumentit. Jos haluat sisällyttää toisen funktion, kirjoita se argumentin ruutuun. Voit lisätä esimerkiksi funktion SUMMA(G2:G5)JOS-funktion Arvo_jos_tosi-ruutuun.

  5. Lisää sitten muut kaavassa tarvittavat argumentit.

    Soluviittausten kirjoittamisen sijaan voit myös valita solut, joihin haluat viitata. Pienennä valinta ikkuna valitsemalla Painikkeen kuva , valitse solut, joihin haluat viitata, ja napsauta sitten Painikkeen kuva , jolloin valinta ikkuna laajennetaan uudelleen.

    Vihje: Jos haluat lisätietoja funktiosta ja sen argumenteista, valitse Tämän funktion ohje.

  6. Kun olet kirjoittanut kaavan argumentit, valitse OK.

  1. Valitse solu, johon haluat kirjoittaa kaavan.

  2. Jos haluat aloittaa kaavan funktion avulla, valitse kaava riviltä Lisää funktio Painikkeen kuva Painikkeen kuva .

  3. Napsauta Lisää funktio-valinta ikkunan Valitse Luokka -ruudussa Kaikki.

    Jos tunnet funktioluokat, voit valita myös luokan.

  4. Jos haluat määrittää toisen funktion argumentiksi, kirjoita funktio kaavan muodostimen argumentti ruutuun tai suoraan soluun.

  5. Lisää sitten muut kaavassa tarvittavat argumentit.

  6. Kun olet suorittanut kaavan argumentit, paina ENTER-näppäintä.

Esimerkkejä

Seuraavassa on esimerkki sisäkkäisten JOS-funktioiden käyttämisestä lukuarvoa vastaavan kirjainarvosanan määrittämiseen.

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Tulos

45

90

78

Kaava

Kuvaus

Tulos

=JOS(A2>89,"A",JOS(A2>79,"B", JOS(A2>69,"C",JOS(A2>59,"D","F"))))

Määrittää kirjainarvosanan solussa A2 olevalle tulokselle sisäkkäisiä JOS-funktioita käyttäen.

=JOS(A2>89,"A",JOS(A2>79,"B", JOS(A2>69,"C",JOS(A2>59,"D","F"))))

'=JOS(A3>89,"A",JOS(A3>79,"B", JOS(A3>69,"C",JOS(A3>59,"D","F"))))

Määrittää kirjainarvosanan solussa A3 olevalle tulokselle sisäkkäisiä JOS-funktioita käyttäen.

=JOS(A3>89,"A",JOS(A3>79,"B", JOS(A3>69,"C",JOS(A3>59,"D","F"))))

'=JOS(A4>89,"A",JOS(A4>79,"B", JOS(A4>69,"C",JOS(A4>59,"D","F"))))

Määrittää kirjainarvosanan solussa A4 olevalle tulokselle sisäkkäisiä JOS-funktioita käyttäen.

=JOS(A4>89,"A",JOS(A4>79,"B", JOS(A4>69,"C",JOS(A4>59,"D","F"))))

Vihjeitä: 

Tarvitsetko lisäohjeita?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Video: Sisäkkäiset JOS-funktiot

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×