Näytä luota lisäämällä digitaalinen allekirjoitus

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Voit näyttää mielestäsi tietokanta on turvallinen ja sen sisältöä voi luottaa lisäämällä digitaalinen allekirjoitus tietokanta. Tämä auttaa tietokannan käyttävien henkilöiden valitseminen luota sitä ja sen sisältöä.

Prosessi, jossa voit allekirjoittaa tietokannan määräytyy sen mukaan, onko tietokanta käyttää uudempaan tiedostomuotoon, kuten .accdb-tiedostossa tai aiemmassa muodossa, kuten .mdb-tiedoston. Molemmat päivitysprosessit kuitenkin edellyttää, että käytät suojausvarmennetta.

Voit käyttää kaupallisen suojausvarmenne tai luo omasi. Tässä ohjeaiheessa kerrotaan, miten voit luoda oman suojausvarmenne.

Artikkelin sisältö

Alkuvalmistelut

Paketointi, allekirjoittaminen ja jakelu Access-tietokantaan

Aiemmassa versiossa luodun tietokannan digitaalinen allekirjoittaminen

Ennen aloittamista

Lisää digitaalinen allekirjoitus, varten on hankkia tai luo sertifikaatti. Ajatella suojausvarmennetta kynä, että voit allekirjoittaa kohteita tai vaha sinetöidä, että vain sinä voit käyttää.

Jos sinulla ei ole suojausvarmennetta, voit luoda yhden SelfCert-työkalun (sisältyy Microsoft Office) avulla.

Itse allekirjoitetun varmenteen luominen

  1. Microsoft Windowsin Käynnistä -painiketta, valitse Kaikki ohjelmat, valitse Microsoft Office, valitse Microsoft Office-työkalutja sitten Digitaalinen varmenne VBA-projekteille.

    -tai-

    Siirry Microsoft Office-ohjelmatiedostot sisältävä kansio.

    Sinun on suoritettava SelfCert.exe-tiedosto ja sijainti voivat vaihdella näiden eri ehtojen perusteella, kuin, jos käytät 32-bittinen tai 64-bittinen Windows-käyttöjärjestelmän tai jos käytössäsi on Office 365: n tilausversio.

    Jos käytössäsi on Office 2019 tai Office 2016, kokeile jotakin seuraavista paikoista:

    • C:\Program Files\Microsoft Office\Office16

    • C:\Program tiedostojen (x86) \Microsoft Office\Office16

    Jos käytät Office 365: ssä, kokeile jotakin seuraavista paikoista:

    • C:\Program Files\Microsoft Office\root\Office16

    • C:\Program tiedostojen (x86) \Microsoft Office\root\Office16

    Jos käytössäsi on Office 2013, Etsi yllä vaihtoehdoista Office15-kansio. Jos käytössäsi on Office 2010: n, Etsi Office14-kansio. Jos käytössäsi on Office 2007: ssä, Etsi Office12-kansio.

    Etsi oikea kansio ja kaksoisnapsauta SelfCert.exe.

    Näkyviin tulee Luo digitaalinen varmenne -valintaikkuna.

  2. Kirjoita Varmenteen nimi -ruutuun uuden testivarmenteen nimi.

  3. Valitse OK kahdesti.

Huomautus: Jos näkyviin ei tule Digitaalinen varmenne VBA-projekteille -komentoa tai jos et löydä SelfCert.exe-tiedostoa, sinun on ehkä asennettava SelfCert.

SelfCert.exe-tiedoston asentaminen

  1. Käynnistä Microsoft Office-asennuksen CD-levy tai muu asennustietoväline.

  2. Valitse asennusohjelmassa Lisää tai poista ominaisuuksia ja napsauta sitten Jatka.

    Huomautus: Jos työskentelet ympäristössä, jossa IT-järjestelmästä vastaava henkilö on asentanut Microsoft Officen eri tietokoneisiin muuten kuin CD-levyn avulla, toimi seuraavasti:

    1. Napsauta Microsoft Windowsissa Käynnistä-painiketta ja valitse sitten Ohjauspaneeli.

    2. Kaksoisnapsauta Lisää tai poista sovellus.

    3. Valitse Microsoft Office-versio ja valitse sitten Muuta.

      Asennus käynnistyy.

    4. Valitse Lisää tai poista ominaisuuksia ja valitse sitten Jatka.

    5. Jatka alla kuvatulla tavalla.

  3. Laajenna Microsoft Office- ja Officen yhteiset toiminnot -solmut napsauttamalla niiden vieressä olevia plusmerkkejä (+).

  4. Valitse Digitaalinen varmenne VBA-projekteille.

  5. Valitse Suorita paikallisena.

  6. Asenna osa valitsemalla Jatka.

SelfCert avulla vain luoda oman organisaatiosi allekirjoituksia käyttöä varten. Jos haluat allekirjoittaa tietokannan ja jakaa tietokannan kaupallisesti, hanki kaupallisen suojausvarmenne kaupalliselta varmenteiden myöntäjältä (CA).

Paketointi, allekirjoittaminen ja jakelu Access -tietokanta

Access on helppoa ja nopeaa voit allekirjoittaa ja jakaa tietokannan. Kun luot .accdb- tai .accde-tiedoston, voit pakata tiedoston, Lisää digitaalinen allekirjoitus-paketin ja jakaa allekirjoitetun paketin muille käyttäjille. Pakkaa ja Allekirjoita-työkalun sijoittaa tietokannan Access Deployment (.accdc)-tiedoston, kirjautuu tiedosto ja sitten esto allekirjoitetun paketin sijaintiin, jossa voit määrittää. Käyttäjät voivat sitten purkaa tietokannan paketista ja käyttää suoraan tietokantaa (ei-paketti-tiedosto).

Muista jatkossa seuraavat asiat:

  • Tietokannan paketointi ja paketin allekirjoittaminen on luotettavuuden merkki. Pakatun ja allekirjoitetun tietokannan digitaalinen allekirjoitus vahvistaa, että tietokantaa ei ole muutettu paketin luomisen jälkeen.

  • Kun tietokanta puretaan paketista, allekirjoitetun paketin ja puretun tietokannan välillä ei ole enää mitään yhteyttä.

  • Pakkaa ja Allekirjoita-työkalulla vain tietokantoja, jotka on tallennettu uudempia tiedostomuotoja (.accdb, .accde,...). Access on myös työkaluja, voit allekirjoittaa ja jakaa tietokannoissa, jotka on vanhemmassa tiedostomuodossa. Käytössä on oltava digitaalinen allekirjoitus-työkalua, joka sopii tiedostomuodossa, jota käytät.

  • Pakettiin voi lisätä vain yhden tietokannan.

  • Prosessi allekirjoittaa digitaalisesti paketin, jossa on koko tietokanta eikä vain makroja tai moduuleja.

  • Prosessi pakkaa pakettitiedoston lataukseen kuluvan ajan säästämiseksi.

  • Voit purkaa tietokantoja paketti-tiedostoista, jotka sijaitsevat palvelimessa on Windows SharePoint Services 3.0 tai uudempi versio.

Seuraavien osien vaiheissa kerrotaan, kuinka voit luoda allekirjoitetun pakettitiedoston sekä purkaa siitä tietokannan ja käyttää sitä.

Allekirjoitetun paketin luominen

  1. Avaa tietokanta, jonka haluat pakata ja allekirjoittaa.

  2. Valitse Tiedosto > Tallenna nimellä > Pakkaa ja Allekirjoita. Huomaa, että jos käytät Access 2007 Microsoft Office-painiketta > Julkaise > Pakkaa ja Allekirjoita.

    Näkyviin tulee Valitse varmenne -valintaikkuna.

  3. Valitse digitaalinen varmenne ja valitse sitten OK.

    Luoda Microsoft Accessin allekirjoitettu paketti -valintaikkuna.

  4. Valitse Kohde-luettelosta allekirjoitetun tietokantapaketin sijainti.

  5. Määritä allekirjoitetun paketin nimi Tiedostonimi-ruutuun ja valitse Luo.

    Access luo .accdc-tiedoston ja sijoittaa sen valitsemaasi sijaintiin.

Allekirjoitetun paketin purkaminen ja käyttäminen

  1. Valitse Tiedosto > Avaa > Selaa. Avaa -valintaikkuna tulee näkyviin. Huomaa, että jos käytät Access 2007 Microsoft Office-painiketta > Avaa.

  2. Valitse tiedostotyypiksi Microsoft Accessin allekirjoitettu paketti (*.accdc) .

  3. Etsi .accdc-tiedoston sisältävä kansio, valitse tiedosto ja valitse sitten Avaa.

  4. Tee jompikumpi seuraavista:

    • Jos luotat käyttöönottopaketin allekirjoittamisessa käytettyyn suojausvarmenteeseen, näkyviin tulee Pura tietokanta kohteeseen -valintaikkuna. Siirry seuraavaan vaiheeseen.

    • Jos et ole vielä valinnut, että suojausvarmenne on luotettava, näkyviin tulee seuraava sanoma.

      Ohjesanoma

      Jos luota tietokantaan, valitse Avaa. Jos luotat kaikki kyseisen toimittajan varmenteen, valitse Luota kaikkiin julkaisijan. Pura tietokanta kohteeseen -valintaikkuna tulee näkyviin.

      Huomautus: Jos allekirjoitat tietokantapaketin itse allekirjoitetulla varmenteella ja valitset Luota kaikkeen julkaisijan sisältöön, kun avaat kyseisen paketin, järjestelmä pitää kaikkia itse allekirjoittamillasi varmenteilla allekirjoitettuja paketteja luotettavina.

  5. Voit myös valita Kohde-luettelosta puretun tietokannan sijainnin ja määrittää puretulle tietokannalle eri nimen Tiedostonimi-ruutuun.

    Vihje: Jos purat tietokannan luotettuun sijaintiin, sen sisältö on automaattisesti käytettävissä aina, kun avaat tietokannan. Jos valitset epäluotettavan sijainnin, jotkin tietokannan osat ovat oletusarvoisesti poissa käytöstä.

  6. Valitse OK.

Jos et ole varma, luotatko varmenteeseen, tutustu artikkeliin Mistä tietää, onko digitaalinen varmenne luotettava. Tämä artikkeli sisältää yleisiä tietoja varmenteen kelvollisuuden määrittämisestä esimerkiksi päivämäärien tarkistamisen avulla.

Sivun alkuun

Aiemmassa versiossa luodun tietokannan digitaalinen allekirjoittaminen

Tärkeää: Tämän osan vaiheet eivät vaikuta tietokantoihin, jotka käyttävät jotakin uusista tiedostomuodoista.

Tietokantojen .mdb- tai .mde-tiedostomuodoissa voit käyttää digitaalinen allekirjoitus tietokannan osiin. Digitaalisen allekirjoituksen vahvistaa, että kaikki makrot, koodimoduuleja ja muut suoritettavan tietokannan osat ovat peräisin allekirjoittajan ja että kukaan ei muutettu niitä tietokannan allekirjoittamisen jälkeen.

Jotta voit käyttää allekirjoitusta tietokannassa, sinulla on oltava digitaalinen varmenne. Jos luot tietokantoja myytäväksi, sinun on hankittava varmenne niitä kaupalliseen käyttöön myöntävältä yhtiöltä. Varmenteiden myöntäjät tarkistavat hakijan taustan varmistaakseen, että sisällön (kuten tietokantojen) tuottaja on hyvämaineinen.

Jos haluat käyttää tietokantaa henkilökohtaisesti tai rajoitettu Access sisältää työkalun luomisen itse allekirjoitettua varmennetta. Seuraavassa kerrotaan, asentaa ja luo itse allekirjoitetun varmenteen SelfCert.exe-työkalun avulla.

Tietokannan allekirjoittaminen digitaalisesti

Huomautus: Muista, että nämä vaiheet koskevat vain käytettäessä tietokannoissa, jotka käyttävät jotakin tietokannan aiempiin tiedostomuotoihin esimerkiksi .mdb-tiedoston. Tietokantojen allekirjoittamisesta artikkelissa osassa pakkaaminen, allekirjoittaminen ja Access-tietokannan jakaminen.

  1. Avaa allekirjoitettava tietokanta.

  2. Käynnistä Visual Basic -editori valitsemalla Tietokantatyökalut-välilehden Makro-ryhmässä Visual Basic.

    Pikanäppäin paina ALT + F11.

  3. Valitse Project Explorer -ikkunassa allekirjoitettava tietokanta tai Visual Basic for Applications (VBA) -projekti.

  4. Valitse Työkalut-valikossa Digitaalinen allekirjoitus.

    Näkyviin tulee Digitaalinen allekirjoitus -valintaikkuna.

  5. Valitse koetestivarmenne napsauttamalla Valitse.

    Näkyviin tulee Valitse varmenne -valintaikkuna.

  6. Valitse varmenne, jonka haluat ottaa käyttöön.

    Jos olet toiminut edellä kuvatulla tavalla, valittava varmenne on SelfCert-ohjelmalla luotu varmenne.

  7. Valitse OK ja sulje Sitten sertifikaatti -valintaikkuna ja valitse OK uudelleen ja sulje sitten Digitaalinen allekirjoitus -valintaikkuna.

Aiemmalla ohjelmistoversiolla luotujen tietokantojen allekirjoitusvihjeitä

  • Jos haluat estää sen, että sovelluksesi käyttäjät muuttavat VBA-projektiasi epähuomiossa ja poistavat allekirjoituksen, lukitse VBA-projekti ennen allekirjoittamista.

    Huomautus: VBA-projektin lukitseminen ei estä toista käyttäjää vaihtamasta digitaalista allekirjoitusta. Yritysten järjestelmänvalvojat voivat rajoittaa ohjelmia, joita käyttäjät suorittavat tietokoneissaan, allekirjoittamalla mallit ja apuohjelmat uudelleen.

  • Kun allekirjoitat VBA-projekti, harkitse aikaleiman niin, että muut Tarkista allekirjoituksesi senkin jälkeen, kun allekirjoitukseen käytettävä varmenne on vanhentunut.

Sivun alkuun

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×