Luotettavan julkaisijan lisääminen, poistaminen ja näyttäminen

Tässä artikkelissa kerrotaan, mikä on luotettava julkaisija, kuinka ottaa käyttöön julkaisijan sisältöä ja miksi on turvallisempaa käyttää luotettavien julkaisijoiden koodiprojekteja. Saat myös lisätietoja siitä, kuinka lisätä, tarkastella tai poistaa luotettavia julkaisijoita Valvontakeskuksen Luotettavat julkaisijat -luettelossa.

Sisältö

Lisätietoja luotettavista julkaisijoista

Julkaisija on henkilö tai yritys, yleensä ohjelmistokehittäjä, joka on julkaissut koodin, kuten makron, ActiveX-komponentin tai apuohjelman. Sinun on tiedettävä julkaisijan henkilöllisyys ja ovatko hänen valtuustietonsa kunnossa, ennen kuin voit pitää häntä luotettavana. Luotettavat julkaisijat ovat hyvämaineisia ja täyttävät kaikki alla luetellut vaatimukset:

  • Heidän koodissaan on digitaalinen allekirjoitus.

  • Digitaalinen allekirjoitus on kelvollinen.

  • Digitaalinen allekirjoitus on voimassa (se ei ole vanhentunut).

  • Digitaaliseen allekirjoitukseen liittyvä varmenne on hyvämaineisen varmenteen myöntäjän (CA) myöntämä.

Jos yrität suorittaa koodia, joka ei täytä kaikkia näitä vaatimuksia, Office ei ota koodia käyttöön vaan näyttää sanomapalkin, jossa ilmoitetaan mahdollisesti vaarallisesta koodista.

Tärkeää: Jos avaat julkaisijan tiedoston ja saat ilmoituksen, että allekirjoitusta ei löydy tai että allekirjoitus on virheellinen, sisältöä ei kannata ottaa käyttöön eikä julkaisijaa kannata määrittää luotettavaksi, ellet ole varma, että koodi on peräisin luotettavasta lähteestä. Lisätietoja digitaalisista allekirjoituksista ja niiden varmenteista löydät artikkelista Mistä tietää, että digitaalinen allekirjoitus on luotettava.

Sivun alkuun

Lisätietoja suojausvaroituksesta ja julkaisijasta

Kun Office näyttää sanomapalkin, jossa varoitetaan mahdollisesti vaarallisesta koodista tiedostossa, voit katsoa lisätietoja koodista ja julkaisijasta, ennen kuin päätät, luotatko koodiin tai julkaisijaan.

Tärkeää: Jos saat varoituksen, että allekirjoitusta ei löydy tai että allekirjoitus on virheellinen, sisältöä ei kannata ottaa käyttöön eikä julkaisijaa kannata määrittää luotettavaksi, ellet ole varma, että koodi on peräisin luotettavasta lähteestä. Lisätietoja digitaalisista allekirjoituksista ja niiden varmenteista löydät artikkelista Mistä tietää, että digitaalinen allekirjoitus on luotettava.

Koodin ja julkaisijan tietojen tarkasteleminen suojausvaroituksen jälkeen

  1. Valitse Tiedosto-välilehti.

  2. Valitse Suojausvaroitus-alueella Ota sisältö käyttöön > Lisäasetukset.

    Office näyttää Microsoft Officen suojausasetuksissa lisätietoja suojausvaroituksen syystä, mukaan lukien julkaisijan koodiin mahdollisesti sisältyvät julkaisijan tiedot.

    Suojausasetukset-valintaikkunan luota julkaisijaan -kohta

Sivun alkuun

Julkaisijan aktiivisen sisällön käyttöön ottaminen, kun näyttöön tulee sanomapalkki

Kun julkaisijan tiedostossa on uutta aktiivista sisältöä (kuten allekirjoitettu makro tai apuohjelma), näyttöön tulee sanomapalkki, jossa on kilpikuvake, varoitusteksti ja Ota sisältö käyttöön -painike. Jos tiedät, että julkaisija on luotettava, voit ottaa aktiivisen sisällön käyttöön. Tällöin tiedostosta tulee luotettu tiedosto, mutta julkaisija ei ole luotettu. Lisätietoja julkaisijan määrittämisestä luotetuksi on tämän artikkelin kohdassa Luotettavan julkaisijan lisääminen, kun suojausvaroitus tulee näyttöön.

Sanomapalkki, jossa on Osa aktiivisesta sisällöstä on poistettu käytöstä -ilmoitus
Sanomapalkki, jossa näkyy suojausvaroitus ja Ota sisältö käyttöön -painike

Tiedoston aktiivisen sisällön käyttöön ottaminen

  • Valitse sanomapalkista Ota sisältö käyttöön.

    Tiedosto avautuu, ja se on luotettu tiedosto.

Sivun alkuun

Luotettavan julkaisijan lisääminen, kun suojausvaroitus tulee näyttöön

Jos julkaisijan pystyy tunnistamaan Officen estämän koodin perusteella ja olet varma, että luotat julkaisijaan, voit lisätä julkaisijan luotettujen julkaisijoiden luetteloon, kun tarkastelet suojausvaroituksen lisätietoja.

Julkaisijan lisääminen luotettujen julkaisijoiden luetteloon suojausvaroituksen jälkeen

  1. Avaa uuden julkaisijan tiedosto.

  2. Valitse Tiedosto.

  3. Valitse Suojausvaroitus-alueella Ota sisältö käyttöön > Lisäasetukset.

  4. Valitse Microsoft Officen suojausasetuksissaLuota kaikkiin tämän julkaisijan tiedostoihin.

Julkaisijan aktiivisen sisällön ottaminen käyttöön yhden kerran suojausvaroituksen tullessa näkyviin

Jos haluat ottaa julkaisijan aktiivisen sisällön käyttöön yhden kerran suojausvaroituksen tullessa näyttöön, mene Microsoft Officen suojausasetukset -valintaikkunaan edellisten ohjeiden mukaisesti. Valitse valintaikkunassa jokaisen luettelon aktiivisen sisällön kohdalla Ota sisältö käyttöön tässä istunnossa.

Aktiiviseen sisältöön luottaminen Suojausasetukset-valintaikkunassa

Sivun alkuun

Luotettavan julkaisijan lisääminen Valvontakeskuksen kautta

Jos tiedät, että julkaisijan aktiivinen sisältö (makrot, ActiveX-komponentit, tietoyhteydet ja niin edelleen) on luotettavaa, voit lisätä julkaisijan luotettujen julkaisijoiden luetteloon Valvontakeskuksessa.

Julkaisijan lisääminen luotettujen julkaisijoiden luetteloon Luottamuskeskuksessa

  1. Avaa uuden julkaisijan tiedosto.

  2. Valitse Tiedosto > Asetukset.

  3. Valitse Valvontakeskus > Valvontakeskuksen asetukset > Luotettavat julkaisijat.

  4. Valitse luettelosta julkaisijan varmenne, ja valitse sitten OK .

    Luottamuskeskuksen Luotettavat julkaisijat -alue

Sivun alkuun

Luotettavan julkaisijan tarkasteleminen tai poistaminen

Voit tarkistaa Officen luotettujen julkaisijoiden luettelossa olevat julkaisijat ja voit halutessasi poistaa julkaisijan seuraavien ohjeiden mukaisesti.

Luotettujen julkaisijoiden luettelon tarkasteleminen ja julkaisijan poistaminen

  1. Avaa julkaisijan luoma tiedosto.

  2. Valitse Tiedosto > Asetukset.

  3. Valitse Valvontakeskus > Valvontakeskuksen asetukset > Luotettavat julkaisijat.

  4. Valitse poistettava julkaisija Luotettavat julkaisijat -luettelosta, ja valitse sitten Poista.

Huomautus: Jos et näe Poista-painiketta Luotettavat julkaisijat -kohdassa, käynnissä olevalla Office-ohjelmalla ei ole järjestelmänvalvojan oikeuksia.

Jos Office ei tarjoa mahdollisuutta poistaa julkaisija, käynnissä olevalla Office-ohjelmalla ei ole järjestelmänvalvojan oikeuksia. Voit poistaa julkaisijan käynnistämällä Office-ohjelman uudelleen ja antamalla järjestelmänvalvojan tunnistetiedot. Jos tietokoneesi käyttöjärjestelmänä on Windows 7, toimi myöhemmin tässä osassa annettavien, Windows 7:ää koskevien ohjeiden mukaisesti.

Office-ohjelman suorittaminen järjestelmänvalvojan tunnistetiedoilla

  1. Pyyhkäise näytön oikeasta reunasta sisäänpäin ja valitse sitten Hae. Jos käytät hiirtä, osoita näytön oikeaan yläkulmaan, odota, että näyttöön tulee oikopolkupalkki, ja valitse sitten Hae.

  2. Kirjoita Office-ohjelman nimi, kuten Word. Etsi Office-ohjelma hakutuloksista ja napauta sitä pitkään tai napsauta hiiren kakkospainiketta. Näytä valikko lopettamalla painaminen ja valitse sitten Suorita järjestelmänvalvojana.

    Jos et ole kirjautunut tietokoneeseen tilillä, jolla on järjestelmänvalvojan oikeudet, Windows pyytää sinua antamaan kyseiset oikeudet omaavan tilin käyttäjänimen ja salasanan Käyttäjätilien valvonta -kohdassa.

  3. Noudata ohjeita kohdassa Luotettujen julkaisijoiden luettelon tarkasteleminen ja julkaisijan poistaminen.

  4. Kun olet muokannut luotettujen julkaisijoiden luetteloa, sulje Office-ohjelma.

    Office-ohjelmien suorittaminen järjestelmänvalvojan oikeuksilla on vähemmän turvallista kuin niiden suorittaminen tavallisena käyttäjänä.

Jos tietokoneesi käyttöjärjestelmänä on Windows 7, toimi seuraavien ohjeiden mukaisesti.

Office-ohjelman suorittaminen järjestelmänvalvojan tunnistetiedoilla Windows 7:ssä

  1. Valitse Käynnistä > Kaikki ohjelmat > Microsoft Office.

  2. Napsauta hiiren kakkospainikkeella Office-ohjelmaa, kuten Wordia.

  3. Valitse Suorita järjestelmänvalvojana.

    Jos et ole kirjautunut tietokoneeseen tilillä, jolla on järjestelmänvalvojan oikeudet, Windows pyytää sinua antamaan kyseiset oikeudet omaavan tilin käyttäjänimen ja salasanan Käyttäjätilien valvonta -kohdassa.

  4. Noudata ohjeita kohdassa Luotettujen julkaisijoiden luettelon tarkasteleminen ja julkaisijan poistaminen.

  5. Kun olet muokannut luotettujen julkaisijoiden luetteloa, sulje Office-ohjelma.

    Office-ohjelmien suorittaminen järjestelmänvalvojan oikeuksilla on vähemmän turvallista kuin niiden suorittaminen tavallisena käyttäjänä.

Sivun alkuun

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×