Office
Kirjaudu sisään

Lomaketietojen lähettäminen asiakirjakirjastoon

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit tallentaa ja järjestää kaikki käyttäjien lomakkeet asiakirjakirjastoon palvelimessa, jossa on käytössä Microsoft Windows SharePoint Services. Asiakirjakirjastossa käyttäjät voivat täyttää lomakemalliin perustuvia lomakkeita, viedä täytettyjen lomakkeiden tietoja Microsoft Office Excel 2003:een tai Microsoft Office Excel 2007 -ohjelmaan tai yhdistää useiden lomakkeiden tietoja yhteen lomakkeeseen.

Jotta käyttäjät voivat lähettää lomakemalliin perustuvia lomakkeita asiakirjakirjastoon, voit lisätä lomakemalliin toissijaisen tietoyhteyden, joka lähettää tietoja lomakemalliin. Lähetystietoyhteyden lisäämisen jälkeen voit määrittää lomakemallin sallimaan käyttäjien lähettää lomaketiedot asiakirjakirjastoon. Kun teet tämän, Microsoft Office InfoPath lisää Lähetä-painikkeen vakiotyökaluriviin ja Lähetä-komennon Tiedosto-valikkoon lomakkeessa. Voit myös mukauttaa lomakemallin lähetysasetuksia seuraavasti:

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon tekstiä.

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

Lähetystietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

  2. Valitse Lähetyksen asetukset -valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruudun valinta.

  3. Valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta SharePoint-asiakirjakirjasto.

  4. Valitse Lisää.

  5. Kirjoita ohjatussa tietoyhteyden muodostamisessa Asiakirjakirjasto-ruutuun SharePoint-asiakirjakirjaston sijainti.

  6. Kirjoita Tiedostonimi-ruutuun nimi, jota käytetään lomakkeen tunnistamiseen asiakirjakirjastossa.

    Vihje: Voit myös varmistaa kaavan avulla, että jokainen lomakenimi on yksilöllinen.

    Toimintaohjeet:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

      • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

      • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

        Vihje: Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

      • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

    Laskutoimitus

    Merkki

    Yhteenlasku

    +

    Vähennyslasku

    -

    Kertolasku

    *

    Jakolasku

    /

    • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

    • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

      Lisätietoja kaavoista on Katso myös -osan linkeissä.

  7. Jos haluat korvata asiakirjakirjaston samannimiset aiemmin luodut lomakkeet, valitse Salli korvaaminen, jos tiedosto on jo olemassa -valintaruutu.

  8. Valitse Seuraava.

  9. Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  10. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  11. Jos et halua, että käyttäjät voivat käyttää Lähetä-komentoa tai vakiotyökalurivinLähetä-painiketta täyttäessään lomakettasi, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      1. Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      2. Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      3. Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×