Lomakemallin ohjelmointikielen vaihtaminen

Huomautus:  Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon .

Lomakemalli voi sisältää vain yhdellä ohjelmointikielellä kirjoitettuja komentosarjoja tai hallittuja koodeja. Voit vaihtaa lomakemallin ohjelmointikieltä poistamalla alkuperäisen komentosarjan tai hallitun koodin, määrittämällä uuden ohjelmointikielen, kirjoittamalla komentosarjan tai hallitun koodin uudella ohjelmointikielellä ja lisäämällä uuden komentosarjan tai hallitun koodin lomakemalliin.

Huomautus: InfoPath ei voi muuntaa olemassa olevien komentosarjojen tai hallittujen koodien ohjelmointikieltä toiseksi ohjelmointikieleksi.

Tässä artikkelissa

Yleiskatsaus

Lomakemallin ohjelmointikielen vaihtaminen

Yleistä

Kun lisäät liiketoimintalogiikan lomakemalliin käyttämällä komentosarjaa tai hallittua koodia (esimerkiksi monimutkaisen laskutoimituksen suorittaminen käyttämällä arvoja, jotka käyttäjät lisäävät lomakkeeseen lomakemallin mukaan), voit käyttää useita eri ohjelmointikieliä, kuten C#-kieltä tai Microsoft Visual Basic -kieltä. Kun olet lisännyt komentosarjan tai hallitun koodin lomakemalliin, kaikissa muutoksissa ja uusissa lomakemalliin lisättävissä komentosarjoissa ja hallituissa koodeissa on käytettävä samaa ohjelmointikieltä.

Koska lomakemallin on mukauduttava uusiin liiketoimintavaatimuksiin, saatat joutua muuttamaan lomamallissa käytettävää ohjelmointikieltä. Kuvittele esimerkiksi seuraavat tilanteet:

  • Yrityksessä on otettu käyttöön uusi käytäntö, jonka mukaan kaikkien Microsoft Windows -ohjelmien ja niiden laajennusten kehityksessä on käytettävä C#-ohjelmointikieltä. Yrityksen aiemmin luoduissa lomakemalleissa on käytetty Visual Basic -ohjelmointikieltä. Jotta uutta käytäntöä voitaisiin noudattaa, kaikkia lomakemalleja on muutettava siten, että niissä käytetään C#-ohjelmointikieltä.

  • Julkaiset Microsoft Office InfoPath 2003:ssa luodun lomakemallin, jonka komentosarja on kirjoitettu JScript-kielellä. Koska Microsoft Office InfoPath 2007 -ohjelmassa on mahdollista täyttää Web-lomakemalleihin perustuvia lomakkeita, aiemmin luotu lomakemalli on muunnettava selainpohjaiseksi lomakemalliksi ja julkaistava InfoPath Forms Services -palvelimessa. InfoPath Forms Services voi kuitenkin näyttää vain hallittuja koodeja sisältäviä lomakemalleja, joten et voi julkaista InfoPath Forms Services -palvelimessa lomakemallia, joka sisältää komentosarjan. Komentosarja on siis muunnettava hallituksi koodiksi, jotta lomakemalli voidaan julkaista InfoPath Forms Services -palvelimessa.

  • Vastaat useiden sellaisten lomakemallien ylläpidosta, joita et ole itse suunnitellut. Nämä lomakemallit sisältävät JScript-ohjelmointikielellä kirjoitettuja komentosarjoja. Vaikka osaat lukea ja kirjoittaa JScript-kielellä kirjoitettuja komentosarjoja, olet etevämpi kirjoittamaan komentosarjoja Microsoft Visual Basic Scripting Edition (VBScript) -ohjelmointikielellä. Koska vastaat lomakemallien ylläpidosta, työsi olisi tehokkaampaan, jos kaikki komentosarjat olisi kirjoitettu VBScript-kielellä. Tästä syystä päätä korvata nykyiset JScript-kielellä kirjoitetut komentosarjat VBScript-kielellä kirjoitetuilla komentosarjoilla.

Jos sinun on muutettava aiemmin luodussa lomakemallissa käytettyä ohjelmointikieltä, sinun on ensin poistettava aiemmin luotu komentosarja tai hallittu koodi lomakemallista. Tämän jälkeen voit määrittää lomakemallille uuden ohjelmointikielen. Kun olet muuttanut lomakemallin ohjelmointikieltä, voit kirjoittaa komentosarjan tai hallitun koodin uudella kielellä käyttämällä Microsoft Script Editoria tai Microsoft Visual Studio Tools for Applications -sovellusta ja lisätä sitten uuden komentosarjan lomakemalliin.

Sivun alkuun

Lomakemallin ohjelmointikielen vaihtaminen

Ennen kuin muutat lomakemallin ohjelmointikieltä, saatat haluta tallentaa kopion alkuperäisestä lähdekoodista tekstieditorissa (esimerkiksi Microsoft Muistiossa) myöhempää käyttöä varten.

Alkuperäisen lähdekoodin tallentaminen

  1. Avaa lomakemalli suunnittelutilassa.

  2. Valitse Työkalut -valikosta Ohjelmointi ja tee sitten jompikumpi seuraavista toimista:

    • Jos lomakemalli sisältää komentosarjan, valitse Microsoft Script Editor.

    • Jos lomakemalli sisältää hallitun koodin, valitse Microsoft Visual Studio Tools for Applications.

  3. Valitse Microsoft Script Editor- tai Microsoft Visual Studio Tools for Applications -sovelluksen Muokkaa-valikosta Valitse kaikki.

  4. Valitse Muokkaa-valikosta Kopioi.

  5. Liitä kopioimasi koodi tekstieditoriin, kuten Muistioon.

  6. Tallenna tekstieditorin tiedosto.

Lomakemallin ohjelmointikielen vaihtaminen

  1. Valitse Työkalut-valikosta Lomakkeen asetukset.

  2. Valitse Lomakkeen asetukset -valintaikkunan Luokka-kohdasta Ohjelmointi.

  3. Valitse Ohjelmointikieli-kohdassa Poista koodi.

  4. Valitse Kyllä sanomaruudussa, joka varoittaa, että olet poistamassa koodin lomakemallista.

  5. Valitse Lomakemallin koodin kieli -luettelosta kieli, jota haluat käyttää lomakemallissa.

    Vihje: Jos vaihdat ohjelmointikielen Visual Basic- tai C#-kieleksi, kirjoita Visual Basic- ja C#-koodin projektisijainti -ruutuun paikka, johon haluat tallentaa projektitiedostot.

Sivun alkuun

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×