LASKE.JOS/LASKE.JOS.JOUKKO-funktion #ARVO!-virheen korjaaminen

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Tässä artikkelissa luetellaan #ARVO!-virheen yleiset syyt LASKE.JOS- ja LASKE.JOS.JOUKKO-funktioissa sekä niiden ratkaiseminen.

Ongelma: Kaava viittaa suljetussa työkirjassa oleviin soluihin

LASKE.JOS/LASKE.JOS.JOUKKO-funktiot, jotka viittaavat suljetussa työkirjassa olevaan soluun tai solualueeseen, aiheuttavat #ARVO!-virheen.

Huomautus: Tämä on tunnettu ongelma useiden muiden Excel-funktioiden, kuten SUMMA.JOS-, SUMMA.JOS.JOUKKO- ja LASKE.TYHJÄT-funktioiden kohdalla. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO!-virheen.

Ratkaisu: Avaa kaavaan merkitty linkitetty työkirja ja päivitä kaava painamalla F9-näppäintä.

Voit ratkaista ongelman myös käyttämällä SUMMA- ja JOS-funktioita yhdessä matriisikaavassa. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO!-virheen.

Ongelma: Merkkijono on yli 255 merkkiä.

Ratkaisu: Lyhennä merkkijonoa, jos mahdollista. Jos et voi lyhentää, jaa arvo useaan merkkijonoon käyttämällä KETJUTA-funktiota tai et-merkkioperaattoria (&). Esimerkki:

  • = LASKE.JOS(B2:B12,”pitkä merkkijono”&”toinen pitkä merkkijono”)

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia siitä, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa

Katso myös

#ARVO!-virheen korjaaminen

LASKE.JOS-funktio

LASKE.JOS.JOUKKO-funktio

JOS-funktio – sisäkkäiset kaavat ja ongelmien välttäminen

Katso video edistyneet Jos-Funktiot

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excelin funktiot (aakkosjärjestyksessä)

Kaikki Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×