Office
Kirjaudu sisään

Kaavavirheiden korjaaminen Excel for Macissa

Olipa kyseessä #ARVO!, #NIMI! tai PHAKU-ongelma, seuraavat tiedot auttavat sinua korjaamaan virheen.

PHAKU

Jos PHAKU tuottaa virheitä tai odottamattomia tuloksia, lataa PHAKU-vianmääritysvihjeet.

#ARVO!-virhe

Tämä ongelma liittyy yleensä numero- ja tekstiarvojen yhdistelmiin. Katso lisätietoja kohdasta #ARVO! ‑virheen korjaaminen.

#NIMI?-virhe

Varmista, että nimet on kirjoitettu oikein, sijoita teksti lainausmerkkien sisään tai sijoita taulukoiden nimet puolilainausmerkkien (') sisään. Katso muut syyt ja ratkaisut kohdasta #NIMI? ‑virheen korjaaminen.

#LUKU!-virhe

Tämä voi esiintyä, jos kirjoitat kaavaan ylimääräisiä merkkejä. Älä esimerkiksi kirjoita kaavaan $1,000. Kirjoita sen sijaan 1000. Katso muut syyt ja ratkaisut kohdasta #LUKU! ‑virheen korjaaminen.

#PUUTTUU-virhe

Jos kaava ei löydä viitattua arvoa, se palauttaa #PUUTTUU!-virheen. Katso lisätietoja kohdasta #PUUTTUU-virheen korjaaminen.

#VIITTAUS!-virhe

Excel näyttää tämän virheen, kun kaavassa on virheellinen soluviittaus. Katso lisätietoja kohdasta #VIITTAUS! ‑virheen korjaaminen.

#JAKO/0!-virhe

Tämä tapahtuu, kun numero jaetaan nollalla (0) tai kun kaava viittaa arvon 0 sisältävään tai tyhjään soluun. Katso lisätietoja kohdasta #JAKO/0! ‑virheen korjaaminen.

Muihin taulukoihin ja työkirjoihin viittaaminen

Jos viittaat toiseen laskentataulukon nimeen, kirjoita ! nimen jälkeen ja kirjoita sitten solu tai alue. Jos taulukon nimessä on välilyöntejä, kirjoita nimi puolilainausmerkkien sisään. Esimerkki: =SUMMA('Myyntiraportti'!A1:A8).

Kun viittaat toiseen ulkoiseen työkirjaan:

  • Kirjoita työkirjan nimi hakasulkeisiin [ ].

  • Kirjoita tiedoston koko polku.

  • Kirjoita polku puolilainausmerkkeihin, jotka sijoitetaan polun alkuun ja laskentataulukon nimen jälkeen ennen huutomerkkiä.

    Esimerkki: =SUMMA('/Käyttäjät/omanimi/Työpöytä/[Q2-toiminnot.xlsx]Myynti'!A1:A8)

Muita pikaratkaisuja, joista voi olla apua

  • Kirjoita jokaisen kaavan alkuun yhtäläisyysmerkki (=). Esimerkiksi: =SUM(A1:A8)

  • Käytä lukuja kerrottaessa *-symbolia älä X-merkkiä. Esimerkiksi: =A1*A8

  • Varmista, että alku- ja loppusulkeita on yhtä paljon niin, että ne muodostavat parin. Tässä esimerkissä on kaksi paria: =JOS(40>50;SUMMA(G2:G5);0)

  • Kaikki tarvittavat argumentit on kirjoitettava. Kaavan muodostin voi auttaa sinua tässä. Ala kirjoittaa kaavaa funktion nimellä ja avaa sitten kaavan muodostin painamalla CONTROL+A.

  • Kaavoissa käytetään lainausmerkkejä tekstin ympärillä. Esimerkiksi: =IF(A2>B2;"Ylittää budjetin";"OK")

  • Muuta viitatun solun tietototyyppiä. Paina KOMENTO + 1 ja valitse Numero.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×