Kaavan kopioiminen täyttökahvaa vetämällä Excel for Mac

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Voit kopioida kaavoja nopeasti vierekkäisiin soluihin täyttökahvalla.

Täyttökahva

Kun vedät kahvan toisiin soluihin, Excel näyttää eri tulokset kullekin solulle.

Kaavan kopioiminen täyttökahvaa vetämällä

Toimi seuraavasti:

  1. Valitse solu, joka sisältää vierekkäisiin soluihin täytettävän kaavan.

  2. Pidä osoitinta oikeassa alakulmassa, kunnes se muuttuu plusmerkiksi (+) kuvassa osoitetulla tavalla:

    Kohdistin täyttökahvan päällä

  3. Vedä täyttökahva alas, ylös tai solut, jotka haluat täyttää yli. Tässä esimerkissä seuraavassa kuvassa vetämällä täyttökahvaa alaspäin:

    Osoitin vetää täyttökahvan alas

  4. Kun vapautat painikkeen, kaava täytetään automaattisesti muihin soluihin:

    Arvot viittaavat täytettyihin soluihin

  5. Voit muuttaa solujen täyttötapaa Automaattisen täytön asetukset -painikkeella Automaattisen täytön asetukset -painike , joka tulee näkyviin, kun lopetat vetämisen. Valitse sitten haluamasi vaihtoehto.

Lisätietoja kaavojen kopioimisesta on artikkelissa Kaavan kopioiminen ja liittäminen toiseen soluun tai laskentataulukkoon.

Vihjeitä: 

  • Voit myös painaa Ctrl + D täyttää kaavaa sarakkeessa alaspäin. Valitse ensin solu, jonka sisältämän kaavan haluat täyttö ja valitse sitten sen alla olevat solut ja painamalla sitten Ctrl + D.

  • Voit myös painaa Ctrl + R voit täyttää kaavaa rivillä oikealle. Valitse ensin solu, jonka sisältämän kaavan haluat täyttö ja valitse sitten sen oikealla puolella solut ja painamalla sitten Ctrl + R.

Täyttäminen epäonnistuu

Täyttämisen joskus toimii moitteettomasti ja muiden kertaa, se ei toimi odotetusti. Minkä vuoksi on tärkeää Tarkista soluviittauksia ensimmäisen solun.

Soluviittaukset osoittavat toisiin soluihin. Jos ensimmäisessä solussa on esimerkiksi seuraava kaava:


=SUMMA(A1,B1)


A1 ja B1 ovat suhteelliset viittaukset. Tämä tarkoittaa vain, kun täytät kaavan alaspäin, viittaukset muuttuu soluissa a1, A2, B2 B1 ja niin edelleen tältä:

=SUM(A1,B1)

=SUMMA(A2,B2)

=SUM(A3,B3)

Joskus, et ehkä halua viittauksia toisiin soluihin, jos haluat muuttaa. Esimerkiksi oletetaan, että haluat määrittää ensimmäisen viittaus, A1, voit pitää viestit kiinteä ja B1, jos haluat muuttaa vetämällä täyttökahvaa. Jos näin on, sinun on kirjoitettava dollarimerkki ($) ensimmäisen viittauksen: =SUM($A$1,B1). Dollarimerkki Pakottaa Excelin säilyttää osoittamalla A1, kun täytät muihin soluihin. Miltä se näyttää seuraavat asiat:

=SUMMA($A$1,B1)

=SUMMA($A$1,B2)

=SUMMA($A$3,B3)

Dollarin merkit ($) sisältäviä viittauksia kutsutaan suoriksi viittauksiksi. Kun soluja täytetään alaspäin, A1-viittaus pysyy muuttumattomana, mutta Excel muuttaa B1-, B2- ja B3-viittaukset.

Täyttökahva ei näy

Jos et näe käsitellä täyttö, se on ehkä piilotettu. Tuo se näyttöön:

  1. Valitse Excel-valikossa Asetukset.

  2. Valitse Muokkaa.

  3. Valitse Muokkausasetukset-kohdassa Ota täyttökahva ja solujen vetäminen ja pudottaminen käyttöön -valintaneliö.

Jos automaattinen työkirjan laskeminen ei toimi, kaavat eivät lasketaan uudelleen silloin, kun soluihin.

Näin voit ottaa sen käyttöön:

  1. Valitse Excel-valikossa Asetukset.

  2. Valitse Laskenta.

  3. Laskenta-asetuksetVarmista, että Automaattinen on valittuna.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×