JOSVIRHE-funktio

JOSVIRHE-funktion avulla voit määrittää kaavan virheet ja hallita niitä. JOSVIRHE palauttaa arvon, jonka määrität, jos kaava laskee virheen. muussa tapa uksessa funktio palauttaa kaavan tuloksen.

Syntaksi

JOSVIRHE(arvo; arvo_jos_virhe)

JOSVIRHE-funktion syntaksissa on seuraavat argumentit:

  • arvo    Pakollinen. Testattava argumentti.

  • value_if_error    Pakollinen. Arvo, joka palautetaan, jos kaava laskee virheen. Seuraavat virhe tyypit lasketaan: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? tai #NULL!.

Huomautuksia

  • Jos arvo tai value_if_error on tyhjä solu, JOSVIRHE tulkitsee sen tyhjäksi merkki jonoksi ("").

  • Jos arvo on matriisi kaava, JOSVIRHE palauttaa arvo-kohdassa määritetyn välin kunkin solun tulos matriisin. Lisätietoja on jäljempänä olevassa toisessa esimerkissä.

Esimerkkejä

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä.

Kiintiö

Myydyt yksiköt

210

35

55

0

23

Kaava

Kuvaus

Tulos

=JOSVIRHE(A2/B2, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=JOSVIRHE(A3/B3, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=JOSVIRHE(A4/B4, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe ("" jaettuna 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Esimerkki 2

Kiintiö

Myydyt yksiköt

Suhde

210

35

6

55

0

Virhe laskutoimituksessa

23

0

Kaava

Kuvaus

Tulos

=C2

Tarkistaa, onko matriisin ensimmäisen alkion ensimmäisen argumentin kaavassa virhe (A2/B2 eli 210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=C3

Tarkistaa, onko matriisin toisen alkion ensimmäisen argumentin kaavassa virhe (A3/B3 eli 55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=C4

Tarkistaa, onko matriisin kolmannen alkion ensimmäisen argumentin kaavassa virhe (A4/B4 eli "" 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Huomautus: Jos käytössäsi on nykyinen Office 365-versio, voit syöttää kaavan tulostus alueella olevaan vasemmassa yläkulmassa olevaan soluun ja vahvistaa kaavan dynaamiseksi matriisi KAAVAKSI painamalla ENTER-näppäintä. Muussa tapa uksessa kaava on kirjoitettava perintönä matriisi kaavana valitsemalla ensin tulostus alueet, syöttämällä kaavan tulostus alueella olevaan vasemmassa yläkulmassa olevaan soluun, ja vahvistamalla se painamalla näppäin yhdistelmää CTRL + VAIHTO + ENTER. Excel lisää puolestasi kaavan alkuun ja loppuun aaltosulkeet. Katso lisätietoja matriisikaavoista kohdasta Matriisikaavoihin liittyviä ohjeita ja esimerkkejä.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×