JOSVIRHE-funktio

Tässä artikkelissa kuvataan Microsoft Excelin JOSVIRHE-funktion kaavasyntaksi ja käyttö.

Kuvaus

Palauttaa määrittämäsi arvon, jos kaavan tulos on virhe. Muussa tapauksessa se palauttaa kaavan tuloksen. JOSVIRHE-funktiolla voit siepata ja käsitellä kaava olevat virheet.

Syntaksi

JOSVIRHE(arvo; arvo_jos_virhe)

JOSVIRHE-funktion syntaksissa on seuraavat argumentit:

  • Arvo    Pakollinen. Testattava argumentti.

  • Arvo_jos_virhe    Pakollinen. Arvo, jonka funktio palauttaa, jos kaavan tulos on virhe. Arvo viittaa mihin tahansa virhearvoon: #PUUTTUU!, #ARVO!, #VIITTAUS!, #JAKO/0!, #LUKU!, #NIMI? tai #TYHJÄ!.

Huomautuksia

  • Jos arvo- tai arvo_jos_virhe-argumentti on tyhjä solu, JOSVIRHE tulkitsee sen tyhjäksi merkkijonoksi ("").

  • Jos arvo on matriisikaava, JOSVIRHE palauttaa arvo-argumentin määrittämän tulosmatriisin alueen kullekin solulle. Lisätietoja on jäljempänä olevassa toisessa esimerkissä.

Esimerkkejä

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Kiintiö

Myydyt yksiköt

210

35

55

0

23

Kaava

Kuvaus

Tulos

=JOSVIRHE(A2/B2, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=JOSVIRHE(A3/B3, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe (55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=JOSVIRHE(A4/B4, "Virhe laskutoimituksessa")

Tarkistaa, onko ensimmäisen argumentin kaavassa virhe ("" jaettuna 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Esimerkki 2

Kiintiö

Myydyt yksiköt

Suhde

210

35

6

55

0

Virhe laskutoimituksessa

23

0

Kaava

Kuvaus

Tulos

=C2

Tarkistaa, onko matriisin ensimmäisen alkion ensimmäisen argumentin kaavassa virhe (A2/B2 eli 210 jaettuna 35:llä). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

6

=C3

Tarkistaa, onko matriisin toisen alkion ensimmäisen argumentin kaavassa virhe (A3/B3 eli 55 jaettuna nollalla). Koska funktio löytää jako nollalla -virheen, se palauttaa arvo_jos_virhe-argumentin arvon.

Virhe laskutoimituksessa

=C4

Tarkistaa, onko matriisin kolmannen alkion ensimmäisen argumentin kaavassa virhe (A4/B4 eli "" 23:lla). Virhettä ei ole, joten funktio palauttaa kaavan tuloksen.

0

Huomaa: Esimerkin kaava on kirjoitettava matriisikaavana. Kun olet kopioinut esimerkin tyhjään työkirjaan, valitse alue C2:C4, paina F2-näppäintä ja paina sitten CTRL+VAIHTO+ENTER.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×